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Preface

Welcome to the IAR C/C++ Development Guide for ARM. The purpose of this
guide is to provide you with detailed reference information that can help you
to use the build tools to best suit your application requirements. This guide
also gives you suggestions on coding techniques so that you can develop
applications with maximum efficiency.

Who should read this guide

Read this guide if you plan to develop an application using the C or C++ language for
the ARM core and need detailed reference information on how to use the build tools.
You should have working knowledge of:

REQUIRED KNOWLEDGE

To use the tools in IAR Embedded Workbench, you should have working knowledge of:

o The architecture and instruction set of the ARM core (refer to the chip
manufacturer's documentation)

o The C or C++ programming language
o Application development for embedded systems
o The operating system of your host computer.

For more information about the other development tools incorporated in the IDE, refer
to their respective documentation, see Other documentation, page 31.

How to use this guide

When you start using the IAR C/C++ compiler and linker for ARM, you should read
Part 1. Using the build tools in this guide.

When you are familiar with the compiler and linker and have already configured your
project, you can focus more on Part 2. Reference information.

If you are new to using this product, we suggest that you first read the guide Getting
Started with IAR Embedded Workbench® for an overview of the tools and the features
that the IDE offers. The tutorials, which you can find in IAR Information Center, will
help you get started using IAR Embedded Workbench.
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What this guide contains

Below is a brief outline and summary of the chapters in this guide.

IAR C/C++ Development Guide
Compiling and Linking for ARM

PART I. USING THE BUILD TOOLS

Introduction to the IAR build tools gives an introduction to the IAR build tools,
which includes an overview of the tools, the programming languages, the available
device support, and extensions provided for supporting specific features of the
ARM core.

Developing embedded applications gives the information you need to get started
developing your embedded software using the IAR build tools.

® Data storage describes how to store data in memory.

® Functions gives a brief overview of function-related extensions—mechanisms for

controlling functions—and describes some of these mechanisms in more detail.

Linking using ILINK describes the linking process using the IAR ILINK Linker and
the related concepts.

Linking your application lists aspects that you must consider when linking your
application, including using ILINK options and tailoring the linker configuration
file.

The DLIB runtime environment describes the DLIB runtime environment in which
an application executes. It covers how you can modify it by setting options,
overriding default library modules, or building your own library. The chapter also
describes system initialization introducing the file cstartup, how to use modules
for locale, and file 1/0.

Assembler language interface contains information required when parts of an
application are written in assembler language. This includes the calling convention.

Using C gives an overview of the two supported variants of the C language and an
overview of the compiler extensions, such as extensions to Standard C.

Using C++ gives an overview of the two levels of C++ support: The
industry-standard EC++ and IAR Extended EC++.

Application-related considerations discusses a selected range of application issues
related to using the compiler and linker.

Efficient coding for embedded applications gives hints about how to write code that
compiles to efficient code for an embedded application.

PART 2. REFERENCE INFORMATION

External interface details provides reference information about how the compiler
and linker interact with their environment—the invocation syntax, methods for
passing options to the compiler and linker, environment variables, the include file
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search procedure, and the different types of compiler and linker output. The chapter
also describes how the diagnostic system works.

o Compiler options explains how to set options, gives a summary of the options, and
contains detailed reference information for each compiler option.

® Linker options gives a summary of the options, and contains detailed reference
information for each linker option.

o Data representation describes the available data types, pointers, and structure types.
This chapter also gives information about type and object attributes.

® FExtended keywords gives reference information about each of the ARM-specific
keywords that are extensions to the standard C/C++ language.

® Pragma directives gives reference information about the pragma directives.

e [ntrinsic functions gives reference information about functions to use for accessing
ARM-specific low-level features.

® The preprocessor gives a brief overview of the preprocessor, including reference
information about the different preprocessor directives, symbols, and other related
information.

o C/C++ standard library functions gives an introduction to the C or C++ library
functions, and summarizes the header files.

o The linker configuration file describes the purpose of the linker configuration file
and describes its contents.

e Section reference gives reference information about the use of sections.

® The stack usage control file describes the syntax and semantics of stack usage
control files.

® /AR utilities describes the IAR utilities that handle the ELF and DWARF object
formats.

o [mplementation-defined behavior for Standard C describes how the compiler
handles the implementation-defined areas of Standard C.

o Implementation-defined behavior for C89 describes how the compiler handles the
implementation-defined areas of the C language standard C89.

Other documentation

User documentation is available as hypertext PDFs and as a context-sensitive online
help system in HTML format. You can access the documentation from the Information
Center or from the Help menu in the IAR Embedded Workbench IDE. The online help
system is also available via the F1 key.
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USER AND REFERENCE GUIDES

The complete set of IAR Systems development tools is described in a series of guides.
Information about:

System requirements and information about how to install and register the IAR
Systems products, is available in the booklet Quick Reference (available in the
product box) and the Installation and Licensing Guide.

Getting started using IAR Embedded Workbench and the tools it provides, is
available in the guide Getting Started with IAR Embedded Workbench®.

Using the IDE for project management and building, is available in the /DE Project
Management and Building Guide for ARM.

Using the IAR C-SPY® Debugger, is available in the C-SPY® Debugging Guide for
ARM.

Programming for the IAR C/C++ Compiler for ARM and linking using the IAR
ILINK Linker, is available in the /4R C/C++ Development Guide for ARM.
Programming for the IAR Assembler for ARM, is available in the /4R Assembler
User Guide for ARM.

Using the IAR DLIB C/C++ standard library functions, is available in the C/C++
standard library reference, available in the online help system.

Performing a static analysis using C-STAT and the required checks, is available in
the C-STAT® Static Analysis Guide.

Developing safety-critical applications using the MISRA C guidelines, is available
in the JAR Embedded Workbench® MISRA C:2004 Reference Guide or the IAR
Embedded Workbench® MISRA C:1998 Reference Guide.

Using I-jet, refer to the IAR Debug probes User Guide for I-jet®, I-jet Trace, and
I-scope.

Using JTAGjet-Trace, refer to the JTAGjet-Trace User Guide for ARM.

Using IAR J-Link and IAR J-Trace, refer to the /AR J-Link and IAR J-Trace User
Guide for JTAG Emulators for ARM Cores.

Porting application code and projects created with a previous version of the IAR

Embedded Workbench for ARM, is available in the /AR Embedded Workbench®
Migration Guide.

Note: Additional documentation might be available depending on your product
installation.

THE ONLINE HELP SYSTEM

The context-sensitive online help contains:

Information about project management, editing, and building in the IDE
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Information about debugging using the IAR C-SPY® Debugger
Reference information about the menus, windows, and dialog boxes in the IDE

Compiler reference information

Keyword reference information for the DLIB library functions. To obtain reference
information for a function, select the function name in the editor window and press
F1.

FURTHER READING

These books might be of interest to you when using the IAR Systems development tools:

e Seal, David, and David Jagger. ARM Architecture Reference Manual.
Addison-Wesley

o Barr, Michael, and Andy Oram, ed. Programming Embedded Systems in C and
C++. O’Reilly & Associates.

o Furber, Steve, ARM System-on-Chip Architecture. Addison-Wesley.

o Harbison, Samuel P. and Guy L. Steele (contributor). C: 4 Reference Manual.
Prentice Hall.

e Josuttis, Nicolai M. The C++ Standard Library: A Tutorial and Reference.
Addison-Wesley.

o Kernighan, Brian W. and Dennis M. Ritchie. The C Programming Language.
Prentice Hall.

o Labrosse, Jean J. Embedded Systems Building Blocks: Complete and Ready-To-Use
Modules in C. R&D Books.

e Lippman, Stanley B. and Josée Lajoie. C++ Primer. Addison-Wesley.
e Mann, Bernhard. C fiir Mikrocontroller. Franzis-Verlag. [Written in German.]

® Meyers, Scott. Effective C++: 50 Specific Ways to Improve Your Programs and
Designs. Addison-Wesley.

o Meyers, Scott. More Effective C++. Addison-Wesley.
o Meyers, Scott. Effective STL. Addison-Wesley.

e Sloss, Andrew N. et al, ARM System Developer's Guide: Designing and Optimizing
System Software. Morgan Kaufmann.

e Stroustrup, Bjarne. The C++ Programming Language. Addison-Wesley.

e Stroustrup, Bjarne. Programming Principles and Practice Using C++.
Addison-Wesley.

e Sutter, Herb. Exceptional C++: 47 Engineering Puzzles, Programming Problems,
and Solutions. Addison-Wesley.
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WEB SITES

Recommended web sites:

o The Advanced RISC Machines Ltd web site, www.arm.com, that contains
information and news about the ARM cores.

o The IAR Systems web site, www.iar.com, that holds application notes and other
product information.

o The web site of the C standardization working group,
www.open-std.org/jtcl/sc22/wgl4.

o The web site of the C++ Standards Committee, www.open-std.org/jtcl/sc22/wg21.
Finally, the Embedded C++ Technical Committee web site,

www.caravan.net/ec2plus, that contains information about the Embedded C++
standard.

Document conventions

When, in the IAR Systems documentation, we refer to the programming language C, the
text also applies to C++, unless otherwise stated.

When referring to a directory in your product installation, for example arm\ doc, the full
path to the location is assumed, for example c: \Program Files\IAR
Systems\Embedded Workbench 7.n\arm\doc.

TYPOGRAPHIC CONVENTIONS

The IAR Systems documentation set uses the following typographic conventions:

Style Used for

computer * Source code examples and file paths.
* Text on the command line.
* Binary, hexadecimal, and octal numbers.

parameter A placeholder for an actual value used as a parameter, for example
filename.h where filename represents the name of the file.

[option] An optional part of a directive, where [ and ] are not part of the actual
directive, butany [, 1, {, or } are part of the directive syntax.

{option} A mandatory part of a directive, where { and } are not part of the
actual directive, but any [, ], {, or } are part of the directive syntax.

[option] An optional part of a command.
[a]b|c] An optional part of a command with alternatives.
{a|b|c} A mandatory part of a command with alternatives.

Table 1: Typographic conventions used in this guide

IAR C/C++ Development Guide
34 Compiling and Linking for ARM
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Style Used for

bold Names of menus, menu commands, buttons, and dialog boxes that
appear on the screen.

italic * A cross-reference within this guide or to another guide.
* Emphasis.

An ellipsis indicates that the previous item can be repeated an arbitrary
number of times.

Identifies instructions specific to the IAR Embedded Workbench® IDE
interface.

Identifies instructions specific to the command line interface.

Identifies helpful tips and programming hints.

Identifies warnings.

Table 1: Typographic conventions used in this guide (Continued)

NAMING CONVENTIONS

The following naming conventions are used for the products and tools from IAR
Systems®, when referred to in the documentation:

Brand name Generic term

IAR Embedded Workbench® for ARM IAR Embedded Workbench®
IAR Embedded Workbench® IDE for ARM the IDE

IAR C-SPY® Debugger for ARM C-SPY, the debugger

IAR C-SPY® Simulator the simulator

IAR C/C++ Compiler™ for ARM the compiler

IAR Assembler™ for ARM the assembler

IAR ILINK Linker™ ILINK, the linker

IAR DLIB Runtime Environment™ the DLIB runtime environment

Table 2: Naming conventions used in this guide
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Part 1. Using the build

tools

This part of the IAR C/C++ Development Guide for ARM includes these

chapters:

e Introduction to the IAR build tools
e Developing embedded applications
e Data storage

e Functions

o Linking using ILINK

e Linking your application

e The DLIB runtime environment

e Assembler language interface

e Using C

e Using C++

e Application-related considerations

e Efficient coding for embedded applications.

w
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Introduction to the I1AR
build tools

e The IAR build tools—an overview
e |AR language overview
e Device support

e Special support for embedded systems

The 1AR build tools—an overview

In the IAR product installation you can find a set of tools, code examples, and user
documentation, all suitable for developing software for ARM-based embedded
applications. The tools allow you to develop your application in C, C++, or in assembler
language.

IAR Embedded Workbench® is a very powerful Integrated Development Environment
(IDE) that allows you to develop and manage complete embedded application projects.
It provides an easy-to-learn and highly efficient development environment with
maximum code inheritance capabilities, comprehensive and specific target support. AR
Embedded Workbench promotes a useful working methodology, and thus a significant
reduction of the development time.

For information about the IDE, see the IDE Project Management and Building Guide
for ARM.

The compiler, assembler, and linker can also be run from a command line environment,

if you want to use them as external tools in an already established project environment.

IAR C/C++ COMPILER

The IAR C/C++ Compiler for ARM is a state-of-the-art compiler that offers the standard
features of the C and C++ languages, plus extensions designed to take advantage of the
ARM-specific facilities.
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IAR ASSEMBLER

The IAR Assembler for ARM is a powerful relocating macro assembler with a versatile
set of directives and expression operators. The assembler features a built-in C language
preprocessor and supports conditional assembly.

The IAR Assembler for ARM uses the same mnemonics and operand syntax as the
Advanced RISC Machines Ltd ARM Assembler, which simplifies the migration of
existing code. For more information, see the [4AR Assembler User Guide for ARM.

THE IAR ILINK LINKER

The IAR ILINK Linker for ARM is a powerful, flexible software tool for use in the
development of embedded controller applications. It is equally well suited for linking
small, single-file, absolute assembler programs as it is for linking large, relocatable
input, multi-module, C/C++, or mixed C/C++ and assembler programs.

SPECIFIC ELF TOOLS

ILINK both uses and produces industry-standard ELF and DWAREF as object format,
additional IAR utilities that handle these formats are provided:

® The IAR Archive Tool—iarchive—creates and manipulates a library (archive) of
several ELF object files

o The IAR ELF Tool—ielftool—performs various transformations on an ELF
executable image (such as, fill, checksum, format conversion etc)

o The IAR ELF Dumper for ARM—iel fdumparm—creates a text representation of
the contents of an ELF relocatable or executable image

o The IAR ELF Object Tool—iobjmanip—is used for performing low-level
manipulation of ELF object files

o The IAR Absolute Symbol Exporter—i symexport—exports absolute symbols
from a ROM image file, so that they can be used when linking an add-on
application.

Note: These ELF utilities are well-suited for object files produced by the tools from IAR
Systems. Thus, we recommend using them instead of the GNU binary utilities.
EXTERNAL TOOLS

For information about how to extend the tool chain in the IDE, see the IDE Project
Management and Building Guide for ARM.
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IAR language overview
The IAR C/C++ Compiler for ARM supports:

o C, the most widely used high-level programming language in the embedded systems
industry. You can build freestanding applications that follow these standards:

e Standard C—also known as C99. Hereafter, this standard is referred to as
Standard C in this guide.

o (C89—also known as C94, C90, C89, and ANSI C. This standard is required
when MISRA C is enabled.

o C++, a modern object-oriented programming language with a full-featured library
well suited for modular programming. Any of these standards can be used:

o Standard C++—can be used with different levels of support for exceptions and
runtime type information (RTTI).

o Embedded C++ (EC++)—a subset of the C++ programming standard, which is
intended for embedded systems programming. It is defined by an industry
consortium, the Embedded C++ Technical committee. See the chapter Using
C++.

o IAR Extended Embedded C++ (EEC++)—EC++ with additional features such
as full template support, multiple inheritance, namespace support, the new cast
operators, as well as the Standard Template Library (STL).

Each of the supported languages can be used in strict or relaxed mode, or relaxed with
TAR extensions enabled. The strict mode adheres to the standard, whereas the relaxed
mode allows some common deviations from the standard.

For more information about C, see the chapter Using C.

For more information about C++, Embedded C++, and Extended Embedded C++, see
the chapter Using C++.

For information about how the compiler handles the implementation-defined areas of
the languages, see the chapter Implementation-defined behavior for Standard C.

It is also possible to implement parts of the application, or the whole application, in
assembler language. See the /AR Assembler User Guide for ARM.

Device support

To get a smooth start with your product development, the IAR product installation
comes with a wide range of device-specific support.
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SUPPORTED ARM DEVICES

The IAR C/C++ Compiler for ARM supports several different ARM cores and devices
based on the instruction sets version 4, 5, 6, 6M, and 7. The object code that the compiler
generates is not always binary compatible between the cores. Therefore it is crucial to
specify a processor option to the compiler. The default core is ARM7TDMI

PRECONFIGURED SUPPORT FILES

The IAR product installation contains preconfigured files for supporting different
devices. If you need additional files for device support, they can be created using one of
the provided ones as a template.

Header files for 1/0

Standard peripheral units are defined in device-specific I/O header files with the
filename extension h. The product package supplies I/O files for all devices that are
available at the time of the product release. You can find these files in the
arm\inc\<vendor> directory. Make sure to include the appropriate include file in your
application source files. If you need additional I/O header files, they can be created using
one of the provided ones as a template. For detailed information about the header file
format, see EWARM_HeaderFormat .pdf located in the arm\doc directory.

Linker configuration files

The arm\config directory contains ready-made linker configuration files for all
supported devices. The files have the filename extension icf and contain the
information required by the linker. For more information about the linker configuration
file, see Placing code and data—the linker configuration file, page 79, and for reference
information, the chapter The linker configuration file.

Device description files

The debugger handles several of the device-specific requirements, such as definitions of
available memory areas, peripheral registers and groups of these, by using device
description files. These files are located in the arm\config directory and they have the
filename extension ddf. The peripheral registers and groups of these can be defined in
separate files (filename extension sfr), which in that case are included in the ddf file.
For more information about these files, see the C-SPY® Debugging Guide for ARM and
EWARM_DDFFORMAT . pdf located in the arm\doc directory.

EXAMPLES FOR GETTING STARTED

The arm\examples directory contains several hundreds of examples of working
applications to give you a smooth start with your development. The complexity of the
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examples ranges from simple LED blink to USB mass storage controllers. Examples are
provided for most of the supported devices.

Special support for embedded systems

This section briefly describes the extensions provided by the compiler to support
specific features of the ARM core.
EXTENDED KEYWORDS

The compiler provides a set of keywords that can be used for configuring how the code
is generated. For example, there are keywords for controlling how to access and store
data objects, as well as for controlling how a function should work internally and how
it should be called/returned.

By default, language extensions are enabled in the IDE.

The command line option -e makes the extended keywords available, and reserves them
so that they cannot be used as variable names. See, -e, page 261 for additional
information.

For more information about the extended keywords, see the chapter Extended keywords.
See also, Data storage, page 59 and Functions, page 63.
PRAGMA DIRECTIVES

The pragma directives control the behavior of the compiler, for example how it allocates
memory, whether it allows extended keywords, and whether it issues warning messages.

The pragma directives are always enabled in the compiler. They are consistent with
standard C, and are very useful when you want to make sure that the source code is
portable.

For more information about the pragma directives, see the chapter Pragma directives.

PREDEFINED SYMBOLS

With the predefined preprocessor symbols, you can inspect your compile-time
environment, for example time of compilation or the build number of the compiler.

For more information about the predefined symbols, see the chapter The preprocessor.

ACCESSING LOW-LEVEL FEATURES

For hardware-related parts of your application, accessing low-level features is essential.
The compiler supports several ways of doing this: intrinsic functions, mixing C and
assembler modules, and inline assembler. For information about the different methods,
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Developing embedded
applications

e Developing embedded software using IAR build tools

e The build process—an overview

Application execution—an overview

Building applications—an overview

Basic project configuration

Developing embedded software using 1AR build tools

Typically, embedded software written for a dedicated microcontroller is designed as an
endless loop waiting for some external events to happen. The software is located in
ROM and executes on reset. You must consider several hardware and software factors
when you write this kind of software. To your help, you have compiler options, extended
keywords, pragma directives, etc.

MAPPING OF MEMORY

Embedded systems typically contain various types of memory, such as on-chip RAM,
external DRAM or SRAM, ROM, EEPROM, or flash memory.

As an embedded software developer, you must understand the features of the different
types of memory. For example, on-chip RAM is often faster than other types of
memories, and variables that are accessed often would in time-critical applications
benefit from being placed here. Conversely, some configuration data might be accessed
seldom but must maintain their value after power off, so they should be saved in
EEPROM or flash memory.

For efficient memory usage, the compiler provides several mechanisms for controlling
placement of functions and data objects in memory. For more information, see
Controlling data and function placement in memory, page 216. The linker places
sections of code and data in memory according to the directives you specify in the linker
configuration file, see Placing code and data—the linker configuration file, page 79.
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COMMUNICATION WITH PERIPHERAL UNITS

If external devices are connected to the microcontroller, you might need to initialize and
control the signalling interface, for example by using chip select pins, and detect and
handle external interrupt signals. Typically, this must be initialized and controlled at
runtime. The normal way to do this is to use special function registers (SFR). These are
typically available at dedicated addresses, containing bits that control the chip
configuration.

Standard peripheral units are defined in device-specific I/O header files with the
filename extension h. See Device support, page 41. For an example, see Accessing
special function registers, page 229.

EVENT HANDLING

In embedded systems, using interrupts is a method for handling external events
immediately; for example, detecting that a button was pressed. In general, when an
interrupt occurs in the code, the core immediately stops executing the code it runs, and
starts executing an interrupt routine instead.

The compiler provides various primitives for managing hardware and software
interrupts, which means that you can write your interrupt routines in C, see Interrupt
Sfunctions for Cortex-M devices, page 65 and Interrupt functions for ARM7/9/11,
Cortex-A, and Cortex-R devices, page 66.

SYSTEM STARTUP

In all embedded systems, system startup code is executed to initialize the system—both
the hardware and the software system—before the main function of the application is
called. The CPU imposes this by starting execution from a fixed memory address.

As an embedded software developer, you must ensure that the startup code is located at
the dedicated memory addresses, or can be accessed using a pointer from the vector
table. This means that startup code and the initial vector table must be placed in
non-volatile memory, such as ROM, EPROM, or flash.

A C/C++ application further needs to initialize all global variables. This initialization is
handled by the linker and the system startup code in conjunction. For more information,
see Application execution—an overview, page 50.

REAL-TIME OPERATING SYSTEMS

In many cases, the embedded application is the only software running in the system.
However, using an RTOS has some advantages.

For example, the timing of high-priority tasks is not affected by other parts of the
program which are executed in lower priority tasks. This typically makes a program
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more deterministic and can reduce power consumption by using the CPU efficiently and
putting the CPU in a lower-power state when idle.

Using an RTOS can make your program easier to read and maintain, and in many cases
smaller as well. Application code can be cleanly separated in tasks which are truly
independent of each other. This makes teamwork easier, as the development work can
be easily split into separate tasks which are handled by one developer or a group of
developers.

Finally, using an RTOS reduces the hardware dependence and creates a clean interface
to the application, making it easier to port the program to different target hardware.

INTEROPERABILITY WITH OTHER BUILD TOOLS

The IAR compiler and linker provide support for AEABI, the Embedded Application
Binary Interface for ARM. For more information about this interface specification, see
the www . arm. com web site.

The advantage of this interface is the interoperability between vendors supporting it; an
application can be built up of libraries of object files produced by different vendors and
linked with a linker from any vendor, as long as they adhere to the AEABI standard.

AEABI specifies full compatibility for C and C++ object code, and for the C library. The
AEABI does not include specifications for the C++ library.

For more information about the AEABI support in the IAR build tools, see AEABI
compliance, page 209.

The ARM IAR build tools with version numbers from 6.xx and up are not fully
compatible with earlier versions of the product, see the /AR Embedded Workbench®
Migration Guide for ARM® for more information.

For more information, see Linker optimizations, page 208.

The build process—an overview

This section gives an overview of the build process; how the various build
tools—compiler, assembler, and linker—fit together, going from source code to an
executable image.

To get familiar with the process in practice, you should run one or more of the tutorials
available from the IAR Information Center.

THE TRANSLATION PROCESS

There are two tools in the IDE that translate application source files to intermediary
object files. The IAR C/C++ Compiler and the IAR Assembler. Both produce
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relocatable object files in the industry-standard format ELF, including the DWARF
format for debug information.

Note: The compiler can also be used for translating C/C++ source code into assembler
source code. If required, you can modify the assembler source code which then can be
assembled into object code. For more information about the IAR Assembler, see the /AR
Assembler User Guide for ARM.

This illustration shows the translation process:

C/C++ Assembler

source
files

source
files

compiler

’* Librarian
Relocatable

object
files g

Customer
library

After the translation, you can choose to pack any number of modules into an archive, or
in other words, a library. The important reason you should use libraries is that each
module in a library is conditionally linked in the application, or in other words, is only
included in the application if the module is used directly or indirectly by a module
supplied as an object file. Optionally, you can create a library; then use the IAR utility
iarchive.

THE LINKING PROCESS

The relocatable modules, in object files and libraries, produced by the IAR compiler and
assembler cannot be executed as is. To become an executable application, they must be
linked.

Note: Modules produced by a toolset from another vendor can be included in the build
as well. Be aware that this also might require a compiler utility library from the same
vendor.
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The IAR ILINK Linker (i1inkarm.exe) is used for building the final application.
Normally, the linker requires the following information as input:

o Several object files and possibly certain libraries
e A program start label (set by default)

o The linker configuration file that describes placement of code and data in the
memory of the target system

This illustration shows the linking process:
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Note: The Standard C/C++ library contains support routines for the compiler, and the
implementation of the C/C++ standard library functions.

During the linking, the linker might produce error messages and logging messages on
stdout and stderr. The log messages are useful for understanding why an application
was linked the way it was, for example, why a module was included or a section
removed.

For more information about the procedure performed by the linker, see The linking
process in detail, page 77.
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AFTER LINKING

The IAR ILINK Linker produces an absolute object file in ELF format that contains the
executable image. After linking, the produced absolute executable image can be used
for:

o Loading into the IAR C-SPY Debugger or any other compatible external debugger
that reads ELF and DWARF.

o Programming to a flash/PROM using a flash/PROM programmer. Before this is
possible, the actual bytes in the image must be converted into the standard Motorola
32-bit S-record format or the Intel Hex-32 format. For this, use ielftool, see The
1AR ELF Tool—ielftool, page 468.

This illustration shows the possible uses of the absolute output ELF/DWAREF file:
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This section gives an overview of the execution of an embedded application divided into
three phases, the

e Initialization phase

e Execution phase

o Termination phase.
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THE INITIALIZATION PHASE

Initialization is executed when an application is started (the CPU is reset) but before the
main function is entered. The initialization phase can for simplicity be divided into:

o Hardware initialization, which generally at least initializes the stack pointer.

The hardware initialization is typically performed in the system startup code
cstartup.s and if required, by an extra low-level routine that you provide. It might
include resetting/starting the rest of the hardware, setting up the CPU, etc, in
preparation for the software C/C++ system initialization.

o Software C/C++ system initialization

Typically, this includes assuring that every global (statically linked) C/C++ symbol
receives its proper initialization value before the main function is called.

o Application initialization

This depends entirely on your application. It can include setting up an RTOS kernel
and starting initial tasks for an RTOS-driven application. For a bare-bone application,
it can include setting up various interrupts, initializing communication, initializing
devices, etc.

For a ROM/flash-based system, constants and functions are already placed in ROM. All
symbols placed in RAM must be initialized before the main function is called. The
linker has already divided the available RAM into different areas for variables, stack,
heap, etc.
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The following sequence of illustrations gives a simplified overview of the different
stages of the initialization.

I When an application is started, the system startup code first performs hardware
initialization, such as initialization of the stack pointer to point at the end of the
predefined stack area:

vector
e Jump to cstartup

cstartup
e Set up stack pointer ~
Initialize variables to zero
ROM °

e Initialize variables

region e Call main( )
main( ) and other code
Initializers
Stack
"
region Zero-initialized variables

Initialized variables

2 Then, memories that should be zero-initialized are cleared, in other words, filled with

Zeros:
vector
e Jump to cstartup
cstartup
® Set up stack pointer
 Initialize variables to zero -
ROAM * Initialize variables
region e Call main()
main( ) and other code
Initializers
Stack
RAM
region Zero-initialized variables <):' 0......
Initialized variables
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Typically, this is data referred to as zero-initialized data; variables declared as, for
example, int i = 0;

For initialized data, data declared, for example, like int i = 6; the initializers are
copied from ROM to RAM:

vector
® Jump to cstartup

cstartup

* Set up stack pointer
 Initialize variables to zero
e |Initialize variables ~
e Call main()

ROM
region

main( ) and other code

Initializers [

Stack

) Copy
region Zero-initialized variables

Initialized variables

Finally, the main function is called:

vector
e Jump to cstartup

cstartup
e Set up stack pointer
e |nitialize variables to zero
ROM o .
region  |Initialize variables
g e Call main()
I‘: main( ) and other code
Initializers
Stack
RAM
region Zero-initialized variables

Initialized variables
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For more information about each stage, see System startup and termination, page 126.
For more information about initialization of data, see Initialization at system startup,
page 82.

THE EXECUTION PHASE

The software of an embedded application is typically implemented as a loop which is
either interrupt-driven or uses polling for controlling external interaction or internal
events. For an interrupt-driven system, the interrupts are typically initialized at the
beginning of the main function.

In a system with real-time behavior and where responsiveness is critical, a multi-task
system might be required. This means that your application software should be
complemented with a real-time operating system. In this case, the RTOS and the
different tasks must also be initialized at the beginning of the main function.

THE TERMINATION PHASE

Typically, the execution of an embedded application should never end. If it does, you
must define a proper end behavior.

To terminate an application in a controlled way, either call one of the Standard C library
functions exit, Exit, or abort, or return from main. If you return from main, the
exit function is executed, which means that C++ destructors for static and global
variables are called (C++ only) and all open files are closed.

Of course, in case of incorrect program logic, the application might terminate in an
uncontrolled and abnormal way—a system crash.

For more information about this, see System termination, page 129.
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In the command line interface, this line compiles the source file myfile.c into the
object file myfile.o using the default settings:

iccarm myfile.c

You must also specify some critical options, see Basic project configuration, page 55.
On the command line, this line can be used for starting the linker:

ilinkarm myfile.o myfile2.0 -o a.out --config my_configfile.icf

In this example, myfile.oandmyfile2.o are object files, and my_configfile.icf
is the linker configuration file. The option -o specifies the name of the output file.
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Note: By default, the label where the application starts is __iar_program_start.
You can use the --entry command line option to change this.

When building a project, the JAR Embedded Workbench IDE can produce extensive
@ build information in the Build messages window. This information can be useful, for
example, as a base for producing batch files for building on the command line. You can
copy the information and paste it in a text file. To activate extensive build information,
choose Tools>Options> Messages and select the option Show build messages: All.

Basic project configuration

This section gives an overview of the basic settings for the project setup that are needed
to make the compiler and linker generate the best code for the ARM device you are
using. You can specify the options either from the command line interface or in the IDE.

You need to make settings for:

e Processor configuration, that is processor variant, CPU mode, interworking, VFP
and floating-point arithmetic, and byte order

o Optimization settings

o Runtime environment, see Setting up the runtime environment, page 111

o Customizing the ILINK configuration, see the chapter Linking your application.

In addition to these settings, many other options and settings can fine-tune the result

even further. For information about how to set options and for a list of all available

options, see the chapters Compiler options, Linker options, and the IDE Project
Management and Building Guide for ARM, respectively.

PROCESSOR CONFIGURATION

To make the compiler generate optimum code, you should configure it for the ARM core
you are using.

Processor variant

The IAR C/C++ Compiler for ARM supports several different ARM cores and devices
based on the instruction sets version 4, 5, 6, and 7. All supported cores support Thumb
instructions and 64-bit multiply instructions. The object code that the compiler
generates is not always binary compatible between the cores. Therefore it is crucial to
specify a processor option to the compiler. The default core is ARM7TDMI.

See the IDE Project Management and Building Guide for ARM, for information about
setting the Processor variant option in the IDE.
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Use the --cpu option to specify the ARM core; see --arm, page 253 and --thumb, page
286, for syntax information.

Interworking

When code is compiled with the --interwork option, ARM and Thumb code can be
freely mixed. Interworking functions can be called from both ARM and Thumb code.
Interworking is default for devices based on the instruction sets version 5, 6, and 7, or
when using the --aeabi compiler option. See also Veneers, page 103.

See the IDE Project Management and Building Guide for ARMfor information about
setting the Generate interwork code option in the IDE.

Use the --interwork option to specify interworking capabilities for your project; see
--interwork, page 267, for syntax information.

VFP and floating-point arithmetic

If you are using an ARM core that contains a Vector Floating Point (VFP) coprocessor,
you can use the --£fpu option to generate code that carries out floating-point operations
utilizing the coprocessor, instead of using the software floating-point library routines.

See the IDE Project Management and Building Guide for ARM, for information about
setting the FPU option in the IDE.

Use the --fpu option to specify the ARM core; see --fpu, page 265 for syntax
information.

Byte order

The compiler supports the big-endian and little-endian byte order. All user and library
modules in your application must use the same byte order.

See the IDE Project Management and Building Guide for ARM for information about
setting the Endian mode option in the IDE.

Use the --endian option to specify the byte order for your project; see --endian, page
264, for syntax information.

OPTIMIZATION FOR SPEED AND SIZE

The compiler’s optimizer performs, among other things, dead-code elimination,
constant propagation, inlining, common sub-expression elimination, static clustering,
instruction scheduling, and precision reduction. It also performs loop optimizations,
such as unrolling and induction variable elimination.

You can decide between several optimization levels and for the highest level you can
choose between different optimization goals—size, speed, or balanced. Most
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optimizations will make the application both smaller and faster. However, when this is
not the case, the compiler uses the selected optimization goal to decide how to perform
the optimization.

The optimization level and goal can be specified for the entire application, for individual
files, and for individual functions. In addition, some individual optimizations, such as
function inlining, can be disabled.

For information about compiler optimizations and for more information about efficient
coding techniques, see the chapter Efficient coding for embedded applications.
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Introduction

An ARM core can address 4 Gbytes of continuous memory, ranging from 0x00000000
to OxFFFFFFFF. Different types of physical memory can be placed in the memory
range. A typical application will have both read-only memory (ROM) and read/write
memory (RAM). In addition, some parts of the memory range contain processor control
registers and peripheral units.

DIFFERENT WAYS TO STORE DATA

In a typical application, data can be stored in memory in three different ways:

Auto variables

All variables that are local to a function, except those declared static, are stored either
in registers or on the stack. These variables can be used as long as the function
executes. When the function returns to its caller, the memory space is no longer valid.
For more information, see Storage of auto variables and parameters, page 60.

Global variables, module-static variables, and local variables declared static

In this case, the memory is allocated once and for all. The word static in this context
means that the amount of memory allocated for this kind of variables does not change
while the application is running. The ARM core has one single address space and the
compiler supports full memory addressing.

Dynamically allocated data.

An application can allocate data on the heap, where the data remains valid until it is
explicitly released back to the system by the application. This type of memory is
useful when the number of objects is not known until the application executes. Note
that there are potential risks connected with using dynamically allocated data in
systems with a limited amount of memory, or systems that are expected to run for a
long time. For more information, see Dynamic memory on the heap, page 61.
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Variables that are defined inside a function—and not declared static—are named auto
variables by the C standard. A few of these variables are placed in processor registers;
the rest are placed on the stack. From a semantic point of view, this is equivalent. The
main differences are that accessing registers is faster, and that less memory is required
compared to when variables are located on the stack.

Auto variables can only live as long as the function executes; when the function returns,
the memory allocated on the stack is released.

THE STACK

The stack can contain:

Local variables and parameters not stored in registers
Temporary results of expressions
The return value of a function (unless it is passed in registers)

Processor state during interrupts

Processor registers that should be restored before the function returns (callee-save
registers).

The stack is a fixed block of memory, divided into two parts. The first part contains
allocated memory used by the function that called the current function, and the function
that called it, etc. The second part contains free memory that can be allocated. The
borderline between the two areas is called the top of stack and is represented by the stack
pointer, which is a dedicated processor register. Memory is allocated on the stack by
moving the stack pointer.

A function should never refer to the memory in the area of the stack that contains free
memory. The reason is that if an interrupt occurs, the called interrupt function can
allocate, modify, and—of course—deallocate memory on the stack.

See also Stack considerations, page 198 and Setting up stack memory, page 97.

Advantages

The main advantage of the stack is that functions in different parts of the program can
use the same memory space to store their data. Unlike a heap, a stack will never become
fragmented or suffer from memory leaks.

It is possible for a function to call itself either directly or indirectly—a recursive
function—and each invocation can store its own data on the stack.
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Potential problems

The way the stack works makes it impossible to store data that is supposed to live after
the function returns. The following function demonstrates a common programming
mistake. It returns a pointer to the variable x, a variable that ceases to exist when the
function returns.

int *MyFunction ()

{
int x;
/* Do something here. */
return &x; /* Incorrect */

}

Another problem is the risk of running out of stack. This will happen when one function
calls another, which in turn calls a third, etc., and the sum of the stack usage of each
function is larger than the size of the stack. The risk is higher if large data objects are
stored on the stack, or when recursive functions are used.

Dynamic memory on the heap

Memory for objects allocated on the heap will live until the objects are explicitly
released. This type of memory storage is very useful for applications where the amount
of data is not known until runtime.

In C, memory is allocated using the standard library function malloc, or one of the
related functions calloc and realloc. The memory is released again using free.

In C++, a special keyword, new, allocates memory and runs constructors. Memory
allocated with new must be released using the keyword delete.

See also Setting up heap memory, page 98.

POTENTIAL PROBLEMS

Applications that are using heap-allocated objects must be designed very carefully,
because it is easy to end up in a situation where it is not possible to allocate objects on
the heap.

The heap can become exhausted if your application uses too much memory. It can also
become full if memory that no longer is in use was not released.

For each allocated memory block, a few bytes of data for administrative purposes is
required. For applications that allocate a large number of small blocks, this
administrative overhead can be substantial.

There is also the matter of fragmentation; this means a heap where small sections of free
memory is separated by memory used by allocated objects. It is not possible to allocate
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a new object if no piece of free memory is large enough for the object, even though the
sum of the sizes of the free memory exceeds the size of the object.

Unfortunately, fragmentation tends to increase as memory is allocated and released. For
this reason, applications that are designed to run for a long time should try to avoid using
memory allocated on the heap.
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Inlining functions

Function-related extensions

In addition to supporting Standard C, the compiler provides several extensions for
writing functions in C. Using these, you can:

Generate code for the different CPU modes ARM and Thumb Typically, this refers
to target-specific keywords, such as __arm, __thumb.

Execute functions in RAM

Write interrupt functions for the different devices
Control function inlining

Facilitate function optimization

Access hardware features.

The compiler uses compiler options, extended keywords, pragma directives, and
intrinsic functions to support this.

For more information about optimizations, see Efficient coding for embedded
applications, page 213. For information about the available intrinsic functions for
accessing hardware operations, see the chapter Intrinsic functions.

ARM and Thumb code

The IAR C/C++ Compiler for ARM can generate code for either the 32-bit ARM, or the
16-bit Thumb or Thumb?2 instruction set. Use the --cpu_mode option, alternatively the
--arm or --thumb options, to specify which instruction set should be used for your
project. For individual functions, it is possible to override the project setting by using
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the extended keywords __armand __ thumb. You can freely mix ARM and thumb code
in the same application, as long as the code is interworking.

When performing function calls, the compiler always attempts to generate the most
efficient assembler language instruction or instruction sequence available. As a result, 4
Gbytes of continuous memory in the range 0x0-0xFFFFFFFF can be used for placing
code. There is a limit of 4 Mbytes per code module.

The size of all code pointers is 4 bytes. There are restrictions to implicit and explicit
casts from code pointers to data pointers or integer types or vice versa. For further
information about the restrictions, see Pointer types, page 327.

In the chapter Assembler language interface, the generated code is studied in more detail
in the description of calling C functions from assembler language and vice versa.

Execution in RAM
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The __ramfunc keyword makes a function execute in RAM. In other words it places
the function in a section that has read/write attributes. The function is copied from ROM
to RAM at system startup just like any initialized variable, see System startup and
termination, page 126.

The keyword is specified before the return type:
__ramfunc void foo(void) ;

If a function declared __ramfunc tries to access ROM, the compiler will issue a
warning.

If the whole memory area used for code and constants is disabled—for example, when
the whole flash memory is being erased—only functions and data stored in RAM may
be used. Interrupts must be disabled unless the interrupt vector and the interrupt service
routines are also stored in RAM.

String literals and other constants can be avoided by using initialized variables. For
example, the following lines:

_ ramfunc void test ()

{
/* myc: initializer in ROM */
const int myc([] = { 10, 20 };

/* string literal in ROM */
msg ("Hello") ;
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can be rewritten to:

__ramfunc void test()

{
/* myc: initialized by cstartup */
static int myc[] = { 10, 20 };

/* hello: initialized by cstartup */
static char hello[] = "Hello";

msg (hello) ;
}

For more information, see Initializing code—copying ROM to RAM, page 101.

Interrupt functions for Cortex-M devices

Cortex-M has a different interrupt mechanism than previous ARM architectures, which
means the primitives provided by the compiler are also different.

INTERRUPTS FOR CORTEX-M

On Cortex-M, an interrupt service routine enters and returns in the same way as a normal
function, which means no special keywords are required. Thus, the keywords __irq,
__fiqg, and __nested are not available when you compile for Cortex-M.

These exception function names are defined in cstartup_M.c and cstartup_M.s.
They are referred to by the library exception vector code:

NMI_Handler
HardFault_Handler
MemManage_Handler
BusFault_Handler
UsageFault_Handler
SVC_Handler
DebugMon_Handler
PendSV_Handler
SysTick_Handler

The vector table is implemented as an array. It should always have the name
vector_table, because the C-SPY debugger looks for that symbol when

determining where the vector table is located.

The predefined exception functions are defined as weak symbols. A weak symbol is

only included by the linker as long as no duplicate symbol is found. If another symbol
is defined with the same name, it will take precedence. Your application can therefore
simply define its own exception function by just defining it using the correct name from
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the list above. If you need other interrupts or other exception handlers, you must make
a copy of the cstartup_M.c or cstartup_M. s file and make the proper addition to
the vector table.

The intrinsic functions __get_CPSR and __set_CPSR are not available when you
compile for Cortex-M. Instead, if you need to get or set values of these or other registers,
you can use inline assembler. For more information, see Passing values between C and
assembler objects, page 231.

Interrupt functions for ARM7/9/11, Cortex-A, and Cortex-R devices
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The IAR C/C++ Compiler for ARM provides the following primitives related to writing
interrupt functions for ARM7/9/11, Cortex-A, and Cortex-R devices:
o The extended keywords: __irg, _fiq, __swi,__nested,

@ The intrinsic functions: __enable_interrupt
__get_interrupt_state

disable_interrupt,

s ——

set_interrupt_state.

ER—

Note: Cortex-M has a different interrupt mechanism than other ARM devices, and for
these devices a different set of primitives is available. For more information, see
Interrupt functions for Cortex-M devices, page 65.

INTERRUPT FUNCTIONS

In embedded systems, using interrupts is a method for handling external events
immediately; for example, detecting that a button was pressed.

Interrupt service routines

In general, when an interrupt occurs in the code, the core immediately stops executing
the code it runs, and starts executing an interrupt routine instead. It is important that the
environment of the interrupted function is restored after the interrupt is handled (this
includes the values of processor registers and the processor status register). This makes
it possible to continue the execution of the original code after the code that handled the
interrupt was executed.

The compiler supports interrupts, software interrupts, and fast interrupts. For each
interrupt type, an interrupt routine can be written.

All interrupt functions must be compiled in ARM mode; if you are using Thumb mode,
use the __arm extended keyword or the #pragma type_attribute=__armdirective
to override the default behavior. This is not applicable for Cortex-M devices.
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Interrupt vectors and the interrupt vector table

Each interrupt routine is associated with a vector address/instruction in the exception
vector table, which is specified in the ARM cores documentation. The interrupt vector
is the address in the exception vector table. For the ARM cores, the exception vector
table starts at address 0x0.

By default, the vector table is populated with a default interrupt handler which loops
indefinitely. For each interrupt source that has no explicit interrupt service routine, the
default interrupt handler will be called. If you write your own service routine for a
specific vector, that routine will override the default interrupt handler.

Defining an interrupt function—an example

To define an interrupt function, the __irqg or the __fiqg keyword can be used. For
example:

__irg __arm void IRQ_Handler (void)

-~

/* Do something */
}

See the ARM cores documentation for more information about the interrupt vector
table.

Note: An interrupt function must have the return type void, and it cannot specify any
parameters.

Interrupt and C++ member functions

Only static member functions can be interrupt functions. When a non-static member
function is called, it must be applied to an object. When an interrupt occurs and the
interrupt function is called, there is no object available to apply the member function to.

INSTALLING EXCEPTION FUNCTIONS

All interrupt functions and software interrupt handlers must be installed in the vector
table. This is done in assembler language in the system startup file cstartup.s.

The default implementation of the ARM exception vector table in the standard runtime
library jumps to predefined functions that implement an infinite loop. Any exception
that occurs for an event not handled by your application will therefore be caught in the
infinite loop (B. ).

The predefined functions are defined as weak symbols. A weak symbol is only included
by the linker as long as no duplicate symbol is found. If another symbol is defined with
the same name, it will take precedence. Your application can therefore simply define its
own exception function by just defining it using the correct name.
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These exception function names are defined in cstartup.s and referred to by the
library exception vector code:

Undefined_Handler
SWI_Handler
Prefetch_Handler
Abort_Handler
IRQ_Handler
FIQ_Handler

To implement your own exception handler, define a function using the appropriate
exception function name from the list above.

For example to add an interrupt function in C, it is sufficient to define an interrupt
function named IRQ_Handler:

__irg __arm void IRQ_Handler ()
{
}

An interrupt function must have C linkage, read more in Calling convention, page 163.
If you use C++, an interrupt function could look, for example, like this:

extern "C"
{

__irg __arm void IRQ_Handler (void) ;

__irg __arm void IRQ_Handler (void)
{
}

No other changes are needed.

INTERRUPTS AND FAST INTERRUPTS

The interrupt and fast interrupt functions are easy to handle as they do not accept
parameters or have a return value. Use any of these keywords:

o To declare an interrupt function, use the __irqg extended keyword or the #pragma
type_attribute=__irqg directive. For syntax information, see _irq, page 338
and type_attribute, page 366, respectively.

o To declare a fast interrupt function, use the __ fiqg extended keyword or the
#pragma type_attribute=__fiq directive. For syntax information, see __fiq,
page 338, and #ype_attribute, page 366, respectively.

Note: An interrupt function (irq) and a fast interrupt function (£ig) must have a return
type of void and cannot have any parameters. A software interrupt function (swi) may
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have parameters and return values. By default, only four registers, R0O-R3, can be used
for parameters and only the registers RO-R1 can be used for return values.

NESTED INTERRUPTS

Interrupts are automatically disabled by the ARM core prior to entering an interrupt
handler. If an interrupt handler re-enables interrupts, calls functions, and another
interrupt occurs, then the return address of the interrupted function—stored in LR—is
overwritten when the second IRQ is taken. In addition, the contents of SPSR will be
destroyed when the second interrupt occurs. The __irqg keyword itself does not save
and restore LR and SPSR. To make an interrupt handler perform the necessary steps
needed when handling nested interrupts, the keyword __nested must be used in
addition to __irqg. The function prolog—function entrance sequence—that the
compiler generates for nested interrupt handlers will switch from IRQ mode to system
mode. Make sure that both the IRQ stack and system stack is set up. If you use the
default cstartup. s file, both stacks are correctly set up.

Compiler-generated interrupt handlers that allow nested interrupts are supported for
IRQ interrupts only. The FIQ interrupts are designed to be serviced quickly, which in
most cases mean that the overhead of nested interrupts would be too high.

This example shows how to use nested interrupts with the ARM vectored interrupt
controller (VIC):

__irg _ _nested __arm void interrupt_handler (void)
{

void (*interrupt_task) ();

unsigned int vector;

/* Get interrupt vector. */
vector = VICVectAddr;

interrupt_task = (void(*) ()) vector;

/* Allow other IRQ interrupts to be serviced. */
__enable_interrupt () ;

/* Execute the task associated with this interrupt. */

(*interrupt_task) () ;

}

Note: The __nested keyword requires the processor mode to be in either User or
System mode.
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SOFTWARE INTERRUPTS

Software interrupt functions are slightly more complex than other interrupt functions, in
the way that they need a software interrupt handler (a dispatcher), are invoked (called)
from running application software, and that they accept arguments and have return
values. The mechanisms for calling a software interrupt function and how the software
interrupt handler dispatches the call to the actual software interrupt function is described
here.

Calling a software interrupt function

To call a software interrupt function from your application source code, the assembler
instruction SVC #immed is used, where immed is an integer value that is referred to as
the software interrupt number—or swi_number—in this guide. The compiler provides
an easy way to implicitly generate this instruction from C/C++ source code, by using the
__swi keyword and the #pragma swi_number directive when declaring the function.

A __swi function can for example be declared like this:

#pragma swi_number=0x23
__swi int swi_function(int a, int b);

In this case, the assembler instruction SvC 0x23 will be generated where the function
is called.

Software interrupt functions follow the same calling convention regarding parameters
and return values as an ordinary function, except for the stack usage, see Calling
convention, page 163.

For more information, see __swi, page 344, and swi_number, page 366, respectively.

The software interrupt handler and functions

The interrupt handler, for example SWI_Handler works as a dispatcher for software
interrupt functions. It is invoked from the interrupt vector and is responsible for
retrieving the software interrupt number and then calling the proper software interrupt
function. The SWI_Handler must be written in assembler as there is no way to retrieve
the software interrupt number from C/C++ source code.

The software interrupt functions

The software interrupt functions can be written in C or C++. Use the __swi keyword in
a function definition to make the compiler generate a return sequence suited for a
specific software interrupt function. The #pragma swi_number directive is not needed
in the interrupt function definition.

For more information, see __swi, page 344.
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Setting up the software interrupt stack pointer

If software interrupts will be used in your application, then the software interrupt stack
pointer (SVC_STACK) must be set up and some space must be allocated for the stack. The
SVC_STACK pointer can be set up together with the other stacks in the cstartup. s file.
As an example, see the set up of the interrupt stack pointer. Relevant space for the
SVC_STACK pointer is set up in the linker configuration file, see Setting up stack
memory, page 97.

INTERRUPT OPERATIONS

An interrupt function is called when an external event occurs. Normally it is called
immediately while another function is executing. When the interrupt function has
finished executing, it returns to the original function. It is imperative that the
environment of the interrupted function is restored; this includes the value of processor
registers and the processor status register.

When an interrupt occurs, the following actions are performed:

o The operating mode is changed corresponding to the particular exception

e The address of the instruction following the exception entry instruction is saved in
R14 of the new mode

o The old value of the CPSR is saved in the SPSR of the new mode

e Interrupt requests are disabled by setting bit 7 of the CPSR and, if the exception is a
fast interrupt, further fast interrupts are disabled by setting bit 6 of the CPSrR

o The PC is forced to begin executing at the relevant vector address.

For example, if an interrupt for vector 0x18 occurs, the processor will start to execute
code at address 0x18. The memory area that is used as start location for interrupts is
called the interrupt vector table. The content of the interrupt vector is normally a branch
instruction jumping to the interrupt routine.

Note: If the interrupt function enables interrupts, the special processor registers needed
to return from the interrupt routine must be assumed to be destroyed. For this reason they
must be stored by the interrupt routine to be restored before it returns. This is handled
automatically if the __nested keyword is used.

Inlining functions
Function inlining means that a function, whose definition is known at compile time, is
integrated into the body of its caller to eliminate the overhead of the function call. This
optimization, which is performed at optimization level High, normally reduces
execution time, but might increase the code size. The resulting code might become more
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difficult to debug. Whether the inlining actually occurs is subject to the compiler’s
heuristics.

The compiler heuristically decides which functions to inline. Different heuristics are
used when optimizing for speed, size, or when balancing between size and speed.
Normally, code size does not increase when optimizing for size.

C VERSUS C++ SEMANTICS

In C++, all definitions of a specific inline function in separate translation units must be
exactly the same. If the function is not inlined in one or more of the translation units,
then one of the definitions from these translation units will be used as the function
implementation.

In C, you must manually select one translation unit that includes the non-inlined version
of an inline function. You do this by explicitly declaring the function as extern in that
translation unit. If you declare the function as extern in more than one translation unit,
the linker will issue a multiple definition error. In addition, in C, inline functions cannot
refer to static variables or functions.

For example:

// In a header file.

static int sX;

inline void F(void)

{
//static int sY; // Cannot refer to statics.
//sX; // Cannot refer to statics.

// In one source file.
// Declare this F as the non-inlined version to use.
extern inline void F();

FEATURES CONTROLLING FUNCTION INLINING
There are several mechanisms for controlling function inlining:

o The inline keyword advises the compiler that the function defined immediately
after the directive should be inlined.

If you compile your function in C or C++ mode, the keyword will be interpreted
according to its definition in Standard C or Standard C++, respectively.

The main difference in semantics is that in Standard C you cannot (in general) simply
supply an inline definition in a header file. You must supply an external definition in
one of the compilation units, by designating the inline definition as being external in
that compilation unit.
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® d#pragma inline is similar to the inline keyword, but with the difference that the
compiler always uses C++ inline semantics.

By using the #pragma inline directive you can also disable the compiler’s
heuristics to either force inlining or completely disable inlining. For more
information, see inline, page 356.

® --use_c++_inline forces the compiler to use C++ semantics when compiling a
Standard C source code file.

® --no_inline, #pragma optimize=no_inline, and #pragma inline=never
all disable function inlining. By default, function inlining is enabled at optimization
level High.

The compiler can only inline a function if the definition is known. Normally, this is
restricted to the current translation unit. However, when the --mfc compiler option for
multi-file compilation is used, the compiler can inline definitions from all translation
units in the multi-file compilation unit. For more information, see Multi-file compilation
units, page 221.

For more information about the function inlining optimization, see Function inlining,
page 224.
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Linking—an overview

The IAR ILINK Linker is a powerful, flexible software tool for use in the development
of embedded applications. It is equally well suited for linking small, single-file, absolute
assembler programs as it is for linking large, relocatable, multi-module, C/C++, or
mixed C/C++ and assembler programs.

The linker combines one or more relocatable object files—produced by the IAR
Systems compiler or assembler—with selected parts of one or more object libraries to
produce an executable image in the industry-standard format Executable and Linking
Format (ELF).

The linker will automatically load only those library modules—user libraries and
Standard C or C++ library variants—that are actually needed by the application you are
linking. Further, the linker eliminates duplicate sections and sections that are not
required.

ILINK can link both ARM and Thumb code, as well as a combination of them. By
automatically inserting additional instructions (veneers), ILINK will assure that the
destination will be reached for any calls and branches, and that the processor state is
switched when required. For more details about how to generate veneers, see Veneers,
page 103.

The linker uses a configuration file where you can specify separate locations for code
and data areas of your target system memory map. This file also supports automatic
handling of the application’s initialization phase, which means initializing global
variable areas and code areas by copying initializers and possibly decompressing them
as well.
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The final output produced by ILINK is an absolute object file containing the executable
image in the ELF (including DWARF for debug information) format. The file can be
downloaded to C-SPY or any other compatible debugger that supports ELF/DWARE, or
it can be stored in EPROM or flash.

To handle ELF files, various tools are included. For information about included utilities,
see Specific ELF tools, page 40.

Modules and sections
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Each relocatable object file contains one module, which consists of:

o Secveral sections of code or data

o Runtime attributes specifying various types of information, for example the version
of the runtime environment

o Optionally, debug information in DWARF format

e A symbol table of all global symbols and all external symbols used.

A section is a logical entity containing a piece of data or code that should be placed at a
physical location in memory. A section can consist of several section fragments,
typically one for each variable or function (symbols). A section can be placed either in
RAM or in ROM. In a normal embedded application, sections that are placed in RAM
do not have any content, they only occupy space.

Each section has a name and a type attribute that determines the content. The type
attribute is used (together with the name) for selecting sections for the ILINK
configuration. The most commonly used attributes are:

code Executable code
readonly Constant variables
readwrite Initialized variables
zeroinit Zero-initialized variables

Note: In addition to these section types—sections that contain the code and data that are
part of your application—a final object file will contain many other types of sections,
for example sections that contain debugging information or other type of meta
information.

A section is the smallest linkable unit; but if possible, ILINK can exclude smaller
units—section fragments—from the final application. For more information, see
Keeping modules, page 97, and Keeping symbols and sections, page 97.
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At compile time, data and functions are placed in different sections. At link time, one of
the most important functions of the linker is to assign addresses to the various sections
used by the application.

The IAR build tools have many predefined section names. See the chapter Section
reference for more information about each section.

You can group sections together for placement by using blocks. See define block
directive, page 432.

The linking process in detail

The relocatable modules in object files and libraries, produced by the IAR compiler and
assembler, cannot be executed as is. To become an executable application, they must be
linked.

Note: Modules produced by a toolset from another vendor can be included in the build
as well, as long as the module is AEABI (ARM Embedded Application Binary
Interface) compliant. Be aware that this also might require a compiler utility library
from the same vendor.

The linker is used for the link process. It normally performs the following procedure
(note that some of the steps can be turned off by command line options or by directives
in the linker configuration file):

o Determine which modules to include in the application. Modules provided in object
files are always included. A module in a library file is only included if it provides a
definition for a global symbol that is referenced from an included module.

o Select which standard library files to use. The selection is based on attributes of the
included modules. These libraries are then used for satisfying any still outstanding
undefined symbols.

e Handle symbols with more than one definition. If there is more than one non-weak
definition, an error is emitted. Otherwise, one of the definitions is picked (the
non-weak one, if there is one) and the others are suppressed. Weak definitions are
typically used for inline and template functions. If you need to override some of the
non-weak definitions from a library module, you must ensure that the library
module is not included (typically by providing alternate definitions for all the
symbols your application uses in that library module).

o Determine which sections/section fragments from the included modules to include
in the application. Only those sections/section fragments that are actually needed by
the application are included. There are several ways to determine of which
sections/section fragments that are needed, for example, the __root object
attribute, the #pragma required directive, and the keep linker directive. In case
of duplicate sections, only one is included.
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Where appropriate, arrange for the initialization of initialized variables and code in
RAM. The initialize directive causes the linker to create extra sections to
enable copying from ROM to RAM. Each section that will be initialized by copying
is divided into two sections, one for the ROM part and one for the RAM part. If
manual initialization is not used, the linker also arranges for the startup code to
perform the initialization.

Determine where to place each section according to the section placement directives
in the /inker configuration file. Sections that are to be initialized by copying appear
twice in the matching against placement directives, once for the ROM part and once
for the RAM part, with different attributes. During the placement, the linker also
adds any required veneers to make a code reference reach its destination or to
switch CPU modes.

Produce an absolute file that contains the executable image and any debug
information provided. The contents of each needed section in the relocatable input
files is calculated using the relocation information supplied in its file and the
addresses determined when placing sections. This process can result in one or more
relocation failures if some of the requirements for a particular section are not met,
for instance if placement resulted in the destination address for a pc-relative jump
instruction being out of range for that instruction.

Optionally, produce a map file that lists the result of the section placement, the
address of each global symbol, and finally, a summary of memory usage for each
module and library.
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This illustration shows the linking process:
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During the linking, ILINK might produce error messages and logging messages on
stdout and stderr. The log messages are useful for understanding why an application
was linked as it was. For example, why a module or section (or section fragment) was
included.

Note: To see the actual content of an ELF object file, use iel fdumparm. See The [AR
ELF Dumper—ielfdump, page 470.

Placing code and data—the linker configuration file

The placement of sections in memory is performed by the IAR ILINK Linker. It uses the
linker configuration file where you can define how ILINK should treat each section and
how they should be placed into the available memories.

A typical linker configuration file contains definitions of:

e Available addressable memories
o Populated regions of those memories
e How to treat input sections

o Created sections
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e How to place sections into the available regions.

The file consists of a sequence of declarative directives. This means that the linking
process will be governed by all directives at the same time.

To use the same source code with different derivatives, just rebuild the code with the
appropriate configuration file.

A SIMPLE EXAMPLE OF A CONFIGURATION FILE

Assume a simple 32-bit architecture that has these memory prerequisites:

There are 4 Gbytes of addressable memory.
There is ROM memory in the address range 0x0000-0x10000.
There is RAM memory in the range 0x20000-0x30000.

The stack has an alignment of 8.

o The system startup code must be located at a fixed address.
A simple configuration file for this assumed architecture can look like this:

/* The memory space denoting the maximum possible amount
of addressable memory */
define memory Mem with size = 4G;

/* Memory regions in an address space */
define region ROM = Mem: [from 0x00000 size 0x100007;
define region RAM = Mem: [from 0x20000 size 0x10000];

/* Create a stack */
define block STACK with size = 0x1000, alignment = 8 { };

/* Handle initialization */

do not initialize { section .noinit };

initialize by copy { readwrite }; /* Initialize RW sections,
exclude zero-initialized
sections */

/* Place startup code at a fixed address */
place at start of ROM { readonly section .cstartup };

/* Place code and data */
place in ROM { readonly }; /* Place constants and initializers in

ROM: .rodata and .data_init */
place in RAM { readwrite, /* Place .data, .bss, and .noinit */
block STACK }; /* and STACK */

IAR C/C++ Development Guide
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This configuration file defines one addressable memory Mem with the maximum of
4 Gbytes of memory. Further, it defines a ROM region and a RAM region in Mem,
namely ROM and RaM. Each region has the size of 64 Kbytes.

The file then creates an empty block called STACK with a size of 4 Kbytes in which the
application stack will reside. To create a block is the basic method which you can use to
get detailed control of placement, size, etc. It can be used for grouping sections, but also
as in this example, to specify the size and placement of an area of memory.

Next, the file defines how to handle the initialization of variables, read/write type
(readwrite) sections. In this example, the initializers are placed in ROM and copied at
startup of the application to the RAM area. By default, ILINK may compress the
initializers if this appears to be advantageous.

The last part of the configuration file handles the actual placement of all the sections into
the available regions. First, the startup code—defined to reside in the read-only
(readonly) section .cstartup—is placed at the start of the ROM region, that is at
address 0x10000. Note that the part within {} is referred to as section selection and it
selects the sections for which the directive should be applied to. Then the rest of the
read-only sections are placed in the ROM region. Note that the section selection

{ readonly section .cstartup } takes precedence over the more generic section
selection { readonly }.

Finally, the read/write (readwrite) sections and the STACK block are placed in the RAM
region.
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This illustration gives a schematic overview of how the application is placed in memory:
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In addition to these standard directives, a configuration file can contain directives that
define how to:

Memory Mem

Region Data

Map a memory that can be addressed in multiple ways
Handle conditional directives
Create symbols with values that can be used in the application

More in detail, select the sections a directive should be applied to

More in detail, initialize code and data.

For more details and examples about customizing the linker configuration file, see the
chapter Linking your application.

For more information about the linker configuration file, see the chapter The linker
configuration file.

Initialization at system startup
In Standard C, all static variables—variables that are allocated at a fixed memory
address—must be initialized by the runtime system to a known value at application
startup. This value is either an explicit value assigned to the variable, or if no value is

IAR C/C++ Development Guide
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given, it is cleared to zero. In the compiler, there are exceptions to this rule, for example
variables declared __no_init, which are not initialized at all.

The compiler generates a specific type of section for each type of variable initialization:

Categories of ) ) Section
Source Section type  Section name

declared data content

Zero-initialized int i; Read/write .bss None

data data, zero-init

Zero-initialized int i = 0; Read/write .bss None

data data, zero-init

Initialized data int 1 = 6; Read/write .data The

(non-zero) data initializer

Non-initialized __no_init int i; Read/write .noinit None

data data, zero-init

Constants const int i = 6; Read-onlydata .rodata The
constant

Code __ramfunc void Read/write .textrw The code

myfunc () {} code

Table 3: Sections holding initialized data

Note: Clustering of static variables might group zero-initialized variables together with
initialized data in .data. The compiler can decide to place constants in the . text
section to avoid loading the address of a constant from a constant table.

For information about all supported sections, see the chapter Section reference.

THE INITIALIZATION PROCESS
Initialization of data is handled by ILINK and the system startup code in conjunction.
To configure the initialization of variables, you must consider these issues:

e Sections that should be zero-initialized are handled automatically by ILINK; they
should only be placed in RAM

o Sections that should be initialized, except for zero-initialized sections, should be
listed in an initialize directive

Normally during linking, a section that should be initialized is split into two sections,
where the original initialized section will keep the name. The contents are placed in
the new initializer section, which will get the original name suffixed with _init. The
initializers should be placed in ROM and the initialized sections in RAM, by means
of placement directives. The most common example is the . data section which the
linker splits into .data and .data_init.
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e Sections that contains constants should not be initialized; they should only be
placed in flash/ROM

e Sections holding __no_init declared variables should not be initialized and thus

should be listed in a do not initialize directive. They should also be placed in
RAM.

In the linker configuration file, it can look like this:

/* Handle initialization */

do not initialize { section .noinit };

initialize by copy { readwrite }; /* Initialize RW sections,
exclude zero-initialized
sections */

/* Place startup code at a fixed address */
place at start of ROM { readonly section .cstartup };

/* Place code and data */
place in ROM { readonly }; /* Place constants and initializers in

ROM: .rodata and .data_init */
place in RAM { readwrite, /* Place .data, .bss, and .noinit */
block STACK }; /* and STACK */

Note: When compressed initializers are used (see initialize directive, page 434), the
contents sections (that is, sections with the _init suffix) are not listed as separate
sections in the map file. Instead, they are combined into aggregates of “initializer bytes”.
You can place the contents sections the usual way in the linker configuration file;
however, this affects the placement (and possibly the number) of the “initializer bytes”
aggregates.

For more information about and examples of how to configure the initialization, see
Linking considerations, page 93.

C++ DYNAMIC INITIALIZATION

The compiler places subroutine pointers for performing C++ dynamic initialization into
sections of the ELF section types SHT_PREINIT_ARRAY and SHT_INIT_ ARRAY. By
default, the linker will place these into a linker-created block, ensuring that all sections
of the section type SHT_PREINIT_ARRAY are placed before those of the type
SHT_INIT_ARRAY. Ifany such sections were included, code to call the routines will also
be included.

The linker-created blocks are only generated if the linker configuration does not contain
section selector patterns for the preinit_array and init_array section types. The
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effect of the linker-created blocks will be very similar to what happens if the linker
configuration file contains this:

define block SHTS$SPREINIT_ARRAY { preinit_array };

define block SHTSSINIT ARRAY { init_array };

define block CPP_INIT with fixed order { block
SHTSSPREINIT ARRAY,
block SHTSSINIT_ARRAY };

If you put this into your linker configuration file, you must also mention the CPP_INIT
block in one of the section placement directives. If you wish to select where the
linker-created block is placed, you can use a section selector with the name

".init_array".

See also section-selectors, page 440.

Stack usage analysis

This section describes how to perform a stack usage analysis using the linker.

In the ARM\ src directory, you can find an example project that demonstrates stack usage
analysis.

INTRODUCTION TO STACK USAGE ANALYSIS

Under the right circumstances, the linker can accurately calculate the maximum stack
usage for each call graph, starting from the program start, interrupt functions, tasks etc.
(each function that is not called from another function, in other words, the root).

If you enable stack usage analysis, a stack usage chapter will be added to the linker map
file, listing for each call graph root the particular call chain which results in the
maximum stack depth.

The analysis is only accurate if there is accurate stack usage information for each
function in the application.

In general, the compiler will generate this information for each C function, but if there
are indirect calls (calls using function pointers) in your application, you must supply a
list of possible functions that can be called from each calling function.

If you use a stack usage control file, you can also supply stack usage information for
functions in modules that do not have stack usage information.

You can use the check that directive in your linker configuration file to check that the
stack usage calculated by the linker does not exceed the stack space you have allocated.
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PERFORMING A STACK USAGE ANALYSIS
Enable stack usage analysis:

In the IDE, choose Project>Options>Linker>Advanced>Enable stack usage
analysis

On the command line, use the linker option --enable_stack_usage
See --enable_stack usage, page 300.
Enable the linker map file:

In the IDE, choose Project>Options>Linker>List>Generate linker map file

On the command line, use the linker option --map

Link your project. Note that the linker will issue warnings related to stack usage under
certain circumstances, see Situations where warnings are issued, page 90.

Review the linker map file, which now contains a stack usage chapter with a summary
of the stack usage for each call graph root. For more information, see Result of an
analysis—the map file contents, page 87.

For more details, analyze the call graph log, see Call graph log, page 90.

Note that there are limitations and sources of inaccuracy in the analysis, see Limitations,
page 89.

You might need to specify more information to the linker to get a more representative
result. See Specifying additional stack usage information, page 88

In the IDE, choose Project>Options>Linker>Advanced>Enable stack usage
analysis>Control file

On the command line, use the linker option --stack_usage_control
See --stack_usage control, page 316.

To add an automatic check that you have allocated memory enough for the stack, use
the check that directive in your linker configuration file. For example, assuming a
stack block named MY_STACK, you can write like this:

check that size(block MY_STACK) >=maxstack("Program entry")
+ totalstack("interrupt") + 100;
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When linking, the linker emits an error if the expression is false (zero). In this example,
an error will be emitted if the sum of the following exceeds the size of the MY_STACK
block:

o The maximum stack usage in the category Program entry (the main program).

o The sum of each individual maximum stack usage in the category interrupt
(assuming that all interrupt routines need space at the same time).

o A safety margin of 100 bytes (to account for stack usage not visible to the analysis).

See check that directive, page 444.

RESULT OF AN ANALYSIS—THE MAP FILE CONTENTS

When stack usage analysis is enabled, the linker map file contains a stack usage chapter
with a summary of the stack usage for each call graph root category, and lists the call
chain that results in the maximum stack depth for each call graph root. This is an
example of what the stack usage chapter in the map file might look like:

EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEREEEEREEREREERERERESESERESRESEEEEEEESEESE]

*** STACK USAGE

* kK

Call Graph Root Category Max Use Total Use

interrupt 104 136
Program entry 168 168

Program entry
"__lar_program_start": 0x000085ac

Maximum call chain 168 bytes
"__lar_program_start" 0
" _cmain" 0
"main" 8
"printf" 24
"_PrintfTiny" 56
"_Prout" 16
"putchar" 16
"__write" 0
" _dwrite" 0
"__iar_sh_stdout" 24
"__iar_get_ttio" 24
"__iar_lookup_ttioh" 0
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interrupt
"FaultHandler": 0x00008434

Maximum call chain 32 bytes
"FaultHandler" 32
interrupt

"IRQHandler": 0x00008424

Maximum call chain 104 bytes
"IRQHandler" 24
"do_something" in suexample.o [1] 80

The summary contains the depth of the deepest call chain in each category as well as the
sum of the depths of the deepest call chains in that category.

Each call graph root belongs to a call graph root category to enable convenient
calculations in check that directives.

SPECIFYING ADDITIONAL STACK USAGE INFORMATION

To specify additional stack usage information you can use either a stack usage control
file (suc) where you specify stack usage control directives or annotate the source code.

You can:

o Specify complete stack usage information (call graph root category, stack usage,
and possible calls) for a function, by using the stack usage control directive
function. Typically, you do this if stack usage information is missing, for example
in an assembler module. In your suc file you can for example write like this:
function MyFunc: 32,

calls MyFunc?2,
calls MyFunc3, MyFuncd: 16;

function [interrupt] MyInterruptHandler: 44;
See also function directive, page 458.

o Exclude certain functions from stack usage analysis, by using the stack usage
control directive exclude. In your suc file you can for example write like this:

exclude MyFunc5, MyFuncé;
See also exclude directive, page 458.

e Specify a list of possible destinations for indirect calls in a function, by using the
stack usage control directive possible calls. Use this for functions which are
known to perform indirect calls and where you know exactly which functions that



Linking using ILINK °

might be called in this particular application. In your suc file you can for example
write like this:

possible calls MyFunc7: MyFunc8, MyFunc9;

If the information about which functions that might be called is available at compile
time, consider using the #pragma calls directive instead.

See also possible calls directive, page 460 and calls, page 350.

e Specify that functions are call graph roots, including an optional call graph root
category, by using the stack usage control directive call graph root or the
#pragma call_graph_root directive. In your suc file you can for example write
like this:

call graph root [task]: MyFunclO, MyFuncll;

If your interrupt functions have not already been designated as call graph roots by the
compiler, you must do so manually. You can do this either by using the #pragma
call_graph_root directive in your source code or by specifying a directive in your
suc file, for example:

call graph root [interrupt]: IrglHandler, Irg2Handler;
See also call graph root directive, page 458 and call_graph root, page 351.

o Specify a maximum number of iterations through any of the cycles in the recursion
nest of which the function is a member. In your suc file you can for example write
like this:

max recursion depth MyFuncl2: 10;

o Selectively suppress the warning about unmentioned functions referenced by a
module for which you have supplied stack usage information in the stack usage
control file. Use the no calls from directive in your suc file, for example like
this:
no calls from [file.o] to MyFuncl3, MyFuncl4;

For more information, see the chapter Specifying additional stack usage information,
page 88.

LIMITATIONS

Apart from missing or incorrect stack usage information, there are also other sources of
inaccuracy in the analysis:

o The linker cannot always identify all functions in object modules that lack stack
usage information. In particular, this might be a problem with object modules
written in assembly language or produced by non-IAR tools. You can provide stack
usage information for such modules using a stack usage control file, and for
assembly language modules you can also annotate the assembler source code with
CFI directives to provide stack usage information. See the /AR Assembler User
Guide for ARM.

89



Stack usage analysis

90

IAR C/C++ Development Guide
Compiling and Linking for ARM

e If you use inline assembler to change the frame size or to perform function calls,
this will not be reflected in the analysis.

o Extra space consumed by other sources (the processor, an operating system, etc) is
not accounted for.
o C++ source code that uses exceptions is not supported.

If you use other forms of function calls, like software interrupts, they will not be
reflected in the call graph.

o Using multi-file compilation (--m£fc) can interfere with using a stack usage control
file to specify properties of module-local functions in the involved files.

Note that stack usage analysis produces a worst case result. The program might not
actually ever end up in the maximum call chain, by design, or by coincidence. In
particular, the set of possible destinations for a virtual function call in C++ might
sometimes include implementations of the function in question which cannot, in fact, be
called from that point in the code.

Stack usage analysis is only a complement to actual measurement. If the result is
important, you need to perform independent validation of the results of the analysis.

SITUATIONS WHERE WARNINGS ARE ISSUED

When stack usage analysis is enabled in the linker, warnings will be generated in the
following circumstances:

e There is a function without stack usage information.

o There is an indirect call site in the application for which a list of possible called
functions has not been supplied.

o There are no known indirect calls, but there is an uncalled function that is not
known to be a call graph root.
o The application contains recursion (a cycle in the call graph) for which no

maximum recursion depth has been supplied, or which is of a form for which the
linker is unable to calculate a reliable estimate of stack usage.

o There are calls to a function declared as a call graph root.

® You have used the stack usage control file to supply stack usage information for
functions in a module that does not have such information, and there are functions
referenced by that module which have not been mentioned as being called in the
stack usage control file.

CALL GRAPH LOG

To help you interpret the results of the stack usage analysis, there is a log output option
that produces a simple text representation of the call graph (--log call_graph).
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Example output:

Program entry:
0 _ iar_program_start [168]

0 _ _cmain [168]
0 _ diar_data_init3 [16]
8 __iar_zero_init3 [8]
16 - [0]
8 __iar_copy_init3 [8]
16 - [0]
0 _ _low_level_init [O0]

0 main [168]
8 printf [160]
32 _PrintfTiny [136]
88 _Prout [80]
104 putchar [64]
120 __write [48]
120 __dwrite [48]
120 __iar_sh_stdout [48]
144 _ iar_get_ttio [24]
168 __iar_lookup_ttioh [0]
120 __iar_sh _write [24]
144 - [0]
88 _ aeabi_uidiv [0]
88 __aeabi_idiv0 [0]
88 strlen [0]

0 exit [8]
0 _exit [8]
0 __exit [8]
0 _ iar_close_ttio [8]
8 _ _iar_lookup_ttioh [0] ***
0 __exit [8] **x*

Each line consists of this information:

The stack usage at the point of call of the function

The name of the function, or a single '-' to indicate usage in a function at a point
with no function call (typically in a leaf function)

o The stack usage along the deepest call chain from that point. If no such value could
be calculated, "[---]" is output instead. "***" marks functions that have already
been shown.

CALL GRAPH XML OUTPUT

The linker can also produce a call graph file in XML format. This file contains one node
for each function in your application, with the stack usage and call information relevant
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to that function. It is intended to be input for post-processing tools and is not particularly
human-readable.

For more information about the XML format used, see the callGraph. txt file in your
product installation.
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e Linking considerations
e Hints for troubleshooting

e Checking module consistency

Linking considerations

Before you can link your application, you must set up the configuration required by
ILINK. Typically, you must consider:

Choosing a linker configuration file

Defining your own memory areas

Placing sections

Reserving space in RAM

Keeping modules

Keeping symbols and sections

Application startup

Setting up stack memory

Setting up heap memory

Setting up the atexit limit

Changing the default initialization

Interaction between ILINK and the application
Standard library handling

Producing other output formats than ELF/DWARF

CHOOSING A LINKER CONFIGURATION FILE

The config directory contains two ready-made templates for the linker configuration
files:

® generic.icf, designed for all cores except for Cortex-M cores

® generic_cortex.icf, designed for all Cortex-M cores.

The files contain the information required by ILINK. The only change, if any, you will

normally have to make to the supplied configuration file is to customize the start and end
addresses of each region so they fit the target system memory map. If, for example, your
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application uses additional external RAM, you must also add details about the external
RAM memory area.

For some devices, device-specific configuration files are automatically selected.

To edit a linker configuration file, use the editor in the IDE, or any other suitable editor.
Alternatively, choose Project>Options>Linker and click the Edit button on the Config
page to open the dedicated linker configuration file editor.

Do not change the original template file. We recommend that you make a copy in the
working directory, and modify the copy instead. If you are using the linker configuration
file editor in the IDE, the IDE will make a copy for you.

Each project in the IDE should have a reference to one, and only one, linker
configuration file. This file can be edited, but for the majority of all projects it is
sufficient to configure the vital parameters in Project>Options>Linker>Config.

DEFINING YOUR OWN MEMORY AREAS

The default configuration file that you selected has predefined ROM and RAM regions.
This example will be used as a starting-point for all further examples in this chapter:

/* Define the addressable memory */
define memory Mem with size = 4G;

/* Define a region named ROM with start address 0 and to be 64
Kbytes large */
define region ROM = Mem: [from 0 size 0x10000];

/* Define a region named RAM with start address 0x20000 and to be
64 Kbytes large */
define region RAM = Mem: [from 0x20000 size 0x10000];

Each region definition must be tailored for the actual hardware.

To find out how much of each memory that was filled with code and data after linking,
inspect the memory summary in the map file (command line option --map).

Adding an additional region
To add an additional region, use the define region directive, for example:

/* Define a 2nd ROM region to start at address 0x80000 and to be
128 Kbytes large */
define region ROM2 = Mem: [from 0x80000 size 0x20000];
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Merging different areas into one region

If the region is comprised of several areas, use a region expression to merge the different
areas into one region, for example:

/* Define the 2nd ROM region to have two areas. The first with
the start address 0x80000 and 128 Kbytes large, and the 2nd with
the start address 0xC0000 and 32 Kbytes large */
define region ROM2 = Mem: [from 0x80000 size 0x20000]

| Mem: [from 0xC0000 size 0x08000];

or equivalently

define region ROM2 = Mem: [from 0x80000 to OxC7FFF]
—-Mem: [from 0xA0000 to OxBFFFF];

PLACING SECTIONS

The default configuration file that you selected places all predefined sections in memory,
but there are situations when you might want to modify this. For example, if you want
to place the section that holds constant symbols in the CONSTANT region instead of in
the default place. In this case, use the place in directive, for example:

/* Place sections with readonly content in the ROM region */
place in ROM {readonly};

/* Place the constant symbols in the CONSTANT region */
place in CONSTANT {readonly section .rodata};

Note: Placing a section—used by the IAR build tools—in a different memory which use
a different way of referring to its content, will fail.

For the result of each placement directive after linking, inspect the placement summary
in the map file (the command line option --map).
Placing a section at a specific address in memory

To place a section at a specific address in memory, use the place at directive, for
example:

/* Place section .vectors at address 0 */

place at address Mem:0x0 {readonly section .vectors};
Placing a section first or last in a region

To place a section first or last in a region is similar, for example:

/* Place section .vectors at start of ROM */
place at start of ROM {readonly section .vectors};

95



Linking considerations

96

IAR C/C++ Development Guide
Compiling and Linking for ARM

Declare and place your own sections

To declare new sections—in addition to the ones used by the IAR build tools—to hold
specific parts of your code or data, use mechanisms in the compiler and assembler. For
example:

/* Place a variable in that section. */
const short MyVariable @ "MYOWNSECTION" = OxFOFO;

This is the corresponding example in assembler language:

name createSection

section MYOWNSECTION:CONST ; Create a section,
; and fill it with

dclé6 O0xFOFO0 ; constant bytes.

end

To place your new section, the original place in ROM {readonly}; directive is
sufficient.

However, to place the section MyOwnSection explicitly, update the linker configuration
file with a place in directive, for example:

/* Place MyOwnSection in the ROM region */
place in ROM {readonly section MyOwnSection};

RESERVING SPACE IN RAM

Often, an application must have an empty uninitialized memory area to be used for
temporary storage, for example a heap or a stack. It is easiest to achieve this at link time.
You must create a block with a specified size and then place it in a memory.

In the linker configuration file, it can look like this:

define block TempStorage with size = 0x1000, alignment = 4 { };
place in RAM { block TempStorage };

To retrieve the start of the allocated memory from the application, the source code could
look like this:

/* Define a section for temporary storage. */
#pragma section = "TempStorage"
char *GetTempStorageStartAddress()
{
/* Return start address of section TempStorage. */
return __ section_begin ("TempStorage") ;
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KEEPING MODULES

If a module is linked as an object file, it is always kept. That is, it will contribute to the
linked application. However, if a module is part of a library, it is included only if it is
symbolically referred to from other parts of the application. This is true, even if the
library module contains a root symbol. To assure that such a library module is always
included, use iarchive to extract the module from the library, see The IAR Archive
Tool—iarchive, page 465.

For information about included and excluded modules, inspect the log file (the
command line option --1og modules).

For more information about modules, see Modules and sections, page 76.

KEEPING SYMBOLS AND SECTIONS

By default, ILINK removes any sections, section fragments, and global symbols that are
not needed by the application. To retain a symbol that does not appear to be needed—or
actually, the section fragment it is defined in—you can either use the root attribute on
the symbol in your C/C++ or assembler source code, or use the ILINK option --keep.
To retain sections based on attribute names or object names, use the directive keep in
the linker configuration file.

To prevent ILINK from excluding sections and section fragments, use the command line
options --no_remove Or --no_fragments, respectively.

For information about included and excluded symbols and sections, inspect the log file
(the command line option --1log sections).

For more information about the linking procedure for keeping symbols and sections, see
The linking process, page 48.
APPLICATION STARTUP

By default, the point where the application starts execution is defined by the
__iar_program_start label, which is defined to point at the start of the cstartup.s
file. The label is also communicated via ELF to any debugger that is used.

To change the start point of the application to another label, use the ILINK option
--entry; see --entry, page 301.
SETTING UP STACK MEMORY

The size of the cSTACK block is defined in the linker configuration file. To change the
allocated amount of memory, change the block definition for CSTACK:

define block CSTACK with size = 0x2000, alignment = 8{ };

Specify an appropriate size for your application.
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For more information about the stack, see Stack considerations, page 198.

SETTING UP HEAP MEMORY
The size of the heap is defined in the linker configuration file as a block:

define block HEAP with size = 0x1000, alignment = 8{ };
place in RAM {block HEAP};

Specify the appropriate size for your application. If you use a heap, you must allocate at
least 50 bytes for it.

SETTING UP THE ATEXIT LIMIT

By default, the atexit function can be called a maximum of 32 times from your
application. To either increase or decrease this number, add a line to your configuration
file. For example, to reserve room for 10 calls instead, write:

define symbol __iar_maximum_atexit_calls = 10;

CHANGING THE DEFAULT INITIALIZATION

By default, memory initialization is performed during application startup. ILINK sets
up the initialization process and chooses a suitable packing method. If the default
initialization process does not suit your application and you want more precise control
over the initialization process, these alternatives are available:

e Suppressing initialization

o Choosing the packing algorithm

o Manual initialization

e Initializing code—copying ROM to RAM.

For information about the performed initializations, inspect the log file (the command
line option --1log initialization).

Suppressing initialization

If you do not want the linker to arrange for initialization by copying, for some or all
sections, make sure that those sections do not match a patternin an initialize by
copy directive (or use an except clause to exclude them from matching). If you do not
want any initialization by copying at all, you can omit the initialize by copy
directive entirely.

This can be useful if your application, or just your variables, are loaded into RAM by
some other mechanism before application startup.
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Choosing a packing algorithm
To override the default packing algorithm, write for example:
initialize by copy with packing = 1z77 { readwrite };

For more information about the available packing algorithms, see initialize directive,
page 434.

Manual initialization

In the usual case, the initialize by copy directive is used for making the linker
arrange for initialization by copying (with or without packing) of sections with content
at application startup. The linker achieves this by logically creating an initialization
section for each such section, holding the content of the section, and turning the original
section into a section without content. Then, the linker adds table elements to the
initialization table so that the initialization will be performed at application startup. You
canuse initialize manually to suppress the creation of table elements to take
control over when and how the elements are copied. This is useful for overlays, but also
in a number of other circumstances.

For sections without content (zero-initialized sections), the situation is reversed. The
linker arranges for zero initialization of all such sections at application startup, except
for those that have been mentioned in a do not initialize directive. Usually, only
.noinit sections are specified in a do not initialize directive, but you can add
any zero-initialized sections you like, and take direct control over when and how these
sections are initialized.

Simple copying example with an implicit block

Assume that you have some initialized variables in MYSECTION. If you add this directive
to your linker configuration file:

initialize manually { section MYSECTION };
you can use this source code example to initialize the section:

#pragma section = "MYSECTION"
#pragma section = "MYSECTION_init"

void DoInit ()

{
char * from = _ section_begin ("MYSECTION_init") ;
char * to = __section_begin("MYSECTION") ;
memcpy (to, from, _ section_size("MYSECTION")) ;
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This piece of source code takes advantage of the fact thatif youuse __section_begin
(and related operators) with a section name, a synthetic block is created by the linker for
those sections.

Example with explicit blocks

Assume that you instead of needing manual initialization for variables in a specific
section, you need it for all initialized variables from a particular library. In that case, you
must create explicit blocks for both the variables and the content. Like this:

initialize manually { section .data object mylib.a };
define block MYBLOCK { section .data object mylib.a };
define block MYBLOCK_init { section .data_init object mylib.a };

You must also place the two new blocks using one of the section placement directives,
the block MYBLOCK in RAM and the block MYBLOCK_init in ROM.

Then you can initialize the sections using the same source code as in the previous
example, only with MYBLOCK instead of MYSECTION.

Overlay example

This is a simple overlay example that takes advantage of automatic block creation:

initialize manually { section MYOVERLAY* };

define overlay MYOVERLAY { section MYOVERLAY1 };
define overlay MYOVERLAY { section MYOVERLAY2 };

You must also place overlay MYOVERLAY somewhere in RAM. The copying could
look like this:

#pragma section = "MYOVERLAY"
#pragma section = "MYOVERLAY1l_init"
#pragma section = "MYOVERLAY2_init"

void SwitchToOverlayl ()
{

char * from = _ section_begin ("MYOVERLAY1_init");
char * to = __section_begin ("MYOVERLAY") ;
memcpy (to, from, _ section_size("MYOVERLAY1l_init"));

void SwitchToOverlay?2 ()
{

char * from = __section_begin ("MYOVERLAY2_init");
char * to = _ section_begin ("MYOVERLAY") ;
memcpy (to, from, _ section_size("MYOVERLAY2_init"));
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Initializing code—copying ROM to RAM

Sometimes, an application copies pieces of code from flash/ROM to RAM. You can
direct the linker to arrange for this to be done automatically at application startup, or do
it yourself at some later time using the techniques described in Manual initialization,
page 99.

You need to list the code sections that should be copied in an initialize by copy
directive. The easiest way is usually to place the relevant functions in a particular section
(for example, RAMCODE), and add section RAMCODE to your initialize by copy
directive. For example:

initialize by copy { rw, section RAMCODE };

If you need to place the RAMCODE functions in some particular location, you must
mention them in a placement directive, otherwise they will be placed together with other
read/write sections.

If you need to control the manner and/or time of copying, you must use an initialize
manually directive instead. See Manual initialization, page 99.

If the functions need to run without accessing the flash/ROM, you can use the
__ramfunc keyword when compiling. See Execution in RAM, page 64.

Running all code from RAM

If you want to copy the entire application from ROM to RAM at program startup, use
the initilize by copy directive, for example:

initialize by copy { readonly, readwrite };

The readwrite pattern will match all statically initialized variables and arrange for
them to be initialized at startup. The readonly pattern will do the same for all read-only
code and data, except for code and data needed for the initialization.

Because the function __low_level_init, if present, is called before initialization, it
and anything it needs, will not be copied from ROM to RAM either. In some
circumstances—for example, if the ROM contents are no longer available to the
program after startup—you might need to avoid using the same functions during startup
and in the rest of the code.

If anything else should not be copied, include it in an except clause. This can apply to,
for example, the interrupt vector table.
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It is also recommended to exclude the C++ dynamic initialization table from being
copied to RAM, as it is typically only read once and then never referenced again. For
example, like this:

initialize by copy { readonly, readwrite }
except { section .intvec, /* Don’t copy
interrupt table */
section .init_array }; /* Don’t copy
C++ init table */

INTERACTION BETWEEN ILINK AND THE APPLICATION

ILINK provides the command line options --config_def and --define_symbol to
define symbols which can be used for controlling the application. You can also use
symbols to represent the start and end of a continuous memory area that is defined in the
linker configuration file. For more information, see Interaction between the tools and
your application, page 200.

To change a reference to one symbol to another symbol, use the ILINK command line
option --redirect. This is useful, for example, to redirect a reference from a
non-implemented function to a stub function, or to choose one of several different
implementations of a certain function, for example, how to choose the DLIB formatter
for the standard library functions printf and scanf.

The compiler generates mangled names to represent complex C/C++ symbols. If you
want to refer to these symbols from assembler source code, you must use the mangled
names.

For information about the addresses and sizes of all global (statically linked) symbols,
inspect the entry list in the map file (the command line option --map).

For more information, see Interaction between the tools and your application, page 200.

STANDARD LIBRARY HANDLING

By default, ILINK determines automatically which variant of the standard library to
include during linking. The decision is based on the sum of the runtime attributes
available in each object file and the library options passed to ILINK.

To disable the automatic inclusion of the library, use the option
--no_library_search. In this case, you must explicitly specify every library file to
be included. For information about available library files, see Prebuilt runtime libraries,
page 118.
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PRODUCING OTHER OUTPUT FORMATS THAN ELF/DWARF

ILINK can only produce an output file in the ELF/DWAREF format. To convert that
format into a format suitable for programming PROM/flash, see The IAR ELF
Tool—ielftool, page 468.

VENEERS
The ARM cores need to use veneers on two occasions:

o When calling an ARM function from Thumb mode or vice versa; the veneer then
changes the state of the microprocessor. The called function must be an
interworking function, see Interworking, page 56. If the core supports the BLX
instruction, a veneer is not needed for changing modes.

o When calling a function that it cannot normally reach; the veneer introduces code
which makes the call successfully reach the destination.

Code for veneers can be inserted between any caller and called function. As a result, the
R12 register must be treated as a scratch register at function calls, including functions
written in assembler. This also applies to jumps.

For more information, see --no_veneers, page 311.

Hints for troubleshooting
ILINK has several features that can help you manage code and data placement correctly,
for example:
o Messages at link time, for examples when a relocation error occurs

o The --1og option that makes ILINK log information to stdout, which can be
useful to understand why an executable image became the way it is, see --log, page
306

o The --map option that makes ILINK produce a memory map file, which contains
the result of the linker configuration file, see --map, page 307.

RELOCATION ERRORS

For each instruction that cannot be relocated correctly, ILINK will generate a relocation
error. This can occur for instructions where the target is out of reach or is of an
incompatible type, or for many other reasons.
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A relocation error produced by ILINK can look like this:

Error [Lp002]:

Kind
Location

Destination:

relocation failed: out of range or illegal value

R_XXX_YYY[0x1]
0x40000448

"myfunc" + 0x2c
Module: somecode.o
Section: 7 (.text)
Offset: O0x2c

0x9000000c
"read"
Module: read.o(iolib.a)

Section: 6 (.text)
Offset: 0x0

The message entries are described in this table:

Message entry

Description

Kind

Location

Destination

The relocation directive that failed. The directive depends on the
instruction used.

The location where the problem occurred, described with the following

details:

* The instruction address, expressed both as a hexadecimal value and as
a label with an offset. In this example, 0x40000448 and
"myfunc" + 0x2c

* The module, and the file. In this example, the
module somecode. o.

* The section number and section name. In this example, section

number 7 with the name . text.

* The offset, specified in number of bytes, in the section. In this

example, 0x2c.

The target of the instruction, described with the following details:

* The instruction address, expressed both as a hexadecimal value and as
a label with an offset. In this example, 0x9000000c¢ and
"read" (thus, no offset).

* The module, and when applicable the library. In this example, the
module read. o and the library iolib.a.

* The section number and section name. In this example, section

number 6 with the name . text.

* The offset, specified in number of bytes, in the section. In this

example, 0x0.

Table 4: Description of a relocation error
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Possible solutions

In this case, the distance from the instruction in myfunc to __read is too long for the
branch instruction.

Possible solutions include ensuring that the two . text sections are allocated closer to
each other or using some other calling mechanism that can reach the required distance.
It is also possible that the referring function tried to refer to the wrong target and that
this caused the range error.

Different range errors have different solutions. Usually, the solution is a variant of the
ones presented above, in other words modifying either the code or the section
placement.

Checking module consistency

This section introduces the concept of runtime model attributes, a mechanism used by
the tools provided by IAR Systems to ensure that modules that are linked into an
application are compatible, in other words, are built using compatible settings. The tools
use a set of predefined runtime model attributes. In addition to these, you can define your
own that you can use to ensure that incompatible modules are not used together.

Note: In addition to the predefined attributes, compatibility is also checked against the
AEABI runtime attributes. These attributes deal mainly with object code compatibility,
etc. They reflect compilation settings and are not user-configurable.

RUNTIME MODEL ATTRIBUTES

A runtime attribute is a pair constituted of a named key and its corresponding value. In
general, two modules can only be linked together if they have the same value for each
key that they both define.

There is one exception: if the value of an attribute is *, then that attribute matches any
value. The reason for this is that you can specify this in a module to show that you have
considered a consistency property, and this ensures that the module does not rely on that
property.

Note: For IAR predefined runtime model attributes, the linker checks them in several
ways.
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Example

In this table, the object files could (but do not have to) define the two runtime attributes
color and taste:

Object file Color Taste
filel blue not defined
file2 red not defined
file3 red *

filed red spicy
file5 red lean

Table 5: Example of runtime model attributes

In this case, £ilel cannot be linked with any of the other files, since the runtime
attribute color does not match. Also, file4 and £ile5 cannot be linked together,
because the taste runtime attribute does not match.

On the other hand, file2 and file3 can be linked with each other, and with either
file4 or £ile5, but not with both.

USING RUNTIME MODEL ATTRIBUTES

To ensure module consistency with other object files, use the #pragma rtmodel
directive to specify runtime model attributes in your C/C++ source code. For example,
if you have a UART that can run in two modes, you can specify a runtime model
attribute, for example vart. For each mode, specify a value, for example model and
mode?2. Declare this in each module that assumes that the UART is in a particular mode.
This is how it could look like in one of the modules:

#pragma rtmodel="uart", "model"

Alternatively, you can also use the rtmodel assembler directive to specify runtime
model attributes in your assembler source code. For example:

rtmodel "uart", "model"

Note that key names that start with two underscores are reserved by the compiler. For
more information about the syntax, see rtmodel, page 363 and the [AR Assembler User
Guide for ARM, respectively.

At link time, the IAR ILINK Linker checks module consistency by ensuring that
modules with conflicting runtime attributes will not be used together. If conflicts are
detected, an error is issued.
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e Additional information on the runtime environment

Introduction to the runtime environment

A runtime environment is the environment in which your application executes.
This section contains information about:

® Runtime environment functionality, page 107
e Briefly about input and output (1/0), page 108
o Briefly about C-SPY emulated 1/0, page 109
e Briefly about retargeting, page 110

RUNTIME ENVIRONMENT FUNCTIONALITY

The DLIB runtime environment supports Standard C and C++ and consists of:

o The C/C++ standard library, both its interface (provided in the system header files)
and its implementation.

e Startup and exit code.

o Low-level I/O interface for managing input and output (I/O).

e Special compiler support, for instance functions for switch handling or integer
arithmetics.

o Support for hardware features:

o Direct access to low-level processor operations by means of intrinsic functions,
such as functions for interrupt mask handling

o Peripheral unit registers and interrupt definitions in include files

o The Vector Floating Point (VFP) coprocessor.

Runtime environment functions are provided in a runtime library.
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The runtime library is delivered both as a prebuilt library and (depending on your
product package) as source files. The prebuilt libraries are available in different
configurations to meet various needs, see Runtime library configurations, page 117.
You can find the libraries in the product subdirectories arm\1ib and arm\src\1lib,
respectively.

For more information about the library, see the chapter C/C++ standard library
functions.

BRIEFLY ABOUT INPUT AND OUTPUT (1/O)

Every application must communicate with its environment. The application might for
example display information on an LCD, read a value from a sensor, get the current date
from the operating system, etc. Typically, your application performs I/O via the C/C++
standard library or some third-party library.

There are many functions in the C/C++ standard library that deal with I/O, including
functions for: standard character streams, file system access, time and date,
miscellaneous system actions, and termination and assert, This set of functions is
referred to as the standard /O interface.

On a desktop computer or a server, the operating system is expected to provide I/O
functionality to the application via the standard I/O interface in the runtime
environment. However, in an embedded system, the runtime library cannot assume that
such functionality is present, or even that there is an operating system at all. Therefore,
the low-level part of the standard I/O interface is not completely implemented by
default:

Your
application-specific
code
Standard I/O
interface | ____

DLIB runtime library
implementation

Low-level I!O implementation i
(unimplemented) ;

Environment
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To make the standard 1/O interface work, you can:

o Let the C-SPY debugger emulate I/O operations on the host computer, see Briefly
about C-SPY emulated 1/0, page 109

® Retarget the standard I/O interface to your target system by providing a suitable
implementation of the interface, see Briefly about retargeting, page 110.

Itis possible to mix these two approaches. You can, for example, let debug printouts and
asserts be emulated by the C-SPY debugger, but implement your own file system. The
debug printouts and asserts are useful during debugging, but no longer needed when
running the application stand-alone (not connected to the C-SPY debugger).

BRIEFLY ABOUT C-SPY EMULATED I/O

C-SPY emulated 1/0 is a mechanism which lets the runtime environment interact with
the C-SPY debugger to emulate I/O actions on the host computer:

Your
application-specific
code
Standard I/O
interface | —

DLIB runtime library
implementation

C-5PY emulated /O

l

Host computer

For example, when C-SPY emulated I/O is enabled:

e Standard character streams are directed to the C-SPY Terminal I/O window

e File system operations are performed on the host computer

o Time and date functions return the time and date of the host computer

e Termination and failed asserts break execution and notify the C-SPY debugger.
This behavior can be valuable during the early development of an application, for
example in an application that uses file I/O before any flash file system I/O drivers are
implemented, or if you need to debug constructions in your application that use stdin
and stdout without the actual hardware device for input and output being available.
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See Setting up your runtime environment, page 111 and The semihosting mechanism,
page 123.

BRIEFLY ABOUT RETARGETING

Retargeting is the process where you adapt the runtime environment so that your
application can execute I/O operations on your target system.

The standard I/O interface is large and complex. To make retargeting easier, the DLIB
runtime environment is designed so that it performs all I/O operations through a small
set of simple functions, which is referred to as the DLIB low-level I/O interface. By
default, the functions in the low-level interface lack usable implementations. Some are
unimplemented, others have stub implementations that do not perform anything except
returning error codes.

To retarget the standard I/O interface, all you have to do is to provide implementations
for the functions in the DLIB low-level I/O interface.

Your
application-specific
code
Standard IO
interface

DLIB runtime library
implementation

DLIB low-level
/O interface

Your low-level
implementation

|

Target system environment

For example, if your application calls the functions printf and fputc in the standard
1/0 interface, the implementations of those functions both call the low-level function
__write to output individual characters. To make them work, you just need to provide
an implementation of the __write function—either by implementing it yourself, or by
using a third-party implementation.

For information about how to override library modules with your own implementations,
see Overriding library modules, page 114. See also The DLIB low-level I/O interface,
page 131 for information about the functions that are part of the interface.
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Setting up the runtime environment

This section contains these tasks:

e Setting up your runtime environment, page 111

A runtime environment with basic project settings to be used during the initial phase
of development.

® Retargeting—Adapting the runtime environment for your target system, page 112
® Overriding library modules, page 114

o Customizing and building your own runtime library, page 115
See also:

® Managing a multithreaded environment, page 143 for information about how to
adapt the runtime environment to treat all library objects according to whether they
are global or local to a thread.

SETTING UP YOUR RUNTIME ENVIRONMENT

You can set up the runtime environment based on some basic project settings. It is also
often convenient to let the C-SPY debugger manage things like standard streams, file
I/0, and various other system interactions. This basic runtime environment can be used
for simulation before you have any target hardware.

To set up the runtime environment:

I Before you build your project, choose Project>Options>General Options to open the
Options dialog box.

2 On the Library Configuration page, verify the following settings:

o Library: choose which library configuration to use. Typically, choose Tiny ,
Normal , or Full .

For information about the various library configurations, see Runtime library
configurations, page 117.

3 On the Library Options page, select Auto for both Printf formatter and Scanf
formatter. This means that the linker will automatically choose the appropriate
formatters based on information from the compiler. For more information about the
available formatters and how to choose one manually, see Formatters for printf, page
120 and Formatters for scanf, page 122, respectively.

4 To enable C-SPY emulated I/O, choose Project>Options>General Options>Library
Configuration and choose Semihosted (--semihosted) or IAR breakpoint
(--semihosting=iar_breakpoint).
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Note that for some Cortex-M devices it is also possible to direct stdout/stderr via
SWO. This can significantly improve stdout/stderr performance compared to
semihosting. For hardware requirements, see the C-SPY® Debugging Guide for ARM.

To enable stdout via SWO on the command line, use the linker option --redirect
__iar_sh_stdout=__iar_sh_stdout_swo.

To enable stdout via SWO in the IDE, select the Semihosted option and the
stdout/stderr via SWO option.

See Briefly about C-SPY emulated 1/O, page 109 and The semihosting mechanism, page
123.

On some systems, terminal output might be slow because the host computer and the
target system must communicate for each character.

For this reason, a replacement for the __write function called __write_bufferedis
included in the runtime library. This module buffers the output and sends it to the
debugger one line at a time, speeding up the output. Note that this function uses about
80 bytes of RAM memory.

To use this feature in the IDE, choose Project>Options>General Options>Library
Options> and select the option Buffered terminal output.

To enable this function on the command line, add this to the linker command line:
--redirect __write=__write_buffered

Some math functions are available in different versions: default versions, smaller than
the default versions, and larger but more accurate than default versions. Consider
which versions you should use.

For more information, see Math functions, page 124.

When you build your project, a suitable prebuilt library and library configuration file
are automatically used based on the project settings you made.

For information about which project settings affect the choice of library file, see
Runtime library configurations, page 117.

You have now set up a runtime environment that can be used while developing your
application source code.

RETARGETING—ADAPTING THE RUNTIME ENVIRONMENT
FOR YOUR TARGET SYSTEM

Before you can run your application on your target system, you must adapt some parts
of the runtime environment, typically the system initialization and the DLIB low-level
I/0 interface functions.
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To adapt your runtime environment for your target system:
Adapt system initialization.

It is likely that you must adapt the system initialization, for example, your application
might need to initialize interrupt handling, I/O handling, watchdog timers, etc. You do
this by implementing the routine __low_level_init, which is executed before the
data sections are initialized. See System startup and termination, page 126 and System
initialization, page 130. Note that you can find device-specific examples on this in the
example projects provided in the product installation; see the Information Center.

Adapt the runtime library for your target system. To implement such functions, you
need a good understanding of the DLIB low-level 1/O interface, see Briefly about
retargeting, page 110.

Typically, you must implement your own functions if your application uses:

e Standard streams for input and output

If any of these streams are used by your application, for example by the functions
printf and scanf, you must implement your versions of the low-level functions
__readand __write.

The low-level functions identify I/O streams, such as an open file, with a file handle
that is a unique integer. The I/O streams normally associated with stdin, stdout,
and stderr have the file handles 0, 1, and 2, respectively. When the handle is -1,
all streams should be flushed. Streams are defined in stdio.h.

e File input and output

The library contains a large number of powerful functions for file I/O operations,
such as fopen, fclose, fprintf, fputs, etc. All these functions call a small set of
low-level functions, each designed to accomplish one particular task; for example,
__open opens a file, and __write outputs characters. Implement your version of
these low-level functions.

® signal and raise

If the default implementation of these functions does not provide the functionality
you need, you can implement your own versions.

e Time and date

To make the time and date functions work, you must implement the functions clock,
__time32,__time64,and __getzone. Whetheryouuse __time32 or__time64
depends on which interface you use for time_t, see time.h, page 422.

Assert, see __aeabi_assert, page 132.
Environment interaction

If the default implementation of system or getenv does not provide the
functionality you need, you can implement your own versions.
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For more information about the functions, see The DLIB low-level I/O interface, page
131.

The library files that you can override with your own versions are located in the
arm\src\1lib directory.

When you have implemented your functions of the low-level I/O interface, you must
add your version of these functions to your project. For information about this, see
Overriding library modules, page 114.

Note: If you have implemented a DLIB low-level I/O interface function and added it to
a project that you have built with support for C-SPY emulated I/O, your low-level
function will be used and not the functions provided with C-SPY emulated I/O. For
example, if you implement your own version of __write, output to the C-SPY
Terminal I/0 window will not be supported. See Briefly about C-SPY emulated 1/0,
page 109.

Before you can execute your application on your target system, you must rebuild your
project with a Release build configuration. This means that the linker will not include
the C-SPY emulated I/O mechanism and the low-level I/O functions it provides. If your
application calls any of the low-level functions of the standard I/O interface, either
directly or indirectly, and your project does not contain these, the linker will issue an
error for every missing low-level function. Also, note that the NDEBUG symbol is
defined in a Release build configuration, which means asserts will no longer be
generated. For more information, see __aeabi_assert, page 132.

OVERRIDING LIBRARY MODULES

To override a library function and replace it with your own
implementation:

Use a template source file—a library source file or another template—and place a copy
of it in your project directory.

The library files that you can override with your own versions are located in the
arm\src\1lib directory.

Modify the file.

Note: To override the functions in a module, you must provide alternative
implementations for all the needed symbols in the overridden module. Otherwise you
will get error messages about duplicate definitions.

Add the modified file to your project, like any other source file.

Note: If you have implemented a DLIB low-level I/O interface function and added it to
a project that you have built with support for C-SPY emulated I/O, your low-level
function will be used and not the functions provided with C-SPY emulated I/O. For
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example, if you implement your own version of __write, output to the C-SPY
Terminal I/O window will not be supported. See Briefly about C-SPY emulated 1/0,
page 109.

You have now finished the process of overriding the library module with your version.

CUSTOMIZING AND BUILDING YOUR OWN RUNTIME
LIBRARY

If the prebuilt library configurations do not meet your requirements, you can customize
your own library configuration, but that requires that you rebuild the library.

Building a customized library is a complex process. Therefore, consider carefully
whether it is really necessary. You must build your own runtime library when:

® You want to define your own library configuration with support for locale, file
descriptors, multibyte characters, etc. This will include or exclude certain parts of
the DLIB runtime environment.

In those cases, you must:

o Make sure that you have installed the library source code (scr\1ib). If not already
installed, you can install it using the IAR License Manager, see the Installation and
Licensing Guide.

e Setup a library project

o Make the required library customizations

e Build your customized runtime library

o Finally, make sure your application project will use the customized runtime library.
To set up a library project:

In the IDE, choose Project>Create New Project and

Note that when you create a new library project from a template, the majority of the files
included in the new project are the original installation files. If you are going to modify
these files, make copies of them first and replace the original files in the project with
these copies.

To customize the library functionality:

The library functionality is determined by a set of configuration symbols. The default

values of these symbols are defined in the file DLib_Defaults.h which you can find
in arm\inc\c. This read-only file describes the configuration possibilities. Note that

you should not modify this file.

In addition, your custom library has its own library configuration file
dlarmCustom.h—which you can find in arm\config\template\project—and
which sets up that specific library with the required library configuration. Customize
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this file by setting the values of the configuration symbols according to the application
requirements. For example, to enable the 11 qualifier in print £ format strings, write in
your library configuration file:

#define _DLIB_PRINTF_LONG_LONG 1

For information about configuration symbols that you might want to customize, see:
o Configuration symbols for printf and scanf, page 140

o Configuration symbols for file input and output, page 141

® Locale, page 141

® Managing a multithreaded environment, page 143

When you are finished, build your library project with the appropriate project options.
After you build your library, you must make sure to use it in your application project.

To build IAR Embedded Workbench projects from the command line, use the IAR
Command Line Build Utility (iarbuild.exe). However, no make or batch files for
building the library from the command line are provided. For information about the
build process and the IAR Command Line Build Utility, see the IDE Project
Management and Building Guide for ARM.

To use the customized runtime library in your application project:

In the IDE, choose Project>Options>General Options and click the Library
Configuration tab.

From the Library drop-down menu, choose Custom DLIB.

In the Configuration file text box, locate your library configuration file.

Click the Library tab, also in the Linker category. Use the Additional libraries text
box to locate your library file.
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This section gives additional information on the runtime environment:

Runtime library configurations, page 117
Prebuilt runtime libraries, page 118
Formatters for printf, page 120

Formatters for scanf, page 122

The C-SPY emulated I/O mechanism, page 123

The semihosting mechanism, page 123

Math functions, page 124



System startup and termination, page 126
System initialization, page 130

The DLIB low-level I/0 interface, page 131
abort, page 132

__aeabi_assert, page 132

clock, page 133

_close, page 133

__exit, page 133

getenv, page 134

__getzone, page 134

__Iseek, page 135

__open, page 135

raise, page 135

__read, page 136

remove, page 137

rename, page 137

signal, page 137

system, page 138

__time32, page 138

__write, page 138
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Configuration symbols for printf and scanf, page 140

Configuration symbols for file input and output, page 141

Locale, page 141

RUNTIME LIBRARY CONFIGURATIONS

The runtime library is provided with different /ibrary configurations, where each
configuration is suitable for different application requirements.

The runtime library configuration is defined in the library configuration file. It contains
information about what functionality is part of the runtime environment. The less
functionality you need in the runtime environment, the smaller the environment
becomes.
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These predefined library configurations are available:

Library configuration = Description

Normal DLIB (default) No locale interface, C locale, no file descriptor support, and no
multibyte characters in printf and scanf.

Full DLIB Full locale interface, C locale, file descriptor support, and multibyte
characters in printf and scanf.

Table 6: Library configurations

Note: In addition to these predefined library configurations, you can provide your own
configuration, see Customizing and building your own runtime library, page 115

If you do not specify a library configuration explicitly you will get the default
configuration. If you use a prebuilt runtime library, a configuration file that matches the
runtime library object file will automatically be used. See Setting up your runtime
environment, page 111.

To override the default library configuration, use one of these methods:
I Use a prebuilt configuration of your choice—to specify a runtime configuration
explicitly:

Choose Project>Options>General Options>Library Configuration>Library and
change the default setting.

@ Use the --d1ib_config compiler option, see --dlib_config, page 261.

The prebuilt libraries are based on the default configurations, see Runtime library
configurations, page 117.

2 If you have built your own customized library, choose Project>Options>Library
Configuration>Library and choose Custom to use your own configuration. For more
information, see Customizing and building your own runtime library, page 115.
PREBUILT RUNTIME LIBRARIES
The prebuilt runtime libraries are configured for different combinations of these options:
o Library configuration—Normal or Full.

The linker will automatically include the correct library object file and library
configuration file. To explicitly specify a library configuration, use the --d1ib_config
compiler option.

IAR C/C++ Development Guide
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Library filename syntax

The names of the libraries are constructed from these elements:

{1ibrary} a1 for the IAR DLIB runtime environment
{cpu} for the ARM core
{1ib_config} Specifies the library configuration:

n = Normal

£ =Full

You can find the library object files and the library configuration files in the subdirectory
arm\1lib\.
Groups of library files

The libraries are delivered in groups of library functions:

Library files for C library functions

These are the functions defined by Standard C, for example functions like printf and
scanf. Note that this library does not include math functions.

The names of the library files are constructed in the following way:
dl{architecture}_{cpu_mode} {byte_order}{lib-config}{rwpi}.a
which more specifically means

dl{4t|5E|6M|6Mx|7M|7Mx|7Sx}_{a|t}{1l|b}{n|f}{s}.a

Library files for C++ and Embedded C++ library functions

These are the functions defined by C++, compiled with support for either Standard C++
or Embedded C++.

The names of the library files are constructed in the following way:

dlpp{architecture}_{cpu_mode} {byte order}
_{lib-config}{language}{rwpi}.a

which more specifically means

dlpp{4t|5E|6M|6Mx|7M|7Mx|7Sx|4as|7as}_{a|t}{1l|b}_{n|f}{c|e}{s].a

Library files for math functions

These are the functions for floating-point arithmetic and functions with a floating-point
type in its signature as defined by Standard C, for example functions like sqrt.
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The names of the library files are constructed in the following way:
m{architecture}_{cpu_mode} {byte order}{fp_implementation}.a
which more specifically means

m{4t|5E|6M|6Mx|7M|TMx|7Sx}_{a|t}{1l|b}{|v]|s}.a

Library files for runtime support functions

These are functions for system startup, initialization, non floating-point AEABI support
routines, and some of the functions that are part of Standard C and C++.

The names of the library files are constructed in the following way:
rt{architecture}_{cpu_mode} {byte_order}.a
which more specifically means

rt{4t|5E|6M|6Mx|7M|7Mx|7Sx}_{a|t}{1l]|b}.a

Library files for debug support functions

These are functions for debug support for the semihosting interface. The names of the
library files are constructed in the following way:

sh{debug_interface}_{byte order}.a
or

sh{architecture}_{byte_order}.a
which more specifically means
sh{s|b|i}_{1]|b}.a

or

sh{6Mx|7Mx|7Sx}_{1|b}.a

FORMATTERS FOR PRINTF

The printf function uses a formatter called _print£. The full version is quite large,
and provides facilities not required in many embedded applications. To reduce the
memory consumption, three smaller, alternative versions are also provided. Note that
the wprint f variants are not affected.

IAR C/C++ Development Guide
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This table summarizes the capabilities of the different formatters:

Formatting capabilities Tiny Smalll Large/ Full
SmallNoMb} LargeNoMb} FullNoMbt

Basic specifiers ¢, d, 1, 0, p, s, u, X, x,and $ Yes Yes Yes Yes
Multibyte support No  Yes/No Yes/No Yes/No
Floating-point specifiers a, and A No No No Yes
Floating-point specifiers e, E, £, F,g,andG ~ No No Yes Yes
Conversion specifier n No No Yes Yes
Format flag +, -, #, 0, and space No Yes Yes Yes
Length modifiers h, 1, L, s, t, and 2 No Yes Yes Yes
Field width and precision, including * No Yes Yes Yes
long long support No No Yes Yes

Table 7: Formatters for printf
T NoMb means without multibytes.

Note: It is possible to optimize these functions even further, but that requires that you
rebuild the library. See Configuration symbols for printf and scanf, page 140.

The compiler can automatically detect which formatting capabilities are needed in a
direct call to printf, if the formatting string is a string literal. This information is
passed to the linker, which combines the information from all modules to select a
suitable formatter for the application. However, if the formatting string is a variable, or
if the call is indirect through a function pointer, the compiler cannot perform the
analysis, forcing the linker to select the Full formatter. In this case, you might want to
override the automatically selected printf formatter.

To override the automatically selected printf formatter in the IDE:

I Choose Project>Options>General Options to open the Options dialog box.

2  On the Library Options page, select the appropriate formatter.
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@ To override the automatically selected printf formatter from the command
line:

I Use one of these ILINK command line options:

--redirect _Printf=_PrintfFull
--redirect _Printf=_PrintfFullNoMb
--redirect _Printf=_PrintfLarge
--redirect _Printf=_PrintfLargeNoMb
--redirect _Printf=_PrintfSmall
--redirect _Printf=_PrintfSmallNoMb
--redirect _Printf=_PrintfTiny
--redirect _Printf=_PrintfTinyNoMb

FORMATTERS FOR SCANF

In a similar way to the print £ function, scanf uses a common formatter, called
_Scanf. The full version is quite large, and provides facilities that are not required in
many embedded applications. To reduce the memory consumption, two smaller,
alternative versions are also provided. Note that the wscanf versions are not affected.

This table summarizes the capabilities of the different formatters:

Small/ Large/ Full/

Formatting capabilities
SmallNoMbt LargeNoMb} FullNoMbt

Basic specifiers ¢, 4, 1, 0, p, s, U, X, %X, and % Yes Yes Yes
Multibyte support Yes/No Yes/No Yes/No
Floating-point specifiers a, and A No No Yes
Floating-point specifiers e, E, £, F, g, and G No No Yes
Conversion specifier n No No Yes
Scan set [ and ] No Yes Yes
Assignment suppressing * No Yes Yes
long long support No No Yes

Table 8: Formatters for scanf
T NoBMb means without multibytes.

Note: It is possible to optimize these functions even further, but that requires that you
rebuild the library. See Configuration symbols for printf and scanf, page 140.

The compiler can automatically detect which formatting capabilities are needed in a
direct call to scanf, if the formatting string is a string literal. This information is passed
to the linker, which combines the information from all modules to select a suitable
formatter for the application. However, if the formatting string is a variable, or if the call
is indirect through a function pointer, the compiler cannot perform the analysis, forcing

IAR C/C++ Development Guide
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the linker to select the full formatter. In this case, you might want to override the
automatically selected scanf formatter.

To manually specify the scanf formatter in the IDE:

Choose Project>Options>General Options to open the Options dialog box.
On the Library Options page, select the appropriate formatter.

To manually specify the scanf formatter from the command line:
Use one of these ILINK command line options:

--redirect _Scanf=_ScanfFull
--redirect _Scanf=_ScanfFullNoMb
--redirect _Scanf=_ScanflLarge
--redirect _Scanf=_ScanfLargeNoMb
--redirect _Scanf=_ScanfSmall
--redirect _Scanf=_ScanfSmallNoMb

THE C-SPY EMULATED 1/O MECHANISM

1 The debugger will detect the presence of the function __DebugBreak, which will
be part of the application if you linked it with the linker option for C-SPY emulated
/0.

2 In this case, the debugger will automatically set a breakpoint at the __DebugBreak
function.

3 When your application calls a function in the DLIB low-level I/O interface, for
example, open, the __DebugBreak function is called, which will cause the
application to stop at the breakpoint and perform the necessary services.

4 The execution will then resume.

See also Briefly about C-SPY emulated 1/0, page 109.

THE SEMIHOSTING MECHANISM

C-SPY emulated I/O is compatible with the semihosting interface provided by ARM
Limited. When an application invokes a semihosting call, the execution stops at a
debugger breakpoint. The debugger then handles the call, performs any necessary
actions on the host computer and then resumes the execution.

There are three variants of semihosting mechanisms available:

e For Cortex-M, the interface uses BKPT instructions to perform semihosting calls
o For other ARM cores, SvC instructions are used for the semihosting calls

® [AR breakpoint, which is an IAR-specific alternative to semihosting that uses SVC.
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To support semihosting via SVC, the debugger must set its semihosting breakpoint on
the Supervisor Call vector to catch SVC calls. If your application uses SVC calls for
other purposes than semihosting, the handling of this breakpoint will cause a severe
performance penalty for each such call. IAR breakpoint is a way to get around this. By
using a special function call instead of an SVC instruction to perform semihosting, the
semihosting breakpoint can be set on that special function instead. This means that
semihosting will not interfere with other uses of the Supervisor Call vector.

Note that IAR breakpoint is an IAR-specific extension of the semihosting standard. If
you link your application with libraries built with toolchains from other vendors than
IAR Systems and use IAR breakpoint, semihosting calls made from code in those
libraries will not work.

MATH FUNCTIONS
Some C/C++ standard library math functions are available in different versions:

o The default versions
o Smaller versions (but less accurate)

o More accurate versions (but larger).

Smaller versions

The functions cos, exp, 1og, 1og2,1ogl0, __iar_Log (ahelp function for log, 1log2,
and 1ogl10), pow, sin, tan,and __iar_Sin (ahelp function for sin and cos) exist in
additional, smaller versions in the library. They are about 20% smaller and about 20%
faster than the default versions. The functions handle INF and NaN values. The
drawbacks are that they almost always lose some precision and they do not have the
same input range as the default versions.

The names of the functions are constructed like:

_lar_xxx_small<f|1l>

where f is used for f1loat variants, 1 is used for long double variants, and no suffix
is used for double variants.
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To specify individual math functions from the command line:

Redirect the default function names to these names when linking, using these options:

--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect

--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect

--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect
--redirect

sin=__iar_sin_small
cos=__iar_cos_small
tan=__iar_tan_small
log=__iar_log_small
log2=__iar_log2_small
logl0=__iar_loglO_small
exp=__iar_exp_small
pow=__1iar_pow_small
__dar_Sin=__iar_Sin_small
__iar_Log=_ _iar_Log_small

sinf=__iar_sin_smallf
cosf=__iar_cos_smallf
tanf=__iar_tan_smallf

logf=__iar_log_smallf
log2f=__iar_ log2_smallf
logl0f=__iar_loglO_smallf
expf=__iar_exp_smallf
powf=__iar pow_smallf
__dar FSin=__iar_Sin_smallf
_ _dar_ FLog=_ iar_Log _smallf

sinl=__iar_sin_smalll
cosl=__iar_cos_smalll
tanl=__iar_tan_smalll

logl=__iar_log_smalll
log2l=__iar_log2_smalll
logl0l=__iar_loglO_smalll
expl=__iar_exp_smalll
powl=__iar pow_smalll
__dar_ LSin=_ iar_Sin_smalll
__iar_ LLog=__iar_Log_smalll

Note that if you want to redirect any of the functions sin, cos,or __iar_Sin, you must
redirect all three functions.

Note that if you want to redirect any of the functions log, 1og2, logl0,0r __iar_Log,
you must redirect all four functions.

More accurate versions

The functions cos, pow, sin, and tan, and the help functions __iar_sin and
__iar_Pow exist in versions in the library that are more exact and can handle larger
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argument ranges. The drawback is that they are larger and slower than the default
versions.

The names of the functions are constructed like:
__iar_xxx_accurate<f|l>

where f is used for f1oat variants, 1 is used for long double variants, and no suffix
is used for double variants.

@ To specify individual math functions from the command line:
I Redirect the default function names to these names when linking, using these options:

--redirect sin=__iar_sin_accurate
--redirect cos=__iar_cos_accurate
--redirect tan=__iar_tan_accurate
--redirect pow=__iar_pow_accurate

--redirect __iar_Sin=__iar_ Sin_accurate
--redirect __iar_Pow=__iar_ Pow_accurate
--redirect sinf=__iar_sin_accuratef
--redirect cosf=__iar_cos_accuratef
--redirect tanf=__ iar_tan_accuratef
--redirect powf=__iar_pow_accuratef
--redirect _ _iar_ FSin=_ iar_Sin_accuratef
--redirect __iar_FPow=__iar_Pow_accuratef
--redirect sinl=__ iar_sin_accuratel
--redirect cosl=__iar_cos_accuratel
--redirect tanl=__iar_tan_accuratel
--redirect powl=__iar_pow_accuratel
--redirect __iar_LSin=_ iar_Sin_accuratel
--redirect _ _iar LPow=__iar_Pow_accuratel

Note that if you want to redirect any of the functions sin, cos,or __iar_Sin, you must
redirect all three functions.

Note that if you want to redirect any of the functions pow or __iar_Pow, you must
redirect both functions.
SYSTEM STARTUP AND TERMINATION

This section describes the runtime environment actions performed during startup and
termination of your application.

The code for handling startup and termination is located in the source files
cstartup.s, cmain.s, cexit.s, and low_level_init.c located in the
arm\src\1lib directory.
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For information about how to customize the system startup code, see System
initialization, page 130.
System startup

During system startup, an initialization sequence is executed before the main function
is entered. This sequence performs initializations required for the target hardware and
the C/C++ environment.

For the hardware initialization, it looks like this:

Library User Application
Start label: __low_level_init()
Hardware User hardware

Setup setup
(returns C/C++
static

[ initialization flag)

Initialization

o When the CPU is reset it will start executing at the program entry label
__iar_program_start in the system startup code.

The stack pointer is initialized to the end of the cSTACK block

For ARM7/9/11, Cortex-A, and Cortex-R devices, exception stack pointers are
initialized to the end of each corresponding section

o The function __low_level_ init is called if you defined it, giving the application
a chance to perform early initializations.
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For the C/C++ initialization, it looks like this:

Library User application
Static C/C++ User hardware
initialization setup

i
Dynamic C++ main()
initialization
T User code
Return from
main
exit()

e Static and global variables are initialized. That is, zero-initialized variables are
cleared and the values of other initialized variables are copied from ROM to RAM
memory. This step is skipped if __low_level init returns zero. For more
information, see Initialization at system startup, page 82.

o Static C++ objects are constructed
o The main function is called, which starts the application.

For information about the initialization phase, see Application execution—an overview,
page 50.
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System termination

This illustration shows the different ways an embedded application can terminate in a
controlled way:

Return from main via library

Library User application
exit()
Explicit call
|
_exit
Dynamic C++ abort()
and atexit code Explicit call
_Exit()
Explicit call
| P
__exit
Application
terminates

An application can terminate normally in two different ways:

e Return from the main function
o Call the exit function.
Because the C standard states that the two methods should be equivalent, the system

startup code calls the exit function if main returns. The parameter passed to the exit
function is the return value of main.

The default exit function is written in C. It calls a small assembler function _exit that

will:

e Call functions registered to be executed when the application ends. This includes
C++ destructors for static and global variables, and functions registered with the
standard function atexit. See also Setting up the atexit limit, page 98.

o Close all open files

o Call __exit

o When __exit is reached, stop the system.

An application can also exit by calling the abort or the _Exit function. The abort
function just calls __exit to halt the system, and does not perform any type of cleanup.

The _Exit function is equivalent to the abort function, except for the fact that _Exit
takes an argument for passing exit status information.
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If you want your application to do anything extra at exit, for example resetting the
system (and if using atexit is not sufficient), you can write your own implementation
of the __exit (int) function.

The library files that you can override with your own versions are located in the
arm\src\1lib directory. See Overriding library modules, page 114.

C-SPY debugging support for system termination

If you have enabled C-SPY emulated I/O during linking, the normal __exit function
is replaced with a special one. C-SPY will then recognize when this function is called
and can take appropriate actions to emulate program termination. For more information,
see Briefly about C-SPY emulated 1/0, page 109.

SYSTEM INITIALIZATION

It is likely that you need to adapt the system initialization. For example, your application
might need to initialize memory-mapped special function registers (SFRs), or omit the
default initialization of data sections performed by the system startup code.

You can do this by implementing your own version of the routine __low_level_init,
which is called from the file cmain. s before the data sections are initialized. Modifying
the file cstartup. s directly should be avoided.

For Cortex-M, the code for handling system startup is located in the source files
cstartup_M.s and low_level_init.c, located in the arm\src\1ib directory.

For other ARM devices, the code for handling system startup is located in the source
files cstartup.s and low_level_init.c, located in the arm\src\1lib directory.

Note: Normally, you do not need to customize either of the files cmain.s or cexit.s.
Note: Regardless of whether you implement your own versionof __low_level_init
or the file cstartup.s, you do not have to rebuild the library.

Customizing __low_level_init

A skeleton low-level initialization file is supplied with the product:
low_level_ init.c. Note that static initialized variables cannot be used within the
file, because variable initialization has not been performed at this point.

The value returned by __low_level_init determines whether or not data sections
should be initialized by the system startup code. If the function returns 0, the data
sections will not be initialized.
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Modifying the cstartup file

As noted earlier, you should not modify the file cstartup. s if implementing your own
version of __low_level_init is enough for your needs. However, if you do need to
modify the file cstartup.s, we recommend that you follow the general procedure for
creating a modified copy of the file and adding it to your project, see Overriding library
modules, page 114.

Note that you must make sure that the linker uses the start label used in your version of
cstartup.s. For information about how to change the start label used by the linker, see
--entry, page 301.

For Cortex-M, you must create a modified copy of cstartup_M.s or cstartup_M.c
to use interrupts or other exception handlers.
THE DLIB LOW-LEVEL 1/O INTERFACE

The runtime library uses a set of low-level functions—which are referred to as the DLIB
low-level I/O interface—to communicate with the target system. Most of the low-level
functions have no implementation.

For more information about this, see Briefly about input and output (1/0), page 108.

This table lists the functions in the DLIB low-level I/O interface:

Function in DLIB low-level I/O interface

Defined in source file

abort abort.c
__aeabi_assert assert.c
clock clock.c
__close close.c
__exit xxexit.c
getenv getenv.c
__getzone getzone.c
_ 1lseek lseek.c
__open open.c
raise raise.c
__read read.c
remove remove.c
rename rename.c
signal signal.c

Table 9: DLIB low-level I/O interface functions
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abort

Source file

Description

C-SPY debug action
Default implementation

See also

__aeabi_assert

Source file
Description

C-SPY debug action
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Function in DLIB low-level I/O interface Defined in source file
system system.c

_ _time32 time.c

__write write.c

Table 9: DLIB low-level 1/0 interface functions (Continued)

Note: You should not use the low-level functions prefixed with __ directly in your
application. Instead you should use the standard library functions that use these
functions. For example, to write to stdout, you should use standard library functions
like printf or puts, which in turn calls the low-level function __write. If you have
forgot to implement a low-level function and your application will call that function via
a standard library function, the linker will issues an error when you link in release build
configuration.

Note: If you implement your own variants of the functions in this interface, your
variants will be used even though you have enabled C-SPY emulated /O, see Briefly
about C-SPY emulated 1/0, page 109.

arm\src\lib\abort.c

Standard C library function that aborts execution.
Exits the application.

Calls __exit (EXIT_FAILURE).

Briefly about retargeting, page 110

System termination, page 129.

arm\src\lib\assert.c
Low-level function that handles a failed assert.

Notifies the C-SPY debugger about the failed assert.
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Default implementation Failed asserts are reported by the function __aeabi_assert. By default, it prints an
error message and calls abort. If this is not the behavior you require, you can
implement your own version of the function.

The assert macro is defined in the header file assert . h. To turn off assertions, define
the symbol NDEBUG.

In the IDE, the symbol NDEBUG is by default defined in a Release project and not defined
in a Debug project. If you build from the command line, you must explicitly define the
symbol according to your needs. See NDEBUG, page 414.

See also Briefly about retargeting, page 110.
clock
Source file arm\src\lib\clock.c
Description Standard C library function that accesses the processor time.
C-SPY debug action Returns the clock on the host computer.

Default implementation ~ Returns -1 to indicate that processor time is not available.

See also Briefly about retargeting, page 110.
__close
Source file arm\src\lib\close.c
Description Low-level function that closes a file.
C-SPY debug action Closes the associated host file on the host computer.

Default implementation None.

See also Briefly about retargeting, page 110.
__exit

Source file arm\src\lib\xxexit.c

Description Low-level function that halts execution.
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C-SPY debug action
Default implementation

See also

getenv

Source file

C-SPY debug action

Default implementation

See also

__getzone

Source file

Description

IAR C/C++ Development Guide
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Notifies that the end of the application was reached.
Loops forever.

Briefly about retargeting, page 110

System termination, page 129.

arm\src\lib\getenv.c
arm\src\lib\environ.c

Accesses the host environment.

The getenv function in the library searches the string pointed to by the global variable
__environ, for the key that was passed as argument. If the key is found, the value of it
is returned, otherwise O (zero) is returned. By default, the string is empty.

To create or edit keys in the string, you must create a sequence of null-terminated strings
where each string has the format:

key=value\0

End the string with an extra null character (if you use a C string, this is added
automatically). Assign the created sequence of strings to the __environ variable.

For example:

const char MyEnv[] = "Key=Value\0Key2=Value2\0”;
__environ = MyEnv;

If you need a more sophisticated environment variable handling, you should implement
your own getenv, and possibly putenv function.

Note: The putenv function is not required by the standard, and the library does not
provide an implementation of it.

Briefly about retargeting, page 110.

arm\src\lib\getzone.c

Low-level function that returns the current time zone.



C-SPY debug action
Default implementation

See also

__Iseek

Source file

Description

C-SPY debug action
Default implementation

See also

__open

Source file

Description

C-SPY debug action
Default implementation

See also

Source file
Description
C-SPY debug action

Default implementation
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Not applicable.
Returns " : .

Briefly about retargeting, page 110.

arm\src\lib\lseek.c

Low-level function for changing the location of the next access in an open file.

Searches in the associated host file on the host computer.
None.

Briefly about retargeting, page 110.

arm\src\lib\open.c

Low-level function that opens a file.
Opens a file on the host computer.
None.

Briefly about retargeting, page 110.

arm\src\lib\raise.c
Standard C library function that raises a signal.
Not applicable.

Calls the signal handler for the raised signal, or terminates with call to
__exit (EXIT_FAILURE).
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See also

__read

Source file
Description

C-SPY debug action

Default implementation

Example
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Briefly about retargeting, page 110.

arm\src\lib\read.c

Low-level function that reads characters from stdin and from files.

Directs stdin to the Terminal I/O window. All other files will read the associated host

file.

None.

The code in this example uses memory-mapped I/O to read from a keyboard, whose port

is assumed to be located at 0x1000:
#include <stddef.h>
_ no_init volatile unsigned char kbIO @ 0x1000;
size_t __read(int handle,
unsigned char *buf,
size_t bufSize)

size_t nChars = 0;

/* Check for stdin

(only necessary if FILE descriptors are enabled)

if (handle
{

return -1;

'=0)

for (/*Empty*/;
{
unsigned char ¢ = kbIO;

bufSize > 0; --bufSize)

if (¢ == 0)
break;
*buf++ = c;

++nChars;

return nChars;

*/
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For information about the handles associated with the streams, see
Retargeting—Adapting the runtime environment for your target system, page 112.

For information about the @ operator, see Controlling data and function placement in
memory, page 216.

See also Briefly about retargeting, page 110.
remove

Source file arm\src\lib\remove.c

Description Standard C library function that removes a file.

C-SPY debug action Removes a file on the host computer.

Default implementation ~ Returns 0 to indicate success, but without removing a file.

See also Briefly about retargeting, page 110.
rename

Source file arm\src\lib\rename.c

Description Standard C library function that renames a file.

C-SPY debug action Renames a file on the host computer.

Default implementation Returns -1 to indicate failure.

See also Briefly about retargeting, page 110.
signal
Source file arm\src\lib\signal.c
Description Standard C library function that changes signal handlers.
C-SPY debug action Not applicable.
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Default implementation As specified by Standard C. You might want to modify this behavior if the environment
supports some kind of asynchronous signals.

See also Briefly about retargeting, page 110.
system
Source file arm\src\lib\system.c
Description Standard C library function that executes commands.
C-SPY debug action Notifies the C-SPY debugger that system has been called and then returns -1.

Default implementation If you need to use the system function, you must implement it yourself. The system
function available in the library returns 0 if a null pointer is passed to it to indicate that
there is no command processor; otherwise it returns -1 to indicate failure. If this is not
the functionality that you require, you can implement your own version. This does not
require that you rebuild the library.

See also Briefly about retargeting, page 110.
__time32

Source file arm\src\lib\time.c

Description Low-level the current calendar time.

C-SPY debug action Returns the time on the host computer.

Default implementation Returns -1 to indicate that calendar time is not available.

See also Briefly about retargeting, page 110.
___Wwrite
Source file arm\src\lib\write.c
Description Low-level function that writes to stdout, stderr, or a file.
C-SPY debug action Directs stdout and stderr to the Terminal I/O window. All other files will write to

the associated host file.
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None.

The code in this example uses memory-mapped I/O to write to an LCD display, whose
port is assumed to be located at address 0x1000:

#include <stddef.h>

__no_init volatile unsigned char 1cdIO @ 0x1000;

size_t _ write(int handle,

}

const unsigned char *buf,
size_t bufSize)

size_t nChars = 0;

/* Check for the command to flush all handles */
if (handle == -1)
{

return 0;

/* Check for stdout and stderr

(only necessary if FILE descriptors are enabled.) */
if (handle != 1 && handle != 2)
{

return -1;

for (/* Empty */; bufSize > 0; --bufSize)
{

lcdIO = *buf;

++buf;

++nChars;

return nChars;

For information about the handles associated with the streams, see
Retargeting—Adapting the runtime environment for your target system, page 112.

Briefly about retargeting, page 110.
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CONFIGURATION SYMBOLS FOR PRINTF AND SCANF

If the provided formatters do not meet your requirements (Formatters for printf, page
120 and Formatters for scanf, page 122), you can customize the Full formatters. Note
that this means you must rebuild the runtime library.

The default behavior of the printf and scanf formatters are defined by configuration
symbols in the file DLib_Defaults.h.

These configuration symbols determine what capabilities the function print £ should

have:

Printf configuration symbols Includes support for
_DLIB_PRINTF_MULTIBYTE Multibyte characters
_DLIB_PRINTF_LONG_LONG Long long (11 qualifier)
_DLIB_PRINTF_SPECIFIER_FLOAT Floating-point numbers
_DLIB_PRINTF_SPECIFIER_A Hexadecimal floating-point numbers
_DLIB_PRINTF_SPECIFIER_N Output count (%)
_DLIB_PRINTF_QUALIFIERS Qualifiers h, 1, I, v, t, and z
_DLIB_PRINTF_FLAGS Flags -, +, #,and 0

_DLIB_PRINTF_WIDTH_AND_PRECISION Width and precision

_DLIB_PRINTF_CHAR_BY_ CHAR Output char by char or buffered

Table 10: Descriptions of printf configuration symbols

When you build a library, these configurations determine what capabilities the function
scanf should have:

Scanf configuration symbols Includes support for
_DLIB_SCANF_MULTIBYTE Multibyte characters
_DLIB_SCANF_LONG_LONG Long long (11 qualifier)
_DLIB_SCANF_SPECIFIER_FLOAT Floating-point numbers
_DLIB_SCANF_SPECIFIER_N Output count (%)
_DLIB_SCANF_QUALIFIERS Qualifiers h, j, 1, t, z,and L
_DLIB_SCANF_SCANSET Scanset ([*])
_DLIB_SCANF_WIDTH Width

_DLIB_SCANF_ASSIGNMENT_ SUPPRESSING Assignment suppressing ([*])

Table 11: Descriptions of scanf configuration symbols
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To customize the formatting capabilities, you must;
Define the configuration symbols in the library configuration file according to your

application requirements.

Rebuild the library, see Customizing and building your own runtime library, page 115.

CONFIGURATION SYMBOLS FOR FILE INPUT AND OUTPUT

File I/O is only supported by libraries with the Full library configuration, see Runtime
library configurations, page 117, or in a customized library when the configuration
symbol __DLIB_FILE DESCRIPTOR is defined. If this symbol is not defined, functions
taking a FILE * argument cannot be used.

To customize your library and rebuild it, see Customizing and building your own
runtime library, page 115.

LOCALE

Locale is a part of the C language that allows language- and country-specific settings for
several areas, such as currency symbols, date and time, and multibyte character
encoding.

Depending on which library configuration you are using, you get different level of locale
support. However, the more locale support, the larger your code will get. It is therefore
necessary to consider what level of support your application needs. See Runtime library
configurations, page 117.

The DLIB runtime library can be used in two main modes:

o With locale interface, which makes it possible to switch between different locales
during runtime

e Without locale interface, where one selected locale is hardwired into the
application.

Locale support in prebuilt libraries
The level of locale support in the prebuilt libraries depends on the library configuration.

o All prebuilt libraries support the C locale only

o All libraries with full library configuration have support for the locale interface. For
prebuilt libraries with locale interface, it is by default only supported to switch
multibyte character encoding at runtime.

e Libraries with normal library configuration do not have support for the locale
interface.

If your application requires a different locale support, you must rebuild the library.
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Customizing the locale support and rebuilding the library
If you decide to rebuild the library, you can choose between these locales:
o The Clocale

o The POSIX locale

e A wide range of European locales.

Locale configuration symbols

The configuration symbol _DLIB_FULL_LOCALE_SUPPORT, which is defined in the
library configuration file, determines whether a library has support for a locale interface
or not. The locale configuration symbols _LOCALE_USE_LANG_REGION and
_ENCODING_USE_ENCODING define all the supported locales and encodings:

#define _DLIB_FULL_LOCALE_SUPPORT 1

#define _LOCALE_USE_C /* C locale */

#define _LOCALE_USE_EN_US /* American English */
#define _LOCALE_USE_EN_GB /* British English */
#define _LOCALE_USE_SV_SE /* Swedish in Sweden */

See DLib_Defaults.h for a list of supported locale and encoding settings.

If you want to customize the locale support, you simply define the locale configuration
symbols required by your application. For more information, see Customizing and
building your own runtime library, page 115.

Note: If you use multibyte characters in your C or assembler source code, make sure
that you select the correct locale symbol (the local host locale).

Building a library without support for locale interface

The locale interface is not included if the configuration symbol
_DLIB_FULL_LOCALE_SUPPORT is set to O (zero). This means that a hardwired locale
is used—by default the Standard C locale—but you can choose one of the supported
locale configuration symbols. The setlocale function is not available and can
therefore not be used for changing locales at runtime.

Building a library with support for locale interface

Support for the locale interface is obtained if the configuration symbol
_DLIB_FULL_LOCALE_SUPPORT is set to 1. By default, the Standard C locale is used,
but you can define as many configuration symbols as required. Because the setlocale
function will be available in your application, it will be possible to switch locales at
runtime.
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Changing locales at runtime

The standard library function setlocale is used for selecting the appropriate portion
of the application’s locale when the application is running.

The setlocale function takes two arguments. The first one is a locale category that is
constructed after the pattern LC_CATEGORY. The second argument is a string that
describes the locale. It can either be a string previously returned by setlocale, or it
can be a string constructed after the pattern:

lang_ REGION
or
lang REGION.encoding

The lang part specifies the language code, and the REGTON part specifies a region
qualifier, and encoding specifies the multibyte character encoding that should be used.

The lang_REGION part matches the _LOCALE_USE_LANG_REGION preprocessor
symbols that can be specified in the library configuration file.
Example

This example sets the locale configuration symbols to Swedish to be used in Finland and
UTF8 multibyte character encoding:

setlocale (LC_ALL, "sv_FI.Utf8");

Managing a multithreaded environment

In a multithreaded environment, the standard library must treat all library objects
according to whether they are global or local to a thread. If an object is a true global
object, any updates of its state must be guarded by a locking mechanism to make sure
that only one thread can update it at any given time. If an object is local to a thread, the
static variables containing the object state must reside in a variable area local to that
thread. This area is commonly named thread-local storage (TLS).

The low-level implementations of locks and TLS are system-specific, and is not
included in the DLIB runtime environment. If you are using an RTOS, check if it
provides some or all of the required functions. Otherwise, you must provide your own.

MULTITHREAD SUPPORT IN THE DLIB RUNTIME
ENVIRONMENT

The DLIB runtime environment uses two kinds of locks—system locks and file stream
locks. The file stream locks are used as guards when the state of a file stream is updated,
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and are only needed in the Full library configuration. The following objects are guarded
with system locks:

o The heap (in other words when malloc, new, free, delete, realloc, or calloc
is used).

o The file system (only available in the Full library configuration), but not the file
streams themselves. The file system is updated when a stream is opened or closed,
in other words when fopen, fclose, fdopen, £flush, or freopen is used.

o The signal system (in other words when signal is used).
o The temporary file system (in other words when tmpnam is used).

o Dynamically initialized function local objects with static storage duration.

These library objects use TLS:

Library objects using TLS When these functions are used

Error functions errno, strerror

Locale functions localeconv, setlocale

Time functions asctime, localtime, gmtime, mktime

Multibyte functions mbrlen, mbrtowc, mbsrtowc, mbtowc, wertomb,

wcsrtomb, wctomb

Rand functions rand, srand
C++ exception engine Not applicable
Miscellaneous functions atexit, strtok

Table 12: Library objects using TLS

Note: If you are using print £/scanf (or any variants) with formatters, each individual
formatter will be guarded, but the complete printf/scanf invocation will not be
guarded.

If one of the C++ variants is used together with the DLIB runtime environment with
multithread support, the compiler option --guard_calls must be used to make sure
that function-static variables with dynamic initializers are not initialized simultaneously
by several threads.

ENABLING MULTITHREAD SUPPORT

Prebuilt libraries with multithread support are provided in the product installation. . See
also, Customizing and building your own runtime library, page 115.
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To configure multithread support for use with threaded applications:

To enable multithread support:

On the command line, use the linker option --threaded_lib.

In the IDE, choose Project>Options>General Options>Library
Configuration>Enable thread support in the library. The linker option
--threaded_1ib and the matching prebuilt library with thread support will
automatically be used. If one of the C++ variants is used, the IDE will automatically use
the compiler option --guard_calls to make sure that function-static variables with
dynamic initializers are not initialized simultaneously by several threads.

To complement the built-in multihread support in the runtime library, you must also:

o Implement code for the library’s system locks interface, see System locks interface,
page 145.

o If file streams are used, implement code for the library’s file stream locks interface
or redirect the interface to the system locks interface (using the linker option
--redirect), see File streams locks interface, page 146.

e Implement code that handles thread creation, thread destruction, and TLS access
methods for the library, see 7LS handling, page 146.

o Modify the linker configuration file accordingly.

See also Lock usage, page 146 for information about used file streams locks and system
locks.

You can find the required declaration of functions and definitions of macros in the
DLib_Threads.h file, which is included by yvals.h.

Build your project.

Note: If you are using a third-party RTOS, check their guidelines for how to enable
multithread support with IAR Systems tools.

System locks interface

This interface must be fully implemented for system locks to work:

typedef void *__iar_ Rmtx; /* Lock info object */

void __iar_system Mtxinit(__iar Rmtx *); /* Initialize a system

lock */
void _ _iar_system Mtxdst(__iar Rmtx *);/*Destroy a system lock */
void __iar_system_Mtxlock(__iar_Rmtx *); /* Lock a system lock */
void __iar_system Mtxunlock(__iar_Rmtx *); /* Unlock a system
lock */
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The lock and unlock implementation must survive nested calls.

File streams locks interface

This interface is only needed for the Full library configuration. If file streams are used,
they can either be fully implemented or they can be redirected to the system locks
interface. This interface must be implemented for file streams locks to work:

typedef void *__iar_ Rmtx; /* Lock info object */
void _ iar_ file_Mtxinit(__iar_Rmtx *);/*Initialize a file lock */
void _ _iar file_ Mtxdst(__iar_Rmtx *); /* Destroy a file lock */
void _ _iar_ file_Mtxlock(__iar_Rmtx *); /* Lock a file lock */
void _ iar_ file_Mtxunlock(__iar Rmtx *); /* Unlock a file lock */

The lock and unlock implementation must survive nested calls.

Lock usage
The number of locks that the DLIB runtime environment assumes exist are:

e _FOPEN_MAX—the maximum number of file stream locks. These locks are only
used in the Full library configuration, in other words only if both the macro symbols
_DLIB_FILE_DESCRIPTOR and _FILE_OP_LOCKS are true.

® _MAX_LOCK—the maximum number of system locks.

Note that even if the application uses fewer locks, the runtime environment will initialize
and destroy all the locks above.

For information about the initialization and destruction code, see xsyslock.c.

TLS handling

The DLIB runtime environment supports TLS memory areas for two types of threads:
the main thread (the main function including the system startup and exit code) and
secondary threads.

The main thread’s TLS memory area:

Is automatically created and initialized by your application’s startup sequence
Is automatically destructed by the application’s destruct sequence

°
°
e Is located in the section __DLIB_PERTHREAD
e Exists also for non-threaded applications.
Each secondary thread’s TLS memory area:

o Must be manually created and initialized

o Must be manually destructed
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e Islocated in a manually allocated memory area.

If you need the runtime library to support secondary threads, you must override the
function:

void *__iar_dlib_perthread_access (void *symbp) ;

The parameter is the address to the TLS variable to be accessed—in the main thread’s
TLS area—and it should return the address to the symbol in the current TLS area.

Two interfaces can be used for creating and destroying secondary threads. You can use
the following interface that allocates a memory area on the heap and initializes it. At
deallocation, it destroys the objects in the area and then frees the memory.

void *__iar_ dlib_perthread_allocate(void) ;
void _ _iar_dlib_perthread_deallocate(void *);

Alternatively, if the application handles the TLS allocation, you can use this interface
for initializing and destroying the objects in the memory area:

void __iar_dlib_perthread_initialize(void *);
void __iar_dlib_perthread_destroy(void *);

These macros can be helpful when you implement an interface for creating and
destroying secondary threads:

Macro Description

__IAR_DLIB_PERTHREAD_SIZE The size needed for the TLS memory area.

__IAR_DLIB_PERTHREAD_INIT_SIZE The initializer size for the TLS memory area.
You should initialize the rest of the TLS
memory area, up to
__IAR DLIB_PERTHREAD_SIZE to zero.

__IAR _DLIB_PERTHREAD_SYMBOL_ The offset to the symbol in the TLS memory
OFFSET (symbolptr) area.

Table 13: Macros for implementing TLS allocation

Note that the size needed for TLS variables depends on which resources in the DLIB
runtime environment your application uses.
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This is an example of how you can handle threads:

#include <yvals.h>

/* A thread's TLS pointer */
void _DLIB_TLS_MEMORY *TLSp;

/* Are we in a secondary thread? */
int InSecondaryThread = 0;

/* Allocate a thread-local TLS memory

area and store a pointer to it in TLSp. */
void AllocateTLS()
{

TLSp = __iar_dlib_perthread_allocate() ;

/* Deallocate the thread-local TLS memory area. */
void DeallocateTLS()
{

__dar_dlib_perthread_deallocate(TLSp) ;

/* Access an object in the
thread-local TLS memory area. */
void _DLIB_TLS_MEMORY *__ iar_dlib_perthread_access (
void _DLIB_TLS_MEMORY *symbp)

char _DLIB_TLS_MEMORY *p = 0;
if (InSecondaryThread)

p = (char _DLIB_TLS_MEMORY *) TLSp;
else
p = (char _DLIB_TLS_MEMORY *)
__segment_begin("__DLIB_PERTHREAD") ;
p += __ IAR DLIB_PERTHREAD_SYMBOL_OFFSET (symbp) ;

return (void _DLIB_TLS_MEMORY *) p;
}

The TLSp variable is unique for each thread, and must be exchanged by the RTOS or
manually whenever a thread switch occurs.

TLS IN THE LINKER CONFIGURATION FILE

Normally, the linker automatically chooses how to initialize static data. If threads are
used, the main thread’s TLS memory area must be initialized by plain copying because
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the initializers are used for each secondary thread’s TLS memory area as well. This is
controlled by the following statement in your linker configuration file:

initialize by copy with packing = none {section _ DLIB_PERTHREAD };
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Mixing C and assembler

Calling assembler routines from C
e Calling assembler routines from C++
e Calling convention

e Call frame information

Mixing C and assembler

The IAR C/C++ Compiler for ARM provides several ways to access low-level
resources:

o Modules written entirely in assembler

o Intrinsic functions (the C alternative)

e Inline assembler.

It might be tempting to use simple inline assembler. However, you should carefully
choose which method to use.

INTRINSIC FUNCTIONS

The compiler provides a few predefined functions that allow direct access to low-level
processor operations without having to use the assembler language. These functions are
known as intrinsic functions. They can be very useful in, for example, time-critical
routines.

An intrinsic function looks like a normal function call, but it is really a built-in function
that the compiler recognizes. The intrinsic functions compile into inline code, either as
a single instruction, or as a short sequence of instructions.

For more information about the available intrinsic functions, see the chapter Intrinsic
functions.
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MIXING C AND ASSEMBLER MODULES

It is possible to write parts of your application in assembler and mix them with your C
or C++ modules.

This causes some overhead in the form of function call and return instruction sequences,
and the compiler will regard some registers as scratch registers. In many cases, the
overhead of the extra instructions can be removed by the optimizer.

An important advantage is that you will have a well-defined interface between what the
compiler produces and what you write in assembler. When using inline assembler, you
will not have any guarantees that your inline assembler lines do not interfere with the
compiler generated code.

When an application is written partly in assembler language and partly in C or C++, you

are faced with several questions:

e How should the assembler code be written so that it can be called from C?

o Where does the assembler code find its parameters, and how is the return value
passed back to the caller?

e How should assembler code call functions written in C?

o How are global C variables accessed from code written in assembler language?

o Why does not the debugger display the call stack when assembler code is being
debugged?

The first question is discussed in the section Calling assembler routines from C, page
160. The following two are covered in the section Calling convention, page 163.

The answer to the final question is that the call stack can be displayed when you run
assembler code in the debugger. However, the debugger requires information about the
call frame, which must be supplied as annotations in the assembler source file. For more
information, see Call frame information, page 170.

The recommended method for mixing C or C++ and assembler modules is described in
Calling assembler routines from C, page 160, and Calling assembler routines from
C++, page 162, respectively.

INLINE ASSEMBLER

Inline assembler can be used for inserting assembler instructions directly into a C or
C++ function. Typically, this can be useful if you need to:

® Access hardware resources that are not accessible in C (in other words, when there
is no definition for an SFR or there is no suitable intrinsic function available).

o Manually write a time-critical sequence of code that if written in C will not have the
right timing.
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o Manually write a speed-critical sequence of code that if written in C will be too
slow.

An inline assembler statement is similar to a C function in that it can take input
arguments (input operands), have return values (output operands), and read or write to
C symbols (via the operands). An inline assembler statement can also declare clobbered
resources (that is, values in registers and memory that have been overwritten).

Limitations

Most things you can to do in normal assembler language are also possible with inline
assembler, with the following differences:

e Alignment cannot be controlled; this means, for example, that DC32 directives
might be misaligned.

o The only accepted register synonyms are SP (for R13), LR (for R14), and pC (for
R15).

e In general, assembler directives will cause errors or have no meaning. However,
data definition directives will work as expected.

o Resources used (registers, memory, etc) that are also used by the C compiler must
be declared as operands or clobbered resources.

e If you do not want to risk that the inline assembler statement to be optimized away
by the compiler, you must declare it volatile.
Accessing a C symbol or using a constant expression requires the use of operands.
Dependencies between the expressions for the operands might result in an error.

The pseudo-instruction LDR Rd, =expr is not available from inline assembler.

Risks with inline assembler

Without operands and clobbered resources, inline assembler statements have no
interface with the surrounding C source code. This makes the inline assembler code
fragile, and might also become a maintenance problem if you update the compiler in the
future. There are also several limitations to using inline assembler without operands and
clobbered resources:

o The compiler’s various optimizations will disregard any effects of the inline
statements, which will not be optimized at all.

o The inline assembler statement will be volatile and clobbered memory is not
implied. This means that the compiler will not remove the assembler statement. It
will simply be inserted at the given location in the program flow. The consequences
or side-effects that the insertion might have on the surrounding code are not taken
into consideration. If, for example, registers or memory locations are altered, they
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might have to be restored within the sequence of inline assembler instructions for
the rest of the code to work properly.

The following example (for ARM mode) demonstrates the risks of using the asm
keyword without operands and clobbers:

int Add(int terml, int term2)
{
asm("adds r0,r0,xrl1l");
return terml;

}

In this example:

o The function Add assumes that values are passed and returned in registers in a way
that they might not always be, for example if the function is inlined.

o The s in the adds instruction implies that the condition flags are updated, which
should be specified using the cc clobber operand. Otherwise, the compiler will
assume that the condition flags are not modified.

Inline assembler without using operands or clobbered resources is therefore often best
avoided.

Reference information for inline assembler

Syntax

IAR C/C++ Development Guide
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The asmand __asm keywords both insert inline assembler instructions. However, when
you compile C source code, the asm keyword is not available when the option
--strictisused. The __asmkeyword is always available.

The syntax of an inline assembler statement is (similar to the one used by GNU gcc):

asm [volatile] ( string [assembler-interfacel])

string can contain one or more valid assembler instructions or data definition
assembler directives, separated by \n.

For example:

asm("label:nop\n"
"b label");

Note that you can define and use local labels in inline assembler instructions.
assembler-interfaceis:

comma-separated list of output operands /* optional */
comma-separated list of input operands /* optional */
comma-separated list of clobbered resources /* optional */
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An inline assembler statement can have one input and one output comma-separated list
of operands. Each operand consists of an optional symbolic name in brackets, a quoted
constraint, followed by a C expression in parentheses.

[[ symbolic-name 1] "[modifiers]constraint" (expr)

For example:

int Add(int terml, int term2)
{

int sum;

asm("add %0,%1,%2"
"=r" (sum)
"r* (terml), "r" (term2));

return sum;

}

In this example, the assembler instruction uses one output operand, sum, two input
operands, terml and term2, and no clobbered resources.

It is possible to omit any list by leaving it empty. For example:

int matrix([M] [N];

void MatrixPreloadRow (int row)

{
asm volatile ("pld [%0]" : : "r" (&matrix[row][0]));

}

Constraint Description

r Uses a general purpose register for the expression:
RO-R12, R14 (for ARM and Thumb?2)
RO-R7 (for Thumbl)

1 RO-R7 (only valid for Thumbl)

Rp Uses a pair of general purpose registers, for example R0, R1

i An immediate integer operand with a constant value. Symbolic
constants are allowed.

J A 16-bit constant suitable for a MOVW instruction (valid for ARM and
Thumb?2).

n An immediate operand, alias for i.

Table 14: Inline assembler operand constraints
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Constraint Description

I An immediate constant valid for a data processing instruction (for ARM
and Thumb2), or a constant in the range 0 to 255 (for Thumbl).

J An immediate constant in the range -4095 to 4095 (for ARM and

Thumb?2), or a constant in the range -255 to -1 (for Thumbl).

K An immediate constant that satisfies the I constraint if inverted (for
ARM and Thumb2), or a constant that satisfies the I constraint
multiplied by any power of 2 (for Thumbl).

L An immediate constant that satisfies the I constraint if negated (for
ARM and Thumb2), or a constant in the range -7 to 7 (for Thumbl).

M An immediate constant that is a multiple of 4 in the range 0 to 1020
(only valid for Thumb1).

N An immediate constant in the range 0 to 3| (only valid for Thumbl).

¢} An immediate constant that is a multiple of 4 in the range -508 to 508

(only valid for Thumbl).

t An S register.

w A D register.
A Q register.

Dv A 32-bit floating-point immediate constant for the VMOV . F32
instruction.

Dy A 64-bit floating-point immediate constant for the VMOV .F64
instruction.

v2S ... v4Q A vector of 2, 3, or 4 consecutive S, D, or Q registers. For example,

v4Q is a vector of four Q registers. The vectors do not overlap, so the
available v4Q register vectors are Q0-03, 04-Q07, 08-Q11, and
Q12-Q15.

Table 14: Inline assembler operand constraints (Continued)

Constraint modifiers Constraint modifiers can be used together with a constraint to modify its meaning. This
table lists the supported constraint modifiers:

Modifier Desciption

= Write-only operand
Read-write operand

& Early clobber output operand which is written to before the instruction
has processed all the input operands.

Table 15: Supported constraint modifiers

IAR C/C++ Development Guide
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Assembler instructions refer to operands by prefixing their order number with %. The
first operand has order number 0 and is referred to by %0.

If the operand has a symbolic name, you can refer to it using the syntax

% [operand.name]. Symbolic operand names are in a separate namespace from C/C++
code and can be the same as a C/C++ variable names. Each operand name must however
be unique in each assembler statement. For example:

int Add(int terml, int term2)
{

int sum;

asm("add %$[RdA],%[Rn],%$[Rm]"
[RA] "=r" (sum)
[Rn]"r" (terml), [Rm]"r" (term2));

return sum;

An operand modifier is a single letter between the % and the operand number, which is
used for transforming the operand.

In the example below, the modifiers L and H are used for accessing the least and most
significant 16 bits, respectively, of an immediate operand:

int Mov32()
{
int a;
asm("movw %$0,%L1 \n"
"movt %0,%H1 \n" : "=r"(a) : "i"(0x12345678UL)) ;
return a;

}

Some operand modifiers can be combined, in which case each letter will transform the
result from the previous modifier. This table describes the transformation performed by
each valid modifier:

Modifier Description

L The lowest-numbered register of a register pair, or the low 16 bits of an
immediate constant.

H The highest-numbered register of a register pair, or the high 16 bits of
an immediate constant.

c For an immediate operand, an integer or symbol address without a
preceding # sign. Cannot be transformed by additional operand
modifiers.

Table 16: Operand modifiers and transformations
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Output operands

Input/output operands
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Modifier Description

B For an immediate operand, the bitwise inverse of integer or symbol
without a preceding # sign. Cannot be transformed by additional
operand modifiers.

0 The least significant register of a register pair.
The most significant register of a register pair.

For a register or a register pair, the register list suitable for 1dm or
stm. Cannot be transformed by additional operand modifiers.

a Transforms a register Rn into a memory operand [Rn, #0] suitable
for pld.

b The low S register part of a D register.

P The high S register part of a D register.

e The low D register part of a Q register, or the low register in a vector of

Neon registers.

£ The high D register part of a Q register; or the high register in a vector
of Neon registers.

h For a (vector of) D or Q registers, the corresponding list of D registers

within curly braces. For example, Q0 becomes {D0, D1}. Cannot be
transformed by additional operand modifiers.

v S register as indexed D register, for example S7 becomes D3 [1].
Cannot be transformed by additional operand modifiers.

Table 16: Operand modifiers and transformations

Input operands cannot have any modifiers, but they can have any valid C expression as
long as the type of the expression fits the register.

The C expression will be evaluated just before any of the assembler instructions in the
inline assembler statement and assigned to the constraint, for example a register.

Output operands must have = as a modifier and the C expression must be an I-value and
specify a writable location. For example, =r for a write-only general purpose register.
The constraint will be assigned to the evaluated C expression (as an l-value)
immediately after the last assembler instruction in the inline assembler statement. Input
operands are assumed to be consumed before output is produced and the compiler may
use the same register for an input and output operand. To prohibit this, prefix the output
constraint with & to make it an early clobber resource, for example =&xr. This will ensure
that the output operand will be allocated in a different register than the input operands.

An operand that should be used both for input and output must be listed as an output
operand and have the + modifier. The C expression must be an I-value and specify a
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writable location. The location will be read immediately before any assembler
instructions and it will be written to right after the last assembler instruction.

This is an example of using a read-write operand:

int Double (int value)
{

asm("add %0,%0,%0" : "+r"(value));

return value;

}

In the example above, the input value for value will be placed in a general purpose
register. After the assembler statement, the result from the ADD instruction will be placed
in the same register.

An inline assembler statement can have a list of clobbered resources.

"resourcel", "resourcel2",

Specify clobbered resources to inform the compiler about which resources the inline
assembler statement destroys. Any value that resides in a clobbered resource and that is
needed after the inline assembler statement will be reloaded.

Clobbered resources will not be used as input or output operands.
This is an example of how to use clobbered resources:

int Add(int terml, int term2)
{

int sum;

asm("adds %0,%1,%2"
"=r" (sum)
"r" (terml), "r" (term2)
||cc||);

return sum;

}

In this example the condition codes will be modified by the ADDS instruction. Therefore,
"cc" must be listed in the clobber list.

This table lists valid clobbered resources:

Clobber Description

RO-R12, R14for ARM mode and Thumb2 General purpose registers
RO-R7,R12, R14 for Thumbl

Table 17: List of valid clobbers
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Clobber Description

S0-S31,D0-D31, Q0-Q15 Floating-point registers

cc The condition flags (N, Z, V, and C)
memory To be used if the instructions modify any

memory. This will avoid keeping memory
values cached in registers across the inline
assembler statement.

Table 17: List of valid clobbers (Continued)

AN EXAMPLE OF HOW TO USE CLOBBERED MEMORY

int StoreExclusive (unsigned long * location, unsigned long value)

{
int failed;

asm("strex %0,%2, [$1]"
"=&r" (failed)
"r"(location), "r"(value)
"memory") ;

/* Note: 'strex' requires ARMv6 (ARM) or ARMv6T2 (THUMB) */

return failed;

Calling assembler routines from C

An assembler routine that will be called from C must:

o Conform to the calling convention
Have a PUBLIC entry-point label

Be declared as external before any call, to allow type checking and optional
promotion of parameters, as in these examples:

extern int foo(void);
or
extern int foo(int i, int j);

One way of fulfilling these requirements is to create skeleton code in C, compile it, and
study the assembler list file.

IAR C/C++ Development Guide
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CREATING SKELETON CODE

The recommended way to create an assembler language routine with the correct
interface is to start with an assembler language source file created by the C compiler.
Note that you must create skeleton code for each function prototype.

The following example shows how to create skeleton code to which you can easily add
the functional body of the routine. The skeleton source code only needs to declare the
variables required and perform simple accesses to them. In this example, the assembler
routine takes an int and a char, and then returns an int:

extern int glInt;
extern char gChar;

int Func(int argl, char arg2)
{

int locInt = argl;

gInt = argl;

gChar = arg2;

return locInt;

}

int main()

{
int locInt = gInt;
gInt = Func(locInt, gChar);
return O;

}

Note: In this example we use a low optimization level when compiling the code to show
local and global variable access. If a higher level of optimization is used, the required
references to local variables could be removed during the optimization. The actual
function declaration is not changed by the optimization level.

COMPILING THE SKELETON CODE

In the IDE, specitfy list options on file level. Select the file in the workspace window.
Then choose Project>Options. In the C/C++ Compiler category, select Override
inherited settings. On the List page, deselect Output list file, and instead select the
Output assembler file option and its suboption Include source. Also, be sure to specify
a low level of optimization.

Use these options to compile the skeleton code:
iccarm skeleton.c -1A . -On -e

The -1a option creates an assembler language output file including C or C++ source
lines as assembler comments. The . (period) specifies that the assembler file should be
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named in the same way as the C or C++ module (skeleton), but with the filename
extension s. The -on option means that no optimization will be used and -e enables
language extensions. In addition, make sure to use relevant compiler options, usually the
same as you use for other C or C++ source files in your project.

The result is the assembler source output file skeleton.s.

Note: The -1a option creates a list file containing call frame information (CFI)
directives, which can be useful if you intend to study these directives and how they are
used. If you only want to study the calling convention, you can exclude the CFI
directives from the list file.

In the IDE, choose Project>Options>C/C++ Compiler>List and deselect the
suboption Include call frame information.

On the command line, use the option -1B instead of -1A. Note that CF I information must
be included in the source code to make the C-SPY Call Stack window work.

The output file
The output file contains the following important information:

The calling convention
The return values

The global variables
The function parameters

How to create space on the stack (auto variables)

Call frame information (CFI).

The cF1I directives describe the call frame information needed by the Call Stack
window in the debugger. For more information, see Call frame information, page 170.

Calling assembler routines from C++
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The C calling convention does not apply to C++ functions. Most importantly, a function
name is not sufficient to identify a C++ function. The scope and the type of the function
are also required to guarantee type-safe linkage, and to resolve overloading.

Another difference is that non-static member functions get an extra, hidden argument,
the this pointer.
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However, when using C linkage, the calling convention conforms to the C calling
convention. An assembler routine can therefore be called from C++ when declared in
this manner:

extern "C"
{
int MyRoutine (int) ;

}

The following example shows how to achieve the equivalent to a non-static member
function, which means that the implicit this pointer must be made explicit. It is also
possible to “wrap” the call to the assembler routine in a member function. Use an inline
member function to remove the overhead of the extra call—this assumes that function
inlining is enabled:

class MyClass;

extern "C"

{
void DoIt (MyClass *ptr, int arg);

class MyClass
{
public:
inline void DoIt (int arg)
{
::DoIt(this, arg);

Calling convention

A calling convention is the way a function in a program calls another function. The
compiler handles this automatically, but, if a function is written in assembler language,
you must know where and how its parameters can be found, how to return to the program
location from where it was called, and how to return the resulting value.

It is also important to know which registers an assembler-level routine must preserve. If
the program preserves too many registers, the program might be ineffective. If it
preserves too few registers, the result would be an incorrect program.

This section describes the calling convention used by the compiler. These items are
examined:

e Function declarations
o C and C++ linkage
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o Preserved versus scratch registers

e Function entrance

o Function exit

o Return address handling.

At the end of the section, some examples are shown to describe the calling convention
1n practice.

The calling convention used by the compiler adheres to the Procedure Call Standard for
the ARM architecture, AAPCS, a part of AEABI; see AEABI compliance, page 209.
AAPCS is not fully described here. For example, the use of floating-point coprocessor
registers when using the VFP calling convention is not covered.

FUNCTION DECLARATIONS

In C, a function must be declared in order for the compiler to know how to call it. A
declaration could look as follows:

int MyFunction(int first, char * second);

This means that the function takes two parameters: an integer and a pointer to a
character. The function returns a value, an integer.

In the general case, this is the only knowledge that the compiler has about a function.
Therefore, it must be able to deduce the calling convention from this information.

USING C LINKAGE IN C++ SOURCE CODE

In C++, a function can have either C or C++ linkage. To call assembler routines from
C++, it is easiest if you make the C++ function have C linkage.

This is an example of a declaration of a function with C linkage:

extern "C"
{

int F(int);
}
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It is often practical to share header files between C and C++. This is an example of a
declaration that declares a function with C linkage in both C and C++:

#ifdef cplusplus
extern "C"

{

#endif

int F(int);

#ifdef __cplusplus
}
#endif

PRESERVED VERSUS SCRATCH REGISTERS

The general ARM CPU registers are divided into three separate sets, which are
described in this section.

Scratch registers

Any function is permitted to destroy the contents of a scratch register. If a function needs
the register value after a call to another function, it must store it during the call, for
example on the stack.

Any of the registers RO to R3, and R12, can be used as a scratch register by the function.
Note that R12 is a scratch register also when calling between assembler functions only
because of automatically inserted instructions for veneers.

Preserved registers

Preserved registers, on the other hand, are preserved across function calls. The called
function can use the register for other purposes, but must save the value before using the
register and restore it at the exit of the function.

The registers R4 through to R11 are preserved registers. They are preserved by the called
function.

Special registers

For some registers, you must consider certain prerequisites:

o The stack pointer register, R13/SP, must at all times point to or below the last
element on the stack. In the eventuality of an interrupt, everything below the point
the stack pointer points to, can be destroyed. At function entry and exit, the stack
pointer must be 8-byte aligned. In the function, the stack pointer must always be
word aligned. At exit, SP must have the same value as it had at the entry.
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e The register R15/PC is dedicated for the Program Counter.

o The link register, R14 /LR, holds the return address at the entrance of the function.

FUNCTION ENTRANCE
Parameters can be passed to a function using one of these basic methods:

o In registers
o On the stack

It is much more efficient to use registers than to take a detour via memory, so the calling
convention is designed to use registers as much as possible. Only a limited number of
registers can be used for passing parameters; when no more registers are available, the
remaining parameters are passed on the stack.These exceptions to the rules apply:

e Interrupt functions cannot take any parameters, except software interrupt functions
that accept parameters and have return values

e Software interrupt functions cannot use the stack in the same way as ordinary
functions. When an Svc instruction is executed, the processor switches to
supervisor mode where the supervisor stack is used. Arguments can therefore not be
passed on the stack if your application is not running in supervisor mode previous to
the interrupt.

Hidden parameters

In addition to the parameters visible in a function declaration and definition, there can
be hidden parameters:

e If the function returns a structure larger than 32 bits, the memory location where the
structure is to be stored is passed as an extra parameter. Notice that it is always
treated as the first parameter.

e If the function is a non-static C++ member function, then the this pointer is passed
as the first parameter (but placed after the return structure pointer, if there is one).
For more information, see Calling assembler routines from C, page 160.

Register parameters

The registers available for passing parameters are:

Parameters Passed in registers

Scalar and floating-point values no larger than 32 bits, Passed using the first free register:
and single-precision (32-bits) floating-point values RO-R3

Table 18: Registers used for passing parameters
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Parameters Passed in registers

long long and double-precision (64-bit) values Passed in first available register pair:
RO:R1,0or R2:R3

Table 18: Registers used for passing parameters

The assignment of registers to parameters is a straightforward process. Traversing the
parameters from left to right, the first parameter is assigned to the available register or
registers. Should there be no more available registers, the parameter is passed on the
stack in reverse order.

When functions that have parameters smaller than 32 bits are called, the values are sign
or zero extended to ensure that the unused bits have consistent values. Whether the
values will be sign or zero extended depends on their type—signed or unsigned.

Stack parameters and layout

Stack parameters are stored in memory, starting at the location pointed to by the stack
pointer. Below the stack pointer (towards low memory) there is free space that the called
function can use. The first stack parameter is stored at the location pointed to by the
stack pointer. The next one is stored at the next location on the stack that is divisible by
four, etc. It is the responsibility of the caller to clean the stack after the called function
has returned.

This figure illustrates how parameters are stored on the stack:

High
address
The caller’s stack frame
Parameter n
Parameter 1
Return address
Low
address Free stack memory

FUNCTION EXIT

A function can return a value to the function or program that called it, or it can have the
return type void.

The return value of a function, if any, can be scalar (such as integers and pointers),
floating-point, or a structure.
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Registers used for returning values

The registers available for returning values are RO and RO : R1.

Return values Passed in registers

Scalar and structure return values no larger RO
than 32 bits, and single-precision (32-bit)
floating-point return values

The memory address of a structure return RO
value larger than 32 bits

long long and double-precision (64-bit) RO:R1
return values

Table 19: Registers used for returning values

If the returned value is smaller than 32 bits, the value is sign- or zero-extended to 32 bits.

Stack layout at function exit

It is the responsibility of the caller to clean the stack after the called function has
returned.

Return address handling

A function written in assembler language should, when finished, return to the caller, by
jumping to the address pointed to by the register LR.

At function entry, non-scratch registers and the Lr register can be pushed with one
instruction. At function exit, all these registers can be popped with one instruction. The
return address can be popped directly to pC.

The following example shows what this can look like:

name call
section .text:CODE
extern func

push {rd-r6,1r} ; Preserve stack alignment 8
bl func

; Do something here.
pop {rd-r6,pc} ;  return

end
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EXAMPLES

The following section shows a series of declaration examples and the corresponding
calling conventions. The complexity of the examples increases toward the end.

Example |
Assume this function declaration:
int addl (int) ;

This function takes one parameter in the register R0, and the return value is passed back
to its caller in the register RO.

This assembler routine is compatible with the declaration; it will return a value that is
one number higher than the value of its parameter:

name return
section .text:CODE
add r0, r0, #1
bx 1r

end

Example 2

This example shows how structures are passed on the stack. Assume these declarations:

struct MyStruct

{
short a;
short b;
short c;
short d;
short e;

Y

int MyFunction (struct MyStruct x, int vy);

The values of the structure members a, b, c, and d are passed in registers RO-R3. The
last structure member e and the integer parameter y are passed on the stack. The calling
function must reserve eight bytes on the top of the stack and copy the contents of the two
stack parameters to that location. The return value is passed back to its caller in the
register RO.
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Example 3
The function below will return a structure of type struct MyStruct.

struct MyStruct
{

int mA[20];
Y
struct MyStruct MyFunction(int x);

It is the responsibility of the calling function to allocate a memory location for the return
value and pass a pointer to it as a hidden first parameter. The pointer to the location
where the return value should be stored is passed in RO. The parameter x is passed in R1.

Assume that the function instead was declared to return a pointer to the structure:
struct MyStruct *MyFunction(int x);

In this case, the return value is a scalar, so there is no hidden parameter. The parameter
x is passed in RO, and the return value is returned in RO.

Call frame information
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When you debug an application using C-SPY, you can view the call stack, that is, the
chain of functions that called the current function. To make this possible, the compiler
supplies debug information that describes the layout of the call frame, in particular
information about where the return address is stored.

If you want the call stack to be available when debugging a routine written in assembler
language, you must supply equivalent debug information in your assembler source using
the assembler directive CFI. This directive is described in detail in the [4AR Assembler
User Guide for ARM.

CFI DIRECTIVES

The cF1 directives provide C-SPY with information about the state of the calling
function(s). Most important of this is the return address, and the value of the stack
pointer at the entry of the function or assembler routine. Given this information, C-SPY
can reconstruct the state for the calling function, and thereby unwind the stack.

A full description about the calling convention might require extensive call frame
information. In many cases, a more limited approach will suffice.

When describing the call frame information, the following three components must be
present:

® A names block describing the available resources to be tracked
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® A common block corresponding to the calling convention

® A data block describing the changes that are performed on the call frame. This
typically includes information about when the stack pointer is changed, and when
permanent registers are stored or restored on the stack.

Resource Description

CFA R13 The call frames of the stack

RO-R12 Processor general-purpose 32-bit registers

R13 Stack pointer, SP

R14 Link register; LR

D0-D31 Vector Floating Point (VFP) 64-bit coprocessor register
CPSR Current program status register

SPSR Saved program status register

Table 20: Call frame information resources defined in a names block

CREATING ASSEMBLER SOURCE WITH CFl SUPPORT

The recommended way to create an assembler language routine that handles call frame
information correctly is to start with an assembler language source file created by the
compiler.

Start with suitable C source code, for example:

int F(int);
int cfiExample (int i)
{

return 1 + F(i);

}

Compile the C source code, and make sure to create a list file that contains call frame
information—the CFI directives.

On the command line, use the option -1A.

In the IDE, choose Project>Options>C/C++ Compiler>List and make sure the
suboption Include call frame information is selected.
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For the source code in this example, the list file looks like this:

NAME

RTMO

EXTE

PUBL

cfi

DEL "__ SystemLibrary",
RN F

IC cfiExample

CFI Names cfiNamesO
CFI StackFrame CFA R13 DATA
CFI Resource R0:32, R1:32,

R6:32, R7:32
CFI
R13:32, R14
CFI

CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI
CFI

SECT

ARM
cfiExample:
PUSH

CFI R14 Frame (CFA,

CFI

Resource R8:32, R9:32,

:32

EndNames cfiNamesO

"DLib"

R2:32,

R10:32,

R3:32,

R11:32,

Common cfiCommonO Using cfiNamesO

CodeAlign 4
DataAlign 4

ReturnAddress R14 CODE

CFA R13+0

RO Undefined

R1 Undefined

R2 Undefined

R3 Undefined

R4 SameValue

R5 SamevValue

R6 SameValue

R7 SameValue

R8 SameValue

R9 SamevValue

R10 SameValue
R11 SameValue
R12 Undefined
R14 SameValue

EndCommon cfiCommon0

ION ' .text' :CODE:NOROOT (2)
CFI Block cfiBlock0O Using cfiCommonO
CFI Function cfiExample

{R4,LR}

R4 Frame (CFA,

-4)
-8)

R4:32,

R5:32,

R12:32,



Assembler language interface ___4

CFI CFA R13+8

MOVS R4,RO

MOVS RO,R4

BL F

ADDS RO,RO,R4

POP {R4,PC} ;7 return

CFI EndBlock cfiBlock0

END

Note: The header file Common . i contains the macros CFI_NAMES_BLOCK,
CFI_COMMON_ARM, and CFI_COMMON_Thumb, which declare a typical names block and
a typical common block. These two macros declare several resources, both concrete and
virtual.
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Using C

e C language overview
e Extensions overview

e |AR C language extensions

C language overview

The IAR C/C++ Compiler for ARM supports the ISO/IEC 9899:1999 standard
(including up to technical corrigendum No.3), also known as C99. In this guide, this
standard is referred to as Standard C and is the default standard used in the compiler.
This standard is stricter than C89.

In addition, the compiler also supports the ISO 9899:1990 standard (including all
technical corrigenda and addenda), also known as C94, C90, C89, and ANSI C. In this
guide, this standard is referred to as C89. Use the --c89 compiler option to enable this
standard.

The C99 standard is derived from C89, but adds features like these:
o The inline keyword advises the compiler that the function defined immediately
after the keyword should be inlined

Declarations and statements can be mixed within the same scope
A declaration in the initialization expression of a for loop

The bool data type

The long long data type

The complex floating-point type

C++ style comments

Compound literals

Incomplete arrays at the end of structs

Hexadecimal floating-point constants

Designated initializers in structures and arrays

The preprocessor operator _Pragma ()

Variadic macros, which are the preprocessor macro equivalents of printf style
functions

o VLA (variable length arrays) must be explicitly enabled with the compiler option
--vla
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Inline assembler using the asm or the __asm keyword, see .

Note: Even though it is a C99 feature, the IAR C/C++ Compiler for ARM does not
support UCNSs (universal character names).

Extensions overview
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The compiler offers the features of Standard C and a wide set of extensions, ranging
from features specifically tailored for efficient programming in the embedded industry
to the relaxation of some minor standards issues.

This is an overview of the available extensions:

IAR C language extensions

For information about available language extensions, see /AR C language extensions,
page 177. For more information about the extended keywords, see the chapter
Extended keywords. For information about C++, the two levels of support for the
language, and C++ language extensions; see the chapter Using C++.

Pragma directives

The #pragma directive is defined by Standard C and is a mechanism for using
vendor-specific extensions in a controlled way to make sure that the source code is
still portable.

The compiler provides a set of predefined pragma directives, which can be used for
controlling the behavior of the compiler, for example how it allocates memory,
whether it allows extended keywords, and whether it outputs warning messages.
Most pragma directives are preprocessed, which means that macros are substituted
in a pragma directive. The pragma directives are always enabled in the compiler. For
several of them there is also a corresponding C/C++ language extension. For
information about available pragma directives, see the chapter Pragma directives.

Preprocessor extensions

The preprocessor of the compiler adheres to Standard C. The compiler also makes
several preprocessor-related extensions available to you. For more information, see
the chapter The preprocessor.

Intrinsic functions

The intrinsic functions provide direct access to low-level processor operations and
can be very useful in, for example, time-critical routines. The intrinsic functions
compile into inline code, either as a single instruction or as a short sequence of
instructions. For more information about using intrinsic functions, see Mixing C and
assembler, page 151. For information about available functions, see the chapter
Intrinsic functions.
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e Library functions

The IAR DLIB Library provides the C and C++ library definitions that apply to
embedded systems. For more information, see DLIB runtime
environment—implementation details, page 417.

Note: Any use of these extensions, except for the pragma directives, makes your source
code inconsistent with Standard C.

ENABLING LANGUAGE EXTENSIONS
You can choose different levels of language conformance by means of project options:

Command line IDE* Description

--strict Strict All' lAR C language extensions are disabled;
errors are issued for anything that is not part
of Standard C.

None Standard All extensions to Standard C are enabled, but no
extensions for embedded systems programming.
For information about extensions, see IAR C
language extensions, page 177.

-e Standard with IAR All IAR C language extensions are enabled.
extensions

Table 21: Language extensions

* In the IDE, choose Project>Options>C/C++ Compiler>Language>Language
conformance and select the appropriate option. Note that language extensions are
enabled by default.

IAR C language extensions

The compiler provides a wide set of C language extensions. To help you to find the
extensions required by your application, they are grouped like this in this section:

® [Extensions for embedded systems programming—extensions specifically tailored
for efficient embedded programming for the specific core you are using, typically to
meet memory restrictions

® Relaxations to Standard C—that is, the relaxation of some minor Standard C issues
and also some useful but minor syntax extensions, see Relaxations to Standard C,
page 180.
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EXTENSIONS FOR EMBEDDED SYSTEMS PROGRAMMING

The following language extensions are available both in the C and the C++
programming languages and they are well suited for embedded systems programming:

e Type attributes and object attributes

For information about the related concepts, the general syntax rules, and for
reference information, see the chapter Extended keywords.

o Placement at an absolute address or in a named section

The @ operator or the directive #pragma location can be used for placing global

and static variables at absolute addresses, or placing a variable or function in a named
section. For more information about using these features, see Controlling data and
function placement in memory, page 216, and location, page 358.

o Alignment control

Each data type has its own alignment; for more information, see Alignment, page
319. If you want to change the alignment, the __packed data type attribute, the
#pragma pack, and the #pragma data_alignment directives are available. If you
want to check the alignment of an object, use the __ALIGNOF__ () operator.

The __ALIGNOF__ operator is used for accessing the alignment of an object. It takes
one of two forms:

® _ _ALIGNOF__ (type)

® __ALIGNOF__ (expression)

In the second form, the expression is not evaluated.
o Anonymous structs and unions

C++ includes a feature called anonymous unions. The compiler allows a similar
feature for both structs and unions in the C programming language. For more
information, see Anonymous structs and unions, page 215.

e Bitfields and non-standard types

In Standard C, a bitfield must be of the type int or unsigned int. Using [ARC

language extensions, any integer type or enumeration can be used. The advantage is
that the struct will sometimes be smaller. For more information, see Bitfields, page
322.

® static_assert()

The construction static_assert (const-expression, "message") ; can be
used in C/C++. The construction will be evaluated at compile time and if
const-expression is false, a message will be issued including the message
string.
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o Parameters in variadic macros

Variadic macros are the preprocessor macro equivalents of print£ style functions.
The preprocessor accepts variadic macros with no arguments, which means if no
parameter matches the . . . parameter, the comma is then deleted in the ",
##__VA_ARGS__ " macro definition. According to Standard C, the . . . parameter
must be matched with at least one argument.

Dedicated section operators

The compiler supports getting the start address, end address, and size for a section with
these built-in section operators:

__section_begin Returns the address of the first byte of the named section or
block.

__section_end Returns the address of the first byte after the named section
or block.

__section_size Returns the size of the named section or block in bytes.

Note: The aliases __segment_begin/__sfb
__segment_size/__sfs can also be used.

segment_end/__sfe, and

[ J—

The operators can be used on named sections or on named blocks defined in the linker
configuration file.

These operators behave syntactically as if declared like:

void * __section_begin(char const * section)
void * __section_end(char const * section)
size_t __section_size(char const * section)

When you use the @ operator or the #pragma location directive to place a data object
or a function in a user-defined section, or when you use named blocks in the linker
configuration file, the section operators can be used for getting the start and end address
of the memory range where the sections or blocks were placed.

The named section must be a string literal and it must have been declared earlier with
the #pragma section directive. The type of the __section_begin operator is a
pointer to void. Note that you must enable language extensions to use these operators.
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The operators are implemented in terms of symbols with dedicated names, and will
appear in the linker map file under these names:

Operator Symbol
__section_begin (sec) sec$$Base
__section_end(sec) sec$SLimit
__section_size(sec) sec$S$SLength

Table 22: Section operators and their symbols

Note that the linker will not necessarily place sections with the same name consecutively
when these operators are not used. Using one of these operators (or the equivalent
symbols) will cause the linker to behave as if the sections were in a named block. This
is to assure that the sections are placed consecutively, so that the operators can be
assigned meaningful values. If this is in conflict with the section placement as specified
in the linker configuration file, the linker will issue an error.

Example
In this example, the type of the __section_begin operator is void *.

#pragma section="MYSECTION"

section_start_address = __section_begin ("MYSECTION") ;

See also section, page 364, and location, page 358.

RELAXATIONS TO STANDARD C

This section lists and briefly describes the relaxation of some Standard C issues and also
some useful but minor syntax extensions:
e Arrays of incomplete types

An array can have an incomplete struct, union, or enum type as its element type.
The types must be completed before the array is used (if it is), or by the end of the
compilation unit (if it is not).

e Forward declaration of enum types

The extensions allow you to first declare the name of an enum and later resolve it by
specifying the brace-enclosed list.

® Accepting missing semicolon at the end of a struct or union specifier

A warning—instead of an error—is issued if the semicolon at the end of a struct
or union specifier is missing.

o Null and void

In operations on pointers, a pointer to void is always implicitly converted to another
type if necessary, and a null pointer constant is always implicitly converted to a null
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pointer of the right type if necessary. In Standard C, some operators allow this kind
of behavior, while others do not allow it.

Casting pointers to integers in static initializers

In an initializer, a pointer constant value can be cast to an integral type if the integral
type is large enough to contain it. For more information about casting pointers, see
Casting, page 328.

Taking the address of a register variable

In Standard C, it is illegal to take the address of a variable specified as a register
variable. The compiler allows this, but a warning is issued.

long float means double
The type Llong float is accepted as a synonym for double.
Repeated typedef declarations

Redeclarations of typedef that occur in the same scope are allowed, but a warning
is issued.

Mixing pointer types

Assignment and pointer difference is allowed between pointers to types that are
interchangeable but not identical; for example, unsigned char * and char *. This
includes pointers to integral types of the same size. A warning is issued.

Assignment of a string constant to a pointer to any kind of character is allowed, and
no warning is issued.

Non-top level const

Assignment of pointers is allowed in cases where the destination type has added type
qualifiers that are not at the top level (for example, int ** to int const **).
Comparing and taking the difference of such pointers is also allowed.

Non-lvalue arrays

A non-lvalue array expression is converted to a pointer to the first element of the
array when it is used.

Comments at the end of preprocessor directives

This extension, which makes it legal to place text after preprocessor directives, is
enabled unless the strict Standard C mode is used. The purpose of this language
extension is to support compilation of legacy code; we do not recommend that you
write new code in this fashion.

An extra comma at the end of enum lists

Placing an extra comma is allowed at the end of an enum list. In strict Standard C
mode, a warning is issued.
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A label preceding a }

In Standard C, a label must be followed by at least one statement. Therefore, it is
illegal to place the label at the end of a block. The compiler allows this, but issues a
warning.

Note that this also applies to the labels of switch statements.

Empty declarations

An empty declaration (a semicolon by itself) is allowed, but a remark is issued
(provided that remarks are enabled).

Single-value initialization

Standard C requires that all initializer expressions of static arrays, structs, and unions
are enclosed in braces.

Single-value initializers are allowed to appear without braces, but a warning is
issued. The compiler accepts this expression:
struct str
{
int a;
} x = 10;

Declarations in other scopes

External and static declarations in other scopes are visible. In the following example,
the variable y can be used at the end of the function, even though it should only be
visible in the body of the i f statement. A warning is issued.
int test(int x)
{

if (%)

{

extern int vy;
y = 1;

return y;

}
Expanding function names into strings with the function as context

Use any of the symbols __func__ or __FUNCTION__ inside a function body to
make the symbol expand into a string that contains the name of the current function.
Use the symbol __ PRETTY_FUNCTION__ to also include the parameter types and
return type. The result might, for example, look like this if you use the

__PRETTY_FUNCTION__ symbol:
"void func(char)"

These symbols are useful for assertions and other trace utilities and they require that
language extensions are enabled, see -e, page 261.
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e Static functions in function and block scopes

Static functions may be declared in function and block scopes. Their declarations are
moved to the file scope.

o Numbers scanned according to the syntax for numbers

Numbers are scanned according to the syntax for numbers rather than the
pp-number syntax. Thus, 0x123e+1 is scanned as three tokens instead of one valid
token. (If the --strict option is used, the pp-number syntax is used instead.)

183



IAR C language extensions

IAR C/C++ Development Guide
184  Compiling and Linking for ARM



Using C++

o Overview—EC++ and EEC++

e Overview—Standard C++

e Enabling support for C++ and variants
e C++ and EC++ feature descriptions

o EEC++ feature description

e EC++ and C++ language extensions

Overview—EC++ and EEC++
IAR Systems supports the C++ language. You can choose between these standards:
Standard C++, the industry-standard Embedded C++, and Extended Embedded C++.
Using C++ describes what you need to consider when using the C++ language.

Embedded C++ is a proper subset ofthe ISO/IEC C++ standard which is intended for
embedded systems programming. It was defined by an industry consortium, the
Embedded C++ Technical Committee. Performance and portability are particularly
important in embedded systems development, which was considered when defining the
language. EC++ offers the same object-oriented benefits as C++, but without some
features that can increase code size and execution time in ways that are hard to predict.

EMBEDDED C++
These C++ features are supported:

o Classes, which are user-defined types that incorporate both data structure and
behavior; the essential feature of inheritance allows data structure and behavior to
be shared among classes

o Polymorphism, which means that an operation can behave differently on different
classes, is provided by virtual functions

o Opverloading of operators and function names, which allows several operators or
functions with the same name, provided that their argument lists are sufficiently
different

o Type-safe memory management using the operators new and delete

e Inline functions, which are indicated as particularly suitable for inline expansion.
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C++ features that are excluded are those that introduce overhead in execution time or
code size that are beyond the control of the programmer. Also excluded are features
added very late before Standard C++ was defined. Embedded C++ thus offers a subset
of C++ which is efficient and fully supported by existing development tools.

Embedded C++ lacks these features of C++:
Templates

Multiple and virtual inheritance
Exception handling

Runtime type information

New cast syntax (the operators dynamic_cast, static_cast,
reinterpret_cast, and const_cast)

e Namespaces

o The mutable attribute.

The exclusion of these language features makes the runtime library significantly more
efficient. The Embedded C++ library furthermore differs from the full C++ library in

that:

o The standard template library (STL) is excluded

e Streams, strings, and complex numbers are supported without the use of templates
e Library features which relate to exception handling and runtime type information

(the headers except, stdexcept, and typeinfo) are excluded.

Note: The library is not in the std namespace, because Embedded C++ does not
support namespaces.

EXTENDED EMBEDDED C++

IAR Systems’ Extended EC++ is a slightly larger subset of C++ which adds these
features to the standard EC++:

Full template support

Multiple and virtual inheritance

Namespace support

The mutable attribute

The cast operators static_cast, const_cast, and reinterpret_cast.
All these added features conform to the C++ standard.

To support Extended EC++, this product includes a version of the standard template
library (STL), in other words, the C++ standard chapters utilities, containers, iterators,
algorithms, and some numerics. This STL is tailored for use with the Extended EC++
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language, which means no exceptions and no support for runtime type information
(rtti). Moreover, the library is not in the std namespace.

Note: A module compiled with Extended EC++ enabled is fully link-compatible with a
module compiled without Extended EC++ enabled.

Overview—Standard C++

The IAR C++ implementation fully complies with the ISO/IEC 14882:2003 C++
standard. In this guide, this standard is referred to as Standard C++.

The main reason for using Standard C++ instead of EC++ or EEC++ is when there is a
need for either:

e Exception support
o Runtime type information (RTTI) support

o The standard C++ library (the EC++ library is a stripped version of the C++ library
where streams and strings are not templates).

If code size is important and your application does not need any of these features, EC++
(or EEC++) is the better choice.

MODES FOR EXCEPTIONS AND RTTI SUPPORT

Both exceptions and runtime type information result in increased code size simply by
being included in your application. You might want to disable either or both of these
features to avoid this increase:

e Support for runtime type information constructs can be disabled by using the
compiler option --no_rtti

e Support for exceptions can be disabled by using the compiler option

--no_exceptions

Even if support is enabled while compiling, the linker can avoid including the extra code
and tables in the final application. If no part of your application actually throws an
exception, the code and tables supporting the use of exceptions are not included in the
application code image. Also, if dynamic runtime type information constructs
(dynamic_cast/typeid) are not used with polymorphic types, the objects needed to
support them are not included in the application code image. To control this behavior,
use the linker options --no_exceptions, --force_exceptions, and
--no_dynamic_rtti_elimination.
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Disabling exception support

When you use the compiler option --no_exceptions, the following will generate a
compiler error:

® throw expressions

® try-catch statements

o Exception specifications on function definitions.

In addition, the extra code and tables needed to handle destruction of objects with auto

storage duration when an exception is propagated through a function will not be
generated when the compiler option --no_exceptions is used.

All functionality in system headers not directly involving exceptions is supported when
the compiler option --no_exceptions is used.

The linker will produce an error if you try to link C++ modules compiled with exception
support with modules compiled without exception support

For more information, see --no_exceptions, page 272.

Disabling RTTI support

When you use the compiler option --no_rtti, the following will generate a compiler
error:

o The typeid operator

o The dynamic_cast operator.

Note: If --no_rtti is used but exception support is enabled, most RTTI support is still
included in the compiler output object file because it is needed for exceptions to work.

For more information, see --no_rtti, page 274.

EXCEPTION HANDLING
Exception handling can be divided into three parts:

o Exception raise mechanisms—in C++ they are the throw and rethrow
expressions.

o Exception catch mechanisms—in C++ they are the try—catch statements, the
exception specifications for a function, and the implicit catch to prevent an
exception leaking out from main.

o Information about currently active functions—if they have try—catch statements

and the set of auto objects whose destructors need to be run if an exception is
propagated through the function.
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When an exception is raised, the function call stack is unwound, function by function,
block by block. For each function or block, the destructors of auto objects that need
destruction are run, and a check is made whether there is a catch handler for the
exception. If there is, the execution will continue from that catch handler.

An application that mixes C++ code with assembler and C code, and that throws
exceptions from one C++ function to another via assembler routines and C functions
must use the linker option --exception_tables with the argument unwind.

The implementation of exceptions

Exceptions are implemented using a table method. For each function, the tables
describe:

e How to unwind the function, that is, how to find its caller on the stack and restore
registers that need restoring

Which catch handlers that exist in the function

Whether the function has an exception specification and which exceptions it allows
to propagate
o The set of auto objects whose destructors must be run.

When an exception is raised, the runtime will proceed in two phases. The first phase will
use the exception tables to search the stack for a function invocation containing a catch
handler or exception specification that would cause stack unwinding to halt at that point.
Once this point is found, the second phase is entered, doing the actual unwinding, and
running the destructors of auto objects where that is needed.

The table method results in virtually no overhead in execution time or RAM usage when
an exception is not actually thrown. It does incur a significant penalty in read-only
memory usage for the tables and the extra code, and throwing and catching an exception
is a relatively expensive operation.

The destruction of auto objects when the stack is being unwound as a result of an
exception is implemented in code separated from the code that handles the normal
operation of a function. This code, together with the code in catch handlers, is placed in
a separate section (. exc.text) from the normal code (normally placed in . text). In
some cases, for instance when there is fast and slow ROM memory, it can be
advantageous to select on this difference when placing sections in the linker
configuration file.
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Enabling support for C++ and variants

@ In the compiler, the default language is C.

To compile files written in Standard C++, use the --c++ compiler option. See --c++,
page 256.

To compile files written in Embedded C++, use the --ec++ compiler option. See
--ec++, page 262.

To take advantage of Extended Embedded C++ features in your source code, use the
--eec++ compiler option. See --eec++, page 262.

To enable EC++, EEC++, or C++ in the IDE, choose Project>Options>C/C++
Compiler>Language and select the appropriate standard.

C++ and EC++ feature descriptions

IAR C/C++ Development Guide
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When you write C++ source code for the IAR C/C++ Compiler for ARM, you must be
aware of some benefits and some possible quirks when mixing C++ features—such as
classes, and class members—with IAR language extensions, such as IAR-specific
attributes.

USING IAR ATTRIBUTES WITH CLASSES

Static data members of C++ classes are treated the same way global variables are, and
can have any applicable IAR type and object attribute.

Member functions are in general treated the same way free functions are, and can have
any applicable IAR type and object attributes. Virtual member functions can only have
attributes that are compatible with default function pointers, and constructors and
destructors cannot have any such attributes.

The location operator @ and the #pragma location directive can be used on static data
members and with all member functions.
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Example of using attributes with classes

class MyClass

{

public:
// Locate a static variable in _ memattr memory at address 60
static __no_init int mI @ 60;

// A static Thumb function
static __thumb void F();

// A Thumb function
__thumb void G();

// Interworking assumed
virtual __arm void ArmH() ;

// Locate a virtual function into SPECIAL
virtual void M() const volatile @ "SPECIAL";
Y
FUNCTION TYPES

A function type with extern "C" linkage is compatible with a function that has C++
linkage.

Example

extern "C"

{

typedef void (*FpC) (void) ; // A C function typedef
}
typedef void (*FpCpp) (void) ; // A C++ function typedef
FpC F1;
FpCpp F2;

void MyF (FpC) ;

void MyG ()
{
MyF (F1) ; // Always works
MyF (F2) ; // FpCpp 1s compatible with FpC
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USING STATIC CLASS OBJECTS IN INTERRUPTS

If interrupt functions use static class objects that need to be constructed (using
constructors) or destroyed (using destructors), your application will not work properly
if the interrupt occurs before the objects are constructed, or, during or after the objects
are destroyed.

To avoid this, make sure that these interrupts are not enabled until the static objects have
been constructed, and are disabled when returning from main or calling exit. For
information about system startup, see System startup and termination, page 126.

Function local static class objects are constructed the first time execution passes through
their declaration, and are destroyed when returning from main or when calling exit.

USING NEW HANDLERS

To handle memory exhaustion, you can use the set_new_handler function.

New handlers in Standard C++

If you do not call set_new_handler, or call it with a NULL new handler, and
operator new fails to allocate enough memory, operator new will throw

std: :bad_alloc if exceptions are enabled. If exceptions are not enabled, operator
new will instead call abort.

If you call set_new_handler with a non-NULL new handler, the provided new
handler will be called by operator new if the operator new fails to allocate enough
memory. The new handler must then make more memory available and return, or abort
execution in some manner. If exceptions are enabled, the new handler can also throw a
std: :bad_alloc exception. The nothrow variant of operator new will only return
NULL in the presence of a new handler if exceptions are enabled and the new handler
throws std: :bad_alloc.

New handlers in Embedded C++

If you do not call set_new_handler, or call it with a NULL new handler, and
operator new fails to allocate enough memory, it will call abort. The nothrow
variant of the new operator will instead return NULL.

If you call set_new_handler with a non-NULL new handler, the provided new
handler will be called by operator newif operator new fails to allocate memory. The
new handler must then make more memory available and return, or abort execution in
some manner. The nothrow variant of operator new will never return NULL in the
presence of a new handler.
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TEMPLATES

C++ and Extended EC++ supports templates according to the C++ standard, but not the
export keyword. The implementation uses a two-phase lookup which means that the
keyword typename must be inserted wherever needed. Furthermore, at each use of a
template, the definitions of all possible templates must be visible. This means that the
definitions of all templates must be in include files or in the actual source file.

DEBUG SUPPORT IN C-SPY

C-SPY® has built-in display support for the STL containers. The logical structure of
containers is presented in the watch views in a comprehensive way that is easy to
understand and follow.

Using C++, you can make C-SPY stop at a throw statement or if a raised exception does
not have any corresponding catch statement.

For more information about this, see the C-SPY® Debugging Guide for ARM.

EEC++ feature description
This section describes features that distinguish Extended EC++ from EC++.

TEMPLATES

The compiler supports templates with the syntax and semantics as defined by Standard
C++. However, note that the STL (standard template library) delivered with the product
is tailored for Extended EC++, see Extended Embedded C++, page 186.

VARIANTS OF CAST OPERATORS

In Extended EC++ these additional variants of C++ cast operators can be used:

const_cast<to> (from)
static_cast<to> (from)
reinterpret_cast<to> (from)

MUTABLE

The mutable attribute is supported in Extended EC++. A mutable symbol can be
changed even though the whole class object is const.

NAMESPACE

The namespace feature is only supported in Extended EC++. This means that you can
use namespaces to partition your code. Note, however, that the library itself is not placed
in the std namespace.
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THE STD NAMESPACE

The std namespace is not used in either standard EC++ or in Extended EC++. If you
have code that refers to symbols in the std namespace, simply define std as nothing;
for example:

#define std

You must make sure that identifiers in your application do not interfere with identifiers
in the runtime library.

EC++ and C++ language extensions

When you use the compiler in any C++ mode and enable IAR language extensions, the
following C++ language extensions are available in the compiler:

IAR C/C++ Development Guide
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In a friend declaration of a class, the c1lass keyword can be omitted, for example:

class B;
class A
{
friend B; //Possible when using IAR language
//extensions
friend class B; //According to the standard
Y
Constants of a scalar type can be defined within classes, for example:

class A
{
const int mSize = 10; //Possible when using IAR language
//extensions
int mArr[mSize];
Y
According to the standard, initialized static data members should be used instead.

In the declaration of a class member, a qualified name can be used, for example:

struct A

{
int A::F(); // Possible when using IAR language extensions
int G(); // According to the standard

}i
It is permitted to use an implicit type conversion between a pointer to a function

with C linkage (extern "C") and a pointer to a function with C++ linkage
(extern "C++"), for example:
extern "C" void F(); // Function with C linkage

void (*PF) () // PF points to a function with C++ linkage
= &F; // Implicit conversion of function pointer.
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According to the standard, the pointer must be explicitly converted.

If the second or third operands in a construction that contains the ? operator are
string literals or wide string literals (which in C++ are constants), the operands can
be implicitly converted to char * or wchar_t *, for example:

bool X;

char *P1 = X ? "abc" : "def"; //Possible when using IAR
//language extensions

char const *P2 = X ? "abc" : "def";//According to the standard

Default arguments can be specified for function parameters not only in the top-level
function declaration, which is according to the standard, but also in typedef
declarations, in pointer-to-function function declarations, and in pointer-to-member
function declarations.

In a function that contains a non-static local variable and a class that contains a
non-evaluated expression (for example a sizeof expression), the expression can
reference the non-static local variable. However, a warning is issued.

An anonymous union can be introduced into a containing class by a typedef name.
It is not necessary to first declare the union. For example:

typedef union

{
int i,3;
} U; // U identifies a reusable anonymous union.

class A

{
public:

U; // OK -- references to A::1i and A::j are allowed.
Yi
In addition, this extension also permits anonymous classes and anonymous structs,
as long as they have no C++ features (for example, no static data members or member
functions, and no non-public members) and have no nested types other than other
anonymous classes, structs, or unions. For example:

struct A

{

struct
{
int i,3;
}; // OK -- references to A::1 and A::j are allowed.

Y
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o The friend class syntax allows nonclass types as well as class types expressed
through a typedef without an elaborated type name. For example:

typedef struct S ST;

class C
{
public:
friend S; // Okay (requires S to be in scope)
friend ST; // Okay (same as "friend S;")
// friend S const; // Error, cv-qualifiers cannot
// appear directly

Y

Note: If you use any of these constructions without first enabling language extensions,
errors are issued.
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Application-related
considerations

e Output format considerations

e Stack considerations

e Heap considerations

o Interaction between the tools and your application
e Checksum calculation for verifying image integrity
e Linker optimizations

e AEABI compliance

o CMSIS integration

Output format considerations

The linker produces an absolute executable image in the ELF/DWARF object file
format.

You can use the IAR ELF Tool—ielftool— to convert an absolute ELF image to a
format more suitable for loading directly to memory, or burning to a PROM or flash
memory etc.

ielftool can produce these output formats:

e Plain binary
® Motorola S-records

o Intel hex.

Note: ielftool can also be used for other types of transformations, such as filling and
calculating checksums in the absolute image.

The source code for ielftool is provided in the arm/src directory. For more
information about ielftool, see The [AR ELF Tool—ielftool, page 468.
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To make your application use stack memory efficiently, there are some considerations
to be made.

STACK SIZE CONSIDERATIONS

The required stack size depends heavily on the application’s behavior. If the given stack
size is too large, RAM will be wasted. If the given stack size is too small, one of two
things can happen, depending on where in memory you located your stack:

e Variable storage will be overwritten, leading to undefined behavior
o The stack will fall outside of the memory area, leading to an abnormal termination
of your application.

Both alternatives are likely to result in application failure. Because the second
alternative is easier to detect, you should consider placing your stack so that it grows
toward the end of the memory.

For more information about the stack size, see Setting up stack memory, page 97, and
Saving stack space and RAM memory, page 227.

STACK ALIGNMENT

The default cstartup code automatically initializes all stacks to an 8-byte aligned
address.

For more information about aligning the stack, see Calling convention, page 163 and
more specifically Special registers, page 165 and Stack parameters and layout, page
167.

EXCEPTION STACK

Cortex-M does not have individual exception stacks. By default, all exception stacks are
placed in the CSTACK section.

The ARM7/9/11, Cortex-A, and Cortex-R devices support five exception modes which
are entered when different exceptions occur. Each exception mode has its own stack to
avoid corrupting the System/User mode stack.

The table shows proposed stack names for the various exception stacks, but any name
can be used:

Processor mode Proposed stack section name Description

Supervisor SVC_STACK Operation system stack.

Table 23: Exception stacks for ARM7/9/11, Cortex-A, and Cortex-R
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Processor mode Proposed stack section name Description

IRQ IRQ_STACK Stack for general-purpose (IRQ)
interrupt handlers.

FIQ FIQ_STACK Stack for high-speed (FIQ)
interrupt handlers.

Undefined UND_STACK Stack for undefined instruction
interrupts. Supports software
emulation of hardware
coprocessors and instruction set
extensions.

Abort ABT_STACK Stack for instruction fetch and data
access memory abort interrupt
handlers.

Table 23: Exception stacks for ARM7/9/11, Cortex-A, and Cortex-R

For each processor mode where a stack is needed, a separate stack pointer must be
initialized in your startup code, and section placement should be done in the linker
configuration file. The IRQ and FIQ stacks are the only exception stacks which are
preconfigured in the supplied cstartup.s and 1nkarm. icf files, but other exception
stacks can easily be added.

To view any of these stacks in the Stack window available in the IDE, these
preconfigured section names must be used instead of user-defined section names.

Heap considerations
The heap contains dynamic data allocated by use of the C function malloc (or a
corresponding function) or the C++ operator new.

If your application uses dynamic memory allocation, you should be familiar with:

e Linker sections used for the heap

e Allocating the heap size, see Setting up heap memory, page 98.

ADVANCED VERSUS BASIC HEAP

The system library contains two separate heap memory handlers—the basic and the
advanced heap handler. If your application appears to make explicit use of heap
allocation, the linker automatically chooses the advanced heap; otherwise, the basic
heap is used.

Note: If your product has a code size limitation, the basic heap is automatically chosen.
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You can use a linker option to explicitly specify which handler you want to use:

o The basic heap (--basic_heap) is a very simple heap allocator, suitable for use in
applications that do not use the heap very much. In particular, it can be used in
applications that only allocate heap memory and never free it. The basic heap is not
particularly speedy, and using it in applications that repeatedly free memory is quite
likely to lead to unneeded fragmentation of the heap. The code for the basic heap is
significantly smaller than that for the advanced heap. See --basic_heap, page 293.

o The advanced heap (--advanced_heap) provides efficient memory management
for applications that use the heap extensively. In particular, applications that
repeatedly allocate and free memory will likely get less overhead in both space and
time. The code for the advanced heap is significantly larger than that for the basic
heap. See --advanced_heap, page 292. For information about the definition, see
iar_dlmalloc.h, page 422.

HEAP SIZE AND STANDARD 1/O

@ If you excluded FILE descriptors from the DLIB runtime environment, as in the Normal
configuration, there are no input and output buffers at all. Otherwise, as in the Full
configuration, be aware that the size of the input and output buffers is set to 512 bytes
in the stdio library header file. If the heap is too small, I/O will not be buffered, which
is considerably slower than when 1/O is buffered. If you execute the application using
the simulator driver of the IAR C-SPY® Debugger, you are not likely to notice the speed
penalty, but it is quite noticeable when the application runs on an ARM core. If you use
the standard I/O library, you should set the heap size to a value which accommodates the
needs of the standard 1/O buffer.

Interaction between the tools and your application

The linking process and the application can interact symbolically in four ways:

o Creating a symbol by using the linker command line option --define_symbol.
The linker will create a public absolute constant symbol that the application can use
as a label, as a size, as setup for a debugger, etc.

o Creating an exported configuration symbol by using the command line option
--config_def or the configuration directive define symbol, and exporting the
symbol using the export symbol directive. ILINK will create a public absolute
constant symbol that the application can use as a label, as a size, as setup for a
debugger, etc.

One advantage of this symbol definition is that this symbol can also be used in
expressions in the configuration file, for example to control the placement of sections
into memory ranges.

IAR C/C++ Development Guide
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o Using the compiler operators __section_begin, __section_end, or
__section_size, or the assembler operators SFB, SFE, or SIZEOF on a named
section or block. These operators provide access to the start address, end address,
and size of a contiguous sequence of sections with the same name, or of a linker
block specified in the linker configuration file.

o The command line option --entry informs the linker about the start label of the
application. It is used by the linker as a root symbol and to inform the debugger
where to start execution.

The following lines illustrate how to use -D to create a symbol. If you need to use this
mechanism, add these options to your command line like this:

--define_symbol NrOfElements=10
--config_def HEAP_SIZE=1024

The linker configuration file can look like this:

define memory Mem with size = 4G;
define region ROM = Mem: [from 0x00000 size 0x100007;
define region RAM = Mem: [from 0x20000 size 0x10000];

/* Export of symbol */
export symbol MY_HEAP_SIZE;

/* Setup a heap area with a size defined by an ILINK option */
define block MyHEAP with size = MY_HEAP_SIZE, alignment = 8 {};

place in RAM { block MyHEAP };
Add these lines to your application source code:

#include <stdlib.h>

/* Use symbol defined by ILINK option to dynamically allocate an
array of elements with specified size. The value takes the form
of a label.

*/
extern int NrOfElements;

typedef char Elements;
Elements *GetElementArray ()
{
return malloc (sizeof (Elements) * (long) &NrOfElements) ;
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/* Use a symbol defined by ILINK option, a symbol that in the
* configuration file was made available to the application.
*/

extern char MY_HEAP_SIZE;

/* Declare the section that contains the heap. */
#pragma section = "MYHEAP"

char *MyHeap ()

{
/* First get start of statically allocated section, */
char *p = __ section_begin ("MYHEAP") ;

/* ...then we zero it, using the imported size. */
for (int i = 0; 1 < (int) &MY_HEAP_SIZE; ++1i)
{
plil = 0;
}

return p;

Checksum calculation for verifying image integrity

The following pages contain information about checksum calculation:

o Briefly about checksum calculation, page 202
o Calculating and verifying a checksum, page 204

o Troubleshooting checksum calculation, page 207

For more information, see also The IAR ELF Tool—ielftool, page 468.

BRIEFLY ABOUT CHECKSUM CALCULATION

You can use a checksum to verify that the image is the same at runtime as when the
image’s original checksum was generated. In other words, to verify that image has not
been corrupted.

This works as follows:

® You need an initial checksum.

You can either use the IAR ELF Tool—ielftool—to generate an initial checksum
or you might have a third-party checksum available.

IAR C/C++ Development Guide
202 Compiling and Linking for ARM



Application-related considerations __¢

o You must generate a second checksum during runtime.

You can either add specific code to your application source code for calculating a
checksum during runtime or you can use some dedicated hardware on your device
for calculating a checksum during runtime.

o You must add specific code to your application source code for comparing the two
checksums and take an appropriate action.

If the two checksums have been calculated in the same way, and if there are no errors
in the image, the checksums should be identical. If not, you should first suspect that
the two checksums were not generated in the same way.

No matter which solutions you use for generating the two checksum, you must make
sure that both checksums are calculated in the exact same way. If you use ielftool for
the initial checksum and use a software-based calculation during runtime, you have full
control of the generation for both checksums. However, if you are using a third-party
checksum for the initial checksum or some hardware support for the checksum
calculation during runtime, there might be additional requirements that you must
consider.

For the two checksums, there are some choices that you must always consider and there
are some choices to make only if there are additional requirements. Still, all of the details
must be the same for both checksums.

Details always to consider:

o Checksum range

The memory range (or ranges) that you want to verify by means of checksums.
Typically, you might want to calculate a checksum for all memory. However, you
might want to calculate a checksum only for specific ranges, for example, if you have
some parts that are certified or if you have some very critical parts. Remember that:

o Itis OK to have several ranges for one checksum.

o The checksum must be calculated from the lowest to the highest address for
every memory range.

o Each memory range must be verified in the same order as defined (for example,
0x100-0x1FF,0x400-0x4FF is not the same as 0x400-0x4FF,0x100-0x1FF).

e If several checksums are used, you should place them in sections with unique
names and use unique symbol names.

o A checksum should never be calculated on a memory range that contains a
checksum or a software breakpoint.

o Algorithm and size of checksum

You should consider which algorithm is most suitable in your case. There are two
basic choices, Sum (a simple arithmetic algorithm) or CRC (which is the most
commonly used algorithm). For CRC there are different sizes to choose for the
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checksum, 2, 4, or 8 bytes where the predefined polynomials are wide enough to suit
the size, for more error detecting power. The predefined polynomials work well for
most, but possibly not for all data sets. If not, you can specify your own size and
polynomial. However, if you want a decent error detecting mechanism, use the
predefined CRC algorithm for your checksum size, typically CRC16 or CRC32.

For more information about selecting an appropriate polynomial for data sets with
non-uniform distribution, see for example section 3.5.3 in Tannenbaum, A.S.,
"Computer Networks", Prentice Hall 1981, ISBN: 0131646990.

o Fill

Every byte in the checksum range must have a well-defined value before the
checksum can be calculated. Typically, bytes with unknown values are any pad bytes
that have been added for alignment. This means that you must specify which fill
pattern to be used during calculation.

o [nitial value

The checksum must always have an explicit initial value.

In addition to these mandatory details, there might be other details to consider.
Typically, this might happen when you have a third-party checksum, you want the
checksum be compliant with the Rocksoft™ checksum model, or when you use
hardware support for generating a checksum during runtime. ielftool provides
support for also controlling alignment, complement, bit order, byte order within words,
and checksum unit size.

CALCULATING AND VERIFYING A CHECKSUM

In this example procedure, a checksum is calculated for ROM memory from 0x8002 up
to 0x8FFF and the 2-byte calculated checksum is placed at 0x8000.

I If you are using ielftool from the command line, you must first allocate a place for
the calculated checksum. You can do this in two ways; by creating a global C/C++ or
assembler constant symbol with a proper size, residing in a specific section (in this
example . checksum), or by using the linker option --place_holder.

For example, to allocate a 2-byte space for the symbol __checksum in the section
.checksum, with alignment 4, specify:

--place_holder __checksum, 2, .checksum, 4

Note: The . checksum section will only be included in your application if the section
appears to be needed. If the checksum is not needed by the application itself, you can
use the linker option --keep=__checksum or the linker directive keep to force the
section to be included.
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Note: If you are using the IDE, the __checksum, __checksum_begin, and
__checksum_end symbols, and the . checksum section are automatically allocated
when you calculate the checksum.

To control the placement of the . checksum section, you must modify the linker
configuration file. For example, it can look like this (note the handling of the block
CHECKSUM):

define block CHECKSUM { ro section .checksum };
place in ROM_region { ro, first block CHECKSUM };

Note: It is possible to omit this step, but in that case the . checksum section will
automatically be placed with other read-only data.

When configuring ielftool to calculate a checksum, there are some choices to make:
o Choose which checksum algorithm you want to use. In this example, the CRC16
algorithm is used.

e Specify the memory range (or ranges) for which the checksum should be calculated.
If you instead want to calculate a checksum for several ranges, you must specity the
ranges using the --checksum option. If you are using the IDE, you specify this
option on the Extra Options page.

o Specify a fill pattern—typically 0xFF or 0x00—for bytes with unknown values.
The fill pattern will be used in all checksum ranges.

For more information, see Briefly about checksum calculation, page 202.

To run ielftool from the IDE, choose Project>Options>Linker>Checksum and
make your settings, for example:

Checksum

Fill unused code memary

Fill pattem: k00
Start address: 8002 End address:  (x8FFF
Generate checksum

Checksum size: Alignment: 1
Algorithm: CRC16 > | |E11021

Result in full size

Initial value
Complement: |Asis 0
Bit order: MSE first - Use as input
[ Reverse byte order within word

Checksum unit size:

I

In the simplest case, you can ignore (or leave with default settings) these options:
Complement, Bit order, Reverse byte order within word, and Checksum unit size.
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@ To run ielftool from the command line, specify the command, for example, like this:

IAR C/C++ Development Guide
206  Compiling and Linking for ARM

ielftool --fill=0x00;0x8002-0x8FFF
--checksum=__ checksum:2, crcl6;0x8002-0x8FFF sourceFile.out
destinationFile.out

Note that ielftool needs an unstripped input ELF image. If you use the linker option
--strip, remove it and use the ielftooloption --strip instead.

The checksum will be created when you build your project and will be automatically
placed in the symbol __checksum in the section . checksum.

If you are using the IDE and want to specify several ranges, choose
Project>Options>Linker>Extra options. Use the --checksum option and specify
the ranges, for example like this:

ielftool --£fi11;0x0-0x3FF,0x8002-0x8FFF
--checksum=__checksum:2,crcl6; 0x0-0x3FF, 0x8002-0x8FFF

Add a function for checksum calculation to your source code. Make sure that the
function uses the same algorithm and settings as for the checksum calculated by
ielftool. For example, a slow variant of the crc16 algorithm but with small memory
footprint (in contrast to the fast variant that uses more memory):

unsigned short SmallCrclé6 (unsigned short sum,
unsigned char *p,
unsigned int len)

while (len--)

{
int 1i;
unsigned char byte = *(p++);
for (1 = 0; 1 < 8; ++1i)

{
unsigned long oSum = sum;
sum <<= 1;
if (byte & 0x80)
sum |= 1;
if (oSum & 0x8000)
sum ~= 0x1021;
byte <<= 1;

}
return sum;

}

You can find the source code for this checksum algorithm in the arm\src\linker
directory of your product installation.
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6 Make sure that your application also contains a call to the function that calculates the
checksum, compares the two checksums, and takes appropriate action if the checksum
values do not match. This code gives an example of how the checksum can be
calculated for your application and to be compared with the ielftool generated
checksum:

/* The calculated checksum */

/* Linker generated symbols */

extern unsigned short const __ checksum;
extern int const __ checksum_start;
extern int const __checksum_end;

void TestChecksum/()
{

unsigned short calc = 0;
unsigned char zeros[2] = {0, 0};

/* Run the checksum algorithm */
calc = SlowCrcl6 (0,
(unsigned char *) &__ checksum_start,
((unsigned char *) &__checksum_end -
((unsigned char *) &__ checksum_start)+1));
/* Fill the end of the byte sequence with zeros. */
calc = SlowCrcl6(calc, zeros, 2);

/* Test the checksum */

if (calc != __checksum)

{
printf ("Incorrect checksum!\n");
abort () ; /* Failure */

/* Checksum is correct */

}

7 You can now build your application project and then download it.

TROUBLESHOOTING CHECKSUM CALCULATION

If the two checksums do not match, there are several possible causes. These are some
troubleshooting hints:

e If possible, start with a small example when trying to get the checksums to match.
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o Verify that the exact memory range or ranges are used in both checksum
calculations.

To help you do this, ielftool produces useful information on stdout about the
exact addresses that were used and the order in which they were accessed.

o Make sure that the checksum symbol is excluded from the checksum calculation.

Compare the checksum placement with the checksum range and make sure they do
not overlap. You can find information in the Build message window after ielftool
has generated a checksum.

e Verify that the checksum calculations use the same polynomial.

Note that for an n-bit polynomial, the n:th bit is always considered to be set. For a
16-bit polynomial (for example, CRC16) this means that 0x11021 is the same as
0x1021.

o Verify that the bits in the bytes are processed in the same order in both checksum
calculations, from the least to the most significant bit or the other way around. You
control this with the Bit order option (or from the command line, the -m parameter
of the --checksum option).

e If you are using the small variant of CRC, check whether you need to feed
additional bytes into the algorithm.

The number of zeros to add at the end of the byte sequence must match the size of
the checksum, in other words, two zeros for a 1-byte checksum, four zeros for a
2-byte checksum, and eight bytes for a 4-byte checksum.

o By default, a symbol that you have allocated in memory by using the linker option
--place_holder is considered by C-SPY to be of the type int. If the size of the
checksum is different than the size of an int, you can change the display format of
the checksum symbol to match its size.

In the C-SPY Watch window, select the symbol and choose Show As from the

context menu. Choose the display format that matches the size of the checksum
symbol.

Linker optimizations
VIRTUAL FUNCTION ELIMINATION

Virtual Function Elimination (VFE) is a linker optimization that removes unneeded
virtual functions and dynamic runtime type information.

In order for Virtual Function Elimination to work, all relevant modules must provide
information about virtual function table layout, which virtual functions are called, and
for which classes dynamic runtime type information is needed. If one or more modules
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do not provide this information, a warning is generated by the linker and Virtual
Function Elimination is not performed.

If you know that modules that lack such information do not perform any virtual function
calls and do not define any virtual function tables, you can use the --vfe=forced
linker option to enable Virtual Function Elimination anyway.

Currently, tools from IAR Systems and from RealView provide the information needed
for Virtual Function Elimination in a way that the linker can use.

Note that you can disable Virtual Function Elimination entirely by using the --no_vfe
linker option. In this case, no warning will be issued for modules that lack VFE
information.

For more information, see --vfe, page 317 and --no_vfe, page 311.

AEABI compliance
The IAR build tools for ARM support the Embedded Application Binary Interface for
ARM, AEABI, defined by ARM Limited. This interface is based on the Intel IA64 ABI
interface. The advantage of adhering to AEABI is that any such module can be linked
with any other AEABI-compliant module, even modules produced by tools provided by
other vendors.

The IAR build tools for ARM support the following parts of the AEABI:

AAPCS Procedure Call Standard for the ARM architecture
CPPABI C++ ABI for the ARM architecture (EC++ parts only)
AAELF ELF for the ARM architecture

AADWARF DWAREF for the ARM architecture

RTABI Runtime ABI for the ARM architecture

CLIBABI C library ABI for the ARM architecture

The IAR build tools only support a bare metal platform, that is a ROM-based system
that lacks an explicit operating system.

Note that:

The AEABI is specified for C89 only
The IAR build tools only support using the default and C locales

°
°
o The AEABI does not specify C++ library compatibility
°

Neither the size of an enum or of wchar_t is constant in the AEABI.
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If AEABI compliance is enabled, almost all optimizations performed in the system
header files are turned off, and certain preprocessor constants become real constant
variables instead.

LINKING AEABI-COMPLIANT MODULES USING THE IAR
ILINK LINKER

When building an application using the IAR ILINK Linker, the following types of
modules can be combined:

o Modules produced using IAR build tools, both AEABI-compliant modules as well
as modules that are not AEABI-compliant

o AEABI-compliant modules produced using build tools from another vendor.

Note: To link a module produced by a compiler from another vendor, extra support
libraries from that vendor might be required.

The IAR ILINK Linker automatically chooses the appropriate standard C/C++ libraries
to use based on attributes from the object files. Imported object files might not have all
these attributes. Therefore, you might need to help ILINK choose the standard library
by verifying one or more of the following details:

o The used CPU by specifying the --cpu linker option

o If full I/O is needed; make sure to link with a Full library configuration in the
standard library

e Explicitly specify runtime library file(s), possibly in combination with the
--no_library_search linker option.

When linking, you should also consider virtual function elimination, see Virtual
function elimination, page 208.

LINKING AEABI-COMPLIANT MODULES USING A
THIRD-PARTY LINKER

If you have a module produced using the IAR C/C++ Compiler and you plan to link that
module using a linker from a different vendor, that module must be AEABI-compliant,
see Enabling AEABI compliance in the compiler, page 211.

In addition, if that module uses any of the IAR-specific compiler extensions, you must
make sure that those features are also supported by the tools from the other vendor. Note
specifically:

o Support for the following extensions must be verified: #pragma pack,
__no_init,__root, and __ramfunc

o The following extensions are harmless to use: #pragma location/@, __arm,

__thumb, __swi,__irqg,__fiqg, and __nested.
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ENABLING AEABI COMPLIANCE IN THE COMPILER

You can enable AEABI compliance in the compiler by setting the --aeabi option. In
this case, you must also use the --guard_calls option.

In the IDE, use the Project>Options>C/C++ Compiler>Extra Options page to
specify the --aeabi and --guard_calls options.

On the command line, use the options --aeabi and --guard_calls to enable AEABI
support in the compiler.

Alternatively, to enable support for AEABI for a specific system header file, you must
define the preprocessor symbol _AEABI_PORTABILITY_LEVEL tO NON-Zero prior to
including a system header file, and make sure that the symbol AEABI_PORTABLE is set
to non-zero after the inclusion of the header file:

#define _AEABI_PORTABILITY_LEVEL 1
#undef _AEABI_PORTABLE

#include <header.h>

#ifndef _AEABI_PORTABLE

#error "header.h not AEABI compatible"
#endif

CMSIS integration

The arm\cMSIS subdirectory contains CMSIS (Cortex Microcontroller Software
Interface Standard) and CMSIS DSP header and library files, and documentation. For
more information about CMSIS, see http://www.arm.com/cmsis.

The special header file inc\c\cmsis_iar.his provided as a CMSIS adaptation of the
current version of the IAR C/C++ Compiler.
CMSIS DSP LIBRARY

IAR Embedded Workbench comes with prebuilt CMSIS DSP libraries in the
arm\CMSIS\Lib\IAR directory. The names of the library files are constructed in this
way:

iar_cortexM<0|3|4><1|b>[f]_math.a

where <0 3 | 4> selects the Cortex—M variant, <1 | b> selects the byte order, and [ £]
indicates that the library is built for FPU (Cortex—M4 only).

The libraries for Cortex-M4 are applicable also to Cortex-M7.
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CUSTOMIZING THE CMSIS DSP LIBRARY

The source code of the CMSIS DSP library is provided in the
arm\CMSIS\DSP_Lib\Source directory. You can find an IAR Embedded Workbench
project which is prepared for building a customized DSP library in the
arm\CMSIS\DSP_Lib\Source\IAR directory.

@BUILDING WITH CMSIS ON THE COMMAND LINE

This section contains examples of how to build your CMSIS-compatible application on
the command line.

CMSIS only (that is without the DSP library)

iccarm -I $EW_DIRS\arm\CMSIS\Include

With the DSP library, for Cortex-M4, little-endian, and with FPU

iccarm --endian=little --cpu=Cortex-M4 --fpu=VFPv4d_sp -I
SEW_DIRS$S\arm\CMSIS\Include -D ARM_MATH_CM4

ilinkarm $SEW_DIRS$\arm\CMSIS\Lib\IAR\iar_cortexM31_math.a

BUILDING WITH CMSIS IN THE IDE

Choose Project>Options>General Options>Library Configuration to enable
CMSIS support.

When enabled, CMSIS include paths and the DSP library will automatically be used.
For more information, see the IDE Project Management and Building Guide for ARM.
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Selecting data types
Controlling data and function placement in memory
Controlling compiler optimizations

Facilitating good code generation

Selecting data types

For efficient treatment of data, you should consider the data types used and the most
efficient placement of the variables.

USING EFFICIENT DATA TYPES

The data types you use should be considered carefully, because this can have a large
impact on code size and code speed.

Use int or long instead of char or short whenever possible, to avoid sign
extension or zero extension. In particular, loop indexes should always be int or
long to minimize code generation. Also, in Thumb mode, accesses through the
stack pointer (SP) is restricted to 32-bit data types, which further emphasizes the
benefits of using one of these data types.

Use unsigned data types, unless your application really requires signed values.
Be aware of the costs of using 64-bit data types, such as double and long long.
Bitfields and packed structures generate large and slow code.

Using floating-point types on a microprocessor without a math co-processor is very
inefficient, both in terms of code size and execution speed.

Declaring a pointer to const data tells the calling function that the data pointed to
will not change, which opens for better optimizations.

For information about representation of supported data types, pointers, and structures
types, see the chapter Data representation.
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FLOATING-POINT TYPES

Using floating-point types on a microprocessor without a math coprocessor is very
inefficient, both in terms of code size and execution speed. Thus, you should consider
replacing code that uses floating-point operations with code that uses integers, because
these are more efficient.

The compiler supports two floating-point formats—32 and 64 bits. The 32-bit
floating-point type £1oat is more efficient in terms of code size and execution speed.
However, the 64-bit format double supports higher precision and larger numbers.

In the compiler, the floating-point type £1loat always uses the 32-bit format, and the
type double always uses the 64-bit format.

Unless the application requires the extra precision that 64-bit floating-point numbers
give, we recommend using 32-bit floating-point numbers instead.

By default, a floating-point constant in the source code is treated as being of the type
double. This can cause innocent-looking expressions to be evaluated in double
precision. In the example below a is converted from a £1oat to a double, the double
constant 1.0 is added and the result is converted back to a float:

double Test (float a)
{

return a + 1.0;

}

To treat a floating-point constant as a £1oat rather than as a double, add the suffix £
to it, for example:

double Test (float a)
{

return a + 1.0f;

}

For more information about floating-point types, see Basic data types—floating-point
types, page 326.

ALIGNMENT OF ELEMENTS IN A STRUCTURE

The ARM core requires that when accessing data in memory, the data must be aligned.
Each element in a structure must be aligned according to its specified type requirements.
This means that the compiler might need to insert pad bytes to keep the alignment
correct.

There are situations when this can be a problem:

o There are external demands; for example, network communication protocols are
usually specified in terms of data types with no padding in between
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® You need to save data memory.
For information about alignment requirements, see Alignment, page 319.

Use the #pragma pack directive or the __packed data type attribute for a tighter
layout of the structure. The drawback is that each access to an unaligned element in the
structure will use more code.

Alternatively, write your own customized functions for packing and unpacking
structures. This is a more portable way, which will not produce any more code apart
from your functions. The drawback is the need for two views on the structure
data—packed and unpacked.

For more information about the #pragma pack directive, see pack, page 361.

ANONYMOUS STRUCTS AND UNIONS

When a structure or union is declared without a name, it becomes anonymous. The effect
is that its members will only be seen in the surrounding scope.

Anonymous structures are part of the C++ language; however, they are not part of the C
standard. In the IAR C/C++ Compiler for ARM they can be used in C if language
extensions are enabled.

In the IDE, language extensions are enabled by default.

@ Use the -e compiler option to enable language extensions. See -e, page 261, for
additional information.

Example
In this example, the members in the anonymous union can be accessed, in function F,
without explicitly specifying the union name:

struct S
{

char mTag;

union
{
long mL;
float mF;
Y
} St

void F(void)
{
St.mL = 5;
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The member names must be unique in the surrounding scope. Having an anonymous
struct or union at file scope, as a global, external, or static variable is also allowed.
This could for instance be used for declaring I/O registers, as in this example:

__no_init volatile
union
{
unsigned char IOPORT;
struct
{
unsigned char way: 1;
unsigned char out: 1;
Y
} @ 0x1000;

/* The variables are used here. */
void Test (void)
{
IOPORT = 0;
way = 1;
out = 1;
}

This declares an I/O register byte TOPORT at address 0x1000. The I/O register has 2 bits
declared, way and out. Note that both the inner structure and the outer union are
anonymous.

Anonymous structures and unions are implemented in terms of objects named after the
first field, with a prefix _a_ to place the name in the implementation part of the
namespace. In this example, the anonymous union will be implemented through an
object named _A_TOPORT.

Controlling data and function placement in memory

The compiler provides different mechanisms for controlling placement of functions and
data objects in memory. To use memory efficiently, you should be familiar with these
mechanisms and know which one is best suited for different situations. You can use:

o The @ operator and the #pragma location directive for absolute placement.

Using the @ operator or the #pragma location directive, you can place individual
global and static variables at absolute addresses. Note that it is not possible to use this
notation for absolute placement of individual functions. For more information, see
Data placement at an absolute location, page 217.
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o The @ operator and the #pragma location directive for section placement.

Using the @ operator or the #pragma location directive, you can place individual
functions, variables, and constants in named sections. The placement of these
sections can then be controlled by linker directives. For more information, see Data
and function placement in sections, page 218

o The @ operator and the #pragma location directive for register placement

Use the @ operator or the #pragma location directive to place individual global
and static variables in registers. The variables must be declared __no_init. This is
useful for individual data objects that must be located in a specific register.

o Using the --section option, you can set the default segment for functions,
variables, and constants in a particular module. For more information, see --section,
page 284.

DATA PLACEMENT AT AN ABSOLUTE LOCATION

The @ operator, alternatively the #pragma location directive, can be used for placing
global and static variables at absolute addresses.

To place a variable at an absolute address, the argument to the @ operator and the
#pragma location directive should be a literal number, representing the actual
address. The absolute location must fulfill the alignment requirement for the variable
that should be located.

Note: All declarations of __no_init variables placed at an absolute address are
tentative definitions. Tentatively defined variables are only kept in the output from the
compiler if they are needed in the module being compiled. Such variables will be
defined in all modules in which they are used, which will work as long as they are
defined in the same way. The recommendation is to place all such declarations in header
files that are included in all modules that use the variables.

Other variables placed at an absolute address use the normal distinction between
declaration and definition. For these variables, you must provide the definition in only
one module, normally with an initializer. Other modules can refer to the variable by
using an extern declaration, with or without an explicit address.

Examples

In this example, a __no_init declared variable is placed at an absolute address. This
is useful for interfacing between multiple processes, applications, etc:

__no_init volatile char alpha @ OxFF2000;/* OK */

The next example contains two const declared objects. The first one is not initialized,
and the second one is initialized to a specific value. Both objects are placed in ROM.
This is useful for configuration parameters, which are accessible from an external
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interface. Note that in the second case, the compiler is not obliged to actually read from
the variable, because the value is known.

#pragma location=0xFF2002
__no_init const int beta; /* OK */
const int gamma @ OxFF2004 = 3; /* OK */

In the first case, the value is not initialized by the compiler; the value must be set by
other means. The typical use is for configurations where the values are loaded to ROM
separately, or for special function registers that are read-only.

__no_init int epsilon @ 0xXFF2007; /* Error, misaligned. */

C++ considerations

In C++, module scoped const variables are static (module local), whereas in C they are
global. This means that each module that declares a certain const variable will contain
a separate variable with this name. If you link an application with several such modules
all containing (via a header file), for instance, the declaration:

volatile const __no_init int x @ 0x100; /* Bad in C++ */
the linker will report that more than one variable is located at address 0x100.

To avoid this problem and make the process the same in C and C++, you should declare
these variables extern, for example:

/* The extern keyword makes x public. */
extern volatile const __no_init int x @ 0x100;

Note: C++ static member variables can be placed at an absolute address just like any
other static variable.

DATA AND FUNCTION PLACEMENT IN SECTIONS

The following method can be used for placing data or functions in named sections other
than default:

o The @ operator, alternatively the #pragma location directive, can be used for
placing individual variables or individual functions in named sections. The named
section can either be a predefined section, or a user-defined section.

® The --section option can be used for placing variables and functions, which are
parts of the whole compilation unit, in named sections.

C++ static member variables can be placed in named sections just like any other static
variable.

If you use your own sections, in addition to the predefined sections, the sections must
also be defined in the linker configuration file.
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Note: Take care when explicitly placing a variable or function in a predefined section
other than the one used by default. This is useful in some situations, but incorrect
placement can result in anything from error messages during compilation and linking to
amalfunctioning application. Carefully consider the circumstances; there might be strict
requirements on the declaration and use of the function or variable.

The location of the sections can be controlled from the linker configuration file.

For more information about sections, see the chapter Section reference.

Examples of placing variables in named sections

In the following examples, a data object is placed in a user-defined section. Note that
you must as always ensure that the section is placed in the appropriate memory area
when linking.

__no_init int alpha @ "MY_NOINIT"; /* OK */

#pragma location="MY_CONSTANTS"

const int beta = 42; /* OK */
const int gamma @ "MY_CONSTANTS" = 17;/* OK */
int theta @ "MY_ZEROS"; /* OK */
int phi @ "MY_INITED" = 4711; /* OK */

The linker will in the zero and initialized cases arrange for the correct type of
initialization for the variable. When placing a __no_init variable in a user-defined
section, you must add a pattern that matches that section to your do not initialize
directive in the linker configuration file. For initialized variables, you can disable the
automatic initialization by using the initialize manually directive.

Examples of placing functions in named sections
void f(void) @ "MY_FUNCTIONS";

void g(void) @ "MY_FUNCTIONS"

{

}

#pragma location="MY_FUNCTIONS"
void h(wvoid) ;

DATA PLACEMENT IN REGISTERS

The @ operator, alternatively the #pragma location directive, can be used for placing
global and static variables in a register.

219



Controlling compiler optimizations

220

To place a variable in a register, the argument to the @ operator and the #pragma
location directive should be an identifier that corresponds to an ARM core register in
the range R4-R11 (R9 cannot be specified in combination with the --rwpi command
line option).

A variable can be placed in a register only if it is declared as __no_init, has file scope,
and its size is four bytes. A variable placed in a register does not have a memory address,
so the address operator & cannot be used.

Within a module where a variable is placed in a register, the specified register will only
be used for accessing that variable. The value of the variable is preserved across function
calls to other modules because the registers R14-R11 are callee saved, and as such they
are restored when execution returns. However, the value of a variable placed in a register
is not always preserved as expected:

e In an exception handler or library callback routine (such as the comparator function
passed to gsort) the value might not be preserved. The value will be preserved if
the command line option --1lock_regs is used for locking the register in all
modules of the application, including library modules.

e In a fast interrupt handler, the value of a variable in R8—R11 is not preserved from
outside the handler, because these registers are banked.

o The longjmp function and C++ exceptions might restore variables placed in
registers to old values, unlike other variables with static storage duration which are
not restored.

The linker does not prevent modules from placing different variables in the same
register. Variables in different modules can be placed in the same register, and another
module could use the register for other purposes.

Note: A variable placed in a register should be defined in an include file, to be included
in every module that uses the variable. An unused definition in a module will cause the
register to not be used in that module.
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The compiler performs many transformations on your application to generate the best
possible code. Examples of such transformations are storing values in registers instead
of memory, removing superfluous code, reordering computations in a more efficient
order, and replacing arithmetic operations by cheaper operations.

The linker should also be considered an integral part of the compilation system, because
some optimizations are performed by the linker. For instance, all unused functions and
variables are removed and not included in the final output.
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SCOPE FOR PERFORMED OPTIMIZATIONS

You can decide whether optimizations should be performed on your whole application
or on individual files. By default, the same types of optimizations are used for an entire
project, but you should consider using different optimization settings for individual files.
For example, put code that must execute very quickly into a separate file and compile it
for minimal execution time, and the rest of the code for minimal code size. This will give
a small program, which is still fast enough where it matters.

You can also exclude individual functions from the performed optimizations. The
#pragma optimize directive allows you to either lower the optimization level, or
specify another type of optimization to be performed. See optimize, page 360, for
information about the pragma directive.

MULTI-FILE COMPILATION UNITS

In addition to applying different optimizations to different source files or even functions,
you can also decide what a compilation unit consists of—one or several source code
files.

By default, a compilation unit consists of one source file, but you can also use multi-file
compilation to make several source files in a compilation unit. The advantage is that
interprocedural optimizations such as inlining and cross jump have more source code to
work on. Ideally, the whole application should be compiled as one compilation unit.
However, for large applications this is not practical because of resource restrictions on
the host computer. For more information, see --mfc, page 270.

Note: Only one object file is generated, and thus all symbols will be part of that object
file.

If the whole application is compiled as one compilation unit, it is very useful to make
the compiler also discard unused public functions and variables before the
interprocedural optimizations are performed. Doing this limits the scope of the
optimizations to functions and variables that are actually used. For more information,
see --discard_unused_publics, page 260.
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OPTIMIZATION LEVELS

The compiler supports different levels of optimizations. This table lists optimizations
that are typically performed on each level:

Optimization level Description
None (Best debug support) Variables live through their entire scope
Low Same as above but variables only live for as long as they are

needed, not necessarily through their entire scope
Table 24: Compiler optimization levels
Medium Same as above, and:

Live-dead analysis and optimization

Dead code elimination

Redundant label elimination

Redundant branch elimination

Code hoisting

Peephole optimization

Some register content analysis and optimization

Common subexpression elimination

Code motion

Static clustering

High (Balanced) Same as above, and:
Instruction scheduling
Cross jumping
Advanced register content analysis and optimization
Loop unrolling
Function inlining
Type-based alias analysis

Note: Some of the performed optimizations can be individually enabled or disabled. For
more information about these, see Fine-tuning enabled transformations, page 223.

A high level of optimization might result in increased compile time, and will most likely
also make debugging more difficult, because it is less clear how the generated code
relates to the source code. For example, at the low, medium, and high optimization
levels, variables do not live through their entire scope, which means processor registers
used for storing variables can be reused immediately after they were last used. Due to
this, the C-SPY Watch window might not be able to display the value of the variable
throughout its scope. At any time, if you experience difficulties when debugging your
code, try lowering the optimization level.
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SPEED VERSUS SIZE

At the high optimization level, the compiler balances between size and speed
optimizations. However, it is possible to fine-tune the optimizations explicitly for either
size or speed. They only differ in what thresholds that are used; speed will trade size for
speed, whereas size will trade speed for size. Note that one optimization sometimes
enables other optimizations to be performed, and an application might in some cases
become smaller even when optimizing for speed rather than size.

If you use the optimization level High speed, the --no_size_constraints compiler
option relaxes the normal restrictions for code size expansion and enables more
aggressive optimizations.

You can choose an optimization goal for each module, or even individual functions,
using command line options and pragma directives (see -O, page 279 and optimize, page
360). For a small embedded application, this makes it possible to achieve acceptable
speed performance while minimizing the code size: Typically, only a few places in the
application need to be fast, such as the most frequently executed inner loops, or the
interrupt handlers.

Rather than compiling the whole application with High (Balanced) optimization, you
can use High (Size) in general, but override this to get High (Speed) optimization only
for those functions where the application needs to be fast.

Because of the unpredictable way in which different optimizations interact, where one
optimization can enable other optimizations, sometimes a function becomes smaller
when compiled with High (Speed) optimization than if High (Size) is used. Also, using
multi-file compilation (see --mfc, page 270) can enable many optimizations to improve
both speed and size performance. It is recommended that you experiment with different
optimization settings so that you can pick the best ones for your project.

FINE-TUNING ENABLED TRANSFORMATIONS

At each optimization level you can disable some of the transformations individually. To
disable a transformation, use either the appropriate option, for instance the command
line option --no_inline, alternatively its equivalent in the IDE Function inlining, or
the #pragma optimize directive. These transformations can be disabled individually:
Common subexpression elimination

Loop unrolling

Function inlining

Code motion

Type-based alias analysis

Static clustering
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Common subexpression elimination

Redundant re-evaluation of common subexpressions is by default eliminated at
optimization levels Medium and High. This optimization normally reduces both code
size and execution time. However, the resulting code might be difficult to debug.

Note: This option has no effect at optimization levels None and Low.

For more information about the command line option, see --no_cse, page 271.

Loop unrolling

Loop unrolling means that the code body of a loop, whose number of iterations can be
determined at compile time, is duplicated. Loop unrolling reduces the loop overhead by
amortizing it over several iterations.

This optimization is most efficient for smaller loops, where the loop overhead can be a
substantial part of the total loop body.

Loop unrolling, which can be performed at optimization level High, normally reduces
execution time, but increases code size. The resulting code might also be difficult to
debug.

The compiler heuristically decides which loops to unroll. Only relatively small loops
where the loop overhead reduction is noticeable will be unrolled. Different heuristics are
used when optimizing for speed, size, or when balancing between size and speed.

Note: This option has no effect at optimization levels None, Low, and Medium.

To disable loop unrolling, use the command line option --no_unrol1l, see --no_unroll,
page 278.

Function inlining

Function inlining means that a function, whose definition is known at compile time, is
integrated into the body of its caller to eliminate the overhead of the call. This
optimization normally reduces execution time, but might increase the code size.

For more information, see Inlining functions, page 71.

Code motion

Evaluation of loop-invariant expressions and common subexpressions are moved to
avoid redundant re-evaluation. This optimization, which is performed at optimization
level Medium and above, normally reduces code size and execution time. The resulting
code might however be difficult to debug.

Note: This option has no effect at optimization levels below Medium.

For more information about the command line option, see --no_code_motion, page 271.
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Type-based alias analysis

When two or more pointers reference the same memory location, these pointers are said
to be aliases for each other. The existence of aliases makes optimization more difficult
because it is not necessarily known at compile time whether a particular value is being
changed.

Type-based alias analysis optimization assumes that all accesses to an object are
performed using its declared type or as a char type. This assumption lets the compiler
detect whether pointers can reference the same memory location or not.

Type-based alias analysis is performed at optimization level High. For application code
conforming to standard C or C++ application code, this optimization can reduce code
size and execution time. However, non-standard C or C++ code might result in the
compiler producing code that leads to unexpected behavior. Therefore, it is possible to
turn this optimization off.

Note: This option has no effect at optimization levels None, Low, and Medium.

For more information about the command line option, see --no_tbaa, page 276.

Example

short F(short *pl, long *p2)
{

*p2 = 0;

*pl = 1;

return *p2;

}

With type-based alias analysis, it is assumed that a write access to the short pointed to
by p1 cannot affect the 1ong value that p2 points to. Thus, it is known at compile time
that this function returns 0. However, in non-standard-conforming C or C++ code these
pointers could overlap each other by being part of the same union. If you use explicit
casts, you can also force pointers of different pointer types to point to the same memory
location.

Static clustering

When static clustering is enabled, static and global variables that are defined within the
same module are arranged so that variables that are accessed in the same function are
stored close to each other. This makes it possible for the compiler to use the same base
pointer for several accesses.

Note: This option has no effect at optimization levels None and Low.

For more information about the command line option, see --no_clustering, page 270.
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Instruction scheduling

The compiler features an instruction scheduler to increase the performance of the
generated code. To achieve that goal, the scheduler rearranges the instructions to
minimize the number of pipeline stalls emanating from resource conflicts within the
MiCroprocessor.

For more information about the command line option, see --no_scheduling, page 275.

Facilitating good code generation

This section contains hints on how to help the compiler generate good code:
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Writing optimization-friendly source code, page 226
Saving stack space and RAM memory, page 227

Function prototypes, page 227

Integer types and bit negation, page 228

Protecting simultaneously accessed variables, page 228
Accessing special function registers, page 229

Passing values between C and assembler objects, page 231

Non-initialized variables, page 231

WRITING OPTIMIZATION-FRIENDLY SOURCE CODE

The following is a list of programming techniques that will, when followed, enable the
compiler to better optimize the application.

Local variables—auto variables and parameters—are preferred over static or global
variables. The reason is that the optimizer must assume, for example, that called
functions can modify non-local variables. When the life spans for local variables
end, the previously occupied memory can then be reused. Globally declared
variables will occupy data memory during the whole program execution.

Avoid taking the address of local variables using the & operator. This is inefficient
for two main reasons. First, the variable must be placed in memory, and thus cannot
be placed in a processor register. This results in larger and slower code. Second, the
optimizer can no longer assume that the local variable is unaffected over function
calls.

Module-local variables—yvariables that are declared static—are preferred over
global variables (non-static). Also avoid taking the address of frequently accessed
static variables.

The compiler is capable of inlining functions, see Function inlining, page 224. To
maximize the effect of the inlining transformation, it is good practice to place the
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definitions of small functions called from more than one module in the header file
rather than in the implementation file. Alternatively, you can use multi-file
compilation. For more information, see Multi-file compilation units, page 221.

o Avoid using inline assembler without operands and clobbered resources. Instead,
use SFRs or intrinsic functions if available. Otherwise, use inline assembler with
operands and clobbered resources or write a separate module in assembler
language. For more information, see Mixing C and assembler, page 151.

SAVING STACK SPACE AND RAM MEMORY
The following is a list of programming techniques that save memory and stack space:

o If stack space is limited, avoid long call chains and recursive functions.

o Avoid using large non-scalar types, such as structures, as parameters or return type.
To save stack space, you should instead pass them as pointers or, in C++, as
references.

FUNCTION PROTOTYPES
It is possible to declare and define functions using one of two different styles:

o Prototyped
o Kernighan & Ritchie C (K&R C)

Both styles are valid C, however it is strongly recommended to use the prototyped style,
and provide a prototype declaration for each public function in a header that is included
both in the compilation unit defining the function and in all compilation units using it.

The compiler will not perform type checking on parameters passed to functions declared
using K&R style. Using prototype declarations will also result in more efficient code in
some cases, as there is no need for type promotion for these functions.

To make the compiler require that all function definitions use the prototyped style, and
that all public functions have been declared before being defined, use the
Project>Options>C/C++ Compiler>Language 1>Require prototypes compiler
option (--require_prototypes).

Prototyped style

In prototyped function declarations, the type for each parameter must be specified.

int Test(char, int); /* Declaration */

int Test(char ch, int i) /* Definition */
{

return i1 + ch;

}
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Kernighan & Ritchie style

In K&R style—pre-Standard C—it is not possible to declare a function prototyped.
Instead, an empty parameter list is used in the function declaration. Also, the definition
looks different.

For example:

int Test(); /* Declaration */

int Test(ch, i) /* Definition */
char ch;

int 1i;

{

return i1 + ch;

INTEGER TYPES AND BIT NEGATION

In some situations, the rules for integer types and their conversion lead to possibly
confusing behavior. Things to look out for are assignments or conditionals (test
expressions) involving types with different size, and logical operations, especially bit
negation. Here, #ypes also includes types of constants.

In some cases there might be warnings (for example, for constant conditional or
pointless comparison), in others just a different result than what is expected. Under
certain circumstances the compiler might warn only at higher optimizations, for
example, if the compiler relies on optimizations to identify some instances of constant
conditionals. In this example an 8-bit character, a 32-bit integer, and two’s complement
is assumed:

void F1 (unsigned char cl)
{
if (cl == ~0x80)

}

Here, the test is always false. On the right hand side, 0x80 is 0x00000080, and
~0x00000080 becomes 0xFFFFFF7F. On the left hand side, c1 is an 8-bit unsigned
character, so it cannot be larger than 255. It also cannot be negative, which means that
the integral promoted value can never have the topmost 24 bits set.

PROTECTING SIMULTANEOUSLY ACCESSED VARIABLES

Variables that are accessed asynchronously, for example by interrupt routines or by code
executing in separate threads, must be properly marked and have adequate protection.
The only exception to this is a variable that is always read-only.
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To mark a variable properly, use the volatile keyword. This informs the compiler,
among other things, that the variable can be changed from other threads. The compiler
will then avoid optimizing on the variable (for example, keeping track of the variable in
registers), will not delay writes to it, and be careful accessing the variable only the
number of times given in the source code.

For more information about the volatile type qualifier and the rules for accessing
volatile objects, see Declaring objects volatile, page 331.
ACCESSING SPECIAL FUNCTION REGISTERS

Specific header files for several ARM devices are included in the IAR product
installation. The header files are named iodevice.h and define the processor-specific
special function registers (SFRs).

Note: Each header file contains one section used by the compiler, and one section used
by the assembler.
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SFRs with bitfields are declared in the header file. This example is from
ioks32c5000a.h:

__no_init volatile union
{
unsigned short mwctl2;
struct
{
unsigned short edr: 1;
unsigned short edw: 1;
unsigned short lee: 2;
unsigned short lemd: 2;
unsigned short lepl: 2;
} mwctl2bit;
} @ 0x1000;

/* By including the appropriate include file in your code,

* it is possible to access either the whole register or any
* individual bit (or bitfields) from C code as follows.

*/

void Test ()

{
/* Whole register access */
mwctl2 = 0x1234;

/* Bitfield accesses */
mwctl2bit.edw = 1;
mwctl2bit.lepl = 3;

}

You can also use the header files as templates when you create new header files for other
ARM devices.
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PASSING VALUES BETWEEN C AND ASSEMBLER OBJECTS

The following example shows how you in your C source code can use inline assembler
to set and get values from a special purpose register:

static unsigned long get_APSR( void )
{

unsigned long value;
asm volatile( "MRS %0, APSR" : "=r"(value) );
return value;

}

static void set_APSR( unsigned long value)

{
asm volatile( "MSR APSR, %0" :: "r"(value) );

}

The general purpose register is used for getting and setting the value of the special
purpose register APSR. The same method can be used also for accessing other special
purpose registers and specific instructions.

To read more about inline assembler, see /nline assembler, page 152.

NON-INITIALIZED VARIABLES

Normally, the runtime environment will initialize all global and static variables when the
application is started.

The compiler supports the declaration of variables that will not be initialized, using the
__no_init type modifier. They can be specified either as a keyword or using the
#pragma object_attribute directive. The compiler places such variables in a
separate segment.

For __no_init, the const keyword implies that an object is read-only, rather than that
the object is stored in read-only memory. It is not possible to give a__no_init object
an initial value.

Variables declared using the __no_init keyword could, for example, be large input
buffers or mapped to special RAM that keeps its content even when the application is
turned off.

For more information, see __no_init, page 341. Note that to use this keyword, language
extensions must be enabled; see -e, page 261. For more information, see also
object_attribute, page 359.
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This part of the IJAR C/C++ Development Guide for ARM contains these

chapters:

e External interface details

e Compiler options

e Linker options

e Data representation

e Extended keywords

e Pragma directives

e Intrinsic functions

e The preprocessor

e C/C++ standard library functions
e The linker configuration file

o Section reference

e The stack usage control file

o |AR utilities

o Implementation-defined behavior for Standard C

e Implementation-defined behavior for C89.
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External interface details

e Invocation syntax

e Include file search procedure
e Compiler output

e ILINK output

e Diagnostics

Invocation syntax

You can use the compiler and linker either from the IDE or from the command line. See
the IDE Project Management and Building Guide for ARM for information about using
the build tools from the IDE.

COMPILER INVOCATION SYNTAX
The invocation syntax for the compiler is:
iccarm [options] [sourcefile] [options]

For example, when compiling the source file prog. c, use this command to generate an
object file with debug information:

iccarm prog.c --debug

The source file can be a C or C++ file, typically with the filename extension c or cpp,
respectively. If no filename extension is specified, the file to be compiled must have the
extension c.

Generally, the order of options on the command line, both relative to each other and to
the source filename, is not significant. There is, however, one exception: when you use
the -I option, the directories are searched in the same order as they are specified on the
command line.

If you run the compiler from the command line without any arguments, the compiler
version number and all available options including brief descriptions are directed to
stdout and displayed on the screen.
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ILINK INVOCATION SYNTAX

The invocation syntax for ILINK is:

ilinkarm [arguments]

Each argument is either a command-line option, an object file, or a library.
For example, when linking the object file prog. o, use this command:
ilinkarm prog.o --config configfile

If no filename extension is specified for the linker configuration file, the configuration
file must have the extension icf.

Generally, the order of arguments on the command line is not significant. There is,
however, one exception: when you supply several libraries, the libraries are searched in
the same order that they are specified on the command line. The default libraries are
always searched last.

The output executable image will be placed in a file named a . out, unless the -o option
is used.

If you run ILINK from the command line without any arguments, the ILINK version
number and all available options including brief descriptions are directed to stdout and
displayed on the screen.

PASSING OPTIONS
There are three different ways of passing options to the compiler and to ILINK:

o Directly from the command line

Specify the options on the command line after the i ccarmor i1inkarm commands;
see Invocation syntax, page 235.

o Via environment variables

The compiler and linker automatically append the value of the environment variables
to every command line; see Environment variables, page 237.

e Viaa text file, using the - £ option; see -f, page 265.

For general guidelines for the option syntax, an options summary, and a detailed
description of each option, see the chapter Compiler options.
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ENVIRONMENT VARIABLES
These environment variables can be used with the compiler:

Environment variable Description

C_INCLUDE Specifies directories to search for include files; for example:
C_INCLUDE=c:\program files\iar systems\embedded
workbench 7.n\arm\inc;c:\headers

QCCARM Specifies command line options; for example: QCCARM=-1A
asm.lst

Table 25: Compiler environment variables

This environment variable can be used with ILINK:

Environment variable Description

ILINKARM_CMD_LINE Specifies command line options; for example:
ILINKARM_CMD_LINE=--config full.icf
--silent

Table 26: ILINK environment variables

Include file search procedure
This is a detailed description of the compiler’s #include file search procedure:
o If the name of the #include file is an absolute path specified in angle brackets or
double quotes, that file is opened.
o If the compiler encounters the name of an #include file in angle brackets, such as:
#include <stdio.h>
it searches these directories for the file to include:

1 The directories specified with the - T option, in the order that they were
specified, see -/, page 267.

2 The directories specified using the C_INCLUDE environment variable, if any; see
Environment variables, page 237.

3 The automatically set up library system include directories. See --dlib_config,
page 261.

e If the compiler encounters the name of an #include file in double quotes, for
example:
#include "vars.h"

it searches the directory of the source file in which the #include statement occurs,
and then performs the same sequence as for angle-bracketed filenames.
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If there are nested #include files, the compiler starts searching the directory of the file
that was last included, iterating upwards for each included file, searching the source file
directory last. For example:

src.c in directory dir\src
#include "src.h"

src.h in directory dir\include
#include "config.h"

When dir\exe is the current directory, use this command for compilation:
iccarm ..\src\src.c -I..\include -I..\debugconfig

Then the following directories are searched in the order listed below for the file
config.h, which in this example is located in the dir\debugconfig directory:

dir\include Current file is src.h

dir\src File including current file (src.c).
dir\include As specified with the first -I option.
dir\debugconfig As specified with the second -I option.

Use angle brackets for standard header files, like stdio.h, and double quotes for files
that are part of your application.

Note: Both \ and / can be used as directory delimiters.

For more information, see Overview of the preprocessor, page 407.

Compiler output
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The compiler can produce the following output:

o A linkable object file

The object files produced by the compiler use the industry-standard format ELF. By
default, the object file has the filename extension o.

o Optional list files

Various kinds of list files can be specified using the compiler option -1, see -/, page
267. By default, these files will have the filename extension 1st.

o Optional preprocessor output files

A preprocessor output file is produced when you use the --preprocess option; by
default, the file will have the filename extension i.
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o Diagnostic messages

Diagnostic messages are directed to the standard error stream and displayed on the
screen, and printed in an optional list file. For more information about diagnostic
messages, see Diagnostics, page 240.

e Error return codes
These codes provide status information to the operating system which can be tested
in a batch file, see Error return codes, page 239.

e Size information
Information about the generated amount of bytes for functions and data for each

memory is directed to the standard output stream and displayed on the screen. Some
of the bytes might be reported as shared.

Shared objects are functions or data objects that are shared between modules. If any
of these occur in more than one module, only one copy is retained. For example, in
some cases inline functions are not inlined, which means that they are marked as
shared, because only one instance of each function will be included in the final
application. This mechanism is sometimes also used for compiler-generated code or
data not directly associated with a particular function or variable, and when only one
instance is required in the final application.

ERROR RETURN CODES

The compiler and linker return status information to the operating system that can be
tested in a batch file.

These command line error codes are supported:

Code Description

0 Compilation or linking successful, but there might have been warnings.

| Warnings were produced and the option --warnings_affect_exit_code

was used.
2 Errors occurred.
3 Fatal errors occurred, making the tool abort.
4 Internal errors occurred, making the tool abort.

Table 27: Error return codes
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ILINK output

ILINK can produce the following output:

o An absolute executable image

The final output produced by the IAR ILINK Linker is an absolute object file
containing the executable image that can be put into an EPROM, downloaded to a
hardware emulator, or executed on your PC using the IAR C-SPY Debugger
Simulator. By default, the file has the filename extension out. The output format is
always in ELF, which optionally includes debug information in the DWARF format.

o Optional logging information

During operation, ILINK logs its decisions on stdout, and optionally to a file. For
example, if a library is searched, whether a required symbol is found in a library
module, or whether a module will be part of the output. Timing information for each
ILINK subsystem is also logged.

o Optional map files

A linker map file—containing summaries of linkage, runtime attributes, memory,
and placement, as well as an entry list— can be generated by the ILINK option
--map, see --map, page 307. By default, the map file has the filename extension map.

e Diagnostic messages

Diagnostic messages are directed to stderr and displayed on the screen, as well as
printed in the optional map file. For more information about diagnostic messages, see
Diagnostics, page 240.

o Error return codes

ILINK returns status information to the operating system which can be tested in a
batch file, see Error return codes, page 239.

e Size information about used memory and amount of time

Information about the generated amount of bytes for functions and data for each
memory is directed to stdout and displayed on the screen.

Diagnostics
This section describes the format of the diagnostic messages and explains how
diagnostic messages are divided into different levels of severity.
MESSAGE FORMAT FOR THE COMPILER

All diagnostic messages are issued as complete, self-explanatory messages. A typical
diagnostic message from the compiler is produced in the form:

filename, linenumber level[tag]: message

IAR C/C++ Development Guide
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with these elements:

filename The name of the source file in which the issue was encountered
linenumber The line number at which the compiler detected the issue
level The level of seriousness of the issue

tag A unique tag that identifies the diagnostic message

message An explanation, possibly several lines long

Diagnostic messages are displayed on the screen, as well as printed in the optional list
file.

Use the option --diagnostics_tables to list all possible compiler diagnostic
messages.

MESSAGE FORMAT FOR THE LINKER

All diagnostic messages are issued as complete, self-explanatory messages. A typical
diagnostic message from ILINK is produced in the form:

level[tag]: message

with these elements:

level The level of seriousness of the issue
tag A unique tag that identifies the diagnostic message
message An explanation, possibly several lines long

Diagnostic messages are displayed on the screen, as well as printed in the optional map
file.

Use the option --diagnostics_tables to list all possible linker diagnostic messages.

SEVERITY LEVELS

The diagnostic messages are divided into different levels of severity:

Remark

A diagnostic message that is produced when the compiler or linker finds a construct that
can possibly lead to erroneous behavior in the generated code. Remarks are by default
not issued, but can be enabled, see --remarks, page 282.
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Warning

A diagnostic message that is produced when the compiler or linker finds a potential
problem which is of concern, but which does not prevent completion of the compilation
or linking. Warnings can be disabled by use of the command line option
--no_warnings, see --no_warnings, page 278.

Error

A diagnostic message that is produced when the compiler or linker finds a serious error.
An error will produce a non-zero exit code.

Fatal error

A diagnostic message that is produced when the compiler finds a condition that not only
prevents code generation, but which makes further processing pointless. After the
message is issued, compilation terminates. A fatal error will produce a non-zero exit
code.

SETTING THE SEVERITY LEVEL

The diagnostic messages can be suppressed or the severity level can be changed for all
diagnostics messages, except for fatal errors and some of the regular errors.

See the chapter Compiler options, for information about the compiler options that are
available for setting severity levels.

For the compiler see also the chapter Pragma directives, for information about the
pragma directives that are available for setting severity levels.

INTERNAL ERROR

An internal error is a diagnostic message that signals that there was a serious and
unexpected failure due to a fault in the compiler or linker. It is produced using this form:

Internal error: message

where message is an explanatory message. If internal errors occur, they should be
reported to your software distributor or IAR Systems Technical Support. Include enough
information to reproduce the problem, typically:

o The product name

o The version number of the compiler or of ILINK, which can be seen in the header of
the list or map files generated by the compiler or by ILINK, respectively

o Your license number
o The exact internal error message text

o The files involved of the application that generated the internal error
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o A list of the options that were used when the internal error occurred.

243



Diagnostics

IAR C/C++ Development Guide
244  Compiling and Linking for ARM



Compiler options

e Options syntax
e Summary of compiler options

e Descriptions of compiler options

Options syntax

Compiler options are parameters you can specify to change the default behavior of the
compiler. You can specify options from the command line—which is described in more
detail in this section—and from within the IDE.

See the online help system for information about the compiler options available in the
IDE and how to set them.

TYPES OF OPTIONS

There are two types of names for command line options, short names and /ong names.
Some options have both.

e A short option name consists of one character, and it can have parameters. You
specify it with a single dash, for example -e

o A long option name consists of one or several words joined by underscores, and it
can have parameters. You specify it with double dashes, for example
--char_is_signed.

For information about the different methods for passing options, see Passing options,
page 236.
RULES FOR SPECIFYING PARAMETERS

There are some general syntax rules for specifying option parameters. First, the rules
depending on whether the parameter is optional or mandatory, and whether the option
has a short or a long name, are described. Then, the rules for specifying filenames and
directories are listed. Finally, the remaining rules are listed.

Rules for optional parameters

For options with a short name and an optional parameter, any parameter should be
specified without a preceding space, for example:

-0 or -Oh
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For options with a long name and an optional parameter, any parameter should be
specified with a preceding equal sign (=), for example:

--misrac2004=n

Rules for mandatory parameters

For options with a short name and a mandatory parameter, the parameter can be
specified either with or without a preceding space, for example:

-I..\srcor-I ..\src\

For options with a long name and a mandatory parameter, the parameter can be specified
either with a preceding equal sign (=) or with a preceding space, for example:

--diagnostics_tables=MyDiagnostics.lst
or

--diagnostics_tables MyDiagnostics.lst

Rules for options with both optional and mandatory parameters

For options taking both optional and mandatory parameters, the rules for specifying the
parameters are:

e For short options, optional parameters are specified without a preceding space
e For long options, optional parameters are specified with a preceding equal sign (=)

e For short and long options, mandatory parameters are specified with a preceding
space.

For example, a short option with an optional parameter followed by a mandatory
parameter:

-1A MyList.lst

For example, a long option with an optional parameter followed by a mandatory
parameter:

--preprocess=n PreprocOutput.lst

Rules for specifying a filename or directory as parameters
These rules apply for options taking a filename or directory as parameters:

o Options that take a filename as a parameter can optionally take a file path. The path
can be relative or absolute. For example, to generate a listing to the file List.1st
in the directory . .\listings\:

iccarm prog.c -1 ..\listings\List.lst
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e For options that take a filename as the destination for output, the parameter can be
specified as a path without a specified filename. The compiler stores the output in
that directory, in a file with an extension according to the option. The filename will
be the same as the name of the compiled source file, unless a different name was
specified with the option -o, in which case that name is used. For example:

iccarm prog.c -1 ..\listings\

The produced list file will have the default name . .\1istings\prog.lst
o The current directory is specified with a period (. ). For example:

iccarm prog.c -1

/ can be used instead of \ as the directory delimiter.

o By specifying -, input files and output files can be redirected to the standard input
and output stream, respectively. For example:

iccarm prog.c -1 -

Additional rules
These rules also apply:

e When an option takes a parameter, the parameter cannot start with a dash (-)
followed by another character. Instead, you can prefix the parameter with two
dashes; this example will create a list file called -r:

iccarm prog.c -1 ---r

e For options that accept multiple arguments of the same type, the arguments can be
provided as a comma-separated list (without a space), for example:
--diag_warning=Be0001,Be0002
Alternatively, the option can be repeated for each argument, for example:

--diag_warning=Be0001
--diag_warning=Be0002

Summary of compiler options

This table summarizes the compiler command line options:

Command line option Description

--aapcs Specifies the calling convention

--aeabi Enables AEABI-compliant code generation

--align_sp_on_irqg Generates code to align SPonentry to __irqg
functions

--arm Sets the default function mode to ARM

Table 28: Compiler options summary
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Command line option

Description

--c89
--char_is_signed
--char_is_unsigned
--cpu

--cpu_mode

—-—Cc++

-D

--debug
--dependencies
--diag_error
--diag_remark
--diag_suppress
--diag_warning
--diagnostics_tables
--discard_unused_publics

--dlib_config

-e
--ec++

--eec++
--enable_hardware_workaround

--enable_multibytes

--enable_restrict

--endian

-—enum_is_int

-—error_limit

-f

--fpu

Specifies the C89 dialect

Treats char as signed

Treats char as unsigned
Specifies a processor variant
Specifies the default CPU mode for functions
Specifies Standard C++

Defines preprocessor symbols
Generates debug information
Lists file dependencies

Treats these as errors

Treats these as remarks
Suppresses these diagnostics
Treats these as warnings

Lists all diagnostic messages
Discards unused public symbols

Uses the system include files for the DLIB library
and determines which configuration of the library
to use

Enables language extensions

Specifies Embedded C++

Specifies Extended Embedded C++
Enables a specific hardware workaround

Enables support for multibyte characters in source
files

Enables the Standard C keyword restrict

Specifies the byte order of the generated code and
data

Sets the minimum size on enumeration types

Specifies the allowed number of errors before
compilation stops

Extends the command line

Selects the type of floating-point unit

Table 28: Compiler options summary (Continued)
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Description

--generate_entries_without_bo

unds

--guard_calls

--header_context

-I

--ignore_uninstrumented_point

ers

--interwork
-1

--legacy

--lock_regs

--macro_positions_in

_diagnostics

--make_all_definitions_weak

--mfc

--misrac

--misracl998

--misrac2004

--misrac_verbose

Generates extra functions for use from
non-instrumented code. See the C-RUN
documentation in the C-SPY® Debugging Guide for
ARM.

Enables guards for function static variable
initialization

Lists all referred source files and header files
Specifies include file path

Disables checking of accesses via pointers from
non-instrumented code. See the C-RUN
documentation in the C-SPY® Debugging Guide for
ARM.

Generates interworking code
Creates a list file

Generates object code linkable with older tool
chains

Prevents the compiler from using specified
registers

Obtains positions inside macros in diagnostic
messages

Turns all variable and function definitions into
weak definitions.

Enables multi-file compilation

Enables error messages specific to MISRA-C:1998.
This option is a synonym of --misrac1998 and
is only available for backwards compatibility.
Enables error messages specific to MISRA-C:1998.
See the IAR Embedded Workbench® MISRA C:1998
Reference Guide.

Enables error messages specific to MISRA-C:2004.
See the IAR Embedded Workbench® MISRA C:2004
Reference Guide.

IAR Embedded Workbench® MISRA C:1998
Reference Guide or the IAR Embedded Workbench®
MISRA C:2004 Reference Guide.

Table 28: Compiler options summary (Continued)
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Command line option

Description

--no_alignment_reduction

--no_clustering
--no_code_motion
--no_const_align
--no_cse
--no_exceptions
--no_fragments
--no_inline

--no_literal_pool

--no_loop_align

--no_mem_idioms

--no_path_in_file_macros

--no_rtti
--no_rw_dynamic_init
--no_scheduling

--no_size_constraints

--no_static_destruction

--no_system_include

--no_tbaa
--no_typedefs_in_diagnostics
--no_unaligned_access
--no_unroll

--no_var_align

--no_warnings

--no_wrap_diagnostics

Disables alignment reduction for simple Thumb
functions

Disables static clustering optimizations

Disables code motion optimization

Disables the alignment optimization for constants.
Disables common subexpression elimination
Disables C++ exception support

Disables section fragment handling

Disables function inlining

Generates code that should run from a memory
region where it is not allowed to read data, only to
execute code

Disables the alignment of labels in loops

Makes the compiler not optimize certain memory
access patterns

Removes the path from the return value of the
symbols __FILE__ and __BASE_FILE__

Disables C++ RTTI support
Disables runtime initialization of static C variables.
Disables the instruction scheduler

Relaxes the normal restrictions for code size
expansion when optimizing for speed.

Disables destruction of C++ static variables at
program exit

Disables the automatic search for system include
files

Disables type-based alias analysis

Disables the use of typedef names in diagnostics
Avoids unaligned accesses

Disables loop unrolling

Aligns variable objects based on the alignment of
their type.

Disables all warnings

Disables wrapping of diagnostic messages

Table 28: Compiler options summary (Continued)
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Description

-0

-o
--only_stdout
--output
--predef_macros

--preinclude

--preprocess
--public_equ
-r

--relaxed_fp

--remarks

--require_prototypes

--ropi

--runtime_checking

--rwpi

--section

--separate_cluster_for_
initialized_variables

--silent

--strict

--system_include_dir

--thumb

--use_c++_inline

--use_unix_directory_

separators

--vectorize

Sets the optimization level

Sets the object filename. Alias for --output.
Uses standard output only

Sets the object filename

Lists the predefined symbols.

Includes an include file before reading the source
file

Generates preprocessor output
Defines a global named assembler label
Generates debug information. Alias for --debug.

Relaxes the rules for optimizing floating-point
expressions

Enables remarks

Verifies that functions are declared before they are
defined

Generates code that uses PC-relative references
to address code and read-only data.

Enables runtime error checking. See the C-RUN
documentation in the C-SPY® Debugging Guide for
ARM.

Generates code that uses an offset from the static
base register to address-writable data.

Changes a section name

Separates initialized and non-initialized variables

Sets silent operation

Checks for strict compliance with Standard
C/C++

Specifies the path for system include files
Sets default function mode to Thumb
Uses C++ inline semantics in C99

Uses / as directory separator in paths

Enables generation of NEON vector instructions

Table 28: Compiler options summary (Continued)
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Command line option Description
--vla Enables C99 VLA support
--warn_about_c_style_casts Makes the compiler warn when C-style casts are

used in C++ source code
--warnings_affect_exit_code Warnings affect exit code

--warnings_are_errors Warnings are treated as errors

Table 28: Compiler options summary (Continued)

Descriptions of compiler options
The following section gives detailed reference information about each compiler option.
& Note that if you use the options page Extra Options to specify specific command line

options, the IDE does not perform an instant check for consistency problems like
conflicting options, duplication of options, or use of irrelevant options.

--aapcs
Syntax aapcs={std|vfp}
Parameters
std Processor registers are used for floating-point parameters and
return values in function calls according to standard AAPCS.
std is the default when the software FPU is selected.
vEp VFP registers are used for floating-point parameters and
return values. The generated code is not compatible with
AEABI code. v£p is the default when a VFP unit is used.
Description Use this option to specify the floating-point calling convention.
To set this option, use Project>Options>C/C++ Compiler>Extra Options.
--aeabi
Syntax --aeabi
Description Use this option to generate AEABI-compliant object code. Note that this option must be

used together with the --guard_calls option.
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See also

Syntax

Description

See also

=-=arm

--c89

Syntax

Description

See also

Syntax

Description
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AEABI compliance, page 209 and --guard_calls, page 266.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--align_sp_on_irqg

Use this option to align the stack pointer (SP) on entry to __irqg declared functions.

This is especially useful for nested interrupts, where the interrupted code uses the same
SP as the interrupt handler. This means that the stack might only have 4-byte alignment,
instead of the 8-byte alignment required by AEABI (and some instructions generated by
the compiler for some cores).

__irq, page 338.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

——arm

Use this option to set default function mode to ARM. This setting must be the same for
all files included in a program, unless they are interworking.

Note: This option has the same effect as the --cpu_mode=arm option.

--interwork, page 267 and __interwork, page 338.

Project>Options>C/C++ Compiler>Code>Processor mode>Arm

--c89

Use this option to enable the C89 C dialect instead of Standard C.

Note: This option is mandatory when the MISRA C checking is enabled.
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--char_is_signed

Syntax

Description

--char_is_unsigned

Syntax

Description

--cpu
Syntax

Parameters

Description
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C language overview, page 175.

Project>Options>C/C++ Compiler>Language 1>C dialect>C89

--char_is_signed

By default, the compiler interprets the plain char type as unsigned. Use this option to
make the compiler interpret the plain char type as signed instead. This can be useful
when you, for example, want to maintain compatibility with another compiler.

Note: The runtime library is compiled without the --char_is_signed option and
cannot be used with code that is compiled with this option.

Project>Options>C/C++ Compiler>Language 2>Plain ‘char’ is

--char_is_unsigned

Use this option to make the compiler interpret the plain char type as unsigned. This is
the default interpretation of the plain char type.

Project>Options>C/C++ Compiler>Language 2>Plain ‘char’ is

--cpu=core

core Specifies a specific processor variant
Use this option to select the processor variant for which the code is to be generated. The
default is ARM7TDMI. The following cores and processor macrocells are recognized:

ARM7TDMI ARM1020E Cortex-MO

ARM7TDMI-S ARM1022E Cortex-MO+
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ARM710T ARM1026EJ-S Cortex-M1
ARM720T ARM1136J Cortex-Msl”
ARM740T ARM1136J-S Cortex-M3
ARM7EJ-S ARM1136JF Cortex-M4
ARMOTDMI ARM1136JF-S Cortex-M4F
ARM920T ARM1176J Cortex-M7

(alias for ARM1176J7)

ARM922T ARM1176J-S Cortex-R4
(alias for ARM1176J%7-S)

ARMO40T ARM1176JF Cortex-R4F
(alias for ARM1176JZF)

ARMOE ARM1176JF-S Cortex-R5

(alias for ARM1176JZF-S)

ARM9E-S Cortex-A5 Cortex-R5F
ARM926EJ-S Cortex-AS5F Cortex-R7
ARM966E-S Cortex-A7 Cortex-R7F
ARM968E-S Cortex-A8 XScale
ARM946E-S Cortex-A9 XScale-IR7
ARM10E Cortex-Al5

* Cortex-M1 with Operating System extension.

See also Processor variant, page 55

Project>Options>General Options>Target>Processor configuration

--cpu_mode

Syntax --cpu_mode={arm|a|thumb|t}

Parameters
arm, a (default) Selects the arm mode as the default mode for functions
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Syntax

Description

See also
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thumb, t Selects the thumb mode as the default mode for functions

Use this option to select the default mode for functions. This setting must be the same
for all files included in a program, unless they are interworking.
--interwork, page 267 and __interwork, page 338.

Project>Options>General Options>Target>Processor mode

—-—Cc++

By default, the language supported by the compiler is C. If you use Standard C++, you
must use this option to set the language the compiler uses to C++.

--ec++, page 262, --eec++, page 262, and Using C++, page 185.
Project>Options>C/C++ Compiler>Language 1>C++

and

Project>Options>C/C++ Compiler>Language 1>C++ dialect>C++

-D symbol[=value]

symbol The name of the preprocessor symbol

value The value of the preprocessor symbol

Use this option to define a preprocessor symbol. If no value is specified, 1 is used. This
option can be used one or more times on the command line.

The option -D has the same effect as a #define statement at the top of the source file:
-Dsymbol
is equivalent to:

#define symbol 1
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Syntax

Description
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Syntax

Parameters
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To get the equivalence of:

#define FOO

specify the = sign but nothing after, for example:
-DFO0=

Project>Options>C/C++ Compiler>Preprocessor>Defined symbols

--debug
-r

Use the --debug or -r option to make the compiler include information in the object
modules required by the IAR C-SPY® Debugger and other symbolic debuggers.
Note: Including debug information will make the object files larger than otherwise.

Project>Options>C/C++ Compiler>Output>Generate debug information

--dependencies([=[1i|m|n][s]] {filename|directory|+}

i (default) Lists only the names of files

m Lists in makefile style (multiple rules)

n Lists in makefile style (one rule)

s Suppresses system files

+ Gives the same output as -o, but with the filename extension d

See also Rules for specifying a filename or directory as parameters, page 246.

Use this option to make the compiler list the names of all source and header files opened
for input into a file with the default filename extension i.
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--diag_error

Syntax

Parameters

Description
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If --dependencies or --dependencies=i is used, the name of each opened input
file, including the full path, if available, is output on a separate line. For example:

c:\iar\product\include\stdio.h
d:\myproject\include\foo.h

If --dependencies=m is used, the output is in makefile style. For each input file, one
line containing a makefile dependency rule is produced. Each line consists of the name
of the object file, a colon, a space, and the name of an input file. For example:

foo.o0: c:\iar\product\include\stdio.h
foo.o0: d:\myproject\include\foo.h

An example of using --dependencies with a popular make utility, such as gmake
(GNU make):

Set up the rule for compiling files to be something like:

) .o
5.0 @ ©.C

S (ICC) $(ICCFLAGS) S$< --dependencies=m $*.d

That is, in addition to producing an object file, the command also produces a
dependency file in makefile style (in this example, using the extension . d).

Include all the dependency files in the makefile using, for example:
-include $ (sources:.c=.d)
Because of the dash (-) it works the first time, when the . d files do not yet exist.

This option is not available in the IDE.

--diag_error=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel17

Use this option to reclassify certain diagnostic messages as errors. An error indicates a
violation of the C or C++ language rules, of such severity that object code will not be
generated. The exit code will be non-zero. This option may be used more than once on
the command line.

Project>Options>C/C++ Compiler>Diagnostics>Treat these as errors
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--diag_suppress

Syntax
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Description

--diag_warning

Syntax

Parameters

Description
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--diag_remark=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel77

Use this option to reclassify certain diagnostic messages as remarks. A remark is the
least severe type of diagnostic message and indicates a source code construction that
may cause strange behavior in the generated code. This option may be used more than
once on the command line.

Note: By default, remarks are not displayed; use the --remarks option to display them.

Project>Options>C/C++ Compiler>Diagnostics>Treat these as remarks

--diag_suppress=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel17

Use this option to suppress certain diagnostic messages. These messages will not be
displayed. This option may be used more than once on the command line.

Project>Options>C/C++ Compiler>Diagnostics>Suppress these diagnostics

--diag_warning=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pe826

Use this option to reclassify certain diagnostic messages as warnings. A warning
indicates an error or omission that is of concern, but which will not cause the compiler
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--diagnostics_tables

Syntax
Parameters

Description

to stop before compilation is completed. This option may be used more than once on the
command line.

Project>Options>C/C++ Compiler>Diagnostics>Treat these as warnings

--diagnostics_tables {filename | directory}
See Rules for specifying a filename or directory as parameters, page 246.

Use this option to list all possible diagnostic messages in a named file. This can be
convenient, for example, if you have used a pragma directive to suppress or change the
severity level of any diagnostic messages, but forgot to document why.

This option cannot be given together with other options.

This option is not available in the IDE.

--discard_unused_publics

Syntax

Description

See also
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--discard_unused_publics

Use this option to discard unused public functions and variables when compiling with
the --mfc compiler option.

Note: Do not use this option only on parts of the application, as necessary symbols
might be removed from the generated output. Use the object attribute __root to keep
symbols that are used from outside the compilation unit, for example interrupt handlers.
If the symbol does not have the __root attribute and is defined in the library, the library
definition will be used instead.

--mfc, page 270 and Multi-file compilation units, page 221.

Project>Options>C/C++ Compiler>Discard unused publics
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--dlib_config filename.h | config

filename A DLIB configuration header file, see Rules for specifying a
filename or directory as parameters, page 246.

config The default configuration file for the specified configuration
will be used. Choose between:

none, no configuration will be used

normal, the normal library configuration will be used
(default)

full, the full library configuration will be used.

Use this option to specify which library configuration to use, either by specifying an
explicit file or by specifying a library configuration—in which case the default file for
that library configuration will be used. Make sure that you specify a configuration that
corresponds to the library you are using. If you do not specify this option, the default
library configuration file will be used.

All prebuilt runtime libraries are delivered with corresponding configuration files. You
can find the library object files and the library configuration files in the directory
arm\1lib. For examples and information about prebuilt runtime libraries, see Prebuilt
runtime libraries, page 118.

If you build your own customized runtime library, you should also create a
corresponding customized library configuration file, which must be specified to the
compiler. For more information, see Customizing and building your own runtime
library, page 115.

To set related options, choose:

Project>Options>General Options>Library Configuration

In the command line version of the compiler, language extensions are disabled by
default. If you use language extensions such as extended keywords and anonymous
structs and unions in your source code, you must use this option to enable them.
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--ect++
Syntax

Description

--ecec++

Syntax

Description

See also
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Note: The -e option and the --strict option cannot be used at the same time.

Enabling language extensions, page 177.
Project>Options>C/C++ Compiler>Language 1>Standard with IAR extensions

Note: By default, this option is selected in the IDE.

--ec++
In the compiler, the default language is C. If you use Embedded C++, you must use this
option to set the language the compiler uses to Embedded C++.
Project>Options>C/C++ Compiler>Language 1>C++

and

Project>Options>C/C++ Compiler>Language 1>C++ dialect>Embedded C++

--eec++

In the compiler, the default language is C. If you take advantage of Extended Embedded
C++ features like namespaces or the standard template library in your source code, you
must use this option to set the language the compiler uses to Extended Embedded C++.
Extended Embedded C++, page 186.

Project>Options>C/C++ Compiler>Language 1>C++

and

Project>Options>C/C++ Compiler>Language 1>C++ dialect>Extended
Embedded C++
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--enable_hardware_workaround

Syntax

Parameters

Description

See also

--enable_multibytes

Syntax

Description

--enable_restrict

Syntax

Description

--enable_hardware_workaround=waid[,waid. . .]

waid The ID number of the workaround to enable. For a list of
available workarounds to enable, see the release notes.

Use this option to make the compiler generate a workaround for a specific hardware
problem.
The release notes for the compiler for a list of available parameters.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--enable_multibytes

By default, multibyte characters cannot be used in C or C++ source code. Use this option
to make multibyte characters in the source code be interpreted according to the host
computer’s default setting for multibyte support.

Multibyte characters are allowed in C and C++ style comments, in string literals, and in
character constants. They are transferred untouched to the generated code.

Project>Options>C/C++ Compiler>Language 2>Enable multibyte support

--enable_restrict

Enables the Standard C keyword restrict. This option can be useful for improving
analysis precision during optimization.

To set this option, use Project>Options>C/C++ Compiler>Extra options
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--endian

Syntax

Parameters

Description

See also

--enum_is_int

Syntax

Description

See also

--error_limit

Syntax

Parameters

Description
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--endian=

big, b Specifies big-endian as the default byte order

little, 1 (default) Specifies little-endian as the default byte order

Use this option to specity the byte order of the generated code and data. By default, the
compiler generates code in little-endian byte order.

Byte order, page 320.

Project>Options>General Options>Target>Endian mode

-—enum_is_int

Use this option to force the size of all enumeration types to be at least 4 bytes.
Note: This option will not consider the fact that an enum type can be larger than an
integer type.

The enum type, page 321.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--error_limit=n

n The number of errors before the compiler stops the
compilation. n must be a positive integer; 0 indicates no
limit.

Use the --error_limit option to specify the number of errors allowed before the
compiler stops the compilation. By default, 100 errors are allowed.



--fpu

Syntax
Parameters

Description

Syntax

Parameters
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This option is not available in the IDE.

-f filename
See Rules for specifying a filename or directory as parameters, page 246.
Use this option to make the compiler read command line options from the named file,

with the default filename extension xc1.

In the command file, you format the items exactly as if they were on the command line
itself, except that you may use multiple lines, because the newline character acts just as
a space or tab character.

Both C and C++ style comments are allowed in the file. Double quotes behave in the
same way as in the Microsoft Windows command line environment.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--fpu={VFPv2 |VFPv3 |VFPv3_d16 |VFPv4 |VFPv4_sp|VFPv4_dl6|VFPv5_sp|
VFPv5_dl6 |VFP9-S|none}

VFPV2 For a system that implements a VFP unit that conforms to the
architecture VFPv2.

VFPv3 For a system that implements a VFP unit that conforms to the
architecture VFPv3.

VFPv3_dlé6 For a system that implements a VFP unit that conforms to the
D16 variant of the architecture VFPv3.

VFPv4 For a system that implements a VFP unit that conforms to the
architecture VFPv4.

VFPv4_dl6 For a system that implements a VFP unit that conforms to the
D16 variant of the architecture VFPv4.

VFPv4_sp For a system that implements a VFP unit that conforms to the
single-precision variant of the architecture VFPv4.
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Description

See also

--guard_calls

Syntax

Description

See also

--header_context

Syntax

Description
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VFPV5_sp For a system that implements a VFP unit that conforms to the
single-precision variant of the architecture VFPvS5.

VFPv5_dl6 For a system that implements a VFP unit that conforms to the
D16 variant of the architecture VFPvS5.

VFP9-S VFPO-S is an implementation of the VFPv2 architecture that
can be used with the ARMOE family of CPU cores. Selecting
the VFP9-S coprocessor is therefore identical to selecting the
VFPv2 architecture.

none (default) The software floating-point library is used.

Use this option to generate code that performs floating-point operations using a Vector
Floating Point (VFP) coprocessor. By selecting a VFP coprocessor, you will override the
use of the software floating-point library for all supported floating-point operations.

VFP and floating-point arithmetic, page 56.
Project>Options>General Options>Target>FPU

--guard_calls

Use this option to enable guards for function static variable initialization. This option
should be used in a threaded C++ environment.
Managing a multithreaded environment, page 143.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--header_context

Occasionally, to find the cause of a problem it is necessary to know which header file
that was included from which source line. Use this option to list, for each diagnostic
message, not only the source position of the problem, but also the entire include stack at
that point.



Syntax

Parameters

Description

See also

--interwork

Syntax

Description

See also

Syntax

Parameters
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This option is not available in the IDE.

-1 path

path The search path for #include files

Use this option to specify the search paths for #include files. This option can be used
more than once on the command line.

Include file search procedure, page 237.

Project>Options>C/C++ Compiler>Preprocessor>Additional include directories

--interwork

Use this option to generate interworking code.

In code compiled with this option, functions will by default be of the type interwork. It
will be possible to mix files compiled as arm and thumb (using the --cpu_mode option)
as long as they are all compiled with the --interwork option.

Note: Source code compiled for an ARM architecture v5 or higher, or for AEABI
compliance, is interworking by default.

__interwork, page 338.

Project>Options>General Options>Target>Generate interwork code

-1[a|A|b|B|c|C|D][N][H] {filename|directory}

a (default) Assembler list file
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--legacy
Syntax

Parameters

Description
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A Assembler list file with C or C++ source as comments

b Basic assembler list file. This file has the same contents as a
list file produced with -1a, except that no extra
compiler-generated information (runtime model attributes,
call frame information, frame size information) is included *

B Basic assembler list file. This file has the same contents as a
list file produced with -1a, except that no extra compiler
generated information (runtime model attributes, call frame
information, frame size information) is included *

c C or C++ list file
c (default) C or C++ list file with assembler source as comments
D C or C++ list file with assembler source as comments, but

without instruction offsets and hexadecimal byte values

N No diagnostics in file

H Include source lines from header files in output. Without this
option, only source lines from the primary source file are
included

* This makes the list file less useful as input to the assembler, but more useful for reading
by a human.

See also Rules for specifying a filename or directory as parameters, page 246.

Use this option to generate an assembler or C/C++ listing to a file. Note that this option
can be used one or more times on the command line.

To set related options, choose:

Project>Options>C/C++ Compiler>List

--legacy={RVCT3.0}

RVCT3.0 Generates object code linkable with the linker in RVCT3.0.
Use this mode together with the --aeabi option to generate
code that should be linked with the linker in RVCT3.0.

Use this option to generate code compatible with the specified toolchain.
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To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--lock_regs

Syntax --lock_regs=register

Parameters
registers A comma-separated list of register names and register

intervals to be locked, in the range R4-R11.

Description Use this option to prevent the compiler from generating code that uses the specified
registers.
Example --lock_regs=R4

--lock_regs=R8—R11
--lock_regs=R4,R8—R11

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--macro_positions_in_diagnostics

Swnax --macro_positions_in_diagnostics

Description Use this option to obtain position references inside macros in diagnostic messages. This
is useful for detecting incorrect source code constructs in macros.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--make_all_definitions_weak

Syntax --make_all_definitions_weak

Description Turns all variable and function definitions in the compilation unit into weak definitions.

Note: Normally, it is better to use extended keywords or pragma directives to turn
individual variable and function definitions into weak definitions.

See also __weak, page 346.
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--mfc

Syntax

Description

Example

See also

This option is not available in the IDE.

--mfc

Use this option to enable multi-file compilation. This means that the compiler compiles
one or several source files specified on the command line as one unit, which enhances
interprocedural optimizations.

Note: The compiler will generate one object file per input source code file, where the
first object file contains all relevant data and the other ones are empty. If you want only
the first file to be produced, use the -o compiler option and specify a certain output file.

iccarm myfilel.c myfile2.c myfile3.c --mfc

--discard_unused_publics, page 260, --output, -o, page 280, and Multi-file compilation
units, page 221.

Project>Options>C/C++ Compiler>Multi-file compilation

--no_alignment_reduction

Syntax

Description

--no_clustering

Syntax

Description
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--no_alignment_reduction

Some simple Thumb/Thumb2 functions can be 2-byte aligned. Use this option to keep
those functions 4-byte aligned.

This option has no effect when compiling for ARM mode.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--no_clustering

Use this option to disable static clustering optimizations.

Note: This option has no effect at optimization.



--no_code_motion

--no_const_align

--NO_

See also

Syntax

Description

See also

Syntax

Description

See also

cse

Syntax

Description
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Static clustering, page 225.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Static clustering

--no_code_motion

Use this option to disable code motion optimizations.

Note: This option has no effect at optimization levels below Medium.

Code motion, page 224.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Code motion

--no_const_align

By default, the compiler uses alignment 4 for objects with a size of 4 bytes or more. Use
this option to make the compiler align const objects based on the alignment of their

type.

For example, a string literal will get alignment 1, because it is an array with elements of
the type const char which has alignment 1. Using this option might save ROM space,
possibly at the expense of processing speed.

Alignment, page 319.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

—--no_cse

Use this option to disable common subexpression elimination.

Note: This option has no effect at optimization levels below Medium.
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See also

--no_exceptions

Syntax

Description

See also

--no_fragments

Syntax

Description

See also
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Common subexpression elimination, page 224.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Common subexpression elimination

--no_exceptions

Use this option to disable exception support in the C++ language. Exception statements
like throw and try—catch, and exception specifications on function definitions will
generate an error message. Exception specifications on function declarations are
ignored. The option is only valid when used together with the --c++ compiler option.

If exceptions are not used in your application, it is recommended to disable support for
them by using this option, because exceptions cause a rather large increase in code size.
Exception handling, page 188.

Project>Options>C/C++ Compiler>Language 1>C++

and

Project>Options>C/C++ Compiler>Language 1>C++ dialect>C++>With
exceptions

--no_fragments

Use this option to disable section fragment handling. Normally, the toolset uses IAR
proprietary information for transferring section fragment information to the linker. The
linker uses this information to remove unused code and data, and thus further minimize
the size of the executable image. When you use this option, this information is not output
in the object files.

Keeping symbols and sections, page 97.

To set this option, use Project>Options>C/C++ Compiler>Extra Options



--no_inline

Syntax
Description

See also

--no_literal_pool

Syntax

Description

See also

--no_loop_align

Syntax

Description

See also
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--no_inline
Use this option to disable function inlining.

Inlining functions, page 71.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Function inlining

--no_literal_pool
Use this option to generate code that should run from a memory region where it is not
allowed to read data, only to execute code.

When this option is used, the compiler will construct addresses and large constants with
the MOv32 pseudo instruction instead of using a literal pool: switch statements are no
longer translated using tables, and constant data is placed in the . rodata section.

This option also affects the automatic library selection performed by the linker. An
IAR-specific ELF attribute is used for determining whether libraries compiled with this
option should be used.

This option is only allowed for ARMv6-M and ARMv7 cores, and can be combined
with the options --ropi or --rwpi only for ARMv7 cores.

--no_literal pool, page 310.

Project>Options>C/C++ Compiler>Code>No data reads in code memory

--no_loop_align

Use this option to disable the 4-byte alignment of labels in loops. This option is only
useful in Thumb2 mode.

In ARM/Thumb1 mode, this option is enabled but does not perform anything.

Alignment, page 319
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--no_mem_idioms

Syntax

Description

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--no_mem_idioms

Use this option to make the compiler not optimize code sequences that clear, set, or copy
amemory region. These memory access patterns (idioms) can otherwise be aggressively
optimized, in some cases using calls to the runtime library. In principle, the
transformation can involve more than a library call.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--no_path_in_file_macros

Syntax

Description

See also

--no_rtti

Syntax

Description

See also
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--no_path_in_file_macros

Use this option to exclude the path from the return value of the predefined preprocessor
symbols __FILE__ and __BASE FILE__.
Description of predefined preprocessor symbols, page 408.

This option is not available in the IDE.

--no_rtti

Use this option to disable the runtime type information (RTTI) support in the C++
language. RTTI statements like dynamic_cast and typeid will generate an error
message. This option is only valid when used together with the --c++ compiler option.
Using C++, page 185.

Project>Options>C/C++ Compiler>Language 1>C++

and

Project>Options>C/C++ Compiler>Language 1>C++ dialect>C++>With RTTI



--no_rw_dynamic_init

Syntax

Description

See also

--no_scheduling

Syntax

Description

See also

--no_Ssize constraints

Syntax

Description

See also
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--no_rw_dynamic_init

Use this option to disable runtime initialization of static C variables.

C source code that is compiled with --ropi or --rwpi cannot have static pointer
variables and constants initialized to addresses of objects that do not have a known
address at link time. To solve this for writable static variables, the compiler generates
code that performs the initialization at program startup (in the same way as dynamic
initialization in C++).

--ropi, page 283 and --rwpi, page 284.

Project>Options>C/C++ Compiler>Code>No dynamic read/write/initialization

--no_scheduling

Use this option to disable the instruction scheduler.

Note: This option has no effect at optimization levels below High.

Instruction scheduling, page 226.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Instruction scheduling

--no_size_constraints

Use this option to relax the normal restrictions for code size expansion when optimizing
for high speed.

Note: This option has no effect unless used with -Ohs.

Speed versus size, page 223.

Project>Options>C/C++ Compiler>Optimizations>Enable transformations>No
size constraints
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--no_static_destruction

Syntax

Description

See also

--no_system_include

Syntax

Description

See also

--no_tbaa

Syntax

Description

See also
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--no_static_destruction
Normally, the compiler emits code to destroy C++ static variables that require
destruction at program exit. Sometimes, such destruction is not needed.

Use this option to suppress the emission of such code.

Setting up the atexit limit, page 98.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--no_system_include

By default, the compiler automatically locates the system include files. Use this option
to disable the automatic search for system include files. In this case, you might need to
set up the search path by using the -1 compiler option.

--dlib_config, page 261, and --system_include_dir, page 286.

Project>Options>C/C++ Compiler>Preprocessor>Ignore standard include
directories

--no_tbaa

Use this option to disable type-based alias analysis.

Note: This option has no effect at optimization levels below High.

Type-based alias analysis, page 225.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Type-based alias analysis
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--no_typedefs_in_diagnostics

Syntax

Description

Example

--no_unaligned_access

Syntax

Description

See also

--no_typedefs_in_diagnostics

Use this option to disable the use of typedef names in diagnostics. Normally, when a
type is mentioned in a message from the compiler, most commonly in a diagnostic
message of some kind, the typedef names that were used in the original declaration are
used whenever they make the resulting text shorter.

typedef int (*MyPtr) (char const *);
MyPtr p = "My text string";
will give an error message like this:

Error[Peldd]: a value of type "char *" cannot be used to
initialize an entity of type "MyPtr"

Ifthe --no_typedefs_in_diagnostics optionis used, the error message will be like
this:

Error[Peldd]: a value of type "char *" cannot be used to
initialize an entity of type "int (*) (char const *)"

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--no_unaligned_access

Use this option to make the compiler avoid unaligned accesses. Data accesses are
usually performed aligned for improved performance. However, some accesses, most
notably when reading from or writing to packed data structures, might be unaligned.
When using this option, all such accesses will be performed using a smaller data size to
avoid any unaligned accesses. This option is only useful for ARMv6 architectures and
higher.

Alignment, page 319.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.
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--no_unroll

Syntax

Description

See also

--no_var_align

Syntax

Description

See also

--no_warnings

Syntax

Description
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--no_unroll

Use this option to disable loop unrolling.

Note: This option has no effect at optimization levels below High.

Loop unrolling, page 224.

Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Loop unrolling

--no_var_align

By default, the compiler uses alignment 4 for variable objects with a size of 4 bytes or
more. Use this option to make the compiler align variable objects based on the alignment
of their type.

For example, a char array will get alignment 1, because its elements of the type char
have alignment 1. Using this option might save RAM space, possibly at the expense of
processing speed.

Alignment, page 319 and --no_const_align, page 271.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--no_warnings

By default, the compiler issues warning messages. Use this option to disable all warning
messages.

This option is not available in the IDE.



--no_wrap_diagnostics

Syntax

Description

Syntax

Parameters

Description

See also
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--no_wrap_diagnostics

By default, long lines in diagnostic messages are broken into several lines to make the
message easier to read. Use this option to disable line wrapping of diagnostic messages.

This option is not available in the IDE.

-0[n|1l|m|h|hs|hz]

n None* (Best debug support)
1 (default) Low*

m Medium

h High, balanced

hs High, favoring speed

hz High, favoring size

*The most important difference between None and Low is that at None, all non-static
variables will live during their entire scope.

Use this option to set the optimization level to be used by the compiler when optimizing
the code. If no optimization option is specified, the optimization level is used by default.
If only -0 is used without any parameter, the optimization level High balanced is used.

A low level of optimization makes it relatively easy to follow the program flow in the
debugger, and, conversely, a high level of optimization makes it relatively hard.

Controlling compiler optimizations, page 220.

Project>Options>C/C++ Compiler>Optimizations
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--only_stdout

Syntax

Description

--output, -o

Syntax

Parameters

Description

--predef_macros

Syntax
Parameters

Description
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--only_stdout
Use this option to make the compiler use the standard output stream (stdout) also for
messages that are normally directed to the error output stream (stderr).

This option is not available in the IDE.

--output {filename|directory}
-o {filename|directory}

See Rules for specifying a filename or directory as parameters, page 246.

By default, the object code output produced by the compiler is located in a file with the
same name as the source file, but with the extension o. Use this option to explicitly
specify a different output filename for the object code output.

This option is not available in the IDE.

--predef_macros {filename | directory}
See Rules for specifying a filename or directory as parameters, page 246.
Use this option to list the predefined symbols. When using this option, make sure to also

use the same options as for the rest of your project.

If a filename is specified, the compiler stores the output in that file. If a directory is
specified, the compiler stores the output in that directory, in a file with the predef
filename extension.

Note that this option requires that you specify a source file on the command line.

This option is not available in the IDE.



--preinclude

Syntax
Parameters

Description

--preprocess

Syntax

Parameters

Description

--public_equ

Syntax

Parameters

Description
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--preinclude includefile
See Rules for specifying a filename or directory as parameters, page 246.

Use this option to make the compiler read the specified include file before it starts to
read the source file. This is useful if you want to change something in the source code
for the entire application, for instance if you want to define a new symbol.

Project>Options>C/C++ Compiler>Preprocessor>Preinclude file

--preprocess[=[c][n][1]] {filename|directory}
c Preserve comments

n Preprocess only

1 Generate #1ine directives

See also Rules for specifying a filename or directory as parameters, page 246.

Use this option to generate preprocessed output to a named file.

Project>Options>C/C++ Compiler>Preprocessor>Preprocessor output to file

--public_equ symboll[=value]

symbol The name of the assembler symbol to be defined

value An optional value of the defined assembler symbol

This option is equivalent to defining a label in assembler language using the EQU
directive and exporting it using the PUBLIC directive. This option can be used more than
once on the command line.
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This option is not available in the IDE.

--relaxed_fp

Syntax --relaxed_fp

Description Use this option to allow the compiler to relax the language rules and perform more
aggressive optimization of floating-point expressions. This option improves
performance for floating-point expressions that fulfill these conditions:

o The expression consists of both single- and double-precision values

o The double-precision values can be converted to single precision without loss of
accuracy

o The result of the expression is converted to single precision.

Note that performing the calculation in single precision instead of double precision
might cause a loss of accuracy.

Example float F(float a, float b)
{
return a + b * 3.0;

}

The C standard states that 3 . 0 in this example has the type double and therefore the
whole expression should be evaluated in double precision. However, when the
--relaxed_f£p optionis used, 3.0 will be converted to £1oat and the whole expression
can be evaluated in £loat precision.

To set related options, choose:

Project>Options>C/C++ Compiler>Language 2>Floating-point semantics

--remarks
Syntax --remarks
Description The least severe diagnostic messages are called remarks. A remark indicates a source
code construct that may cause strange behavior in the generated code. By default, the
compiler does not generate remarks. Use this option to make the compiler generate
remarks.
See also Severity levels, page 241.
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--require_prototypes

Syntax

Description

--ropi
Syntax

Description

See also
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Project>Options>C/C++ Compiler>Diagnostics>Enable remarks

--require_prototypes

Use this option to force the compiler to verify that all functions have proper prototypes.
Using this option means that code containing any of the following will generate an error:

e A function call of a function with no declaration, or with a Kernighan & Ritchie
C declaration

o A function definition of a public function with no previous prototype declaration

e An indirect function call through a function pointer with a type that does not include
a prototype.

Project>Options>C/C++ Compiler>Language 1>Require prototypes

--ropi

Use this option to make the compiler generate code that uses pc-relative references to
address code and read-only data.

When this option is used, these limitations apply:

o C++ constructions cannot be used
o The object attribute __ramfunc cannot be used

e Pointer constants cannot be initialized with the address of another constant, a string
literal, or a function. However, writable variables can be initialized to constant
addresses at runtime.

--no_rw_dynamic_init, page 275, and Description of predefined preprocessor symbols,
page 408.

Project>Options>C/C++ Compiler>Code>Code and read-only data (ropi)
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--rwpi
Syntax

Description

See also

--section

Syntax

Description

Example

See also
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--rwpi

Use this option to make the compiler generate code that uses the offset from the static
base register (R9) to address-writable data.

When this option is used, these limitations apply:

o The object attribute __ramfunc cannot be used

e Pointer constants cannot be initialized with the address of a writable variable.
However, static writable variables can be initialized to writable addresses at
runtime.

--no_rw_dynamic_init, page 275, and Description of predefined preprocessor symbols,
page 408.
Project>Options>C/C++ Compiler>Code>Read/write data (rwpi)

--section OldName=NewName

The compiler places functions and data objects into named sections which are referred
to by the IAR ILINK Linker. Use this option to change the name of the section 01dName
to NewName.

This is useful if you want to place your code or data in different address ranges and you
find the @ notation, alternatively the #pragma location directive, insufficient. Note
that any changes to the section names require corresponding modifications in the linker
configuration file.

To place functions in the section MyText, use:

--section .text=MyText

Controlling data and function placement in memory, page 216.

Project>Options>C/C++ Compiler>Output>Code section name



Compiler options _¢

--separate_cluster_for_initialized_variables

Syntax --separate_cluster_for_initialized_variables

Description Use this option to separate initialized and non-initialized variables when using variable
clustering. This might reduce the number of bytes in the ROM area which are needed
for data initialization, but it might lead to larger code.

This option can be useful if you want to have your own data initialization routine, but
want the IAR tools to arrange for the zero-initialized variables.
See also Manual initialization, page 99 and initialize directive, page 434.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--silent
Syntax --silent
Description By default, the compiler issues introductory messages and a final statistics report. Use
this option to make the compiler operate without sending these messages to the standard
output stream (normally the screen).
This option does not affect the display of error and warning messages.
This option is not available in the IDE.
--strict
Syntax --strict
Description By default, the compiler accepts a relaxed superset of Standard C and C++. Use this
option to ensure that the source code of your application instead conforms to strict
Standard C and C++.
Note: The -e option and the --strict option cannot be used at the same time.
See also Enabling language extensions, page 177.

Project>Options>C/C++ Compiler>Language 1>Language conformance>Strict
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--system_include_dir

Syntax

Parameters

Description

See also

--thumb

Syntax

Description

See also

--use_c++_inline

Syntax

Description

See also
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--system_include_dir path

path The path to the system include files, see Rules for specifying
a filename or directory as parameters, page 246.

By default, the compiler automatically locates the system include files. Use this option
to explicitly specify a different path to the system include files. This might be useful if
you have not installed IAR Embedded Workbench in the default location.
--dlib_config, page 261, and --no_system_include, page 276.

This option is not available in the IDE.

--thumb

Use this option to set default function mode to Thumb. This setting must be the same for
all files included in a program, unless they are interworking.

Note: This option has the same effect as the --cpu_mode=thumb option.

--interwork, page 267 and __interwork, page 338.

Project>Options>C/C++ Compiler>Code>Processor mode>Thumb

--use_c++_inline

Standard C uses slightly different semantics for the inline keyword than C++ does.
Use this option if you want C++ semantics when you are using C.
Inlining functions, page 71

Project>Options>C/C++ Compiler>Language 1>C dialect>C99>C++ inline
semantics
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--use_unix_directory_separators

Syntax --use_unix_directory_separators
Description Use this option to make DWARF debug information use / (instead of \) as directory
separators in file paths.

This option can be useful if you have a debugger that requires directory separators in
UNIX style.

To set this option, use Project>Options>C/C++ Compiler>Extra Options.

--vectorize
Syntax --vectorize
Description Use this option to enable generation of NEON vector instructions.
Loops will only be vectorized if the target processor has NEON capability and the
optimization level is -Ohs.
Project>Options>C/C++ Compiler>Optimizations>Enable
transformations>Vectorize
--vla
Syntax --vla
Description Use this option to enable support for C99 variable length arrays. Such arrays are located
on the heap. This option requires Standard C and cannot be used together with the
--c89 compiler option.
Note: --v1a should not be used together with the 1ongjmp library function, as that can
lead to memory leakages.
See also C language overview, page 175.

Project>Options>C/C++ Compiler>Language 1>C dialect>Allow VLA
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--warn_about_c_style_casts

Syntax

Description

--warn_about_c_style_casts

Use this option to make the compiler warn when C-style casts are used in C++ source
code.

This option is not available in the IDE.

--warnings_affect_exit_code

Syntax

Description

--warnings_are_errors

Syntax

Description

See also
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--warnings_affect_exit_code
By default, the exit code is not affected by warnings, because only errors produce a
non-zero exit code. With this option, warnings will also generate a non-zero exit code.

This option is not available in the IDE.

--warnings_are_errors

Use this option to make the compiler treat all warnings as errors. If the compiler
encounters an error, no object code is generated. Warnings that have been changed into
remarks are not treated as errors.

Note: Any diagnostic messages that have been reclassified as warnings by the option
--diag_warning or the #pragma diag_warning directive will also be treated as
errors when --warnings_are_errors is used.

--diag_warning, page 259.

Project>Options>C/C++ Compiler>Diagnostics>Treat all warnings as errors



Linker options

e Summary of linker options
e Descriptions of linker options

For general syntax rules, see Options syntax, page 245.

Summary of linker options

This table summarizes the linker options:

Command line option Description

--advanced_heap Uses an advanced heap

--basic_heap Uses a basic heap

--BE8 Uses the big-endian format BE8

--BE32 Uses the big-endian format BE32

--bounds_table_size Specifies the size of the global bounds table. See
the C-RUN documentation in the C-SPY®
Debugging Guide for ARM.

--call_graph Produces a call graph file in XML format

--config Specifies the linker configuration file to be used by
the linker

--config_def Defines symbols for the configuration file

--config_search Specifies more directories to search for linker

configuration files

--cpp_init_routine Specifies a user-defined C++ dynamic initialization
routine

--cpu Specifies a processor variant

--debug_heap Uses the checked heap. See the C-RUN
documentation in the C-SPY® Debugging Guide for
ARM.

--define_symbol Defines symbols that can be used by the
application

--dependencies Lists file dependencies

--diag_error Treats these message tags as errors

Table 29: Linker options summary
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Command line option

Description

--diag_remark
--diag_suppress
--diag_warning
--diagnostics_tables
--enable_hardware_workaround
--enable_stack_usage

--entry

-—error_limit

--exception_tables
--export_builtin_config

--extra_init

-f
--force_exceptions
--force_output

--ignore_uninstrumented_point
ers

--image_input

--inline

--keep

--log

--log_file
--mangled_names_in_messages
--map
--merge_duplicate_sections

--misrac

Treats these message tags as remarks
Suppresses these diagnostic messages
Treats these message tags as warnings
Lists all diagnostic messages

Enables specified hardware workaround
Enables stack usage analysis

Treats the symbol as a root symbol and as the
start of the application

Specifies the allowed number of errors before
linking stops

Generates exception tables for C code
Produces an icf file for the default configuration

Specifies an extra initialization routine that will be
called if it is defined.

Extends the command line
Always includes exception runtime code
Produces an output file even if errors occurred

Disables checking of accessing via pointers in
memory for which no bounds have been set. See
the C-RUN documentation in the C-SPY®
Debugging Guide for ARM.

Puts an image file in a section

Inlines small routines

Forces a symbol to be included in the application
Enables log output for selected topics

Directs the log to a file

Adds mangled names in messages

Produces a map file

Merges equivalent read-only sections

Enables error messages specific to MISRA-C:1998.
This option is a synonym to --misrac1998 and
is only available for backwards compatibility.

Table 29: Linker options summary (Continued)
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Command line option Description

--misracl998 Enables error messages specific to MISRA-C:1998.
See the IAR Embedded Workbench® MISRA C:1998
Reference Guide.

--misrac2004 Enables error messages specific to MISRA-C:2004.
See the IAR Embedded Workbench® MISRA C:2004
Reference Guide.

--misrac_verbose Enables verbose logging of MISRA C checking. See
the IAR Embedded Workbench® MISRA C:1998
Reference Guide and the IAR Embedded
Workbench® MISRA C:2004 Reference Guid.

--no_dynamic_rtti_elimination Includes dynamic runtime type information even
when it is not needed.

--no_exceptions Generates an error if exceptions are used
--no_fragments Disables section fragment handling
--no_library_search Disables automatic runtime library search
--no_literal_pool Generates code that should run from a memory

region where it is not allowed to read data, only to
execute code

--no_Jlocals Removes local symbols from the ELF executable
image.

--no_range_reservations Disables range reservations for absolute symbols

--no_remove Disables removal of unused sections

--no_veneers Disables generation of veneers

--no_vfe Disables Virtual Function Elimination

--no_warnings Disables generation of warnings

--no_wrap_diagnostics Does not wrap long lines in diagnostic messages

-0 Sets the object filename. Alias for --output.

--only_stdout Uses standard output only

--output Sets the object filename

--pi_veneers Generates position independent veneers.

--place_holder Reserve a place in ROM to be filled by some other
tool, for example a checksum calculated by
ielftool.

--redirect Redirects a reference to a symbol to another
symbol

Table 29: Linker options summary (Continued)
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Command line option Description

--remarks Enables remarks

--search Specifies more directories to search for object and
library files

--semihosting Links with debug interface

--silent Sets silent operation

--skip_dynamic_initialization Suppresses dynamic initialization during system

startup
--stack_usage_control Specifies a stack usage control file
--strip Removes debug information from the executable
image
--threaded_1lib Configures the runtime library for use with
threads
--vfe Controls Virtual Function Elimination
--warnings_affect_exit_code Warnings affects exit code
--warnings_are_errors Warnings are treated as errors
--whole_archive Treats every object file in the archive as if it was

specified on the command line.

Table 29: Linker options summary (Continued)

Descriptions of linker options

--advanced_heap

Syntax
Description

See also

IAR C/C++ Development Guide
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A

The following section gives detailed reference information about each linker option.

Note that if you use the options page Extra Options to specify specific command line
options, the IDE does not perform an instant check for consistency problems like
conflicting options, duplication of options, or use of irrelevant options.

--advanced_heap
Use this option to use an advanced heap.

Advanced versus basic heap, page 199

To set this option, use Project>Options>Linker>Extra Options.



--basic_heap

Syntax
Description

See also

--BE8

Syntax

Description

See also

--BE32

Syntax

Description

See also
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--basic_heap
Use this option to use a basic heap.

Advanced versus basic heap, page 199

To set this option, use Project>Options>Linker>Extra Options.

--BES

Use this option to specify the Byte Invariant Addressing mode.

This means that the linker reverses the byte order of the instructions, resulting in
little-endian code and big-endian data. This is the default byte addressing mode for
ARMV6 big-endian images. This is the only mode available for ARM v6M and ARM
v7 with big-endian images.

Byte Invariant Addressing mode is only available on ARM processors that support
ARMv6, ARM v6M, and ARM v7.
Byte order, page 56, Byte order, page 320, --BE32, page 293, and --endian, page 264.

Project>Options>General Options>Target>Endian mode

--BE32

Use this option to specify the legacy big-endian mode.

This produces big-endian code and data. This is the only byte-addressing mode for all
big-endian images prior to ARMv6. This mode is also available for ARM v6 with
big-endian, but not for ARM v6M or ARM v7.

Byte order, page 56, Byte order, page 320, --BES, page 293, and --endian, page 264.

Project>Options>General Options>Target>Endian mode
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--call_graph

Syntax
Parameters

Description

See also

--config

Syntax
Parameters

Description

See also

--config_def

Syntax

Parameters

Description
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--call_graph {filename|directory}
See Rules for specifying a filename or directory as parameters, page 246.

Use this option to produce a call graph file. If no filename extension is specified, the
extension cgx is used. This option can only be used once on the command line.

Using this option enables stack usage analysis in the linker.

Stack usage analysis, page 85
Project>Options>Linker>Advanced>Call graph output (XML)

--config filename

See Rules for specifying a filename or directory as parameters, page 246.

Use this option to specify the configuration file to be used by the linker (the default
filename extension is ic£). If no configuration file is specified, a default configuration

is used. This option can only be used once on the command line.

The chapter The linker configuration file.

Project>Options>Linker>Config>Linker configuration file

--config_def symbol=constant_value

symbol The name of the symbol to be used in the configuration file.

constant_value The constant value of the configuration symbol.

Use this option to define a constant configuration symbol to be used in the configuration
file. This option has the same effect as the define symbol directive in the linker
configuration file. This option can be used more than once on the command line.



See also

--config_search

Syntax

Parameters

Description

See also

--cpp_init_routine

Syntax

Parameters

Description
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--define_symbol, page 297 and Interaction between ILINK and the application, page
102.

Project>Options>Linker>Config>Defined symbols for configuration file

--config_search path

path A path to a directory where the linker should search for
linker configuration include files.

Use this option to specify more directories to search for files when processing an
include directive in a linker configuration file.

By default, the linker searches for configuration include files only in the system
configuration directory. To specify more than one search directory, use this option for
each path.

include directive, page 449.

To set this option, use Project>Options>Linker>Extra Options.

--cpp_init_routine routine

routine A user-defined C++ dynamic initialization routine.

When using the IAR C/C++ compiler and the standard library, C++ dynamic
initialization is handled automatically. In other cases you might need to use this option.

If any sections with the section type INIT_ARRAY or PREINIT_ARRAY are included in
your application, the C++ dynamic initialization routine is considered to be needed. By
default, this routine is named __iar_cstart_call_ctors and is called by the startup
code in the standard library. Use this option if you are not using the standard library and
require another routine to handle these section types.
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--cpu
Syntax

Parameters

Description

See also

To set this option, use Project>Options>Linker>Extra Options.

——Cpu=core

core Specifies a specific processor variant

Use this option to select the processor variant to link your application for. The default is
to use a processor or architecture compatible with the object file attributes.

--cpu, page 254

Project>Options>General Options>Target>Processor configuration

--default_to_complex_ranges

Syntax

Description

See also
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--default_to_complex_ranges

Normally, if initialize directivesin alinker configuration file do not specify simple
ranges Or complex ranges, the linker uses simple ranges if the associated
section placement directives use single range regions.

Use this option to make the linker always use complex ranges by default. This was
the behavior of the linker before the introduction of simple ranges and complex
ranges.

initialize directive, page 434.

Project>Options>Linker>Extra Options



--define_symbol

Syntax

Parameters

Description

See also

--dependencies

Syntax

Parameters

Description

Example
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--define_symbol symbol=constant_value

symbol The name of the constant symbol that can be used by the
application.

constant_value The constant value of the symbol.

Use this option to define a constant symbol, that is a label, that can be used by your
application. This option can be used more than once on the command line. Note that his
option is different from the define symbol directive.

--config_def, page 294 and Interaction between ILINK and the application, page 102.
Project>Options>Linker>#define>Defined symbols

--dependencies[=[i|m]] {filename|directory}

i (default) Lists only the names of files

m Lists in makefile style

See also Rules for specifying a filename or directory as parameters, page 246.

Use this option to make the linker list the names of the linker configuration, object, and
library files opened for input into a file with the default filename extension i.

If --dependencies or --dependencies=i is used, the name of each opened input
file, including the full path, if available, is output on a separate line. For example:

c:\myproject\foo.o
d:\myproject\bar.o

If --dependencies=m is used, the output is in makefile style. For each input file, one
line containing a makefile dependency rule is produced. Each line consists of the name
of the output file, a colon, a space, and the name of an input file. For example:

a.out: c:\myproject\foo.o
a.out: d:\myproject\bar.o
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--diag_error

Syntax

Parameters

Description

--diag_remark

Syntax

Parameters

Description
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This option is not available in the IDE.

--diag_error=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pell7

Use this option to reclassify certain diagnostic messages as errors. An error indicates a
problem of such severity that an executable image will not be generated. The exit code
will be non-zero. This option may be used more than once on the command line.

Project>Options>Linker>Diagnostics>Treat these as errors

--diag_remark=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel77

Use this option to reclassify certain diagnostic messages as remarks. A remark is the
least severe type of diagnostic message and indicates a construction that may cause
strange behavior in the executable image. This option may be used more than once on
the command line.

Note: By default, remarks are not displayed; use the - -remarks option to display them.

Project>Options>Linker>Diagnostics>Treat these as remarks



--diag_suppress

Syntax

Parameters

Description

--diag_warning
Syntax

Parameters

Description

--diagnostics_tables

Syntax
Parameters

Description
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--diag_suppress=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pell7

Use this option to suppress certain diagnostic messages. These messages will not be
displayed. This option may be used more than once on the command line.

Project>Options>Linker>Diagnostics>Suppress these diagnostics

--diag_warning=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pe826

Use this option to reclassify certain diagnostic messages as warnings. A warning
indicates an error or omission that is of concern, but which will not cause the linker to
stop before linking is completed. This option may be used more than once on the
command line.

Project>Options>Linker>Diagnostics>Treat these as warnings

--diagnostics_tables {filename | directory}
See Rules for specifying a filename or directory as parameters, page 246.
Use this option to list all possible diagnostic messages in a named file. This can be

convenient, for example, if you have used a pragma directive to suppress or change the
severity level of any diagnostic messages, but forgot to document why.

This option cannot be given together with other options.
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This option is not available in the IDE.

--enable_hardware_workaround

Syntax --enable_hardware_workaround=waid[waid[...]]

Parameters
waid The ID number of the workaround that you want to

enable. For a list of available workarounds, see the release
notes available in the Information Center.

Description Use this option to make the linker generate a workaround for a specific hardware
problem.
See also The release notes for the linker for a list of available parameters.

To set this option, use Project>Options>Linker>Extra Options.

--enable_stack_usage

Syntax --enable_stack_usage

Description Use this option to enable stack usage analysis. If a linker map file is produced, a stack
usage chapter is included in the map file.
Note: If you use at least one of the --stack_usage_control or --call_graph
options, stack usage analysis is automatically enabled.

See also Stack usage analysis, page 85

Project>Options>Linker>Advanced>Enable stack usage analysis

IAR C/C++ Development Guide
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--entry
Syntax -—entry symbol
Parameters
symbol The name of the symbol to be treated as a root symbol and
start label
Description Use this option to make a symbol be treated as a root symbol and the start label of the

application. This is useful for loaders. If this option is not used, the default start symbol
is__iar_program_start. A root symbol is kept whether or not it is referenced from
the rest of the application, provided its module is included. A module in an object file is
always included but a module part of a library is only included if needed.

Note: The label referred to must be available in your application. You must also make
sure that the reset vector refers to the new start label (for example --redirect
__iar_program_start=_myStartLabel).

Project>Options>Linker>Library>Override default program entry

--error_limit

Syntax --—error_limit=n
Parameters
n The number of errors before the linker stops linking. n must
be a positive integer; 0 indicates no limit.
Description Use the --error_1limit option to specify the number of errors allowed before the

linker stops the linking. By default, 100 errors are allowed.

This option is not available in the IDE.
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--exception_tables

Syntax

Parameters

Description

See also

--export_builtin_config

Syntax
Parameters

Description
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--exception_tables={nocreate|unwind|cantunwind}

nocreate (default) Does not generate entries. Uses the least amount of memory,
but the result is undefined if an exception is propagated
through a function without exception information.

unwind Generates unwind entries that enable an exception to be
correctly propagated through functions without exception
information.

cantunwind Generates no-unwind entries so that any attempt to

propagate an exception through the function will result in a
call to terminate.

Use this option to determine what the linker should do with functions that do not have
exception information but which do have correct call frame information.

The compiler ensures that C functions get correct call frame information. For functions
written in assembler language you need to use assembler directives to generate call
frame information.

Using C++, page 185.

To set this option, use Project>Options>Linker>Extra Options.

--export_builtin_config filename
See Rules for specifying a filename or directory as parameters, page 246.

Exports the configuration used by default to a file.

This option is not available in the IDE.



--extra_init

Syntax

Parameters

Description

Syntax
Parameters

Description

--force_exceptions

Syntax

Description
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--extra_init routine

routine A user-defined initialization routine.

Use this option to make the linker add an entry for the specified routine at the end of the
initialization table. The routine will be called during system startup, after other
initialization routines have been called and before main is called. Note that the routine
must preserve the value passed to it in register R0. No entry is added if the routine is not
defined.

To set this option, use Project>Options>Linker>Extra Options.

-f filename
See Rules for specifying a filename or directory as parameters, page 246.
Use this option to make the linker read command line options from the named file, with

the default filename extension xc1.

In the command file, you format the items exactly as if they were on the command line
itself, except that you may use multiple lines, because the newline character acts just as
a space or tab character.

Both C and C++ style comments are allowed in the file. Double quotes behave in the
same way as in the Microsoft Windows command line environment.

To set this option, use Project>Options>Linker>Extra Options.

--force_exceptions

Use this option to make the linker include exception tables and exception code even
when the linker heuristics indicate that exceptions are not used.

The linker considers exceptions to be used if there is a throw expression that is not a
rethrow in the included code. If there is no such throw expression in the rest of the
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See also

--force_output

Syntax

Description

--image_input
Syntax

Parameters

Description
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code, the linker arranges for operator new, dynamic_cast, and typeid to call
abort instead of throwing an exception on failure. If you need to catch exceptions from
these constructs but your code contains no other throws, you might need to use this
option.

Using C++, page 185.

Project>Options>Linker>Optimizations>C++ Exceptions>Allow>Always include

--force_output

Use this option to produce an output executable image regardless of any linking errors.

To set this option, use Project>Options>Linker>Extra Options

--image_input filename [, symbol, [section[,alignment]]]

filename The pure binary file containing the raw image you want to
link

symbol The symbol which the binary data can be referenced with.

section The section where the binary data will be placed; default is
.text.

alignment The alignment of the section; default is 1.

Use this option to link pure binary files in addition to the ordinary input files. The file’s
entire contents are placed in the section, which means it can only contain pure binary
data.

Note: Just as for sections from object files, sections created by using the
--image_input option are not included unless actually needed. You can either specify
a symbol in the option and reference this symbol in your application (or by use of a
--keep option), or you can specify a section name and use the keep directive in a linker
configuration file to ensure that the section is included.



Example

See also

Description

--keep

Syntax

Parameters

Description
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--image_input bootstrap.abs,Bootstrap, CSTARTUPCODE, 4

The contents of the pure binary file bootstrap.abs are placed in the section
CSTARTUPCODE. The section where the contents are placed is 4-byte aligned and will
only be included if your application (or the command line option --keep) includes a
reference to the symbol Bootstrap.

--keep, page 305.

Project>Options>Linker>Input>Raw binary image

--inline
Some routines are so small that they can fit in the space of the instruction that calls the

routine. Use this option to make the linker replace the call of a routine with the body of
the routine, where applicable.

Project>Options>Linker>Optimizations>Inline small routines

--keep symbol

symbol The name of the symbol to be treated as a root symbol
Normally, the linker keeps a symbol only if it is needed by your application. Use this

option to make a symbol always be included in the final application.

Project>Options>Linker>Input>Keep symbols
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--log

Syntax

Parameters

Description

See also

--log_file

Syntax
Parameters

Description
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--log topicl, topic,...]

topic can be one of:

call_graph Lists the call graph as seen by stack usage analysis.

initialization Lists copy batches and the compression selected for each
batch.

libraries Lists all decisions taken by the automatic library selector.

This might include extra symbols needed (--keep),
redirections (--redirect), as well as which runtime
libraries that were selected.

modules Lists each module that is selected for inclusion in the
application, and which symbol that caused it to be included.

redirects Lists redirected symbols.

sections Lists each symbol and section fragment that is selected for
inclusion in the application, and the dependence that caused
it to be included.

unused_fragments Lists those section fragments that were not included in the
application.
veeners Lists some veneer creation and usage statistics.

Use this option to make the linker log information to stdout. The log information can
be useful for understanding why an executable image became the way it is.

--log _file, page 306.

Project>Options>Linker>List>Generate log

--log_file filename
See Rules for specifying a filename or directory as parameters, page 246.

Use this option to direct the log output to the specified file.



See also
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--log, page 306.

Project>Options>Linker>List>Generate log

--mangled_names_in_messages

Syntax

Description

--map

Syntax

Description

--mangled_names_in_messages

Use this option to produce both mangled and unmangled names for C/C++ symbols in
messages. Mangling is a technique used for mapping a complex C name or a C++ name
(for example, for overloading) into a simple name. For example, void h(int, char)
becomes _Zlhic.

This option is not available in the IDE.

--map {filename|directory}

Use this option to produce a linker memory map file. The map file has the default
filename extension map. The map file contains:

Linking summary in the map file header which lists the version of the linker, the
current date and time, and the command line that was used.

o Runtime attribute summary which lists runtime attributes.

o Placement summary which lists each section/block in address order, sorted by

placement directives.

Initialization table layout which lists the data ranges, packing methods, and
compression ratios.

Module summary which lists contributions from each module to the image, sorted
by directory and library.

Entry list which lists all public and some local symbols in alphabetical order,
indicating which module they came from.

Some of the bytes might be reported as shared.

Shared objects are functions or data objects that are shared between modules. If any
of these occur in more than one module, only one copy is retained. For example, in
some cases inline functions are not inlined, which means that they are marked as
shared, because only one instance of each function will be included in the final
application. This mechanism is sometimes also used for compiler-generated code or
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data not directly associated with a particular function or variable, and when only one
instance is required in the final application.

This option can only be used once on the command line.

Project>Options>Linker>List>Generate linker map file

--merge_duplicate_sections

Syntax --merge_duplicate_sections

Description Use this option to keep only one copy of equivalent read-only sections. Note that this
can cause different functions or constants to have the same address, so an application
that depends on the addresses being different will not work correctly with this option
enabled.

Project>Options>Linker>Optimizations>Merge duplicate sections

--no_dynamic_rtti_elimination

Syntax --no_dynamic_rtti_elimination

Description Use this option to make the linker include dynamic (polymorphic) runtime type
information (RTTI) data in the application image even when the linker heuristics
indicate that it is not needed.

The linker considers dynamic runtime type information to be needed if there is a
typeid or dynamic_cast expression for a polymorphic type in the included code. By
default, if the linker detects no such expression, RTTI data will not be included just to
make dynamic RTTI requests work.

Note: A typeid expression for a non-polymorphic type results in a direct reference to
a particular RTTI object and will not cause the linker to include any potentially
unneeded objects.

See also Using C++, page 185.

To set this option, use Project>Options>Linker>Extra Options.
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--no_exceptions

Syntax

Description

See also

--no_fragments

Syntax

Description

See also

--no_library_search

Syntax

Description

Linker options °

--no_exceptions

Use this option to make the linker generate an error if there is a throw in the included
code. This option is useful for making sure that your application does not use
exceptions.

Using C++, page 185.

To set related options, choose:

Project>Options>Linker>Optimizations>Allow C++ exceptions

--no_fragments

Use this option to disable section fragment handling. Normally, the toolset uses IAR
proprietary information for transferring section fragment information to the linker. The
linker uses this information to remove unused code and data, and thus further minimize
the size of the executable image. Use this option to disable the removal of fragments of
sections, instead including or not including each section in its entirety, usually resulting
in a larger application.

Keeping symbols and sections, page 97.

To set this option, use Project>Options>Linker>Extra Options

--no_library_ search

Use this option to disable the automatic runtime library search. This option turns off the
automatic inclusion of the correct standard libraries. This is useful, for example, if the
application needs a user-built standard library, etc.

Note that the option disables all steps of the automatic library selection, some of which
might need to be reproduced if you are using the standard libraries. Use the

--log libraries linker option together with automatic library selection enabled to
determine which the steps are.
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--no_literal_pool

Syntax

Description

See also

--no_locals

Syntax

Description

Project>Options>Linker>Library>Automatic runtime library selection

--no_literal_pool
Use this option for code that should run from a memory region where it is not allowed
to read data, only to execute code.

When this option is used, the linker will use the MOV32 pseudo instruction in a
mode-changing veneer, to avoid using the data bus to load the destination address. The
option also means that libraries compiled with this option will be used.

The option --no_literal_pool is only allowed for ARMv7-M cores.

--no_literal _pool, page 273.

To set this option, use Project>Options>Linker>Extra Options.

--no_locals

Use this option to remove local symbols from the ELF executable image.

Note: This option does not remove any local symbols from the DWARF information in
the executable image.

Project>Options>Linker>QOutput

--no_range_reservations

Syntax

Description
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--no_range_reservations
Normally, the linker reserves any ranges used by absolute symbols with a non-zero size,
excluding them from consideration for place in commands.

When this option is used, these reservations are disabled, and the linker is free to place
sections in such a way as to overlap the extent of absolute symbols.



=--NOo_remove

Syntax

Description

See also

=-=-No_veneers

Syntax

Description

See also

--no_vfe

Syntax

Description

See also

Linker options °

To set this option, use Project>Options>Linker>Extra Options.

——no_remove

When this option is used, unused sections are not removed. In other words, each module
that is included in the executable image contains all its original sections.
Keeping symbols and sections, page 97.

To set this option, use Project>Options>Linker>Extra Options.

——no_veneers

Use this option to disable the insertion of veneers even though the executable image
needs it. In this case, the linker will generate a relocation error for each reference that
needs a veneer.

Veneers, page 103.

To set this option, use Project>Options>Linker>Extra Options.

--no_vfe

Use this option to disable the Virtual Function Elimination optimization. All virtual
functions in all classes with at least one instance will be kept, and Runtime Type
Information data will be kept for all polymorphic classes. Also, no warning message will
be issued for modules that lack VFE information.

--vfe, page 317 and Virtual function elimination, page 208.

To set related options, choose:

Project>Options>Linker>Optimizations>PerformC++ Virtual Function
Elimination
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--no_warnings

Syntax

Description

--no_wrap_diagnostics

Syntax

Description

--only_stdout

Syntax

Description

--output, -o

Syntax

Parameters

Description
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--no_warnings
By default, the linker issues warning messages. Use this option to disable all warning
messages.

This option is not available in the IDE.

--no_wrap_diagnostics
By default, long lines in diagnostic messages are broken into several lines to make the
message easier to read. Use this option to disable line wrapping of diagnostic messages.

This option is not available in the IDE.

--only_stdout
Use this option to make the linker use the standard output stream (stdout) also for
messages that are normally directed to the error output stream (stderr).

This option is not available in the IDE.

--output {filename|directory}
-0 {filename|directory}

See Rules for specifying a filename or directory as parameters, page 246.

By default, the object executable image produced by the linker is located in a file with
the name a . out. Use this option to explicitly specify a different output filename, which
by default will have the filename extension out.

Project>Options>Linker>Output>Output file
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--pi_veneers

Syntax --pi_veneers

Description Use this option to make the linker generate position-independent veneers. Note that this
type of veneer is larger and slower than normal veneers.

See also Veneers, page 103.

To set this option, use Project>Options>Linker>Extra Options.

--place_holder

Syntax --place_holder symbol[,sizel,section|,alignment]]]
Parameters
symbol The name of the symbol to create
size Size in ROM; by default 4 bytes
section Section name to use; by default . text
alignment Alignment of section; by default 1
Description Use this option to reserve a place in ROM to be filled by some other tool, for example a

checksum calculated by ielftool. Each use of this linker option results in a section
with the specified name, size, and alignment. The symbol can be used by your
application to refer to the section.

Note: Like any other section, sections created by the --place_holder option will only
be included in your application if the section appears to be needed. The --keep linker
option, or the keep linker directive can be used for forcing such section to be included.

See also IAR utilities, page 465.

To set this option, use Project>Options>Linker>Extra Options

--redirect

Syntax --redirect from symbol=to_symbol
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Parameters

Description

--remarks

Syntax

Description

See also

--search

Syntax

Parameters

Description

See also
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from_symbol The name of the source symbol

to_symbol The name of the destination symbol

Use this option to change references to an external symbol so that they refer to another
symbol.

Note: Redirection will normally not affect references within a module.

To set this option, use Project>Options>Linker>Extra Options

--remarks

The least severe diagnostic messages are called remarks. A remark indicates a source
code construct that may cause strange behavior in the generated code. By default, the
linker does not generate remarks. Use this option to make the linker generate remarks.

Severity levels, page 241.

Project>Options>Linker>Diagnostics>Enable remarks

--search path

path A path to a directory where the linker should search for
object and library files.

Use this option to specify more directories for the linker to search for object and library
files in.

By default, the linker searches for object and library files only in the working directory.
Each use of this option on the command line adds another search directory.
The linking process, page 48.

This option is not available in the IDE.



--semihosting

Syntax

Parameters

Description

See also

--silent

Syntax

Description
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--semihosting[=iar_breakpoint]

iar_breakpoint The IAR-specific mechanism can be used when
debugging applications that use SWI/SVC extensively.

Use this option to include the debug interface—breakpoint mechanism—in the output
image. If no parameter is specified, the SWI/SVC mechanism is included for
ARM7/9/11, and the BKPT mechanism is included for Cortex-M.

The semihosting mechanism, page 123.

Project>Options>General Options>Library Configuration>Semihosted

--silent

By default, the linker issues introductory messages and a final statistics report. Use this
option to make the linker operate without sending these messages to the standard output
stream (normally the screen).

This option does not affect the display of error and warning messages.

This option is not available in the IDE.

--skip_dynamic_initialization

Syntax

Description

--skip_dynamic_initialization

When using the IAR C/C++ compiler and the standard library, C++ dynamic
initialization is handled automatically.

Use this option to suppress dynamic initialization to be performed during system
startup. Typically, this can be useful if you need to set up, for example, heap
management for an RTOS before the initialization takes place.

In this case you must add a call to the library function
__iar dynamic_initialization in your application source code. Initialization
will then take place at the time of the call to this function.
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--stack_usage_control

Syntax
Parameters

Description

See also

--strip
Syntax

Description

--threaded _lib

Syntax

Description
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To set this option, use Project>Options>Linker>Extra Options.

--stack_usage_control=filename
See Rules for specifying a filename or directory as parameters, page 246.

Use this option to specify a stack usage control file. This file controls stack usage
analysis, or provides more stack usage information for modules or functions. You can
use this option multiple times to specify multiple stack usage control files. If no filename
extension is specified, the extension suc is used.

Using this option enables stack usage analysis in the linker.

Stack usage analysis, page 85

Project>Options>Linker>Advanced>Control file

--strip

By default, the linker retains the debug information from the input object files in the
output executable image. Use this option to remove that information.

To set related options, choose:

Project>Options>Linker>Output>Include debug information in output

--threaded_1lib

Use this option to automatically configure the runtime library for use with threads.

Project>Options>General Options>Library Configuration>Enable thread
support in library



--vfe

Syntax

Parameters

Description

See also
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--vie=[forced]

forced Performs Virtual Function Elimination even if one or more
modules lack the needed virtual function elimination
information.

Use this option to perform Virtual Function Elimination even if one or more modules
lack the needed virtual function elimination information. Without the parameter
forced, this option has no effect.

Forcing the use of Virtual Function Elimination can be unsafe if some of the modules
that lack the needed information perform virtual function calls or use dynamic Runtime
Type Information.

--no_vfe, page 311 and Virtual function elimination, page 208.

To set related options, choose:

Project>Options>Linker>Optimizations>Perform C++ Virtual Function
Elimination

--warnings_affect_exit_code

Syntax

Description

--warnings_are_errors

Syntax

Description

--warnings_affect_exit_code

By default, the exit code is not affected by warnings, because only errors produce a
non-zero exit code. With this option, warnings will also generate a non-zero exit code.

This option is not available in the IDE.

--warnings_are_errors
Use this option to make the linker treat all warnings as errors. If the linker encounters

an error, no executable image is generated. Warnings that have been changed into
remarks are not treated as errors.
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See also

--whole_archive

Syntax
Parameters

Description

Example

See also
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Note: Any diagnostic messages that have been reclassified as warnings by the option
--diag_warning will also be treated as errors when --warnings_are_errors is
used.

--diag_warning, page 259 and --diag_warning, page 299.

Project>Options>Linker>Diagnostics>Treat all warnings as errors

--whole_archive filename
See Rules for specifying a filename or directory as parameters, page 246.

Use this option to make the linker treat every object file in the archive as if it was
specified on the command line. This is useful when an archive contains root content that
is always included from an object file (filename extension o), but only included from an
archive if some entry from the module is referred to.

If archive.a contains the object files filel.o, file2.0,and £ile3.o, using
--whole_archive archive.a isequivalent to specifying filel.o file2.o
file3.o.

Keeping modules, page 97

To set this option, use Project>Options>Linker>Extra Options
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e Alignment

e Byte order

e Basic data types—integer types

e Basic data types—floating-point types
e Pointer types

e Structure types

e Type qualifiers

e Data types in C++

See the chapter Efficient coding for embedded applications for information about
which data types provide the most efficient code for your application.

Alignment

Every C data object has an alignment that controls how the object can be stored in
memory. Should an object have an alignment of, for example, 4, it must be stored on an
address that is divisible by 4.

The reason for the concept of alignment is that some processors have hardware
limitations for how the memory can be accessed.

Assume that a processor can read 4 bytes of memory using one instruction, but only
when the memory read is placed on an address divisible by 4. Then, 4-byte objects, such
as long integers, will have alignment 4.

Another processor might only be able to read 2 bytes at a time; in that environment, the
alignment for a 4-byte 1long integer might be 2.

A structure type will have the same alignment as the structure member with the most
strict alignment. To decrease the alignment requirements on the structure and its
members, use #pragma pack or the __packed data type attribute.
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All data types must have a size that is a multiple of their alignment. Otherwise, only the
first element of an array would be guaranteed to be placed in accordance with the
alignment requirements. This means that the compiler might add pad bytes at the end of
the structure. For more information about pad bytes, see Packed structure types, page
329.

Note that with the #pragma data_alignment directive you can increase the
alignment demands on specific variables.
ALIGNMENT ON THE ARM CORE

The alignment of a data object controls how it can be stored in memory. The reason for
using alignment is that the ARM core can access 4-byte objects more efficiently when
the object is stored at an address divisible by 4.

Objects with alignment 4 must be stored at an address divisible by 4, while objects with
alignment 2 must be stored at addresses divisible by 2.

The compiler ensures this by assigning an alignment to every data type, ensuring that
the ARM core will be able to read the data.

For related information, see --align_sp_on_irq, page 253 and --no_const_align, page
271.

Byte order

IAR C/C++ Development Guide
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In the little-endian byte order, which is default, the least significant byte is stored at the
lowest address in memory. The most significant byte is stored at the highest address.

In the big-endian byte order, the most significant byte is stored at the lowest address in
memory. The Jeast significant byte is stored at the highest address. If you use the
big-endian byte order, it might be necessary to use the

#pragma bitfields=reversed directive to be compatible with code for other
compilers and I/O register definitions of some devices, see Bitfields, page 322.

Note: There are two variants of the big-endian mode, BE§ and BE32, which you specify
at link time. In BES data is big-endian and code is little-endian. In BE32 both data and
code are big-endian. In architectures before v6, the BE32 endian mode is used, and after
v6 the BES mode is used. In the v6 (ARM11) architecture, both big-endian modes are
supported.
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Basic data types—integer types

The compiler supports both all Standard C basic data types and some additional types.

INTEGER TYPES—AN OVERVIEW

This table gives the size and range of each integer data type:

Data type Size Range Alignment
bool 8 bits Oto | |
char 8 bits 0 to 255 |
signed char 8 bits -128 to 127 |
unsigned char 8 bits 0 to 255 |
signed short 16 bits -32768 to 32767 2
unsigned short 16 bits 0 to 65535 2
signed int 32 bits 231023 4
unsigned int 32 bits 0to 232 4
signed long 32 bits 2302311 4
unsigned long 32 bits 0to0 232 4
signed long long 64 bits 263 10283, 8
unsigned long long 64 bits 0 to 2841 8

Table 30: Integer types

Signed variables are represented using the two’s complement form.

BOOL

The bool data type is supported by default in the C++ language. If you have enabled
language extensions, the bool type can also be used in C source code if you include the
file stdbool.h. This will also enable the boolean values false and true.

THE ENUM TYPE

The compiler will use the smallest type required to hold enum constants, preferring
signed rather than unsigned.

When IAR Systems language extensions are enabled, and in C++, the enum constants
and types can also be of the type long, unsigned long, long long, Or unsigned
long long.
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To make the compiler use a larger type than it would automatically use, define an enum
constant with a large enough value. For example:

/* Disables usage of the char type for enum */
enum Cards{Spadel, Spade2,
DontUseChar=257};

For related information, see --enum_is_int, page 264.

THE CHAR TYPE

The char type is by default unsigned in the compiler, but the --char_is_signed
compiler option allows you to make it signed. Note, however, that the library is compiled
with the char type as unsigned.

THE WCHAR_T TYPE

The wchar_t data type is an integer type whose range of values can represent distinct
codes for all members of the largest extended character set specified among the
supported locals.

The wchar_t data type is supported by default in the C++ language. To use the
wchar_t type also in C source code, you must include the file stddef . h from the
runtime library.

BITFIELDS

In Standard C, int, signed int, and unsigned int can be used as the base type for
integer bitfields. In standard C++, and in C when language extensions are enabled in the
compiler, any integer or enumeration type can be used as the base type. It is
implementation defined whether a plain integer type (char, short, int, etc) results in
a signed or unsigned bitfield.

In the IAR C/C++ Compiler for ARM, plain integer types are treated as unsigned.

Bitfields in expressions are treated as int if int can represent all values of the bitfield.
Otherwise, they are treated as the bitfield base type.

Each bitfield is placed in the next container of its base type that has enough available
bits to accommodate the bitfield. Within each container, the bitfield is placed in the first
available byte or bytes, taking the byte order into account.

In addition, the compiler supports an alternative bitfield allocation strategy (disjoint
types), where bitfield containers of different types are not allowed to overlap. Using this
allocation strategy, each bitfield is placed in a new container if its type is different from
that of the previous bitfield, or if the bitfield does not fit in the same container as the
previous bitfield. Within each container, the bitfield is placed from the least significant
bit to the most significant bit (disjoint types) or from the most significant bit to the least
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significant bit (reverse disjoint types). This allocation strategy will never use less space
than the default allocation strategy (joined types), and can use significantly more space
when mixing bitfield types.

Use the #pragma bitfield directive to choose which bitfield allocation strategy to
use, see bitfields, page 349.

Assume this example:

struct BitfieldExample

{
uint32_t a : 12;
uintlé_t b : 3;
uintlé_t c : 7;
uint8_t d;

}s

The example in the joined types bitfield allocation strategy

To place the first bitfield, a, the compiler allocates a 32-bit container at offset 0 and puts
a into the first and second bytes of the container.

For the second bitfield, b, a 16-bit container is needed and because there are still four
bits free at offset 0, the bitfield is placed there.

For the third bitfield, c, as there is now only one bit left in the first 16-bit container, a
new container is allocated at offset 2, and c is placed in the first byte of this container.

The fourth member, d, can be placed in the next available full byte, which is the byte at
offset 3.

In little-endian mode, each bitfield is allocated starting from the least significant free bit
of its container to ensure that it is placed into bytes from left to right.

MSB LSB
uint32_t a = padding
MSE  LSB MsB  LSB MsB  LSB MSB  LSB
a b |a c d
0 [ 2 3
\MsB Lse/ \MsB LSB,
uintlé6_t | |b c
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In big-endian mode, each bitfield is allocated starting from the most significant free bit
of its container to ensure that it is placed into bytes from left to right.

MSB LSB
uint32_t a = padding
MSE  LSB MsB  LSB MsB  LSB MSB  LSB
a a |b c d
0 [ 2 3
\MsB Lse/ \MsB LSB,
uintlé_t b c

The example in the disjoint types bitfield allocation strategy

To place the first bitfield, a, the compiler allocates a 32-bit container at offset 0 and puts
a into the least significant 12 bits of the container.

To place the second bitfield, b, a new container is allocated at offset 4, because the type
of the bitfield is not the same as that of the previous one. b is placed into the least
significant three bits of this container.

The third bitfield, c, has the same type as b and fits into the same container.

The fourth member, 4, is allocated into the byte at offset 6. d cannot be placed into the
same container as b and c because it is not a bitfield, it is not of the same type, and it
would not fit.

When using reverse order (reverse disjoint types), each bitfield is instead placed starting
from the most significant bit of its container.
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This is the layout of bitfield example in little-endian mode:

MSB LSB MSB LsB

uint32_t a uintl6_t ¢ |b = padding

MSB LSB MsB LSB  MSB ISB MSB  ISB MsB LS8 MsB LB  MsB LSB

a a c b c d
0 | 2 3 4 5 6
MSB LSB  MSB LSB MSB  LSB MSB LSB  MSB LSB  MSB LB MSB LSB
a a c b c d reversed

LsB/

uint32_t a uintlé6_t | b| ¢

This is the layout of bitfield example in big-endian mode:

MSB LSB MSB LSB
uint32_t a uintl6_t c |b = padding
MSB LSB  MsB LSB  MSB LS8 MSB  LSB MsB LSB  MSB LS8 MSB LSB
a a c c b d
0 | 2 3 4 5 6
MSB LSB  MSB LSB MSB  LSB MSB LSB  MSB LSB  MSB LB MSB LSB
a a b c c d reversed

\ MsB 18/
uint32_t a uintl6_t b| ¢
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In the IAR C/C++ Compiler for ARM, floating-point values are represented in standard
IEEE 754 format. The sizes for the different floating-point types are:

Type Size Range (+/-) Decimals Exponent Manissa Alignment
float 32 bits *1.18E-38 to £3.40E+38 7 8 bits 23 bits 4
double 64 bits +2.23E-308 to +1.79E+308 |5 I'l bits 52 bits 8

long 64 bits +2.23E-308 to +1.79E+308 |5 I'l bits 52 bits 8
double

Table 31: Floating-point types

For Cortex-MO and Cortex-M1, the compiler does not support subnormal numbers. All
operations that should produce subnormal numbers will instead generate zero. For
information about the representation of subnormal numbers for other cores, see
Representation of special floating-point numbers, page 327.

FLOATING-POINT ENVIRONMENT

Exception flags for floating-point values are supported for devices with a VFP unit, and
they are defined in the fenv.h file. For devices without a VFP unit, the functions
defined in the fenv.h file exist but have no functionality.

The feraiseexcept function does not raise an inexact floating-point exception
when called with FE_OVERFLOW or FE_UNDERFLOW.

32-BIT FLOATING-POINT FORMAT

The representation of a 32-bit floating-point number as an integer is:
31 30 pER)) 0

S | Exponent Mantissa

The exponent is 8 bits, and the mantissa is 23 bits.
The value of the number is:
(-1)8 * p(Fxponent-127) « 1 Mantissa
The range of the number is at least:
+1.18E-38 to *3.39E+38

The precision of the float operators (+, -, *, and /) is approximately 7 decimal digits.
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64-BIT FLOATING-POINT FORMAT

The representation of a 64-bit floating-point number as an integer is:
63 62 52 51 0

S | Exponent Mantissa

The exponent is 11 bits, and the mantissa is 52 bits.

The value of the number is:

(-1)S = o (Exponent-1023) % 1 Mantissa

The range of the number is at least:
+2.23E-308 to *1.79E+308

The precision of the float operators (+, -, *, and /) is approximately 15 decimal digits.

REPRESENTATION OF SPECIAL FLOATING-POINT NUMBERS
This list describes the representation of special floating-point numbers:

e Zero is represented by zero mantissa and exponent. The sign bit signifies positive or
negative zero.

e Infinity is represented by setting the exponent to the highest value and the mantissa
to zero. The sign bit signifies positive or negative infinity.

e Not a number (NaN) is represented by setting the exponent to the highest positive
value and the most significant bit in the mantissa to 1. The value of the sign bit is
ignored.

o Subnormal numbers are used for representing values smaller than what can be
represented by normal values. The drawback is that the precision will decrease with
smaller values. The exponent is set to O to signify that the number is subnormal,
even though the number is treated as if the exponent was 1. Unlike normal numbers,
subnormal numbers do not have an implicit 1 as the most significant bit (the MSB)
of the mantissa. The value of a subnormal number is:

(—1)S » 2(1-BIAS) « o Mantissa

where BIAS is 127 and 1023 for 32-bit and 64-bit floating-point values, respectively.

Pointer types

The compiler has two basic types of pointers: function pointers and data pointers.

FUNCTION POINTERS

The size of function pointers is always 32 bits, and the range is 0x0-0xFFFFFFFF.

327



Pointer types

328

IAR C/C++ Development Guide
Compiling and Linking for ARM

When function pointer types are declared, attributes are inserted before the * sign, for
example:

typedef void (__thumb __interwork * IntHandler) (void);

This can be rewritten using #pragma directives:

#pragma type_attribute=__thumb __interwork
typedef void IntHandler_function(void) ;
typedef IntHandler_function *IntHandler;

DATA POINTERS

There is one data pointer available. Its size is 32 bits and the range is 0x0-0xFFFFFFFF.

CASTING

Casts between pointers have these characteristics:

Casting a value of an integer type to a pointer of a smaller type is performed by
truncation

Casting a pointer type to a smaller integer type is performed by truncation
Casting a pointer type to a larger integer type is performed by zero extension
Casting a data pointer to a function pointer and vice versa is illegal

Casting a function pointer to an integer type gives an undefined result

Casting a value of an unsigned integer type to a pointer of a larger type is performed
by zero extension

size_t

size_t is the unsigned integer type of the result of the sizeof operator. In the IAR
C/C++ Compiler for ARM, the type used for size_t is unsigned int.

ptrdiff_t

ptrdiff_t is the signed integer type of the result of subtracting two pointers. In the
IAR C/C++ Compiler for ARM, the type used for ptrdif£f_t is the signed integer
variant of the size_t type.

intptr_t

intptr_t is a signed integer type large enough to contain a void *. In the IAR C/C++
Compiler for ARM, the type used for intptr_t is signed long int.

uintptr_t

uintptr_t is equivalent to intptr_t, with the exception that it is unsigned.
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Structure types

The members of a struct are stored sequentially in the order in which they are
declared: the first member has the lowest memory address.

ALIGNMENT OF STRUCTURE TYPES

The struct and union types have the same alignment as the member with the highest
alignment requirement. Note that this alignment requirement also applies to a member
that is a structure. To allow arrays of aligned structure objects, the size of a struct is
adjusted to an even multiple of the alignment.

GENERAL LAYOUT

Members of a struct are always allocated in the order specified in the declaration.
Each member is placed in the struct according to the specified alignment (offsets).

struct First
{
char c;
short s;
} os;

This diagram shows the layout in memory:

c pad s

0 | 2 3

The alignment of the structure is 2 bytes, and a pad byte must be inserted to give
short s the correct alignment.

PACKED STRUCTURE TYPES

The is used for relaxing the alignment requirements of the members of a structure. This
changes the layout of the structure. The members are placed in the same order as when
declared, but there might be less pad space between members.

Note that accessing an object that is not correctly aligned requires code that is both
larger and slower. If such structure members are accessed many times, it is usually better
to construct the correct values in a struct that is not packed, and access this struct
instead.

Special care is also needed when creating and using pointers to misaligned members.
For direct access to misaligned members in a packed struct, the compiler will emit the
correct (but slower and larger) code when needed. However, when a misaligned member
is accessed through a pointer to the member, the normal (smaller and faster) code is
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used. In the general case, this will not work, because the normal code might depend on
the alignment being correct.

This example declares a packed structure:

#pragma pack(1l)
struct S
{

char c;

short s;

Y

#pragma pack ()

The structure s has this memory layout:

c S

0 | 2

The next example declares a new non-packed structure, 52, that contains the structure s
declared in the previous example:

struct S2

{
struct S s;
long 1;

}i

The structure S2 has this memory layout

The structure s will use the memory layout, size, and alignment described in the
previous example. The alignment of the member 1 is 4, which means that alignment of
the structure s2 will become 4.

For more information, see Alignment of elements in a structure, page 214.

Type qualifiers

IAR C/C++ Development Guide
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According to the C standard, volatile and const are type qualifiers.
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DECLARING OBJECTS VOLATILE

By declaring an object volatile, the compiler is informed that the value of the object
can change beyond the compiler’s control. The compiler must also assume that any
accesses can have side effects—thus all accesses to the volatile object must be
preserved.

There are three main reasons for declaring an object volatile:
o Shared access; the object is shared between several tasks in a multitasking
environment

o Trigger access; as for a memory-mapped SFR where the fact that an access occurs
has an effect

o Modified access; where the contents of the object can change in ways not known to
the compiler.

Definition of access to volatile objects

The C standard defines an abstract machine, which governs the behavior of accesses to
volatile declared objects. In general and in accordance to the abstract machine:

o The compiler considers each read and write access to an object declared volatile
as an access

o The unit for the access is either the entire object or, for accesses to an element in a
composite object—such as an array, struct, class, or union—the element. For
example:

char volatile a;
a=>5; /* A write access */
a += 6; /* First a read then a write access */

® An access to a bitfield is treated as an access to the underlying type

o Adding a const qualifier to a volatile object will make write accesses to the
object impossible. However, the object will be placed in RAM as specified by the C
standard.

However, these rules are not detailed enough to handle the hardware-related
requirements. The rules specific to the IAR C/C++ Compiler for ARM are described
below.

Rules for accesses

In the IAR C/C++ Compiler for ARM, accesses to volatile declared objects are
subject to these rules:

o All accesses are preserved

o All accesses are complete, that is, the whole object is accessed
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o All accesses are performed in the same order as given in the abstract machine

o All accesses are atomic, that is, they cannot be interrupted.

The compiler adheres to these rules for accesses to all 8-, 16-, and 32-bit scalar types,
except for accesses to unaligned 16- and 32-bit fields in packed structures.

For all combinations of object types not listed, only the rule that states that all accesses
are preserved applies.

DECLARING OBJECTS VOLATILE AND CONST

If you declare a volatile object const, it will be write-protected but it will still be
stored in RAM memory as the C standard specifies.

To store the object in read-only memory instead, but still make it possible to access it as
a const volatile object, define the variable like this:

const volatile int x @ "FLASH";

The compiler will generate the read/write section FLASH. That section should be placed
in ROM and is used for manually initializing the variables when the application starts
up.

Thereafter, the initializers can be reflashed with other values at any time.

DECLARING OBJECTS CONST

The const type qualifier is used for indicating that a data object, accessed directly or
via a pointer, is non-writable. A pointer to const declared data can point to both
constant and non-constant objects. It is good programming practice to use const
declared pointers whenever possible because this improves the compiler’s possibilities
to optimize the generated code and reduces the risk of application failure due to
erroneously modified data.

Static and global objects declared const are allocated in ROM.

In C++, objects that require runtime initialization cannot be placed in ROM.

Data types in C++

IAR C/C++ Development Guide
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In C++, all plain C data types are represented in the same way as described earlier in this
chapter. However, if any Embedded C++ features are used for a type, no assumptions
can be made concerning the data representation. This means, for example, that it is not
supported to write assembler code that accesses class members.
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e General syntax rules for extended keywords
e Summary of extended keywords

e Descriptions of extended keywords

General syntax rules for extended keywords

The compiler provides a set of attributes that can be used on functions or data objects to
support specific features of the ARM core. There are two types of attributes—zype
attributes and object attributes:

o Type attributes affect the external functionality of the data object or function

o Object attributes affect the internal functionality of the data object or function.

The syntax for the keywords differs slightly depending on whether it is a type attribute
or an object attribute, and whether it is applied to a data object or a function.

For more information about each attribute, see Descriptions of extended keywords, page
337.

Note: The extended keywords are only available when language extensions are enabled
in the compiler.

In the IDE, language extensions are enabled by default.

@ Use the -e compiler option to enable language extensions. See -e, page 261.

TYPE ATTRIBUTES

Type attributes define how a function is called, or how a data object is accessed. This
means that if you use a type attribute, it must be specified both when a function or data
object is defined and when it is declared.

You can either place the type attributes explicitly in your declarations, or use the pragma
directive #pragma type_attribute.

Type attributes can be further divided into memory type attributes and general type
attributes. Memory type attributes are referred to as simply memory attributes in the rest
of the documentation.
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General type attributes
Available function type attributes (affect how the function should be called):

arm

J—  ——

fiqg, __interwork, __irqg,__swi,__task,__thumb
Available data type attributes:

_big_endian little_endian__packed

— s ——

You can specify as many type attributes as required for each level of pointer indirection.

Syntax for type attributes used on data objects

Type attributes use almost the same syntax rules as the type qualifiers const and
volatile. For example:

__little_endian int i;
int __little_endian j;

Both i and j will be accessed with little-endian byte order.

Unlike const and volatile, when a type attribute is used before the type specifier in
a derived type, the type attribute applies to the object, or typedef itself, except in
structure member declarations.

Using a type definition can sometimes make the code clearer:

typedef __packed int packed_int;
packed_int *qgl;

packed_int is a typedef for packed integers. The variable g1 can point to such integers.

You can also use the #pragma type_attributes directive to specify type attributes
for a declaration. The type attributes specified in the pragma directive are applied to the
data object or typedef being declared.

#pragma type_attribute=__packed
int * qQ2;

The variable g2 is packed.

Syntax for type attributes used on functions

The syntax for using type attributes on functions differs slightly from the syntax of type
attributes on data objects. For functions, the attribute must be placed either in front of
the return type, or in parentheses, for example:

__irg __arm void my_handler (void) ;
or

void (__irg __arm my_handler) (void) ;
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This declaration of my_handler is equivalent with the previous one:

#pragma type_attribute=__irg __arm
void my_handler (void) ;

OBJECT ATTRIBUTES

Normally, object attributes affect the internal functionality of functions and data objects,
but not directly how the function is called or how the data is accessed. This means that
an object attribute does not normally need to be present in the declaration of an object.

These object attributes are available:

o Object attributes that can be used for variables:

__absolute, __no_alloc,__no_allocl6,__no_alloc_str,
__no_alloc_strl6, __no_init

o Object attributes that can be used for functions and variables:

location, @ root, __weak

s ——

o Object attributes that can be used for functions:

__intrinsic,__nested, __noreturn, __ramfunc, __stackless

You can specify as many object attributes as required for a specific function or data
object.

For more information about 1ocation and @, see Controlling data and function
placement in memory, page 216.
Syntax for object attributes

The object attribute must be placed in front of the type. For example, to place myarray
in memory that is not initialized at startup:

__no_init int myarray[10];

The #pragma object_attribute directive can also be used. This declaration is
equivalent to the previous one:

#pragma object_attribute=__no_init
int myarray[10];

Note: Object attributes cannot be used in combination with the typedef keyword.
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Summary of extended keywords

This table summarizes the extended keywords:

Extended keyword

Description

__absolute
__arm

__big _endian
__fig

__interwork

__intrinsic
__irqg

__little_endian

__no_alloc,
__no_allocle6

__no_alloc_str,
__no_alloc_strlé6

__nested

__no_init
_ _noreturn
__packed
__pcrel

__ramfunc

__root

_sbrel

__stackless
__swi
__task
_thumb

__weak

Makes references to the object use absolute addressing
Makes a function execute in ARM mode

Declares a variable to use the big-endian byte order
Declares a fast interrupt function

Declares a function to be callable from both ARM and Thumb
mode

Reserved for compiler internal use only
Declares an interrupt function
Declares a variable to use the little-endian byte order

Makes a constant available in the execution file

Makes a string literal available in the execution file

Allows an __irqg declared interrupt function to be nested, that is,
interruptible by the same type of interrupt

Places a data object in non-volatile memory
Informs the compiler that the function will not return
Decreases data type alignment to |

Used internally by the compiler for constant data when the
--ropi compiler option is used

Makes a function execute in RAM

Ensures that a function or variable is included in the object code
even if unused

Used internally by the compiler for constant data when the
--rwpi compiler option is used

Makes a function callable without a working stack
Declares a software interrupt function

Relaxes the rules for preserving registers

Makes a function execute in Thumb mode

Declares a symbol to be externally weakly linked

Table 32: Extended keywords summary

IAR C/C++ Development Guide
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Descriptions of extended keywords

___absolute

Syntax

Description

Example

arm

Syntax

Description

Example

See also

__big endian

Syntax

Description

This section gives detailed information about each extended keyword.

See Syntax for object attributes, page 335.

The __absolute keyword makes references to the object use absolute addressing.
The following limitations apply:
o Only available when the --ropi or --rwpi compiler option is used

o Can only be used on external declarations.

extern __ absolute char otherBuffer[100];

See Syntax for type attributes used on functions, page 334.

The __arm keyword makes a function execute in ARM mode. An __arm declared
function can, unless it is also declared __interwork, only be called from functions that
also execute in ARM mode.

A function declared __arm cannot be declared __thumb.

Note: Non-interwork ARM functions cannot be called from Thumb mode.
__arm int funcl (void) ;

__interwork, page 338.

See Syntax for type attributes used on data objects, page 334.

The __big_endian keyword is used for accessing a variable that is stored in the
big-endian byte order regardless of what byte order the rest of the application uses. The
__big_endian keyword is available when you compile for ARMv6 or higher.

Note that this keyword cannot be used on pointers. Also, this attribute cannot be used on
arrays.
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Example

See also

_fiq

Syntax

Description

Example

__interwork

Syntax

Description

Example

__intrinsic

Description

__irq

Syntax

Description
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__big endian long my_variable;

__little_endian, page 339.

See Syntax for type attributes used on functions, page 334.

The __figkeyword declares a fast interrupt function. All interrupt functions must be
compiled in ARM mode. A function declared __fiqg does not accept parameters and
does not have a return value. This keyword is not available when you compile for
Cortex-M devices.

__fig __arm void interrupt_function (void) ;

See Syntax for type attributes used on functions, page 334.

A function declared __interwork can be called from functions executing in either
ARM or Thumb mode.

Note: By default, functions are interwork when the --interwork compiler option is
used, and when the --cpu option is used and it specifies a core where interwork is
default.

typedef void (__thumb __interwork *IntHandler) (void) ;

The __intrinsic keyword is reserved for compiler internal use only.

See Syntax for type attributes used on functions, page 334.

The __irqgkeyword declares an interrupt function. All interrupt functions must be
compiled in ARM mode. A function declared __irqg does not accept parameters and
does not have a return value. This keyword is not available when you compile for
Cortex-M devices.



Example

See also

__little_endian

Syntax

Description

Example

See also

__nested

Syntax

Description

Example

See also

Extended keywords ___o

__irg __arm void interrupt_function (void) ;

--align_sp_on_irq, page 253

See Syntax for type attributes used on data objects, page 334.

The __little_endian keyword is used for accessing a variable that is stored in the
little-endian byte order regardless of what byte order the rest of the application uses. The
__little_endian keyword is available when you compile for ARMv6 or higher.

Note that this keyword cannot be used on pointers. Also, this attribute cannot be used on
arrays.

__little_endian long my_variable;

__big endian, page 337.

See Syntax for object attributes, page 335.

The __nested keyword modifies the enter and exit code of an interrupt function to
allow for nested interrupts. This allows interrupts to be enabled, which means new
interrupts can be served inside an interrupt function, without overwriting the SPSR and
return address in R14. Nested interrupts are only supported for __irqg declared
functions.

Note: The __nested keyword requires the processor mode to be in either User or
System mode.

__irg __nested __arm void interrupt_handler (void) ;

Nested interrupts, page 69 and --align_sp_on_irq, page 253.

__no_alloc, __no_allocl 6

Syntax

See Syntax for object attributes, page 335.
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Description

Example

See also

Usethe __no_allocor__no_alloclé6 object attribute on a constant to make the
constant available in the executable file without occupying any space in the linked
application.

You cannot access the contents of such a constant from your application. You can take
its address, which is an integer offset to the section of the constant. The type of the offset
is unsigned long when __no_alloc is used, and unsigned short when
__no_allocl6 is used.

__no_alloc const struct MyData my_data @ "XXX" = {...};

__no_alloc_str, __no_alloc_strl6, page 340.

__no_alloc_str, __no_alloc_strlé

Syntax

Description

IAR C/C++ Development Guide
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_ no_alloc_str(string literal @ section)
and

__no_alloc_strlé6(string literal @ section)

where

string literal The string literal that you want to make available in the
executable file.

section The name of the section to place the string literal in.

Usethe __no_alloc_stror__no_alloc_strlé6 operators to make string literals

available in the executable file without occupying any space in the linked application.

The value of the expression is the offset of the string literal in the section. For
__no_alloc_str, thetype of the offsetisSunsigned long.For__no_alloc_strls,
the type of the offset is unsigned short.



Example

See also

Description

Example

See also

__horeturn

Syntax

Description

Example
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#define MYSEG "YYY"
#define X(str) __no_alloc_str(str @ MYSEG)

extern void dbg_printf (unsigned long fmt, ...)
#define DBGPRINTF (fmt, ...) dbg_printf(X(fmt), _ VA_ARGS_ )

void
foo(int i, double d)

{
DBGPRINTF ("The value of i is: %d, the value of d is: %f",i,d);

}

Depending on your debugger and the runtime support, this could produce trace output
on the host computer. Note that there is no such runtime support in C-SPY, unless you
use an external plugin module.

__no_alloc, _no_allocl6, page 339.

See Syntax for object attributes, page 335.

Usethe __no_init keyword to place a data object in non-volatile memory. This means
that the initialization of the variable, for example at system startup, is suppressed.

__no_init int myarray[10];

Non-initialized variables, page 231 and do not initialize directive, page 437.

See Syntax for object attributes, page 335.

The __noreturn keyword can be used on a function to inform the compiler that the
function will not return. If you use this keyword on such functions, the compiler can
optimize more efficiently. Examples of functions that do not return are abort and exit.

Note: At optimization levels medium or high, the __noreturn keyword might cause
incorrect call stack debug information at any point where it can be determined that the
current function cannot return.

__noreturn void terminate(void) ;
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__packed

Syntax

Description

Example
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See Syntax for type attributes used on data objects, page 334. An exception is when the
keyword is used for modifying the structure type in a struct or union declarations,
see below.

Use the __packed keyword to specify a data alignment of 1 for a data type. __packed
can be used in two ways:

o When used before the struct or union keyword in a structure definition, the
maximum alignment of each member in the structure is set to 1, eliminating the
need for gaps between the members.

You can also use the __packed keyword with structure declarations, but it is illegal
to refer to a structure type defined without the __packed keyword using a structure
declaration with the __packed keyword.

o When used in any other position, it follows the syntax rules for type attributes, and
affects a type in its entirety. A type with the __packed type attribute is the same as
the type attribute without the __packed type attribute, except that it has a data
alignment of 1. Types that already have an alignment of 1 are not affected by the
__packed type attribute.

A normal pointer can be implicitly converted to a pointer to __packed, but the reverse
conversion requires a cast.

Note: Accessing data types at other alignments than their natural alignment can result
in code that is significantly larger and slower.

Use either __packed or #pragma pack to relax the alignment restrictions for a type
and the objects defined using that type. Mixing __packed and #pragma pack might
lead to unexpected behavior.

/* No pad bytes in X: */

_ _packed struct X { char ch; int i; };
/* __packed is optional here: */
struct X * xp;

/* NOTE: no __ packed: */

struct Y { char ch; int 1i; };

/* ERROR: Y not defined with __ packed: */
_ packed struct Y * yp ;

/* Member 'i' has alignment 1: */
struct Z2 { char ch; packed int i; };



See also

__ramfunc

Syntax

Description

Example

See also
__root
Syntax

Description

Example
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void Foo(struct X * xp)

{

/* Error:"int *" -> "int packed *" not allowed: */
int * pl = xp->1;
/* OK: */

int packed * p2 = &xp->i;
/* OK, char not affected */
char * p3 = &xp->ch;

pack, page 361.

See Syntax for type attributes used on functions, page 334.

The __ramfunc keyword makes a function execute in RAM. Two code sections will be
created: one for the RAM execution (. textrw), and one for the ROM initialization
(.textrw_init).

If a function declared __ramfunc tries to access ROM, the compiler will issue a
warning. This behavior is intended to simplify the creation of upgrade routines, for
instance, rewriting parts of flash memory. If this is not why you have declared the
function __ramfunc, you can safely ignore or disable these warnings.

Functions declared __ramfunc are by default stored in the section named . textrw.
__ramfunc int FlashPage(char * data, char * page);

The C-SPY® Debugging Guide for ARM to read more about __ramfunc declared
functions in relation to breakpoints.

See Syntax for object attributes, page 335.
A function or variable with the __root attribute is kept whether or not it is referenced
from the rest of the application, provided its module is included. Program modules are

always included and library modules are only included if needed.

__root int myarray[10];
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See also

__stackless

Syntax

Description

Example

_swi

Syntax

Description
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For more information about root symbols and how they are kept, see Keeping symbols
and sections, page 97.

See Syntax for object attributes, page 335.

The __stackless keyword declares a function that can be called without a working
stack.

A function declared __stackless violates the calling convention in such a way that it
is not possible to return from it. However, the compiler cannot reliably detect if the
function returns and will not issue an error if it does.

__stackless void start_application(void) ;

See Syntax for type attributes used on functions, page 334.

The __swi declares a software interrupt function. It inserts an svc (formerly SwI)
instruction and the specified software interrupt number to make a proper function call.
A function declared __swi accepts arguments and returns values. The __swi keyword
makes the compiler generate the correct return sequence for a specific software interrupt
function. Software interrupt functions follow the same calling convention regarding
parameters and return values as an ordinary function, except for the stack usage.

The __swi keyword also expects a software interrupt number which is specified with
the #pragma swi_number=number directive. The swi_number is used as an
argument to the generated assembler SvC instruction, and can be used by the SVC
interrupt handler, for example SWI_Handler, to select one software interrupt function
in a system containing several such functions. Note that the software interrupt number
should only be specified in the function declaration—typically, in a header file that you
include in the source code file that calls the interrupt function—not in the function
definition.

Note: All interrupt functions must be compiled in ARM mode, except for Cortex-M.
Use either the __arm keyword or the #pragma type_attribute=__arm directive to
alter the default behavior if needed.
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Example To declare your software interrupt function, typically in a header file, write for example
like this:

#pragma swi_number=0x23
__swi int swiOx23_function(int a, int b);

To call the function:

int x = swiOx23_function(l, 2); /* Will be replaced by SVC 0x23,
hence the linker will never
try to locate the
swi0x23_function */

Somewhere in your application source code, you define your software interrupt
function:

swi __arm int the_actual_swiOx23_function(int a, int b)

{

return 42;

See also Software interrupts, page 70 and Calling convention, page 163.
__task
Syntax See Syntax for type attributes used on functions, page 334.
Description This keyword allows functions to relax the rules for preserving registers. Typically, the

keyword is used on the start function for a task in an RTOS.

Because a function declared __task can corrupt registers that are needed by the calling
function, you should only use __task on functions that do not return or call such a
function from assembler code.

The function main can be declared __task, unless it is explicitly called from the
application. In real-time applications with more than one task, the root function of each
task can be declared __task.

Example __task void my_handler (void) ;
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__thumb

Syntax

Description

Example

See also

__weak

Syntax

Description

Example
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See Syntax for type attributes used on functions, page 334.

is also declared __interwork, the function declared __thumb can only be called from
functions that also execute in Thumb mode.

The __ thumb keyword makes a function execute in Thumb mode. Unless the function

A function declared __thumb cannot be declared __arm.

Note: Non-interwork Thumb functions cannot be called from ARM mode.
__thumb int func2(void) ;

__interwork, page 338.

See Syntax for object attributes, page 335.

Using the __weak object attribute on an external declaration of a symbol makes all
references to that symbol in the module weak.

Using the __weak object attribute on a public definition of a symbol makes that
definition a weak definition.

The linker will not include a module from a library solely to satisfy weak references to
a symbol, nor will the lack of a definition for a weak reference result in an error. If no
definition is included, the address of the object will be zero.

When linking, a symbol can have any number of weak definitions, and at most one
non-weak definition. If the symbol is needed, and there is a non-weak definition, this
definition will be used. If there is no non-weak definition, one of the weak definitions
will be used.

extern __ _weak int foo; /* A weak reference. */

__weak void bar (void) /* A weak definition. */

{

/* Increment foo if it was included. */
if (&foo != 0)
++foo;



Pragma directives

e Summary of pragma directives

e Descriptions of pragma directives

Summary of pragma directives

The #pragma directive is defined by Standard C and is a mechanism for using

vendor-specific extensions in a controlled way to make sure that the source code is still

portable.

The pragma directives control the behavior of the compiler, for example how it allocates
memory for variables and functions, whether it allows extended keywords, and whether

it outputs warning messages.

The pragma directives are always enabled in the compiler.

This table lists the pragma directives of the compiler that can be used either with the
#pragma preprocessor directive or the _Pragma () preprocessor operator:

Pragma directive

Description

bitfields

calls
call_graph_root
data_alignment

default_function_attributes

default_no_bounds

default_variable_attributes

define_with_bounds

Controls the order of bitfield members.

Lists possible called functions for indirect calls.
Specifies that the function is a call graph root.
Gives a variable a higher (more strict) alignment.

Sets default type and object attributes for
declarations and definitions of functions.

Applies #pragma no_bounds to a whole set of
functions. See the C-RUN documentation in the
C-SPY® Debugging Guide for ARM.

Sets default type and object attributes for
declarations and definitions of variables.

Instruments a function to track pointer bounds. See
the C-RUN documentation in the C-SPY® Debugging
Guide for ARM.

Table 33: Pragma directives summary
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Pragma directive

Description

define_without_bounds

diag_default
diag_error
diag_remark
diag_suppress
diag_warning

disable_check

error

generate_entry_without_boun

ds

include_alias
inline
language

location

message

no_bounds

object_attribute

optimize

pack

__printf_args

Defines the version of a function that does not have
extra bounds information. See the C-RUN
documentation in the C-SPY® Debugging Guide for
ARM.

Changes the severity level of diagnostic messages.
Changes the severity level of diagnostic messages.
Changes the severity level of diagnostic messages.
Suppresses diagnostic messages.

Changes the severity level of diagnostic messages.

Specifies that the immediately following function
does not check accesses against bounds. See the
C-RUN documentation in the C-SPY® Debugging
Guide for ARM.

Signals an error while parsing.

Enables generation of an extra entry without bounds
for the immediately following function. See the
C-RUN documentation in the C-SPY® Debugging
Guide for ARM.

Specifies an alias for an include file.
Controls inlining of a function.
Controls the IAR Systems language extensions.

Specifies the absolute address of a variable, places a
variable in a register, or places groups of functions or
variables in named sections.

Prints a message.

Specifies that the immediately following function is
not instrumented for bounds checking. See the
C-RUN documentation in the C-SPY® Debugging
Guide for ARM.

Adds object attributes to the declaration or
definition of a variable or function.

Specifies the type and level of an optimization.

Specifies the alignment of structures and union
members.

Verifies that a function with a printf-style format
string is called with the correct arguments.

Table 33: Pragma directives summary (Continued)
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Description

public_equ

required

rtmodel

__scanf_args

section

segment

STDC CX_LIMITED_RANGE

STDC FENV_ACCESS

STDC FP_CONTRACT

swi_number
unroll

vectorize

weak

type_attribute

Defines a public assembler label and gives it a value.

Ensures that a symbol that is needed by another
symbol is included in the linked output.

Adds a runtime model attribute to the module.

Verifies that a function with a scanf-style format
string is called with the correct arguments.

Declares a section name to be used by intrinsic
functions.

This directive is an alias for #pragma section.

Specifies whether the compiler can use normal
complex mathematical formulas or not.

Specifies whether your source code accesses the
floating-point environment or not.

Specifies whether the compiler is allowed to contract
floating-point expressions or not.

Sets the interrupt number of a software interrupt.
Unrolls loops.

Enables or disables generation of NEON vector
instructions for a loop.

Makes a definition a weak definition, or creates a
weak alias for a function or a variable.

Adds type attributes to a declaration or to
definitions.

Table 33: Pragma directives summary (Continued)

Note: For portability reasons, see also Recognized pragma directives (6.10.6), page

508.

Descriptions of pragma directives

This section gives detailed information about each pragma directive.

bitfields

Syntax

#pragma bitfields=disjoint_types|joined_types|
reversed_disjoint_types|reversed|default}
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Parameters

Description

Example

See also

calls

Syntax

Parameters

Description

IAR C/C++ Development Guide
Compiling and Linking for ARM

disjoint_types

joined_types

reversed_disjoint_types

reversed

default

Bitfield members are placed from the least significant
bit to the most significant bit in the container type.
Storage containers of bitfields with different base
types will not overlap.

Bitfield members are placed depending on the byte
order. Storage containers of bitfields will overlap other
structure members. For more information, see
Bitfields, page 322.

Bitfield members are placed from the most significant
bit to the least significant bit in the container type.
Storage containers of bitfields with different base
types will not overlap.

This is an alias for reversed_disjoint_types.

Restores to default layout of bitfield members. The
default behavior for the compiler is joined_types.

Use this pragma directive to control the layout of bitfield members.

#pragma bitfields=disjoint_types
/* Structure that uses disjoint bitfield types. */

struct S

{
unsigned char error
unsigned char size
unsigned short code

Y

1;
4;
10;

#pragma bitfields=default /* Restores to default setting. */

Bitfields, page 322.

#pragma calls=function|,

function...]

function Any declared function

Use this pragma directive to list the functions that can be indirectly called in the
following statement. This information can be used for stack usage analysis in the linker.



Example

See also

call_graph_root

Syntax

Parameters

Description

Example

See also

data_alignment

Syntax

Parameters

Description

Pragma directives °

Note: For an accurate result, you must list all possible called functions.
void Funl (), Fun2();

void Caller (void (*fp) (void))

{

#pragma calls = Funl, Fun2
(*fp) ()7

Stack usage analysis, page 85

#pragma call_graph_root[=category]

category A string that identifies an optional call graph root category

Use this pragma directive to specify that, for stack usage analysis purposes, the
immediately following function is a call graph root. You can also specify an optional
category. The compiler will usually automatically assign a call graph root category to
interrupt and task functions. If you use the #pragma call_graph_root directive on
such a function you will override the default category. You can specity any string as a
category.

#pragma call_graph_root="interrupt"

Stack usage analysis, page 85

#pragma data_alignment=expression

expression A constant which must be a power of two (1, 2, 4, etc.).

Use this pragma directive to give a variable a higher (more strict) alignment of the start
address than it would otherwise have. This directive can be used on variables with static
and automatic storage duration.
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When you use this directive on variables with automatic storage duration, there is an
upper limit on the allowed alignment for each function, determined by the calling
convention used.

Note: Normally, the size of a variable is a multiple of its alignment. The
data_alignment directive only affects the alignment of the variable’s start address,
and not its size, and can thus be used for creating situations where the size is not a
multiple of the alignment.

default_function_attributes

Syntax

Parameters

Description

Example

IAR C/C++ Development Guide
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#pragma default_function_attributes=[ attribute...]
where attribute can be:

type_attribute
object_attribute
@ section_name

type_attribute See Type attributes, page 333.
object_attribute See Object attributes, page 335.
@ section_name See Data and function placement in sections, page 218.

Use this pragma directive to set default section placement, type attributes, and object
attributes for function declarations and definitions. The default settings are only used for
declarations and definitions that do not specify type or object attributes or location in
some other way.

Specifying a default_function_attributes pragma directive with no attributes,
restores the initial state where no such defaults have been applied to function
declarations and definitions.

/* Place following functions in section MYSEC" */
#pragma default_function_attributes = @ "MYSEC"
int funl (int x) { return x + 1; }

int fun2(int x) { return x - 1;

/* Stop placing functions into MYSEC */

#pragma default_function_attributes =

has the same effect as:

int funl(int x) @ "MYSEC" { return x + 1; }
int fun2(int x) @ "MYSEC" { return x - 1; }



See also
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location, page 358
object_attribute, page 359

type_attribute, page 366

default_variable_attributes

Syntax

Parameters

Description

Example

See also

#pragma default_variable_attributes=[ attribute...]
where attribute can be:

type_attribute
object_attribute
@ section_name

type_attribute See Type attributes, page 333.
object_attributes See Object attributes, page 335.
@ section_name See Data and function placement in sections, page 218.

Use this pragma directive to set default section placement, type attributes, and object
attributes for declarations and definitions of variables with static storage duration. The
default settings are only used for declarations and definitions that do not specify type or
object attributes or location in some other way.

Specifying adefault_variable_attributes pragma with no attributes restores the

initial state of no such defaults being applied to variables with static storage duration.

/* Place following variables in section MYSEC" */
#pragma default_variable_attributes = @ "MYSEC"
int varl = 42;

int var2 = 17;

/* Stop placing variables into MYSEC */

#pragma default_variable_attributes =

has the same effect as:

int varl @ "MYSEC" = 42;
int var2 @ "MYSEC" = 17;

location, page 358
object_attribute, page 359

type_attribute, page 366
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diag default

Syntax

Parameters

Description

See also

diag error

Syntax

Parameters

Description
See also

diag remark

Syntax

Parameters

Description

See also
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#pragma diag_default=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel77.

Use this pragma directive to change the severity level back to the default, or to the
severity level defined on the command line by any of the options --diag_error,
--diag_remark, --diag_suppress, Or --diag_warnings, for the diagnostic
messages specified with the tags.

Diagnostics, page 240.

#pragma diag_error=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel77.

Use this pragma directive to change the severity level to error for the specified
diagnostics.

Diagnostics, page 240.

#pragma diag_remark=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pel77.

Use this pragma directive to change the severity level to remark for the specified
diagnostic messages.

Diagnostics, page 240.



diag suppress

Syntax

Parameters

Description

See also

diag_warning

Syntax

Parameters

Description
See also

error

Syntax

Parameters

Description
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#pragma diag_suppress=tagl, tag,...]

tag The number of a diagnostic message, for example the
message number Pell7.

Use this pragma directive to suppress the specified diagnostic messages.

Diagnostics, page 240.

#pragma diag_warning=tagl, tag, ...]

tag The number of a diagnostic message, for example the
message number Pe826.

Use this pragma directive to change the severity level to warning for the specified
diagnostic messages.

Diagnostics, page 240.

#pragma error message

message A string that represents the error message.

Use this pragma directive to cause an error message when it is parsed. This mechanism
is different from the preprocessor directive #error, because the #pragma error
directive can be included in a preprocessor macro using the _Pragma form of the
directive and only causes an error if the macro is used.
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Example

include_alias

Syntax

Parameters

Description

Example

See also

inline
Syntax

Parameters
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#1if FOO_AVAILABLE

#define FOO

#else

#define FOO _Pragma("error\"Foo is not available\"")
#endif

If FOO_AVAILABLE is zero, an error will be signaled if the FOO macro is used in actual
source code.

#pragma include_alias ("orig header" , "subst_header")
#pragma include_alias (<orig _header> , <subst_header>)

orig_header The name of a header file for which you want to create an
alias.
subst_header The alias for the original header file.

Use this pragma directive to provide an alias for a header file. This is useful for
substituting one header file with another, and for specifying an absolute path to a relative
file.

This pragma directive must appear before the corresponding #include directives and
subst_header must match its corresponding #include directive exactly.

#pragma include_alias (<stdio.h> , <C:\MyHeaders\stdio.h>)
#include <stdio.h>

This example will substitute the relative file stdio.h with a counterpart located
according to the specified path.

Include file search procedure, page 237.

#pragma inline[=forced|=never]

No parameter Has the same effect as the inline keyword.

forced Disables the compiler’s heuristics and forces inlining.
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never Disables the compiler’s heuristics and makes sure that the
function will not be inlined.

Description Use #pragma inline to advise the compiler that the function defined immediately after
the directive should be inlined according to C++ inline semantics.

Specifying #pragma inline=forced will always inline the defined function. If the
compiler fails to inline the function for some reason, for example due to recursion, a
warning message is emitted.

Inlining is normally performed only on the High optimization level. Specifying
#pragma inline=forced will enable inlining of the function also on the Medium
optimization level.

See also Inlining functions, page 71.
language
Syntax #pragma language={extended|default|save|restore}
Parameters
extended Enables the IAR Systems language extensions from the first

use of the pragma directive and onward.

default From the first use of the pragma directive and onward,
restores the settings for the IAR Systems language
extensions to whatever that was specified by compiler
options.

save|restore Saves and restores, respectively, the IAR Systems language
extensions setting around a piece of source code.

Each use of save must be followed by a matching restore
in the same file without any intervening #include directive.

Description Use this pragma directive to control the use of language extensions.

Example At the top of a file that needs to be compiled with IAR Systems extensions enabled:

#pragma language=extended
/* The rest of the file. */
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See also

location

Syntax

Parameters

Description
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Around a particular part of the source code that needs to be compiled with IAR Systems
extensions enabled, but where the state before the sequence cannot be assumed to be the
same as that specified by the compiler options in use:

#pragma language=save
#pragma language=extended
/* Part of source code. */
#pragma language=restore

-e, page 261 and --strict, page 285.

#pragma location={address|register|NAME}

address The absolute address of the global or static variable or
function for which you want an absolute location.

register An identifier that corresponds to one of the ARM core
registers R4-R11.

NAME A user-defined section name; cannot be a section name
predefined for use by the compiler and linker.

Use this pragma directive to specify:

o The location—the absolute address—of the global or static variable whose
declaration follows the pragma directive. The variables must be declared
__no_init.

e Anidentifier specifying a register. The variable defined after the pragma directive is
placed in the register. The variable must be declared as __no_init and have file
scope.

A string specifying a section for placing either a variable or function whose declaration
follows the pragma directive. Do not place variables that would normally be in different
sections (for example, variables declared as __no_init and variables declared as
const) in the same named section.



Example

See also

message

Syntax

Parameters

Description

Example

object_attribute

Syntax

Parameters

Description
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#pragma location=0xFFFF0400
_ _no_init volatile char PORT1; /* PORT1 is located at address
O0xFFFF0400 */

#pragma location=R8
__no_init int TASK; /* TASK is placed in R8 */

#pragma location="FLASH"
char PORT2; /* PORT2 is located in section FLASH */

/* A better way 1s to use a corresponding mechanism */
#define FLASH _Pragma ("location=\"FLASH\"")

/* .. *)

FLASH int i; /* i is placed in the FLASH section */

Controlling data and function placement in memory, page 216 and Declare and place
your own sections, page 96.

#pragma message (message)

message The message that you want to direct to the standard output
stream.

Use this pragma directive to make the compiler print a message to the standard output
stream when the file is compiled.

#ifdef TESTING

#pragma message("Testing")
#endif

#pragma object_attribute=object_attributel[ object_attribute...]

For information about object attributes that can be used with this pragma directive, see
Object attributes, page 335.

Use this pragma directive to add one or more IAR-specific object attributes to the
declaration or definition of a variable or function. Object attributes affect the actual
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variable or function and not its type. When you define a variable or function, the union
of the object attributes from all declarations including the definition, is used.

Example #pragma object_attribute=__no_init

char bar;

is equivalent to:

__no_init char bar;

See also General syntax rules for extended keywords, page 333.
optimize
Syntax #pragma optimize=[goal] [level] [no_optimization...]
Parameters
goal Choose between:

level

no_optimization

IAR C/C++ Development Guide
360 Compiling and Linking for ARM

size, optimizes for size
balanced, optimizes balanced between speed and size
speed, optimizes for speed.

no_size_constraints, optimizes for speed, but relaxes the
normal restrictions for code size expansion.

Specifies the level of optimization; choose between none,
low, medium, or high.

Disables one or several optimizations; choose between:
no_code_motion, disables code motion

no_cse, disables common subexpression elimination
no_inline, disables function inlining

no_tbaa, disables type-based alias analysis
no_unroll, disables loop unrolling

no_vectorize, disables generation of NEON vector
instructions

no_scheduling, disables instruction scheduling.

vectorize, enables generation of NEON vector instructions
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Description Use this pragma directive to decrease the optimization level, or to turn off some specific
optimizations. This pragma directive only affects the function that follows immediately
after the directive.

The parameters size, balanced, speed, and no_size_constraints only have
effect on the high optimization level and only one of them can be used as it is not
possible to optimize for speed and size at the same time. It is also not possible to use
preprocessor macros embedded in this pragma directive. Any such macro will not be
expanded by the preprocessor.

Note: If you use the #pragma optimize directive to specify an optimization level that
is higher than the optimization level you specify using a compiler option, the pragma
directive is ignored.

Example #pragma optimize=speed
int SmallAndUsedOften ()
{
/* Do something here. */

#pragma optimize=size
int BigAndSeldomUsed ()
{
/* Do something here. */

See also Fine-tuning enabled transformations, page 223.
pack

Syntax #pragma pack (n)
#pragma pack()
#pragma pack({push|pop}[,name] [,n])

Parameters
n Sets an optional structure alignment; one of: 1, 2, 4, 8, 0r 16
Empty list Restores the structure alignment to default
push Sets a temporary structure alignment
pop Restores the structure alignment from a temporarily pushed

alignment

name An optional pushed or popped alignment label
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Description

See also

__printf_args
Syntax

Description

Example

public_equ
Syntax

Parameters

Description

Example

IAR C/C++ Development Guide
Compiling and Linking for ARM

Use this pragma directive to specify the maximum alignment of struct and union
members.

The #pragma pack directive affects declarations of structures following the pragma
directive to the next #pragma pack or the end of the compilation unit.

Note: This can result in significantly larger and slower code when accessing members
of the structure.

Use either __packed or #pragma pack to relax the alignment restrictions for a type
and the objects defined using that type. Mixing __packed and #pragma pack might
lead to unexpected behavior.

Structure types, page 329.

#pragma __printf_args

Use this pragma directive on a function with a printf-style format string. For any call to
that function, the compiler verifies that the argument to each conversion specifier (for
example %d) is syntactically correct.

#pragma __printf_args
int printf(char const *,...);

void PrintNumbers (unsigned short x)

{
printf("%d", x); /* Compiler checks that x is an integer */

#pragma public_equ="symbol", value

symbol The name of the assembler symbol to be defined (string).
value The value of the defined assembler symbol (integer constant
expression).

Use this pragma directive to define a public assembler label and give it a value.

#pragma public_equ="MY_SYMBOL", 0x123456



See also

required

Syntax

Parameters

Description

Example

rtmodel

Syntax

Parameters

Description
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--public_equ, page 281.

#pragma required=symbol

symbol Any statically linked function or variable.

Use this pragma directive to ensure that a symbol which is needed by a second symbol
is included in the linked output. The directive must be placed immediately before the
second symbol.

Use the directive if the requirement for a symbol is not otherwise visible in the
application, for example if a variable is only referenced indirectly through the section it
resides in.

const char copyright[] = "Copyright by me";

#pragma required=copyright
int main()
{

/* Do something here. */

}

Even if the copyright string is not used by the application, it will still be included by the
linker and available in the output.

#pragma rtmodel="key", "value"

"key A text string that specifies the runtime model attribute.

"value" A text string that specifies the value of the runtime model
attribute. Using the special value * is equivalent to not
defining the attribute at all.

Use this pragma directive to add a runtime model attribute to a module, which can be
used by the linker to check consistency between modules.

This pragma directive is useful for enforcing consistency between modules. All modules
that are linked together and define the same runtime attribute key must have the same
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Example

See also

__scanf_args

Syntax

Description

Example

section

Syntax
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value for the corresponding key, or the special value *. It can, however, be useful to state
explicitly that the module can handle any runtime model.

A module can have several runtime model definitions.

Note: The predefined compiler runtime model attributes start with a double underscore.
To avoid confusion, this style must not be used in the user-defined attributes.
#pragma rtmodel="I2C", "ENABLED"

The linker will generate an error if a module that contains this definition is linked with

a module that does not have the corresponding runtime model attributes defined.

Checking module consistency, page 105.

#pragma __scanf_args

Use this pragma directive on a function with a scanf-style format string. For any call to
that function, the compiler verifies that the argument to each conversion specifier (for
example %d) is syntactically correct.

#pragma __scanf_args
int scanf (char const *,...);

int GetNumber ()
{
int nr;
scanf ("%d", &nr); /* Compiler checks that
the argument is a
pointer to an integer */

return nr;

#pragma section="NAME"
alias

#pragma segment="NAME"



Parameters

Description

Example

See also
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NAME The name of the section.

Use this pragma directive to define a section name that can be used by the section
operators __section_begin, _section_end, and __section_size. All section
declarations for a specific section must have the same memory type attribute and
alignment.

Note: To place variables or functions in a specific section, use the #pragma location
directive or the @ operator.

#pragma section="MYSECTION"

Dedicated section operators, page 179 and the chapter Linking your application.

STDC CX_LIMITED_RANGE

Syntax

Parameters

Description

STDC FENV_ACCESS

Syntax

Parameters

#pragma STDC CX_LIMITED_RANGE {ON|OFF|DEFAULT}

ON Normal complex mathematic formulas can be used.
OFF Normal complex mathematic formulas cannot be used.
DEFAULT Sets the default behavior, that is OFF.

Use this pragma directive to specify that the compiler can use the normal complex
mathematic formulas for * (multiplication), / (division), and abs.

Note: This directive is required by Standard C. The directive is recognized but has no
effect in the compiler.

#pragma STDC FENV_ACCESS {ON|OFF|DEFAULT}

ON Source code accesses the floating-point environment. Note
that this argument is not supported by the compiler.

OFF Source code does not access the floating-point environment.

DEFAULT Sets the default behavior, that is OFF.
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Description Use this pragma directive to specify whether your source code accesses the
floating-point environment or not.

Note: This directive is required by Standard C.

STDC FP_CONTRACT

Syntax #pragma STDC FP_CONTRACT {ON|OFF |DEFAULT}
Parameters

ON The compiler is allowed to contract floating-point
expressions.

OFF The compiler is not allowed to contract floating-point
expressions. Note that this argument is not supported by the
compiler.

DEFAULT Sets the default behavior, that is ON.

Description Use this pragma directive to specify whether the compiler is allowed to contract

floating-point expressions or not. This directive is required by Standard C.

Example #pragma STDC FP_CONTRACT=ON

swi_number

Syntax #pragma swi_number=number
Parameters
number The software interrupt number
Description Use this pragma directive together with the __swi extended keyword. It is used as an

argument to the generated svC assembler instruction, and is used for selecting one
software interrupt function in a system containing several such functions.

Example #pragma swi_number=17

See also Software interrupts, page 70.

type_attribute

Syntax #pragma type_attribute=type_attr|[ type_ attr...]

IAR C/C++ Development Guide
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Parameters

Description

Example

See also

unroll

Syntax

Parameters

Description
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For information about type attributes that can be used with this pragma directive, see
TBype attributes, page 333.

Use this pragma directive to specify IAR-specific type attributes, which are not part of
Standard C. Note however, that a given type attribute might not be applicable to all kind
of objects.

This directive affects the declaration of the identifier, the next variable, or the next
function that follows immediately after the pragma directive.
In this example, thumb-mode code is generated for the function foo:

#pragma type_attribute=__thumb
void foo(void)

{

}

This declaration, which uses extended keywords, is equivalent:

__thumb void foo(void)
{
}

The chapter Extended keywords.

#pragma unroll=n

n The number of loop bodies in the unrolled loop, a constant
integer. #pragma unroll = 1 will prevent the unrolling of
a loop.

Use this pragma directive to specify that the loop following immediately after the
directive should be unrolled and that the unrolled loop should have n copies of the loop
body. The pragma directive can only be placed immediately before a for, do, orwhile
loop, whose number of iterations can be determined at compile time.

Normally, unrolling is most effective for relatively small loops. However, in some cases,
unrolling larger loops can be beneficial if it exposes opportunities for further
optimizations between the unrolled loop iterations, for example common subexpression
elimination or dead code elimination.
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Example

See also

vectorize

Syntax

Parameters

Description

Example

weak

Syntax

Parameters
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The #pragma unroll directive can be used to force a loop to be unrolled if the
unrolling heuristics are not aggressive enough. The pragma directive can also be used to
reduce the aggressiveness of the unrolling heuristics.

#pragma unroll=4
for (1 = 0; 1 < 64; ++1)
{
foo(i * k; (1 + 1) * k);

Loop unrolling, page 224

#pragma vectorize [= never]
No parameter Enables generation of NEON vector instructions.
never Disables generation of NEON vector instructions.

Use this pragma directive to enable or disable generation of NEON vector instructions
for the loop that follows immediately after the pragma directive. This pragma directive
can only be placed immediately before a for, do, or while loop. If the optimization
level is lower than High, the pragma directive has no effect.

#pragma vectorize
for (i = 0; 1 < 1024; ++1i)

#pragma weak symboll[=symbol2]

symboll A function or variable with external linkage.

symbol2 A defined function or variable.
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Description This pragma directive can be used in one of two ways:

o To make the definition of a function or variable with external linkage a weak
definition. The __weak attribute can also be used for this purpose.

o To create a weak alias for another function or variable. You can make more than one
alias for the same function or variable.
Example To make the definition of foo a weak definition, write:
#pragma weak foo
To make NMI_Handler a weak alias for Default_Handler, write:
#pragma weak NMI_Handler=Default_Handler
If NMI_Handler is not defined elsewhere in the program, all references to

NMI_Handler will refer to Default_Handler.

See also __weak, page 346.
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Intrinsic functions

e Summary of intrinsic functions

e Descriptions of intrinsic functions

Summary of intrinsic functions

To use intrinsic functions in an application, include the header file intrinsics.h.

To use Neon intrinsic functions in an application, include the header file arm_neon.h.
For more information, see Intrinsic functions for Neon instructions, page 377.

Note that the intrinsic function names start with double underscores, for example:

__disable_interrupt

This table summarizes the intrinsic functions:

Intrinsic function

Description

__as_get_base

__as_get_bounds

__as_make_bounds

__CLREX
__CLZ
__disable_fiqg
__disable_interrupt
__disable_irqg

DMB

__DSB

__enable_fiqg

__enable_interrupt

Creates a pointer of the same type as the parameter,
representing the base of the area pointed to by the
parameter. See the C-RUN documentation in the C-SPY®
Debugging Guide for ARM.

Creates a pointer of the same type as the parameter,
representing the upper bound of the area pointed to by the
parameter. See the C-RUN documentation in the C-SPY®
Debugging Guide for ARM.

Creates a pointer with bounds information. See the C-RUN
documentation in the C-SPY® Debugging Guide for ARM.

Inserts a CLREX instruction

Inserts a CLZ instruction

Disables fast interrupt requests (fiq)
Disables interrupts

Disables interrupt requests (irq)
Inserts a DMB instruction

Inserts a DSB instruction

Enables fast interrupt requests (fiq)

Enables interrupts

Table 34: Intrinsic functions summary
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Intrinsic function Description

__enable_irqg Enables interrupt requests (irq)

__get_BASEPRI Returns the value of the
Cortex-M3/Cortex-M4/Cortex-M7 BASEPRI register

__get_CONTROL Returns the value of the Cortex-M CONTROL register

__get_CPSR Returns the value of the ARM CPSR (Current Program

Status Register)

_ _get_FAULTMASK Returns the value of the
Cortex-M3/Cortex-M4/Cortex-M7 FAULTMASK register

__get_FPSCR Returns the value of FPSCR

__get_interrupt_state Returns the interrupt state

__get_IPSR Returns the value of the IPSR register
__get_LR Returns the value of the link register
__get_MSP Returns the value of the MSP register
__get_PRIMASK Returns the value of the Cortex-M PRIMASK register
__get_PSP Returns the value of the PSP register
__get_PSR Returns the value of the PSR register
__get_SB Returns the value of the static base register
__get_SP Returns the value of the stack pointer register
__1ISB Inserts an ISB instruction

__LDC Inserts the coprocessor load instruction LDC
__LDCL Inserts the coprocessor load instruction LDCL
__LDbC2 Inserts the coprocessor load instruction LDC2
__LDC2L Inserts the coprocessor load instruction LDC2L
_ _LDC_noidx Inserts the coprocessor load instruction LDC
__LDCL_noidx Inserts the coprocessor load instruction LDCL
__LDC2_noidx Inserts the coprocessor load instruction LDC2
_ _LDC2L_noidx Inserts the coprocessor load instruction LDC2L
_ _LDREX Inserts an LDREX instruction

_ _LDREXB Inserts an LDREXB instruction

_ _LDREXD Inserts an LDREXD instruction

_ _LDREXH Inserts an LDREXH instruction

__MCR Inserts the coprocessor write instruction MCR
__MCR2 Inserts the coprocessor write instruction MCR2

Table 34: Intrinsic functions summary (Continued)
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Description

__MRC

__MRC2
__no_operation
__PKHBT
__PKHTB
__PLD
__PLDW
__PLT
__QADD
__0OADDS8
__OQADD16
__0OASX

__OQCFlag

__QDADD
__QDOUBLE
__QDSUB
__QFlag

__0QSAX
__QSUB
__QSUBS8
__QSUB16
__RBIT

_reset_Q_flag

__reset_QC_flag

__REV

__REV16
__REVSH
__SADD8

__SADD16

Inserts the coprocessor read instruction MRC
Inserts the coprocessor read instruction MRC2
Inserts a NOP instruction

Inserts a PKHBT instruction

Inserts a PKHTB instruction

Inserts the preload data instruction PLD
Inserts the preload data instruction PLDW
Inserts a PLT instruction

Inserts a QADD instruction

Inserts a QADDS instruction

Inserts a QADD1 6 instruction

Inserts a QASX instruction

Returns the value of the cumulative saturation flag of the
FPSCR register

Inserts a QDADD instruction
Inserts a QDOUBLE instruction
Inserts a QDSUB instruction

Returns the Q flag that indicates if overflow/saturation has
occurred

Inserts a QSAX instruction
Inserts a QSUB instruction
Inserts a QSUBS instruction
Inserts a QSUB16 instruction
Inserts an RBIT instruction

Clears the Q flag that indicates if overflow/saturation has
occurred

Clears the value of the cumulative saturation flag QC of the
FPSCR register

Inserts an REV instruction

Inserts an REV16 instruction
Inserts an REVSH instruction
Inserts an SADDS instruction

Inserts an SADD16 instruction

Table 34: Intrinsic functions summary (Continued)
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Intrinsic function

Description

__SASX
_SEL

__set_BASEPRI

__set_CONTROL

__set_CPSR

__set_FAULTMASK

__set_FPSCR
__set_interrupt_state
__set_LR
__set_MSP

_ _set_PRIMASK
__set_PSP
__set_SB
__set_SP
__SEV
__SHADDS8
__SHADD16
__SHASX
__SHSAX
__SHSUBS8
__SHSUBL16
__SMLABB
_ _SMLABT
__SMLAD
__SMLADX
__SMLALBB
__SMLALBT
__SMLALD
__SMLALDX

__SMLALTB

Inserts an SASX instruction
Inserts an SEL instruction

Sets the value of the Cortex-M3/Cortex-M4/Cortex-M7
BASEPRI register

Sets the value of the Cortex-M CONTROL register

Sets the value of the ARM CPSR (Current Program Status
Register)

Sets the value of the Cortex-M3/Cortex-M4/Cortex-M7
FAULTMASK register

Sets the value of the FPSCR register

Restores the interrupt state

Assigns a new address to the link register

Sets the value of the MSP register

Sets the value of the Cortex-M PRIMASK register
Sets the value of the PSP register

Assigns a new address to the static base register
Assigns a new address to the stack pointer register
Inserts an SEV instruction

Inserts an SHADDS instruction

Inserts an SHADD1 6 instruction

Inserts an SHASX instruction

Inserts an SHSAX instruction

Inserts an SHSUBS instruction

Inserts an SHSUB1 6 instruction

Inserts an SMLABB instruction

Inserts an SMLABT instruction

Inserts an SMLAD instruction

Inserts an SMLADX instruction

Inserts an SMLALBB instruction

Inserts an SMLALBT instruction

Inserts an SMLALD instruction

Inserts an SMLALDX instruction

Inserts an SMLALTB instruction

Table 34: Intrinsic functions summary (Continued)
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Description

__SMLALTT

__SMLATB

_ _SMLATT

__SMLAWB

__SMLAWT

__SMLSD

__SMLSDX

__SMLSLD

__SMLSLDX

__SMMLA

_SMMLAR

__SMMLS

_SMMLSR

_ _SMMUL

__SMMULR

__SMUAD

__SMUADX

__SMUL

__SMULBB

__SMULBT

__SMULTB

__SMULTT

__SMULWB

__SMULWT

__SMUSD

__SMUSDX

__SSAT

__SSAT16

__SSAX

__SSUBS8

__SSUBl6

_STC

Inserts an SMLALTT instruction
Inserts an SMLATB instruction
Inserts an SMLATT instruction
Inserts an SMLAWB instruction
Inserts an SMLAWT instruction
Inserts an SMLSD instruction
Inserts an SML,SDX instruction
Inserts an SMLSLD instruction
Inserts an SML.SL.DX instruction
Inserts an SMMLA instruction
Inserts an SMMLAR instruction
Inserts an SMMLS instruction
Inserts an SMMLSR instruction
Inserts an SMMUL instruction
Inserts an SMMULR instruction
Inserts an SMUAD instruction
Inserts an SMUADX instruction
Inserts a signed |6-bit multiplication
Inserts an SMULBB instruction
Inserts an SMULBT instruction
Inserts an SMULTB instruction
Inserts an SMULTT instruction
Inserts an SMULWB instruction
Inserts an SMULWT instruction
Inserts an SMUSD instruction
Inserts an SMUSDX instruction
Inserts an SSAT instruction
Inserts an SSAT16 instruction
Inserts an SSAX instruction
Inserts an SSUBS instruction
Inserts an SSUB16 instruction

Inserts the coprocessor store instruction STC

Table 34: Intrinsic functions summary (Continued)
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Intrinsic function

Description

__STCL

__STC2

__STC2L

__STC_noidx

_ _STCL_noidx

__STC2_noidx

__STC2L_noidx

__STREX

_ _STREXB

__STREXD

__STREXH

_SWP

__SWPB

__SXTAB

__SXTAB16

__SXTAH

__SXTB16

__UADDS8

__UADDl6

__UASX

__UHADDS

_UHADD16

__UHASX

__UHSAX

_ _UHSUBS8

__UHSUB16

__UMAAL

__UQADD8

UQADD16

__UQASX

UQSAX

__UQSUBS8

Inserts the coprocessor store instruction STCL
Inserts the coprocessor store instruction STC2
Inserts the coprocessor store instruction STC2L
Inserts the coprocessor store instruction STC
Inserts the coprocessor store instruction STCL
Inserts the coprocessor store instruction STC2
Inserts the coprocessor store instruction STC2L
Inserts a STREX instruction

Inserts a STREXB instruction

Inserts a STREXD instruction

Inserts a STREXH instruction

Inserts an SWP instruction

Inserts an SWPB instruction

Inserts an SXTAB instruction

Inserts an SXTAB16 instruction

Inserts an SXTAH instruction

Inserts an SXTB16 instruction

Inserts a UADDS instruction

Inserts a UADD16 instruction

Inserts a UASX instruction

Inserts a UHADDS instruction

Inserts a UHADD16 instruction

Inserts a UHASX instruction

Inserts a UHSAX instruction

Inserts a UHSUBS instruction

Inserts a UHSUBL6 instruction

Inserts a UMAAL instruction

Inserts a UQADDS instruction

Inserts a UQADD1 6 instruction

Inserts a UQASX instruction

Inserts a UQSAX instruction

Inserts a UQSUBS instruction

Table 34: Intrinsic functions summary (Continued)
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Intrinsic function Description

__UQSUB16 Inserts a UQSUB16 instruction
__USADS8 Inserts a USADS instruction
__USADAS8 Inserts a USAD8AS instruction
__USAT Inserts a USAT instruction
__USAT16 Inserts a USAT16 instruction
__USAX Inserts a USAX instruction
__USUBS8 Inserts a USUBS instruction
__USUBl6 Inserts a USUB16 instruction
_ _UXTAB Inserts a UXTAB instruction
__UXTAB16 Inserts a UXTAB16 instruction
__UXTAH Inserts a UXTAH instruction
__UXTB16 Inserts a UXTB16 instruction
__WFE Inserts a WFE instruction
__WFI Inserts a WFI instruction
__YIELD Inserts a YIELD instruction

Table 34: Intrinsic functions summary (Continued)

INTRINSIC FUNCTIONS FOR NEON INSTRUCTIONS

The Neon co-processor implements the Advanced SIMD instruction set extension, as
defined by the ARM architecture. To use Neon intrinsic functions in an application,
include the header file arm_neon.h. The functions use vector types that are named
according to this pattern:

<type><size>x<number_of_ lanes>_t
where:

® typeisint,unsigned int, float, or poly
® size i$8,16,32,0r 64

® number_of lanesisl, 2,4, 8,0r 16.

The total bit width of a vector type is size times number_of_Ilanes, and should fit in
a D register (64 bits) or a Q register (128 bits).

For example:
__intrinsic float32x2_t vsub_f32(float32x2_t, float32x2_t);

The intrinsic function vsub_£32 inserts a VSUB. F32 instruction that operates on two
64-bit vectors (D registers), each with two elements (lanes) of 32-bit floating-point type.
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Some functions use an array of vector types. As an example, the definition of an array
type with four elements of type £loat32x2_t is:

typedef struct
{
float32x2_t vall[4];
}
float32x2x4_t;

Descriptions of intrinsic functions

__CLREX

Syntax

Description

_CLZ

Syntax

Description

__disable_fiq

Syntax

Description
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This section gives reference information about each intrinsic function.

void __CLREX(void) ;

Inserts a CLREX instruction.

This intrinsic function requires architecture ARMv6K or ARMv7 for ARM mode, and
AVRvV7 for Thumb mode.

unsigned char __CLZ (unsigned long) ;

Inserts a CLZ instruction.

This intrinsic function requires an ARMvS architecture or higher for ARM mode, and
ARMV6T? or higher for Thumb mode.

void __disable_fig(void) ;

Disables fast interrupt requests (fiq).

This intrinsic function can only be used in privileged mode and is not available for
Cortex-M devices.



__disable_interrupt

Syntax

Description

__disable_irq

Syntax

Description

__DMB

Syntax

Description

_DSB

Syntax

Description

__enable_fiq

Syntax

Description

Intrinsic functions __¢

void __disable_interrupt (void) ;
Disables interrupts. For Cortex-M devices, it raises the execution priority level to O by

setting the priority mask bit, PRIMASK. For other devices, it disables interrupt requests
(irq) and fast interrupt requests (fiq).

This intrinsic function can only be used in privileged mode.

void __disable_irqg(void) ;

Disables interrupt requests (irq).

This intrinsic function can only be used in privileged mode and is not available for
Cortex-M devices.

void __DMB(void) ;

Inserts a DMB instruction. This intrinsic function requires an ARMv6M architecture, or
an ARMV7 architecture or higher.

void __DSB(void) ;

Inserts a DSB instruction. This intrinsic function requires an ARMv6M architecture, or
an ARMV7 architecture or higher.

void __enable_fig(void) ;

Enables fast interrupt requests (fiq).

This intrinsic function can only be used in privileged mode, and it is not available for
Cortex-M devices.
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__enable_interrupt

Syntax

Description

__enable_irq

Syntax

Description

__get_BASEPRI

Syntax

Description

__get CONTROL

Syntax

Description

__get_ CPSR

Syntax

Description
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void __enable_interrupt (void) ;
Enables interrupts. For Cortex-M devices, it resets the execution priority level to default

by clearing the priority mask bit, PRIMASK. For other devices, it enables interrupt
requests (irq) and fast interrupt requests (fiq).

This intrinsic function can only be used in privileged mode.

void __enable_irqg(void) ;

Enables interrupt requests (irq).

This intrinsic function can only be used in privileged mode, and it is not available for
Cortex-M devices.

unsigned long __get_BASEPRI (void) ;

Returns the value of the BASEPRI register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M3, Cortex-M4, or Cortex-M7 device.

unsigned long __get_CONTROL (void) ;

Returns the value of the CONTROL register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M device.

unsigned long __get_CPSR(void) ;

Returns the value of the ARM cpsRr (Current Program Status Register). This intrinsic
function can only be used in privileged mode, is not available for Cortex-M devices, and
it requires ARM mode.



__get FAULTMASK

Syntax

Description

__get FPSCR

Syntax

Description

__get_interrupt_state

Syntax

Description

Example

Intrinsic functions __¢

unsigned long __get_ FAULTMASK (void) ;

Returns the value of the FAULTMASK register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M3, Cortex-M4, or Cortex-M7 device.

unsigned long __get_FPSCR(void) ;

Returns the value of FpPSCR (floating-point status and control register).

This intrinsic function is only available for devices with a VFP coprocessor.

__1istate_t __get_interrupt_state(void);

Returns the global interrupt state. The return value can be used as an argument to the
__set_interrupt_state intrinsic function, which will restore the interrupt state.
This intrinsic function can only be used in privileged mode, and cannot be used when
using the --aeabi compiler option.

#include "intrinsics.h"

void CriticalFn()

{
_ _istate_t s = __get_interrupt_state();
__disable_interrupt();

/* Do something here. */

_ set_interrupt_state(s);

}

The advantage of using this sequence of code compared to using
__disable_interrupt and __enable_interrupt is that the code in this example
will not enable any interrupts disabled before the call of __get_interrupt_state.
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__get IPSR

Syntax unsigned long __get_IPSR(void);

Description Returns the value of the IPSR register (Interrupt Program Status Register). This intrinsic
function can only be used in privileged mode, and is only available for Cortex-M
devices.

__get LR
Syntax unsigned long __get_LR(void);
Description Returns the value of the link register (R14).
__get MSP
Syntax unsigned long __get_MSP(void) ;
Description Returns the value of the MSP register (Main Stack Pointer). This intrinsic function can

only be used in privileged mode, and is only available for Cortex-M devices.

__get_PRIMASK

Syntax unsigned long __get_PRIMASK (void) ;

Description Returns the value of the PRIMASK register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M device.

__get PSP
Syntax unsigned long __get_PSP(void);
Description Returns the value of the psP register (Process Stack Pointer). This intrinsic function can

only be used in privileged mode, and is only available for Cortex-M devices.
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__get PSR

Syntax unsigned long __get_PSR(void) ;

Description Returns the value of the PSR register (combined Program Status Register). This intrinsic
function can only be used in privileged mode, and is only available for Cortex-M
devices.

__get SB
Syntax unsigned long __get_SB(void) ;
Description Returns the value of the static base register (R9).
__get SP
Syntax unsigned long __get_SP(void);
Description Returns the value of the stack pointer register (R13).
_ISB

Syntax void __ISB(void) ;

Description Inserts an ISB instruction. This intrinsic function requires an ARMv6M architecture, or
an ARMV7 architecture or higher.

__LDC
__LDCL
__LDC2
__LDC2L
Syntax void __LDCxxx(__ul coproc, __ul CRn, __ul const *src);
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384

Parameters

Description

__LDC noidx
__LDCL noidx
__LDC2 noidx

__LDC2L_noidx

Syntax

Parameters

Description

IAR C/C++ Development Guide
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coproc The coprocessor number 0. . 15.
CRn The coprocessor register to load.
src A pointer to the data to load.

Inserts the coprocessor load instruction LDC—or one of its variants—which means that
a value will be loaded into a coprocessor register. The parameters coproc and CrRn will
be encoded in the instruction and must therefore be constants.

The intrinsic functions __LDC and __LDCL require architecture ARMv4 or higher for
ARM mode, and ARMvV6T?2 or higher for Thumb mode.

The intrinsic functions __1.DC2 and __LDC2L require architecture ARMvS or higher for
ARM mode, and ARMvV6T?2 or higher for Thumb mode.

void __LDCxxx _noidx(__ul coproc, __ul CRn, __ul const *src, __ul
option) ;

coproc The coprocessor number 0. . 15.

CRn The coprocessor register to load.

src A pointer to the data to load.

option Additional coprocessor option 0. . 255.

Inserts the coprocessor load instruction LDC, or one of its variants. A value will be
loaded into a coprocessor register. The parameters coproc, CRn, and option will be
encoded in the instruction and must therefore be constants.

The intrinsic functions __LDC_noidx and __LDCL_noidx require architecture ARMv4
or higher for ARM mode, and ARMvV6T?2 or higher for Thumb mode.



__LDREX

__LDREXB

__LDREXD

__LDREXH

Syntax

Description

_MCR

__MCR2

Syntax

Parameters

Intrinsic functions __¢

The intrinsic functions __LDC2_noidx and __LDC2L_noidx require architecture
ARMYVS or higher for ARM mode, and ARMv6T?2 or higher for Thumb mode.

unsigned long __LDREX (unsigned long *);

unsigned char __LDREXB (unsigned char *);

unsigned long long __LDREXD(unsigned long long *);
unsigned short __LDREXH (unsigned short *);

Inserts the specified instruction.

The __LDREX intrinsic function requires architecture ARMv6 or higher for ARM mode,
and ARMv6T?2 or higher for Thumb mode.

The __LDREXB and the __ LDREXH intrinsic functions require architecture ARMv6K or
ARMYv7 for ARM mode, and ARMv7 for Thumb mode.

The __LDREX intrinsic function requires architecture ARMv6K or ARMv7 for ARM
mode, and ARMv7 but not ARMv7-M for Thumb mode.

void __MCR(__ul coproc, __ul opcode_1, __ul src, __ul CRn, __ul
CRm, __ul opcode_2);

void __MCR2(__ul coproc, __ul opcode 1, __ul src, __ul CRn, __ul
CRm, __ul opcode_2);

coproc The coprocessor number 0. . 15.

opcode_1 Coprocessor-specific operation code.
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386

Description

_MRC

__MRC2

Syntax

Parameters

Description
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src The value to be written to the coprocessor.

CRn The coprocessor register to write to.

CRm Additional coprocessor register; set to zero if not used.

opcode_2 Additional coprocessor-specific operation code; set to zero if
not used.

Inserts a coprocessor write instruction (MCR or MCR2). A value will be written to a
coprocessor register. The parameters coproc, opcode_1, CRn, CRm, and opcode_2 will
be encoded in the instruction and must therefore be constants.

The intrinsic function __MCR requires either ARM mode, or an ARMv6T?2 or higher for
Thumb mode.

The intrinsic function __MCR2 requires an ARMvST architecture or higher for ARM
mode, or ARMv6T2 or higher for Thumb mode.

unsigned long __MRC(__ul coproc, __ul opcode 1, __ul CRn, __ul

CRm, __ul opcode_2);

unsigned long __MRC2(__ul coproc, __ul opcode_1, __ul CRn, __ul

CRm, __ul opcode_2);

coproc The coprocessor number 0. . 15.

opcode_1 Coprocessor-specific operation code.

CRn The coprocessor register to write to.

CRm Additional coprocessor register; set to zero if not used.

opcode_2 Additional coprocessor-specific operation code; set to zero if
not used.

Inserts a coprocessor read instruction (MRC or MRC2). Returns the value of the specified
coprocessor register. The parameters coproc, opcode_1, CRn, CRm, and opcode_2 will
be encoded in the instruction and must therefore be constants.

The intrinsic function __MRC requires either ARM mode, or an ARMvV6T?2 or higher for
Thumb mode.



__ho_operation

Syntax

Description

__PKHBT

Syntax

Parameters

Description

__PKHTB

Syntax

Parameters

Description

Intrinsic functions __¢

The intrinsic function __MRC2 requires an ARMvST architecture or higher for ARM
mode, or ARMv6T?2 or higher for Thumb mode.

void __no_operation (void) ;

Inserts a NOP instruction.

unsigned long __PKHBT (unsigned long x, unsigned long y, unsigned
long count) ;

x First operand.
v Second operand, optionally shifted left.
count Shift count 0-31, where 0 means no shift.

Inserts a PKHBT instruction, with an optionally shifted operand (LSL) for count in the
range 1-31.

This intrinsic function requires an ARM v6 architecture or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __PKHTB(unsigned long x, unsigned long y, unsigned
long count) ;

x First operand.
v Second operand, optionally shifted right (arithmetic shift).
count Shift count 0—32, where 0 means no shift.

Inserts a PKHTB instruction, with an optionally shifted operand (ASR) for count in the
range 1-32.
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This intrinsic function requires an ARM v6 architecture or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARM v7E-M for Thumb mode.

__PLD
__PLDW
Syntax void __PLD(void const *);
void __PLDW(void const *);
Description Inserts a preload data instruction (PLD or PLDW).
The intrinsic function __PLD requires an ARMv7 architecture. __PLDW requires an
ARMV7 architecture with MP extensions (for example Cortex-AS).
_PLI
Syntax void __PLI(void const *);
Description Inserts a PLI instruction.
This intrinsic function requires an ARM v7 architecture.
__QADD
__QDADD
__QDSUB
__QSUB
Syntax signed long __QOxxx(signed long, signed long) ;
Description Inserts the specified instruction.

These intrinsic functions require architecture ARMVSE or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
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__QADDS
__QADDIé
__QASX
__QSAX
__QSUBS

__QSUBIé6

Syntax

Description

__QCFlag

Syntax

Description

__QDOUBLE

Syntax

Description

Intrinsic functions __¢

unsigned long __Qxxx(unsigned long, unsigned long) ;

Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __QCFlag(void) ;

Returns the value of the cumulative saturation flag QC of the FPSCR register
(Floating-point Status and Control Register). This intrinsic function is only available for
devices with Neon (Advanced SIMD).

signed long __QDOUBLE (signed long) ;

Inserts an instruction QADD Rd, Rs, Rs for a source register Rs, and a destination register
Rd.

This intrinsic function requires architecture ARMVSE or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
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__QFlag

Syntax

Description

__RBIT

Syntax

Description

__reset_Q_flag

Syntax

Description

__reset_QC _flag

Syntax

Description
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int __QFlag(void) ;

Returns the ¢ flag that indicates if overflow/saturation has occurred.

This intrinsic function requires architecture ARMVSE or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __RBIT (unsigned long) ;

Inserts an RBIT instruction, which reverses the bit order in a 32-bit register.

This intrinsic function requires architecture ARMvV6T?2 or higher.

void __reset_Q_ flag(void);

Clears the Q flag that indicates if overflow/saturation has occurred.

This intrinsic function requires an ARM V5E architecture or higher for ARM mode, and
ARM v7A, ARM v7R, or ARM v7E-M for Thumb mode.

void __reset_QC_flag(void) ;

Clears the value of the cumulative saturation flag oc of the FPSCR register
(Floating-point Status and Control Register). This intrinsic function is only available for
devices with Neon (Advanced SIMD).
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__REV
__REVIé6
__REVSH
Syntax unsigned long __REV(unsigned long) ;
unsigned long __REV16 (unsigned long) ;
signed long __REVSH(short) ;
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher.
__SADDS8
__SADDI6
__SASX
__SSAX
__SSuBS8
__SSUBI6
Syntax unsigned long __Sxxx(unsigned long, unsigned long);
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
__SEL
Syntax unsigned long __SEL(unsigned long, unsigned long) ;
Description Inserts an SEL instruction.
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__set_BASEPRI

Syntax

Description

__set CONTROL

Syntax

Description

__set_CPSR

Syntax

Description

__set_FAULTMASK

Syntax

Description

__set_FPSCR

Syntax

Description

IAR C/C++ Development Guide
392  Compiling and Linking for ARM

This intrinsic function requires architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

void __set_BASEPRI (unsigned long) ;

Sets the value of the BASEPRT register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M3, Cortex-M4, or Cortex-M7 device.

void __set_CONTROL (unsigned long) ;

Sets the value of the CONTROL register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M device.

void __set_CPSR(unsigned long) ;
Sets the value of the ARM cpsr (Current Program Status Register). Only the control

field is changed (bits 0-7). This intrinsic function can only be used in privileged mode,
is not available for Cortex-M devices, and it requires ARM mode.

void _ _set_FAULTMASK (unsigned long) ;

Sets the value of the FAULTMASK register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M3, Cortex-M4, or Cortex-M7 device.

void __set_FPSCR(unsigned long) ;

Sets the value of FPSCR (floating-point status and control register)

This intrinsic function is only available for devices with a VFP coprocessor.
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__set_interrupt_state

Syntax void __set_interrupt_state(__istate_t);

Description Restores the interrupt state to a value previously returned by the
__get_interrupt_state function.

For information about the __istate_t type, see _get interrupt state, page 381.

__set LR
Syntax void __set_LR(unsigned long) ;
Description Assigns a new address to the link register (R14).
__set_ MSP
Syntax void __set_MSP(unsigned long) ;
Description Sets the value of the MSP register (Main Stack Pointer). This intrinsic function can only

be used in privileged mode, and is only available for Cortex-M devices.

__set_PRIMASK

Syntax void __set_PRIMASK (unsigned long) ;

Description Sets the value of the PRIMASK register. This intrinsic function can only be used in
privileged mode and it requires a Cortex-M device.

__set_PSP
Syntax void __set_PSP(unsigned long);
Description Sets the value of the PSP register (Process Stack Pointer). This intrinsic function can

only be used in privileged mode, and is only available for Cortex-M devices.
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__set_SB
Syntax void __set_SB(unsigned long) ;
Description Assigns a new address to the static base register (R9).
__set_SP
Syntax void __set_SP(unsigned long);
Description Assigns a new address to the stack pointer register (R13).
__SEV
Syntax void __SEV(void) ;
Description Inserts an SEV instruction.
This intrinsic function requires architecture ARMv7 for ARM mode, and ARMv6-M or
ARMYV7 for Thumb mode.
__SHADDS
__SHADDIé6
__SHASX
__SHSAX
__SHSUBS
__SHSUBI6
Syntax unsigned long __SHxxx(unsigned long, unsigned long) ;
Description Inserts the specified instruction.
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These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

__SMLABB
__SMLABT
__SMLATB
__SMLATT
__SMLAWB
__SMLAWT
Syntax unsigned long __SMLAxxx(unsigned long, unsigned long, unsigned
long) ;
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
__SMLAD
__SMLADX
__SMLSD
__SMLSDX
Syntax unsigned long __SMLxxx(unsigned long, unsigned long, unsigned
long) ;
Description Inserts the specified instruction.
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__SMLALBB

__SMLALBT

__SMLALTB

__SMLALTT

Syntax

Description

__SMLALD

__SMLALDX

__SMLSLD

__SMLSLDX

Syntax

Description
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These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long long __SMLALxxx(unsigned long, unsigned long,
unsigned long long) ;

Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long long _ _SMLxxx(unsigned long, unsigned long,
unsigned long long) ;

Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
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__SMMLA
__SMMLAR
__SMMLS
__SMMLSR
Syntax unsigned long __SMMLxxx (unsigned long, unsigned long, unsigned
long) ;
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
__SMMUL
__SMMULR
Syntax unsigned long __SMMULxxx(unsigned long, unsigned long) ;
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMV7-R, or ARMV7E-M for Thumb mode.
__SMUAD
__SMUADX
__SMUSD
__SMUSDX
Syntax unsigned long __SMUxxx(unsigned long, unsigned long) ;
Description Inserts the specified instruction.
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__SMUL

Syntax

Description

__SMULBB

__SMULBT

__SMULTB

__SMULTT

__SMULWB

__SMULWT

Syntax

Description

__SSAT

Syntax

Description
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These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

signed long __SMUL(signed short, signed short);

Inserts a signed 16-bit multiplication.

This intrinsic function requires architecture ARMVS-E or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __SMULxxx(unsigned long, unsigned long) ;

Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __SSAT(unsigned long, unsigned long) ;

Inserts an SSAT instruction.

The compiler will incorporate a shift instruction into the operand when possible. For
example, __SSAT (x << 3,11) compiles to SSAT R4, #11,Rn,LSL #3, where the
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value of x has been placed in register Rn and the return value of __SSAT will be placed
in register Rd.

This intrinsic function requires architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMv7-R, or ARMv7-M for Thumb mode.

__SSATI6
Syntax unsigned long __SSAT16 (unsigned long, unsigned long) ;
Description Inserts an SSAT16 instruction.
This intrinsic function requires architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMV7-R, or ARM v7E-M for Thumb mode.
__STC
__STCL
__STC2
__STC2L
Syntax void __STCxxx(__ul coproc, __ul CRn, __ul const *dst);
Parameters
coproc The coprocessor number 0. . 15.
CRn The coprocessor register to load.
dst A pointer to the destination.
Description Inserts the coprocessor store instruction STC—or one of its variants—which means that

the value of the specified coprocessor register will be written to a memory location. The
parameters coproc and CRn will be encoded in the instruction and must therefore be
constants.

The intrinsic functions __STC and __STCL require architecture ARMv4 or higher for
ARM mode, and ARM v6T?2 or higher for Thumb mode.

The intrinsic functions __STC2 and __ STC2L require architecture ARMvS or higher for
ARM mode, and ARMv6-T?2 or higher for Thumb mode.
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__STC noidx

__STCL _noidx

__STC2 noidx

__STC2L _noidx

Syntax

Parameters

Description
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void __STCxxx noidx(__ul coproc, __ul CRn, __ul const *dst, __ul
option) ;

coproc The coprocessor number 0. . 15.

CRn The coprocessor register to load.

dst A pointer to the destination.

option Additional coprocessor option 0. . 255.

Inserts the coprocessor store instruction STC—or one of its variants—which means that
the value of the specified coprocessor register will be written to a memory location. The
parameters coproc, CRn, and option will be encoded in the instruction and must
therefore be constants.

The intrinsic functions __STC_noidx and __STCL_noidx require architecture
ARMV4 or higher for ARM mode, and ARMv6-T2 or higher for Thumb mode.

The intrinsic functions __STC2_noidx and __STC2L_noidx require architecture
ARMYVS or higher for ARM mode, and ARMv6-T2 or higher for Thumb mode.
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__STREX
__STREXB
__STREXD
__STREXH
Syntax unsigned long _ _STREX (unsigned long, unsigned long *);
unsigned long __STREXB (unsigned char, unsigned char *);
unsigned long __STREXD(unsigned long long, unsigned long long*);
unsigned long _ _STREXH (unsigned short, unsigned short *);
Description Inserts the specified instruction.
The __ sTREX intrinsic function requires architecture ARMv6 or higher for ARM mode,
and ARMv6-T2 or higher for Thumb mode.
The __STREXB and the __ STREXH intrinsic functions require architecture ARMv6K or
ARMvV7 for ARM mode, and ARMv7 for Thumb mode.
The __STREXD intrinsic function requires architecture ARMv6K or ARMv7 for ARM
mode, and ARMv7 except for ARMv7-M for Thumb mode.
__SWP
__SWPB
Syntax unsigned long __SWP(unsigned long, unsigned long *);
char __SWPB(unsigned char, unsigned char *);
Description Inserts the specified instruction.

These intrinsic functions require ARM mode.
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__SXTAB

__SXTABI6

__SXTAH

__SXTBI6

Syntax unsigned long __SXTxxx(unsigned long, unsigned long) ;

Description Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

__UADDS8

__UADDIé6

__UASX

__USAX

__UsuBs

__USuUBIé6

Syntax unsigned long _ _Uxxx(unsigned long, unsigned long) ;

Description Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
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__UHADDS
__UHADDIé6
__UHASX
__UHSAX
__UHSUBS
__UHSUBI®6
Syntax unsigned long _ _UHxxx(unsigned long, unsigned long);
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
__UMAAL
Syntax unsigned long long __UMAAL (unsigned long, unsigned long,
unsigned long, unsigned long) ;
Description Inserts an UMAAL instruction.

This intrinsic function requires architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMV7-R, or ARMV7E-M for Thumb mode.
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__UQADDS
__UQADDIé6
__UQASX
__UQSAX
__UQSUBS8

__UQSUBIé6

Syntax

Description

__USADS8

__USADAS

Syntax

Description

__USAT

Syntax

Description
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unsigned long __UQxxx(unsigned long, unsigned long) ;

Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __USADxxx(unsigned long, unsigned long) ;

Inserts the specified instruction.

These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.

unsigned long __USAT (unsigned long, unsigned long) ;

Inserts a USAT instruction.

The compiler will incorporate a shift instruction into the operand when possible. For
example, __USAT (x << 3,11) compiles to USAT Rd, #11,Rn,LSL #3, where the

[ J—
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value of x has been placed in register Rn and the return value of __UsAT will be placed
in register Rd.

This intrinsic function requires architecture ARMv6 or higher for ARM mode, and
ARMv7-A, ARMv7-R, or ARMv7-M for Thumb mode.

__USATI®6
Syntax unsigned long __USAT16 (unsigned long, unsigned long) ;
Description Inserts a USAT16 instruction.
This intrinsic function requires architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMvV7-R, or ARMV7E-M for Thumb mode.
__UXTAB
__UXTABI 6
__UXTAH
__UXTBI6
Syntax unsigned long __UXTxxx(unsigned long, unsigned long) ;
Description Inserts the specified instruction.
These intrinsic functions require architecture ARMv6 or higher for ARM mode, and
ARMvV7-A, ARMv7-R, or ARMV7E-M for Thumb mode.
__WFE
__WFI
__YIELD
Syntax void long __xxx(void) ;
Description Inserts the specified instruction.

405



Descriptions of intrinsic functions

These intrinsic functions require architecture ARMv7 for ARM mode, and ARMv6-M,
or ARMv7 for Thumb mode.
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The preprocessor

e Overview of the preprocessor
e Description of predefined preprocessor symbols

e Descriptions of miscellaneous preprocessor extensions

Overview of the preprocessor
The preprocessor of the IAR C/C++ Compiler for ARM adheres to Standard C. The
compiler also makes these preprocessor-related features available to you:
e Predefined preprocessor symbols

These symbols allow you to inspect the compile-time environment, for example the
time and date of compilation. For more information, see Description of predefined
preprocessor symbols, page 408.

o User-defined preprocessor symbols defined using a compiler option

In addition to defining your own preprocessor symbols using the #define directive,
you can also use the option -D, see -D, page 256.

[ ] Preprocessor extensions

There are several preprocessor extensions, for example many pragma directives; for
more information, see the chapter Pragma directives. For information about the
corresponding _Pragma operator and the other extensions related to the
preprocessor, see Descriptions of miscellaneous preprocessor extensions, page 414.

e Preprocessor output

Use the option --preprocess to direct preprocessor output to a named file, see
--preprocess, page 281.

To specify a path for an include file, use forward slashes:
#include "mydirectory/myfile"

In source code, use forward slashes:

file = fopen("mydirectory/myfile","rt");

Note that backslashes can also be used. In this case, use one in include file paths and two
in source code strings.
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Description of predefined preprocessor symbols

This section lists and describes the preprocessor symbols.

__AAPCS__

Description An integer that is set based on the --aapcs option. The symbol is set to 1 if the AAPCS
base standard is the selected calling convention (--aapcs=std). The symbol is
undefined for other calling conventions.

See also --aapcs, page 252.

__AAPCS_VFP__

Description An integer that is set based on the --aapcs option. The symbol is set to 1 if the VFP
variant of AAPCS is the selected calling convention (--aapcs=vfp). The symbol is
undefined for other calling conventions.

See also --aapcs, page 252.

__ARM_ADVANCED_SIMD__

Description An integer that is set based on the --cpu option. The symbol is set to 1 if the selected
processor architecture has the Advanced SIMD architecture extension. The symbol is
undefined for other cores.

See also --cpu, page 254.
__ARM_MEDIA__
Description An integer that is set based on the --cpu option. The symbol is set to 1 if the selected

processor architecture has the ARMv6 SIMD extensions for multimedia. The symbol is
undefined for other cores.

See also --cpu, page 254.
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__ARM_PROFILE_M__

Description

See also

__ARMVFP__

Description

See also

__ARMVFP_DI6__

Description

See also

__ARMVFP_FPI16__

Description

See also

__ARMVFP_SP__

Description

See also

The preprocessor Py

An integer that is set based on the --cpu option. The symbol is set to 1 if the selected
processor architecture is a profile M core. The symbol is undefined for other cores.

--cpu, page 254.

An integer that reflects the --£fpu option and is defined to __ARMVFPV2__,
__ARMVFPV3__,or __ARMVFPV4__. These symbolic names can be used when testing
the __ArRMvFP__ symbol. If VFP code generation is disabled (default), the symbol will
be undefined.

--fpu, page 265.

An integer that is set based on the --fpu option. The symbol is set to 1 if the selected
FPU is a VFPv3 or VFPv4 unit with only 16 D registers. Otherwise, the symbol is
undefined.

--fpu, page 265.

An integer that is set based on the --fpu option. The symbol is set to 1 if the selected
FPU only supports 16-bit floating-point numbers. Otherwise, the symbol is undefined.

--fpu, page 265.

An integer that is set based on the --fpu option. The symbol is set to 1 if the selected
FPU only supports 32-bit single-precision. Otherwise, the symbol is undefined.

--fpu, page 265.
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__BASE_FILE__

Description

See also

__BUILD_NUMBER__

Description

__CORE__

Description

__COUNTER__

Description

__cplusplus

Description

__CPU_MODE__

Description
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A string that identifies the name of the base source file (that is, not the header file), being
compiled.

__FILE ,page4ll, and --no_path_in_file macros, page 274.

A unique integer that identifies the build number of the compiler currently in use.

An integer that identifies the chip core in use. The value reflects the setting of the --cpu

option and is defined to __ARM4TM__, _ARM5__, _ARMSE__, _ARM6__,
__ARM6M__, __ARM6SM__, _ARM7M__,_ _ARM7EM__, __ARM7A__,Or
__ARM7R___. These symbolic names can be used when testing the __CORE___ symbol.

A macro that expands to a new integer each time it is expanded, starting at zero (0) and
counting up.

An integer which is defined when the compiler runs in any of the C++ modes, otherwise
it is undefined. When defined, its value is 199711L. This symbol can be used with
#ifdef to detect whether the compiler accepts C++ code. It is particularly useful when
creating header files that are to be shared by C and C++ code.

This symbol is required by Standard C.

An integer that reflects the selected CPU mode and is defined to 1 for Thumb and 2 for
ARM.



__DATE__

Description

__embedded_cplusplus

Description

__FILE__

Description

See also

__func__

Description

See also

__FUNCTION__

Description

See also

The preprocessor Py

A string that identifies the date of compilation, which is returned in the form "Mmm dd
vyyy', for example "oct 30 2014"

This symbol is required by Standard C.

An integer which is defined to 1 when the compiler runs in Embedded C++ or Extended
Embedded C++ mode, otherwise the symbol is undefined. This symbol can be used with
#1ifdef to detect whether the compiler accepts C++ code. It is particularly useful when
creating header files that are to be shared by C and C++ code.

This symbol is required by Standard C.

A string that identifies the name of the file being compiled, which can be both the base
source file and any included header file.

This symbol is required by Standard C.

__BASE FILE _, page 410, and --no_path_in_file_macros, page 274.

A predefined string identifier that is initialized with the name of the function in which
the symbol is used. This is useful for assertions and other trace utilities. The symbol
requires that language extensions are enabled.

This symbol is required by Standard C.

-e, page 261 and  PRETTY FUNCTION _, page 412.

A predefined string identifier that is initialized with the name of the function in which
the symbol is used. This is useful for assertions and other trace utilities. The symbol
requires that language extensions are enabled.

-e, page 261 and  PRETTY FUNCTION _, page 412.
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__IAR_SYSTEMS_ICC_

Description

__ICCARM__

Description

__LINE__

Description

__LITTLE_ENDIAN__

Description

An integer that identifies the IAR compiler platform. The current value is 8. Note that
the number could be higher in a future version of the product. This symbol can be tested
with #ifdef to detect whether the code was compiled by a compiler from IAR Systems.

An integer that is set to 1 when the code is compiled with the IAR C/C++ Compiler for
ARM.

An integer that identifies the current source line number of the file being compiled,
which can be both the base source file and any included header file.

This symbol is required by Standard C.

An integer that reflects the setting of the --endian option and is defined to 1 when the
byte order is little-endian. The symbol is defined to 0 when the byte order is big-endian.

An integer that reflects the byte order and is defined to 0 (big-endian).

__PRETTY_FUNCTION__

Description

See also

__ROPIL__

Description

See also
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A predefined string identifier that is initialized with the function name, including
parameter types and return type, of the function in which the symbol is used, for
example "void func (char) ". This symbol is useful for assertions and other trace
utilities. The symbol requires that language extensions are enabled.

-e, page 261 and__func__, page 411.

An integer that is defined when the --ropi compiler option is used.

--ropi, page 283.



__RWPIL__

Description

See also

__STDC__

Description

__STDC_VERSION__

Description

__TIME__

Description

__TIMESTAMP__

Description

__VER__

Description

The preprocessor Py

An integer that is defined when the --rwpi compiler option is used.

--rwpi, page 284.

An integer that is set to 1, which means the compiler adheres to Standard C. This symbol
can be tested with #i fdef to detect whether the compiler in use adheres to Standard C.*

This symbol is required by Standard C.

An integer that identifies the version of the C standard in use. The symbol expands to
199901L,unless the --c89 compiler option is used in which case the symbol expands
to 199409L. This symbol does not apply in EC++ mode.

This symbol is required by Standard C.

A string that identifies the time of compilation in the form "hh:mm:ss".

This symbol is required by Standard C.

A string constant that identifies the date and time of the last modification of the current
source file. The format of the string is the same as that used by the asctime standard
function (in other words, "Tue Sep 16 13:03:52 2014").

An integer that identifies the version number of the IAR compiler in use. For example,
version 5.11.3 is returned as 5011003.
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Descriptions of miscellaneous preprocessor extensions

NDEBUG

Description

See also

#warning message

Syntax

Description
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This section gives reference information about the preprocessor extensions that are
available in addition to the predefined symbols, pragma directives, and Standard C
directives.

This preprocessor symbol determines whether any assert macros you have written in
your application shall be included or not in the built application.

If this symbol is not defined, all assert macros are evaluated. If the symbol is defined,
all assert macros are excluded from the compilation. In other words, if the symbol is:

o defined, the assert code will not be included

e not defined, the assert code will be included

This means that if you write any assert code and build your application, you should
define this symbol to exclude the assert code from the final application.

Note that the assert macro is defined in the assert .h standard include file.
In the IDE, the NDEBUG symbol is automatically defined if you build your application in

the Release build configuration.

__aeabi_assert, page 132.

#warning message
where message can be any string.
Use this preprocessor directive to produce messages. Typically, this is useful for

assertions and other trace utilities, similar to the way the Standard C #error directive
is used. This directive is not recognized when the --strict compiler option is used.



C/C++ standard library
functions

e C/C++ standard library overview
e DLIB runtime environment—implementation details

For detailed reference information about the library functions, see the online
help system.

C/C++ standard library overview

The IAR DLIB Runtime Environment is a complete implementation of the C/C++
standard library, compliant with Standard C and C++. This library also supports
floating-point numbers in IEEE 754 format and it can be configured to include different
levels of support for locale, file descriptors, multibyte characters, etc.

For more information about customization, see the chapter The DLIB runtime
environment.

For detailed information about the library functions, see the online documentation
supplied with the product. There is also keyword reference information for the DLIB
library functions. To obtain reference information for a function, select the function
name in the editor window and press F1.

For more information about library functions, see the chapter /mplementation-defined
behavior for Standard C in this guide.

HEADER FILES

Your application program gains access to library definitions through header files, which
it incorporates using the #include directive. The definitions are divided into several
different header files, each covering a particular functional area, letting you include just
those that are required.

It is essential to include the appropriate header file before making any reference to its
definitions. Failure to do so can cause the call to fail during execution, or generate error
or warning messages at compile time or link time.
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LIBRARY OBJECT FILES

Most of the library definitions can be used without modification, that is, directly from
the library object files that are supplied with the product. For information about how to
set up a runtime library, see Setting up the runtime environment, page 111. The linker
will include only those routines that are required—directly or indirectly—by your
application.

ALTERNATIVE MORE ACCURATE LIBRARY FUNCTIONS

The default implementation of cos, sin, tan, and pow is designed to be fast and small.
As an alternative, there are versions designed to provide better accuracy. They are
named __iar_xxx_accuratef for float variants of the functions and
__iar_xxx_accuratel for long double variants of the functions, and where xxx is
cos, sin, etc.

To use any of these more accurate versions, use the --redirect linker option.

REENTRANCY

A function that can be simultaneously invoked in the main application and in any
number of interrupts is reentrant. A library function that uses statically allocated data is
therefore not reentrant.

Most parts of the DLIB runtime environment are reentrant, but the following functions
and parts are not reentrant because they need static data:

o Heap functions—malloc, free, realloc, calloc, and the C++ operators new
and delete
Locale functions—1localeconv, setlocale

Multibyte functions—mbrlen, mbrtowc, mbsrtowc, mbtowc, wertomb,
wcsrtomb, wectomb

Rand functions—rand, srand
Time functions—asctime, localtime, gmtime, mktime

The miscellaneous functions atexit, strerror, strtok

Functions that use files or the heap in some way. This includes scanf, sscanf,
getchar, and putchar. In addition, if you are using the options
--enable_multibyte and --dlib_config=Full, the printf and sprintf
functions (or any variants) can also use the heap.

Functions that can set errno are not reentrant, because an errno value resulting from
one of these functions can be destroyed by a subsequent use of the function before it is
read. This applies to math and string conversion functions, among others.
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Remedies for this are:

o Do not use non-reentrant functions in interrupt service routines

o Guard calls to a non-reentrant function by a mutex, or a secure region, etc.

THE LONGJMP FUNCTION

A longjmp is in effect a jump to a previously defined setjmp. Any variable length
& arrays or C++ objects residing on the stack during stack unwinding will not be
destroyed. This can lead to resource leaks or incorrect application behavior.

DLIB runtime environment—implementation details
The DLIB runtime environment provides most of the important C and C++ standard
library definitions that apply to embedded systems. These are of the following types:

o Adherence to a free-standing implementation of Standard C. The library supports
most of the hosted functionality, but you must implement some of its base
functionality. For additional information, see the chapter Implementation-defined
behavior for Standard C in this guide.

e Standard C library definitions, for user programs.
® C++ library definitions, for user programs.

® CSTARTUP, the module containing the start-up code, see the chapter The DLIB
runtime environment in this guide.

o Runtime support libraries; for example low-level floating-point routines.
e Intrinsic functions, allowing low-level use of ARM features. See the chapter

Intrinsic functions for more information.

In addition, the DLIB runtime environment includes some added C functionality, see
Added C functionality, page 421.

C HEADER FILES

This section lists the C header files specific to the DLIB runtime environment. Header
files may additionally contain target-specific definitions; these are documented in the
chapter Using C.

This table lists the C header files:

Header file Usage
assert.h Enforcing assertions when functions execute
complex.h Computing common complex mathematical functions

Table 35: Traditional Standard C header files—DLIB
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Header file Usage

ctype.h Classifying characters

errno.h Testing error codes reported by library functions
fenv.h Floating-point exception flags

float.h Testing floating-point type properties
inttypes.h Defining formatters for all types defined in stdint.h
iso0646.h Using Amendment |—iso646.h standard header
limits.h Testing integer type properties

locale.h Adapting to different cultural conventions
math.h Computing common mathematical functions
setjmp.h Executing non-local goto statements

signal.h Controlling various exceptional conditions
stdarg.h Accessing a varying number of arguments
stdbool.h Adds support for the bool data type in C.
stddef.h Defining several useful types and macros
stdint.h Providing integer characteristics

stdio.h Performing input and output

stdlib.h Performing a variety of operations

string.h Manipulating several kinds of strings

tgmath.h Type-generic mathematical functions

time.h Converting between various time and date formats
uchar.h Unicode functionality (IAR extension to Standard C)
wchar.h Support for wide characters

wctype.h Classifying wide characters

Table 35: Traditional Standard C header files—DLIB (Continued)

C++ HEADER FILES
This section lists the C++ header files:

® The C++ library header files
The header files that constitute the Standard C++ and the Embedded C++ library.
o The C++ standard template library (STL) header files

The header files that constitute STL for the Standard C++ and the Extended
Embedded C++ library.

® The C++ C header files

IAR C/C++ Development Guide
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The C++ header files that provide the resources from the C library.

The C++ library header files

This table lists the header files that can be used in C++ as well as in Embedded C++:

Header file Usage

complex Defining a class that supports complex arithmetic

exception Defining several functions that control exception handling; only usable in
C++

fstream Defining several /O stream classes that manipulate external files

iomanip Declaring several I/O stream manipulators that take an argument

ios Defining the class that serves as the base for many I/O streams classes

iosfwd Declaring several /O stream classes before they are necessarily defined

iostream Declaring the I/O stream objects that manipulate the standard streams

istream Defining the class that performs extractions

limits Defining numerical values; only usable in C++

locale Adapting to different cultural conventions; only usable in C++

new Declaring several functions that allocate and free storage

ostream Defining the class that performs insertions

sstream Defining several /O stream classes that manipulate string containers

stdexcept Defining several classes useful for reporting exceptions; only usable in C++

streambuf Defining classes that buffer I/O stream operations

string Defining a class that implements a string container

strstream Defining several /O stream classes that manipulate in-memory character
sequences

typeinfo Defining type information support; only usable in C++

Table 36: C++ header files

The C++ standard template library (STL) header files

The following table lists the standard template library (STL) header files that can be
used in C++ as well as in Extended Embedded C++:

Header file Description

algorithm Defines several common operations on sequences

bitset Defining a container with fixed-sized sequences of bits; only usable in
C++

Table 37: Standard template library header files
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Header file Description

deque A deque sequence container

functional Defines several function objects

hash_map A map associative container, based on a hash algorithm
hash_set A set associative container, based on a hash algorithm
iterator Defines common iterators, and operations on iterators
list A doubly-linked list sequence container

map A map associative container

memory Defines facilities for managing memory

numeric Performs generalized numeric operations on sequences
queue A queue sequence container

set A set associative container

slist A singly-linked list sequence container

stack A stack sequence container

utility Defines several utility components

valarray Defining varying length array container; only usable in C++
vector A vector sequence container

Table 37: Standard template library header files (Continued)

Using Standard C libraries in C++

The C++ library works in conjunction with some of the header files from the Standard
C library, sometimes with small alterations. The header files come in two forms—new
and traditional—for example, cassert and assert.h.

This table shows the new header files:

Header file Usage

cassert Enforcing assertions when functions execute
ccomplex Computing common complex mathematical functions
cctype Classifying characters

cerrno Testing error codes reported by library functions
cfenv Floating-point exception flags

cfloat Testing floating-point type properties

cinttypes Defining formatters for all types defined in stdint.h
ciso646 Using Amendment |—iso646.h standard header

Table 38: New Standard C header files—DLIB
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Header file Usage

climits Testing integer type properties

clocale Adapting to different cultural conventions
cmath Computing common mathematical functions
csetjmp Executing non-local goto statements
csignal Controlling various exceptional conditions
cstdarg Accessing a varying number of arguments
cstdbool Adds support for the bool data type in C.
cstddef Defining several useful types and macros
cstdint Providing integer characteristics

cstdio Performing input and output

cstdlib Performing a variety of operations
cstring Manipulating several kinds of strings
ctgmath Type-generic mathematical functions
ctime Converting between various time and date formats
cwchar Support for wide characters

cwctype Classifying wide characters

Table 38: New Standard C header files—DLIB (Continued)

LIBRARY FUNCTIONS AS INTRINSIC FUNCTIONS

Certain C library functions will under some circumstances be handled as intrinsic
functions and will generate inline code instead of an ordinary function call, for example
memcpy, memset, and strcat.

ADDED C FUNCTIONALITY
The DLIB runtime environment includes some added C functionality.

The following include files provide these features:

fenv.h
iar_dlmalloc.h
stdio.h
stdlib.h

string.h

time.h
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fenv.h

In fenv.h, trap handling support for floating-point numbers is defined with the
functions fegettrapenable and fegettrapdisable.

iar_dimalloc.h

The iar_dlmalloc.h header file contains support for the advanced (dlmalloc) heap
handler. For more information, see Heap considerations, page 199.

stdio.h

These functions provide additional I/O functionality:

fdopen Opens a file based on a low-level file descriptor.

fileno Gets the low-level file descriptor from the file descriptor
(FILE*).

__gets Corresponds to fgets on stdin.

getw Gets a wchar_t character from stdin.

putw Puts a wchar_t character to stdout.

__ungetchar Corresponds to ungetc on stdout.

__write_array Corresponds to fwrite on stdout.

string.h

These are the additional functions defined in string.h:

strdup Duplicates a string on the heap.

strcasecmp Compares strings case-insensitive.
strncasecmp Compares strings case-insensitive and bounded.
strnlen Bounded string length.

time.h

There are two interfaces for using time_t and the associated functions time, ctime,
difftime, gmtime, localtime, and mktime:

o The 32-bit interface supports years from 1900 up to 2035 and uses a 32-bit integer
for time_t. The type and function have names like __time32_t, __time32, etc.
This variant is mainly available for backwards compatibility.

——
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o The 64-bit interface supports years from -9999 up to 9999 and uses a signed
long long for time_t. The type and function have names like __time64_t,
__timeéb4, etc.

In both interfaces, time_t starts at the year 1970.
The interfaces are defined in the system header file time.h.

An application can use either interface, and even mix them by explicitly using the 32-
or 64-bit variants. By default, the library and the header redirect time_t, time etc. to
the 32-bit variants. However, to explicitly redirect them to their 64-bit variants, define
_DLIB_TIME_USES_64 in front of the inclusion of time.h or ctime.

See also, _ time32, page 138.

clock_t is represented by a 32-bit integer type.

SYMBOLS USED INTERNALLY BY THE LIBRARY

The following symbols are used by the library, which means that they are visible in
library source files, etc:

__assignment_by bitwise_copy_allowed
This symbol determines properties for class objects.
__code, __data

These symbols are used as memory attributes internally by the compiler, and they might
have to be used as arguments in certain templates.

__constrange ()

Determines the allowed range for a parameter to an intrinsic function and that the
parameter must be of type const.

__construction_by_bitwise_copy_allowed
This symbol determines properties for class objects.
__has_constructor, __has_destructor

These symbols determine properties for class objects and they function like the sizeof
operator. The symbols are true when a class, base class, or member (recursively) has a
user-defined constructor or destructor, respectively.

__memory_of

Determines the class memory. A class memory determines which memory a class
object can reside in. This symbol can only occur in class definitions as a class memory.
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Note: The symbols are reserved and should only be used by the library.

Use the compiler option --predef_macros to determine the value for any predefined
symbols.

IAR C/C++ Development Guide
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The linker configuration
file

e Overview

e Defining memories and regions

e Regions

e Section handling

e Section selection

e Using symbols, expressions, and numbers
e Structural configuration

Before you read this chapter you must be familiar with the concept of sections,
see Modules and sections, page 76.

Overview

To link and locate an application in memory according to your requirements, ILINK
needs information about how to handle sections and how to place them into the available
memory regions. In other words, ILINK needs a configuration, passed to it by means of
the linker configuration file.

This file consists of a sequence of directives and typically, provides facilities for:

e Defining available addressable memories

giving the linker information about the maximum size of possible addresses and
defining the available physical memory, as well as dealing with memories that can be
addressed in different ways.

e Defining the regions of the available memories that are populated with ROM or
RAM

giving the start and end address for each region.
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e Section groups

dealing with how to group sections into blocks and overlays depending on the section
requirements.

o Defining how to handle initialization of the application

giving information about which sections that are to be initialized, and how that
initialization should be made.

e Memory allocation
defining where—in what memory region—each set of sections should be placed.
o Using symbols, expressions, and numbers

expressing addresses and sizes, etc, in the other configuration directives. The
symbols can also be used in the application itself.

e Structural configuration
meaning that you can include or exclude directives depending on a condition, and to
split the configuration file into several different files.

Comments can be written either as C comments (/*. . .*/) or as C++ comments

/...

Defining memories and regions

IAR C/C++ Development Guide
Compiling and Linking for ARM

ILINK needs information about the available memory spaces, or more specifically it
needs information about:

o The maximum size of possible addressable memories

The define memory directive defines a memory space with a given size, which is
the maximum possible amount of addressable memory, not necessarily physically
available. See define memory directive, page 427.

e Available physical memory

The define region directive defines a region in the available memories in which
specific sections of application code and sections of application data can be placed.
See define region directive, page 427.

A region consists of one or several memory ranges. A range is a continuous sequence
of bytes in a memory and several ranges can be expressed by using region
expressions. See Region expression, page 429.

This section gives detailed information about each linker directive specific to defining
memories and regions.
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define memory directive

Syntax

Parameters

Description

Example

define region directive

Syntax

Parameters

Description

define memory [ name ] with size = size expr [ ,unit-size 1;
where unit-sizeis one of:

unitbitsize = bitsize_expr
unitbytesize = bytesize expr

and where expr is an expression, see expressions, page 446.

size_expr Specifies how many units the memory space
contains; always counted from address zero.

bitsize_expr Specifies how many bits each unit contains.

bytesize expr Specifies how many bytes each unit contains. Each
byte contains 8 bits.

The define memory directive defines a memory space with a given size, which is the
maximum possible amount of addressable memory, not necessarily physically available.
This sets the limits for the possible addresses to be used in the linker configuration file.
For many microcontrollers, one memory space is sufficient. However, some
microcontrollers require two or more. For example, a Harvard architecture usually
requires two different memory spaces, one for code and one for data. If only one
memory is defined, the memory name is optional. If no unit-sizeis given, the unit
contains 8 bits.

/* Declare the memory space Mem of four Gigabytes */
define memory Mem with size = 4G;

define region name = region-expr;

where region-expr is a region expression, see also Regions, page 428.

name The name of the region.

The define region directive defines a region in which specific sections of code and
sections of data can be placed. A region consists of one or several memory ranges, where
each memory range consists of a continuous sequence of bytes in a specific memory.
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Example

Several ranges can be combined by using region expressions. Note that those ranges do
not need to be consecutive or even in the same memory.

/* Define the 0x10000-byte code region ROM located at address
0x10000 in memory Mem */
define region ROM = Mem: [from 0x10000 size 0x10000];

Regions

Region literal

Syntax

Parameters

Description

IAR C/C++ Development Guide
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A region is s a set of non-overlapping memory ranges. A region expression is built up
out of region literals and set operations (union, intersection, and difference) on regions.

[ memory-name: ]1[from expr { to expr | size expr }

[ repeat expr [ displacement expr 11]

where expr is an expression, see expressions, page 446.

memory-name The name of the memory space in which the region literal
will be located. If there is only one memory, the name is
optional.

from expr expr is the start address of the memory range (inclusive).

to expr expr is the end address of the memory range (inclusive).

size expr expr is the size of the memory range.

repeat expr expr defines several ranges in the same memory for the

region literal.

displacement expr expristhe displacement from the previous range start in the
repeat sequence. Default displacement is the same value as
the range size.

A region literal consists of one memory range. When you define a range, the memory it
resides in, a start address, and a size must be specified. The range size can be stated
explicitly by specifying a size, or implicitly by specifying the final address of the range.
The final address is included in the range and a zero-sized range will only contain an
address. A range can span over the address zero and such a range can even be expressed
by unsigned values, because it is known where the memory wraps.
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The repeat parameter will create a region literal that contains several ranges, one for
each repeat. This is useful for banked or far regions.

Exmnpk /* The 5-byte size range spans over the address zero */
Mem: [from -2 to 2]

/* The 512-byte size range spans over zero, in a 64-Kbyte memory
*/
Mem: [from OxXFF00 to OxFF]

/* Defining several ranges in the same memory, a repeating
literal */
Mem: [from 0 size 0x100 repeat 3 displacement 0x1000]

/* Resulting in a region containing:
Mem: [from 0 size 0x100]
Mem: [from 0x1000 size 0x100]
Mem: [from 0x2000 size 0x100]

*/
See also define region directive, page 427, and Region expression, page 429.
Region expression
Syntax region-operand
| region-expr | region-operand

| region-expr - region-operand
| region-expr & region-operand

where region-operand is one of:

( region-expr )
region-name
region-literal
empty-region

where region-name is a region, see define region directive, page 427

where region-literal is aregion literal, see Region literal, page 428

and where empty-region is an empty region, see Empty region, page 430.
Description Normally, a region consists of one memory range, which means a region literal is

sufficient to express it. When a region contains several ranges, possibly in different

memories, it is instead necessary to use a region expression to express it. Region
expressions are actually set expressions on sets of memory ranges.
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Example

Empty region
Syntax

Description

Example

IAR C/C++ Development Guide
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To create region expressions, three operators are available: union (| ), intersection (&),
and difference (-). These operators work as in set theory. For example, if you have the
sets A and B, then the result of the operators would be:

e A | B:all elements in either set A or set B
e A & B:all elements in both set A and B

e A - B:all elements in set A but not in B.

/* Resulting in a range starting at 1000 and ending at 2FFF, in
memory Mem */
Mem: [from 0x1000 to Ox1FFF] | Mem:[from 0x1500 to Ox2FFF]

/* Resulting in a range starting at 1500 and ending at 1FFF, in
memory Mem */
Mem: [from 0x1000 to OxX1FFF] & Mem: [from 0x1500 to Ox2FFF]

/* Resulting in a range starting at 1000 and ending at 14FF, in
memory Mem */
Mem: [from 0x1000 to OxX1FFF] - Mem: [from 0x1500 to Ox2FFF]

/* Resulting in two ranges. The first starting at 1000 and ending
at 1FFF, the second starting at 2501 and ending at 2FFF.
Both located in memory Mem */

Mem: [from 0x1000 to Ox2FFF] - Mem: [from 0x2000 to Ox24FF]

The empty region does not contain any memory ranges. If the empty region is used in a
placement directive that actually is used for placing one or more sections, ILINK will
issue an error.

define region Code = Mem: [from 0 size 0x10000];
if (Banked) {
define region Bank = Mem: [from 0x8000 size 0x1000];
} else {
define region Bank = [];
}

define region NonBanked = Code - Bank;

/* Depending on the Banked symbol, the NonBanked region is either
one range with 0x10000 bytes, or two ranges with 0x8000 and
0x7000 bytes, respectively. */
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See also Region expression, page 429.

Section handling
Section handling describes how ILINK should handle the sections of the execution
image, which means:
e Placing sections in regions

The place at and place into directives place sets of sections with similar
attributes into previously defined regions. See place at directive, page 438 and place
in directive, page 439.

o Making sets of sections with special requirements

The block directive makes it possible to create empty sections with specific sizes
and alignments, sequentially sorted sections of different types, etc.
The overlay directive makes it possible to create an area of memory that can
contain several overlay images. See define block directive, page 432, and define
overlay directive, page 433.

e Initializing the application
The directives initialize and do not initialize control how the application
should be started. With these directives, the application can initialize global symbols
at startup, and copy pieces of code. The initializers can be stored in several ways, for

example they can be compressed. See initialize directive, page 434 and do not
initialize directive, page 437.

o Keeping removed sections

The keep directive retains sections even though they are not referred to by the rest
of the application, which means it is equivalent to the oot concept in the assembler
and compiler. See keep directive, page 437.

® use init table directive

This section gives detailed information about each linker directive specific to section
handling.
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define block directive

Syntax

Parameters

Description
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define [movable]l block name
[ with param, param... 1]

extended-selectors
}
[except
{
section_selectors
11

where param can be one of:

size = expr
maximum size = expr
alignment = expr

fixed order
static base [basename]

and where the rest of the directive selects sections to include in the block, see Section
selection, page 440.

name The name of the block to be defined.

size Customizes the size of the block. By default, the size of a
block is the sum of its parts dependent of its contents.

maximum size Specifies an upper limit for the size of the block. An error is
generated if the sections in the block do not fit.

alignment Specifies a minimum alignment for the block. If any section
in the block has a higher alignment than the minimum
alignment, the block will have that alignment.

fixed order Places sections in fixed order; if not specified, the order of
the sections will be arbitrary.

static base Specifies that the static base with the name basename will

[basename] be placed at the start of the block or in the middle of the
block, as appropriate for the particular static base. The
startup code must ensure that the register that holds the static
base is initialized to the correct value. If there is only one
static base, the name can be omitted.

The block directive defines a contiguous area of memory that contains a possibly
empty set of sections or other blocks. Blocks with no content are useful for allocating



Example

See also

define overlay directive

Syntax

Parameters
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space for stacks or heaps. Blocks with content are usually used to group together
sections that must to be consecutive.

You can access the start, end, and size of a block from an application by using the
__section_begin section_end, or __section_size operators. If there is no
block with the specified name, but there are sections with that name, a block will be
created by the linker, containing all such sections.

QU

movable blocks are for use with read-only and read-write position independence.
Making blocks movable enables the linker to validate the application’s use of addresses.
Movable blocks are located in exactly the same way as other blocks, but the linker will
check that the appropriate relocations are used when referring to symbols in movable
blocks.

/* Create a 0x1000-byte block for the heap */
define block HEAP with size = 0x1000, alignment = 8 { };

Interaction between the tools and your application, page 200. See define overlay
directive, page 433 for an Accessing example.

define overlay name [ with param, param... ]

{
extended-selectors;

}
[except
{

section_selectors
115

For information about extended selectors and except clauses, see Section selection, page
440.

name The name of the overlay.

size Customizes the size of the overlay. By default, the size of a
overlay is the sum of its parts dependent of its contents.

maximum size Specifies an upper limit for the size of the overlay. An error
is generated if the sections in the overlay do not fit.

alignment Specifies a minimum alignment for the overlay. If any
section in the overlay has a higher alignment than the
minimum alignment, the overlay will have that alignment.
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Description

See also

initialize directive

Syntax

Parameters
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fixed order Places sections in fixed order; if not specified, the order of
the sections will be arbitrary.

The overlay directive defines a named set of sections. In contrast to the block
directive, the overlay directive can define the same name several times. Each definition
will then be grouped in memory at the same place as all other definitions of the same
name. This creates an overlaid memory area, which can be useful for an application that
has several independent sub-applications.

Place each sub-application image in ROM and reserve a RAM overlay area that can hold
all sub-applications. To execute a sub-application, first copy it from ROM to the RAM
overlay. Note that ILINK does not help you with managing interdependent overlay
definitions, apart from generating a diagnostic message for any reference from one
overlay to another overlay.

The size of an overlay will be the same size as the largest definition of that overlay name
and the alignment requirements will be the same as for the definition with the highest
alignment requirements.

Note: Sections that were overlaid must be split into a RAM and a ROM part and you
must take care of all the copying needed.

Manual initialization, page 99.

initialize { by copy | manually }
[ with param, param... 1

where param can be one of:

packing = algorithm
simple ranges
complex ranges

by copy Splits the section into sections for initializers and initialized
data, and handles the initialization at application startup
automatically.

manually Splits the section into sections for initializers and initialized
data. The initialization at application startup is not handled
automatically.



Description

The linker configuration file __¢

algorithm Specifies how to handle the initializers. Choose between:

none - Disables compression of the selected section
contents. This is the default method for initialize manually.

zeros - Compresses consecutive bytes with the value zero.

packbits - Compresses with the PackBits algorithm. This
method generates good results for data with many identical
consecutive bytes.

1z77 - Compresses with the Lempel-Ziv-77 algorithm.
This method handles a larger variety of inputs well, but has
a slightly larger decompressor.

auto - ILINK estimates the resulting size using each
packing method (except for auto), and then chooses the
packing method that produces the smallest estimated size.
Note that the size of the decompressor is also included. This
is the default method for initialize by copy.

smallest - This is a synonym for auto.

The initialize directive splits each selected section into one section that holds
initializer data and another section that holds the space for the initialized data. The
section that holds the space for the initialized data retains the original section name, and
the section that holds initializer data gets the name suffix _init. You can choose
whether the initialization at startup should be handled automatically (initialize by
copy) or whether you should handle it yourself (initialize manually).

When you use the packing method auto (default for initialize by copy), ILINK
will automatically choose an appropriate packing algorithm for the initializers. To
override this, specify a different packing method. The --1log initialization
option shows how ILINK decided which packing algorithm to use.

When initializers are compressed, a decompressor is automatically added to the image.

Each decompressor has two variants: one that can only handle a single source and
destination range at a time, and one that can handle more complex cases. By default, the
linker chooses a decompressor variant based on whether the associated section
placement directives specify a single- or multi-range memory region. In general, this is
the desired behavior, but you can use the with complex rangesorthewith simple
ranges modifier on an initialize directive to specify which decompressor variant
to use. You can also use the command line option --default_to_complex_ranges
to make initialize directives by default use complex ranges. The simple ranges
decompressors are normally hundreds of bytes smaller than the complex ranges
variants.

435



Section handling

436

Example

See also
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When initializers are compressed, the exact size of the compressed initializers is
unknown until the exact content of the uncompressed data is known. If this data contains
other addresses, and some of these addresses are dependent on the size of the
compressed initializers, the linker fails with error Lp017. To avoid this, place
compressed initializers last, or in a memory region together with sections whose
addresses do not need to be known.

Due to an internal dependence, generation of compressed initializers can also fail (with
error LP021) if the address of the initialized area depends on the size of its initializers.
To avoid this, place the initializers and the initialized area in different parts of the
memory (for example, the initializers are placed in ROM and the initialized area in
RAM).

Unless initialize manually is used, ILINK will arrange for initialization to occur
during system startup by including an initialization table. Startup code calls an
initialization routine that reads this table and performs the necessary initializations.

Zero-initialized sections are not affected by the initialize directive.

The initialize directive is normally used for initialized variables, but can be used for
copying any sections, for example copying executable code from slow ROM to fast
RAM, or for overlays. For another example, see define overlay directive, page 433.

Sections that are needed for initialization are not affected by the initialize by copy
directive. This includes the __low_level_init function and anything it references.

Anything reachable from the program entry label is considered needed for initialization
unless reached via a section fragment with a label starting with __iar_init$$done.
The --1log sections option, in addition to logging the marking of section fragments
to be included in the application, also logs the process of determining which sections are
needed for initialization.

/* Copy all read-write sections automatically from ROM to RAM at
program start */

initialize by copy { rw };

place in RAM { rw };

place in ROM { ro };

Initialization at system startup, page 82, and do not initialize directive, page 437.
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do not initialize directive

Syntax do not initialize
{

section-selectors
}
[except
{

section-selectors

11

For information about extended selectors and except clauses, see Section selection, page
440.

Description The do not initialize directive specifies the sections that should not be initialized
by the system startup code. The directive can only be used on zeroinit sections.

The compiler keyword __no_init places variables into sections that must be handled
by a do not initialize directive.

Example /* Do not initialize read-write sections whose name ends with
_noinit at program start */
do not initialize { rw section .*_noinit };
place in RAM { rw section .*_noinit };

See also Initialization at system startup, page 82, and initialize directive, page 434.

keep directive

Syntax keep
{

section-selectors
}
[except
{

section-selectors
115

For information about extended selectors and except clauses, see Section selection, page
440.

Description The keep directive specifies that all selected sections should be kept in the executable
image, even if there are no references to the sections.

Example keep { section .keep* } except {section .keep};
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place at directive

Syntax

Parameters

Description

Example

See also
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[ "name": 1
place at { address [ memory: 1 expr | start of region_expr |
end of region_expr }
{
extended-selectors

}
[except
{

section-selectors
11

For information about extended selectors and except clauses, see Section selection, page
440.

memory: expr A specific address in a specific memory. The address must
be available in the supplied memory defined by the
define memory directive. The memory specifier is
optional if there is only one memory.

start of region_expr A region expression thatresults in a single-internal
region. The start of the interval is used.

end of region expr A region expression that results in a single-internal
region. The end of the interval is used.

The place at directive places sections and blocks either at a specific address or, at the
beginning or the end of a region. The same address cannot be used for two different
place at directives. It is also not possible to use an empty region in a place at
directive. If placed in a region, the sections and blocks will be placed before any other
sections or blocks placed in the same region with a place in directive.

The name, if specified, is used in the map file and in some log messages.
/* Place the read-only section .startup at the beginning of the
code_region */

"START": place at start of ROM { readonly section .startup };

place in directive, page 439.
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place in directive

Syntax [ "name": 1]
place in region-expr
{

extended-selectors

}
[except{
section-selectors

1
where region-expr is a region expression, see also Regions, page 428.

and where the rest of the directive selects sections to include in the block. See Section
selection, page 440.

Description The place in directive places sections and blocks in a specific region. The sections and
blocks will be placed in the region in an arbitrary order.

To specify a specific order, use the block directive. The region can have several ranges.

The name, if specitied, is used in the map file and in some log messages.

Example /* Place the read-only sections in the code_region */
"ROM": place in ROM { readonly };

See also place at directive, page 438.

use init table directive

Syntax use init table name for

{
extended-selectors
}
[except
{

section-selectors
11

For information about extended selectors and except clauses, see Section selection, page
440.

Parameters
name The name of the init table.
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Description

Example

Normally, all initialization entries are generated into a single initialization table (called
Table). Use this directive to cause some of the entries to be put into a separate table.
You can then use this initialization table at another time, or under different
circumstances, than the normal initialization table.

Initialization entries for all variables not mentioned in ause init table directive are
put into the normal initialization table. By having multiple use init table directives
you can have multiple initialization tables.

The start, end, and size of the init table can be accessed in the application program by
using __section_begin, _section_end, or __section_size of
"Region$$name", respectively, or via the symbols Region$$name$$Base
Region$$name$S$Limit, and Region$$name$S$Length

use init table Core2 for { section *.corel};

/* __section_begin("Region$$Core2") can be used to get the start
of the Core2 init table. */

Section selection

section-selectors

Syntax

IAR C/C++ Development Guide
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The purpose of section selection is to specify—by means of section selectors and except
clauses—the sections that an ILINK directive should be applied to. All sections that
match one or more of the section selectors will be selected, and none of the sections
selectors in the except clause, if any. Each section selector can match sections on section
attributes, section name, and object or library name.

Some directives provide functionality that requires more detailed selection capabilities,
for example directives that can be applied on both sections and blocks. In this case, the
extended-selectors are used.

This section gives detailed information about each linker directive specific to section
selection.

{ [ section-selector 1[, section-selector...] }
where section-selectoris:

[ section-attribute 1[ section-type 1[ section sectionname ]
[object {module | filename } ]

where section-attributeis:

[ ro [ code | data 1 | rw [ code | data ] | zi 1



Parameters

Description

The linker configuration file __¢

and where ro, rw, and zi also can be readonly, readwrite, and zeroinit,

respectively.

And section-type]is:

[ preinit_array | init_array 1

ro Oor readonly
rw Or readwrite

z1 Or zeroinit

code

data
preinit_array
init_array

sectionname

module

filename

Read-only sections.
Read/write sections.

Zero-initialized sections. These sections have no content and
should possibly be initialized with zeros during system
startup.

Sections that contain code.

Sections that contain data.

Sections of the ELF section type SHT_PREINIT_ ARRAY.
Sections of the ELF section type SHT_INIT_ARRAY.
The section name. Two wildcards are allowed:

2 matches any single character

* matches zero or more characters.

A name in the form objectname (1ibraryname) . Sections
from object modules where both the object name and the
library name match their respective patterns are selected. An
empty library name pattern selects only sections from object
files.

The name of an object file, a library, or an object in a library.
Two wildcards are allowed:

2 matches any single character

* matches zero or more characters.

A section selector selects all sections that match the section attribute, section type,
section name, and the name of the object, where object is an object file, a library, or an
object in a library. Up to three of the four conditions can be omitted. If the section
attribute is omitted, any section will be selected, without restrictions on the section
attribute. If the section type is omitted, sections of any type will be selected.
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Example

See also

If the section name part or the object name part is omitted, sections will be selected
without restrictions on the section name or object name, respectively.

It is also possible to use only { } without any section selectors, which can be useful
when defining blocks.

Note that a section selector with narrower scope has higher priority than a more generic
section selector.

If more than one section selector matches for the same purpose, one of them must be
more specific. A section selector is more specific than another one if:
It specifies a section type and the other one does not

It specifies a section name or object name with no wildcards and the other one does
not

o There could be sections that match the other selector that also match this one, and
the reverse is not true.

Selector | Selector 2 More specific
section "foo*" section "f*" Selector 1
section "*x" section "f*" Neither

ro code section "f*" ro section "f*" Selector 1
init_array ro section "xx" Selector 1
section ".intvec" ro section ".int*" Selector 1
section ".intvec" object "foo.o" Neither

Table 39: Examples of section selector specifications
{ rw } /* Selects all read-write sections */

{ section .mydata* } /* Selects only .mydata* sections */
/* Selects .mydata* sections available in the object special.o */
{ section .mydata* object special.o }

Assuming a section in an object named foo. o in a library named 1ib. a, any of these
selectors will select that section:

object foo.o(lib.a)
object f*(lib¥*)
object foo.o
object lib.a

initialize directive, page 434, do not initialize directive, page 437, and keep directive,
page 437.



The linker configuration file __¢

extended-selectors
Syntax { [ extended-selector 1[, extended-selector...]l }
where extended-selector is:
[ first | last | midway 1
{ section-selector |
block name [ inline-block-def 1 |
overlay name }
where inline-block-def is:
[ block-params ] extended-selectors
Parameters
first Places the selected sections, block, or overlay first in the
containing placement directive, block, or overlay.
last Places the selected sections, block or overlay last in the
containing placement directive, block, or overlay.
midway Places the selected sections, block, or overlay so that they are
no further than half the maximum size of the containing
block away from either edge of the block. Note that this
parameter can only be used inside a block that has a
maximum size.
name The name of the block or overlay.
Description Use extended-selectors to select content for inclusion in a placement directive,

block, or overlay. In addition to using section selection patterns, you can also explicitly
specify blocks or overlays for inclusion.

Using the first or last keyword, you can specify one pattern, block, or overlay that
is to be placed first or last in the containing placement directive, block, or overlay. If you
need more precise control of the placement order you can instead use a block with fixed
order.

Blocks can be defined separately, using the define block directive, or inline, as part
of an extended-selector.

The midway parameter is primarily useful together with a static base that can have both
negative and positive offsets.
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Example

See also

define block First { ro section .f* }; /* Define a block holding
any read-only section*/
matching ".f*" */
define block Table { first block First, ro section .b };

/* Define a block where
the block First comes
before the sections
matching ".b*". */

You can also define the block First inline, instead of in a separate define block
directive:

define block Table { first block First { ro section .f* },
ro section .b* };

define block directive, page 432, define overlay directive, page 433, and place at
directive, page 438.

Using symbols, expressions, and numbers

check that directive

Syntax

Parameters
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In the linker configuration file, you can also:

o Define and export symbols

The define symbol directive defines a symbol with a specified value that can be
used in expressions in the configuration file. The symbol can also be exported to be
used by the application or the debugger. See define symbol directive, page 445, and
export directive, page 446.

o Use expressions and numbers

In the linker configuration file, expressions and numbers are used for specifying
addresses, sizes, etc. See expressions, page 446.

This section gives detailed information about each linker directive specific to defining
symbols, expressions and numbers.

check that expression;

expression A boolean expression.



Description

Example

See also

define symbol directive

Syntax

Parameters

Description

The linker configuration file __¢

You can use the check that directive to compare the results of stack usage analysis
against the sizes of blocks and regions. If the expression evaluates to zero, an error is
emitted.

Three extra operators are available for use only in check that expressions:

maxstack(category) The stack depth of the deepest call chain for any call
graph root function in the category.

totalstack(category) The sum of the stack depths of the deepest call chains
for each call graph root function in the category.

size(block) The size of the block.

check that maxstack("Program entry")
+ totalstack("interrupt")
+ 1K
<= size(block CSTACK) ;

Stack usage analysis, page 85.

define [ exported ] symbol name = expr;

exported Exports the symbol to be usable by the executable
image.

name The name of the symbol.

expr The symbol value.

The define symbol directive defines a symbol with a specified value. The symbol can
then be used in expressions in the configuration file. The symbols defined in this way
work exactly like the symbols defined with the option --config_def outside of the
configuration file.

The define exported symbol variant of this directive is a shortcut for using the
directive define symbol in combination with the export symbol directive. On the
command line this would require both a --config_def option and a
--define_symbol option to achieve the same effect.

Note:

o A symbol cannot be redefined
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Example

See also

export directive

Syntax

Parameters

Description

Example

expressions

Syntax
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o Symbols that are either prefixed by _x, where x is a capital letter, or that contain __
(double underscore) are reserved for toolset vendors.

/* Define the symbol my_ symbol with the value 4 */
define symbol my_ symbol = 4;

export directive, page 446 and Interaction between ILINK and the application, page
102.

export symbol name;

name The name of the symbol.

The export directive defines a symbol to be exported, so that it can be used both from
the executable image and from a global label. The application, or the debugger, can then
refer to it for setup purposes etc.

/* Define the symbol my_symbol to be exported */
export symbol my_symbol;

An expression is built up of the following constituents:

expression binop expression

unop expression

expression ? expression : expression
(expression)

number

symbol

func-operator

where binop is one of these binary operators:
oo, R, %, <<, 3>, <, > =S, s 8, 0, |, &G, |
where unop is one of this unary operators:

+, -, Y, ~

where number is a number, see numbers, page 447



Description

numbers

Syntax

Description
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where symbol is a defined symbol, see define symbol directive, page 445 and
--config def, page 294

and where func-operator is one of these function-like operators:

minimum(expr, expr) Returns the smallest of the two parameters.

maximum (expr, expr) Returns the largest of the two parameters.

isempty (r) Returns True if the region is empty, otherwise
False.

isdefinedsymbol (expr-symbol Returns True if the expression symbol is defined,
) otherwise False.

start (r) Returns the lowest address in the region.
end (r) Returns the highest address in the region.
size(r) Returns the size of the complete region.

where expr is an expression, and r is a region expression, see Region expression, page
429.

In the linker configuration file, an expression is a 65-bit value with the range -2°64 to
2764. The expression syntax closely follows C syntax with some minor exceptions.
There are no assignments, casts, pre- or post-operations, and no address operations (*,
&, [1,->,and .). Some operations that extract a value from a region expression, etc, use
a syntax resembling that of a function call. A boolean expression returns 0 (False) or 1
(True).

nr [nr-suffix]
where nr is either a decimal number or a hexadecimal number (0x. .. or 0X...).

and where nr-suffixis one of:

K /* Kilo = (1 << 10) 1024 */

M /* Mega = (1 << 20) 1048576 */

G /* Giga = (1 << 30) 1073741824 */

T /* Tera = (1 << 40) 1099511627776 */

P /* Peta = (1 << 50) 1125899906842624 */

A number can be expressed either by normal C means or by suffixing it with a set of
useful suffixes, which provides a compact way of specifying numbers.
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Example

1024 is the same as 0x400, which is the same as 1K.

Structural configuration

error directive

Syntax

Parameters

Description

Example

if directive

Syntax
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The structural directives provide means for creating structure within the configuration,
such as:
e Conditional inclusion

An if directive includes or excludes other directives depending on a condition,
which makes it possible to have directives for several different memory
configurations in the same file. See if directive, page 448.

e Dividing the linker configuration file into several different files

The include directive makes it possible to divide the configuration file into several
logically distinct files. See include directive, page 449.

e Signaling an error for unsupported cases

This section gives detailed information about each linker directive specific to structural
configuration.

error string

string The error message.

An error directive can be used for signaling an error if the directive occurs in the active
part of a conditional directive.

error "Unsupported configuration"

if (expr) {
directives

[ } else if (expr) {
directives 1

[ } else {
directives 1
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where expr is an expression, see expressions, page 446.

Parameters
directives Any ILINK directive.

Description An if directive includes or excludes other directives depending on a condition, which
makes it possible to have directives for several different memory configurations, for
example both a banked and non-banked memory configuration, in the same file.

The directives inside an if part, else if part, or an else part are syntax checked and
processed regardless of whether the conditional expression was true or false, but only
the directives in the part where the conditional expression was true, or the else part if
none of the conditions were true, will have any effect outside the i £ directive. The i £
directives can be nested.

Example See Empty region, page 430.

include directive

Syntax include "filename";
Parameters
filename A path where both / and \ can be used as the directory
delimiter.
Description The include directive makes it possible to divide the configuration file into several

logically distinct parts, each in a separate file. For instance, there might be parts that you
need to change often and parts that you seldom edit.

Normally, the linker searches for configuration include files in the system configuration
directory. You can use the --config_search linker option to add more directories to
search.

See also --config_search, page 295
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Section reference

e Summary of sections
e Descriptions of sections and blocks

For more information about sections, see the chapter Modules and sections,
page 76.

Summary of sections

This table lists the ELF sections and blocks that are used by the IAR build tools:

Section Description

.bss Holds zero-initialized static and global variables.

CSTACK Holds the stack used by C or C++ programs.

.data Holds static and global initialized variables.

.data_init Holds initial values for . data sections when the linker directive

initialize is used.

_ _DLIB_PERTHREAD Holds variables that contain static states for DLIB modules.
.exc.text Holds exception-related code.

HEAP Holds the heap used for dynamically allocated data.
.lar.dynexit Holds the atexit table.

.init_array Holds a table of dynamic initialization functions.

.intvec Holds the reset vector table

IRQ_STACK Holds the stack for interrupt requests, IRQ, and exceptions.
.noinit Holds __no_init static and global variables.
.preinit_array Holds a table of dynamic initialization functions.
.prepreinit_array Holds a table of dynamic initialization functions.

.rodata Holds constant data.

.text Holds the program code.

.textrw Holds __ramfunc declared program code.
.textrw_init Holds initializers for the . textrw declared section.

Table 40: Section summary
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Descriptions of sections and blocks

In addition to the ELF sections used for your application, the tools use a number of other
ELF sections for a variety of purposes:

e Sections starting with . debug generally contain debug information in the DWARF
format

e Sections starting with . iar.debug contain supplemental debug information in an
IAR format

e The section . comment contains the tools and command lines used for building the
file

Sections starting with . rel or .rela contain ELF relocation information
The section . symtab contains the symbol table for a file

The section . strtab contains the names of the symbol in the symbol table

The section . shstrtab contains the names of the sections.

Descriptions of sections and blocks

This section gives reference information about each section, where the:

e Description describes what type of content the section is holding and, where
required, how the section is treated by the linker
® Memory placement describes memory placement restrictions.

For information about how to allocate sections in memory by modifying the linker
configuration file, see Placing code and data—the linker configuration file, page 79.

.bss
Description Holds zero-initialized static and global variables.
Memory placement This section can be placed anywhere in memory.
CSTACK
Description Block that holds the internal data stack.
Memory placement This block can be placed anywhere in memory.
See also Setting up stack memory, page 97.

IAR C/C++ Development Guide
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.data
Description Holds static and global initialized variables. In object files, this includes the initial
values. When the linker directive initialize is used, a corresponding .data_init
section is created for each .data section, holding the possibly compressed initial
values.
Memory placement This section can be placed anywhere in memory.
.data_init
Description Holds the possibly compressed initial values for . data sections. This section is created

by the linker if the initialize linker directive is used.

Memory placement This section can be placed anywhere in memory.

__DLIB_PERTHREAD

Description Holds thread-local static and global initialized variables used by the main thread.

This section is placed automatically. If you change the placement, you must not change
its initialization. The initialization of this section must be controlled with the
initialize directive.

Memory placement This section can be placed anywhere in memory.
See also Managing a multithreaded environment, page 143.
.exc.text
Description Holds code that is only executed when your application handles an exception.
Memory placement In the same memory as . text.
See also Exception handling, page 188.
HEAP
Description Holds the heap used for dynamically allocated data in memory, in other words data

allocated by malloc and free, and in C++, new and delete.
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Memory placement

See also

.iar.dynexit

Description
Memory placement

See also

.init_array

Description
Memory placement

.intvec

Description

Memory placement

IRQ_STACK

Description

Memory placement

See also
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This section can be placed anywhere in memory.

Setting up heap memory, page 98.

Holds the table of calls to be made at exit.
This section can be placed anywhere in memory.

Setting up the atexit limit, page 98.

Holds pointers to routines to call for initializing one or more C++ objects with static
storage duration.

This section can be placed anywhere in memory.

Holds the reset vector table and exception vectors which contain branch instructions to
cstartup, interrupt service routines etc.

Must be placed at address range 0x00 to 0x3F.

Holds the stack which is used when servicing IRQ exceptions. Other stacks may be
added as needed for servicing other exception types: FIQ, SVC, ABT, and UND. The
cstartup. s file must be modified to initialize the exception stack pointers used.

Note: This section is not used when compiling for Cortex-M.
This section can be placed anywhere in memory.

Exception stack, page 198



.noinit
Description

Memory placement

.preinit_array

Description

Memory placement

See also

.prepreinit_array

Description

Memory placement

See also

.rodata

Description
Memory placement

text

Description

Memory placement

Section reference ___4

Holds static and global __no_init variables.

This section can be placed anywhere in memory.

Like .init_array, butis used by the library to make some C++ initializations happen
before the others.

This section can be placed anywhere in memory.

.init_array, page 454.

Like .init_array, butis used when C static initialization is rewritten as dynamic
initialization. Performed before all C++ dynamic initialization.

This section can be placed anywhere in memory.

.init_array, page 454.

Holds constant data. This can include constant variables, string and aggregate literals,
etc.

This section can be placed anywhere in memory.

Holds program code, including the code for system initialization.

This section can be placed anywhere in memory.
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textrw

Description
Memory placement

See also

textrw_init

Description
Memory placement

See also
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Holds ___ramfunc declared program code.
This section can be placed anywhere in memory.

__ramfunc, page 343.

Holds initializers for the . textrw declared sections.
This section can be placed anywhere in memory.

__ramfunc, page 343.



The stack usage control file

e Overview
e Stack usage control directives
e Syntactic components

Before you read this chapter, see Stack usage analysis, page 85.

Overview

A stack usage control file consists of a sequence of directives that control stack usage
analysis. You can use C ("/*...x/") and C++ ("//...") comments in these files.

The default filename extension for stack usage control files is suc.

C++ NAMES

When you specify the name of a C++ function in a stack usage control file, you must
use the name exactly as used by the linker. Both the number and names of parameters,
as well as the names of types must match. However, most non-significant white-space
differences are accepted. In particular, you must enclose the name in quote marks
because all C++ function names include non-identifier characters.

You can also use wildcards in function names. "#*" matches any sequence of characters,
and "#?" matches a single character. This makes it possible to write function names that
will match any instantiation of a template function.

Examples:

"operator new(unsigned int)"

"ostream: :flush()" // EC++
"std::ostream::flush()" // C++
"operator << (ostream &, char const *)"

"void _Sort<#*>(#*, #*, #*)"

Stack usage control directives

This section gives detailed reference information about each stack usage control
directive.
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call graph root directive

Syntax

Parameters

Description

Example

See also

exclude directive

Syntax

Parameters

Description

Example

function directive

Syntax

Parameters
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call graph root [ category 1 : func-spec [, func-spec... 1;
category See category, page 461
func-spec See func-spec, page 461

Specifies that the listed functions are call graph roots. You can optionally specify a call
graph root category. Call graph roots are listed under their category in the Stack Usage
chapter in the linker map file.

The linker will normally issue a warning for functions needed in the application that are
not call graph roots and which do not appear to be called.

call graph root [task]: MyFunclO, MyFuncll;

call graph_root, page 351.

exclude func-spec [, func-spec... 1;

func-spec See func-spec, page 461

Excludes the specified functions, and call trees originating with them, from stack usage
calculations.

exclude MyFunc5, MyFuncé;

[ override ] function [ category 1 func-spec : stack-size
[ , call-info... 1;

category See category, page 461
func-spec See func-spec, page 461
call-info See call-info, page 462



Description

Example
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stack-size See stack-size, page 462

Specifies what the maximum stack usage is in a function and which other functions that
are called from that function.

Normally, an error is issued if there already is stack usage information for the function,
but if you start with override, the error will be suppressed and the information
supplied in the directive will be used instead of the previous information.

function MyFuncl: 32,
calls MyFunc2,

calls MyFunc3, MyFunc4d: 16;

function [interrupt] MyInterruptHandler: 44;

max recursion depth directive

Syntax

Parameters

Description

Example

no calls from directive

Syntax

Parameters

max recursion depth func-spec : size;

func-spec See func-spec, page 461

size See size, page 463

Specifies the maximum number of iterations through any of the cycles in the recursion
nest of which the function is a member.

A recursion nest is a set of cycles in the call graph where each cycle shares at least one
node with another cycle in the nest.

Stack usage analysis will base its result on the max recursion depth multiplied by the
stack usage of the deepest cycle in the nest. If the nest is not entered on a point along
one of the deepest cycles, no stack usage result will be calculated for such calls.

max recursion depth MyFuncl2: 10;

no calls from module-spec to func-spec [, func-spec... 1;

func-spec See func-spec, page 461
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460

Description

Example

possible calls directive

Syntax

Parameters

Description

Example

See also

module-spec See module-spec, page 461

When you provide stack usage information for some functions in a module without
stack usage information, the linker warns about functions that are referenced from the
module but not listed as called. This is primarily to help avoid problems with C runtime
routines, calls to which are generated by the compiler, beyond user control.

If there actually is no call to some of these functions, use the no calls from directive
to selectively suppress the warning for the specified functions. You can also disable the
warning entirely (--diag_suppress or
Project>Options>Linker>Diagnostics>Suppress these diagnostics).

no calls from [file.o] to MyFuncl3, MyFunl4;

possible calls calling-func : called-func [ , called-func... 1;
calling-func See func-spec, page 461
called-func See func-spec, page 461

Specifies an exhaustive list of possible destinations for all indirect calls in one function.
Use this for functions which are known to perform indirect calls and where you know
exactly which functions that might be called in this particular application. Consider
using the #pragma calls directive if the information about which functions that might
be called is available when compiling.

possible calls MyFunc7: MyFunc8, MyFunc9;

When the function does not perform any calls, the list is empty:

possible calls MyFunc8: ;

calls, page 350.

Syntactic components
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The stack usage control directives use some syntactical components. These are
described below.



category

Syntax

Description

Example

func-spec
Syntax

Description

Example

module-spec

Syntax

Description
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[ name ]

A call graph root category. You can use any name you like. Categories are not
case-sensitive.

category examples:

[interrupt]
[task]

[ 21 name [ module-spec 1

Specifies the name of a symbol, and for module-local symbols, the name of the module
it is defined in. Normally, if func-spec does not match a symbol in the program, a
warning is emitted. Prefixing with ? suppresses this warning.

func-spec examples:

xFun
MyFun [file.o]
?"funl (int)"

[name [ (name) 1]

Specifies the name of a module, and optionally, in parentheses, the name of the library

it belongs to. To distinguish between modules with the same name, you can specify:

o The complete path of the file ("D: \C1\test\file.o")

o As many path elements as are needed at the end of the path ("test\file.o")

o Some path elements at the start of the path, followed by " . . . ", followed by some
path elements at the end ("D:\...\file.o").

Note that when using multi-file compilation (--mfc), multiple files are compiled into a
single module, named after the first file.
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Example

name

Description

Example

call-info
Syntax
Description

Example

stack-size

Syntax
Description

Example
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module-spec examples:

[file.o]
[file.o(1lib.a)]
["D:\Cl\test\file.o"]

A name can be either an identifier or a quoted string.

non

The first character of an identifier must be either a letter or one of the characters

"o

"s", or ".". The rest of the characters can also be digits.

—

A quoted string starts and ends with " and can contain any character. Two consecutive
» characters can be used inside a quoted string to represent a single ".

name examples:

MyFun
file.o
"file-1.0"

calls func-spec [ , func-spec... 1l : stack-size ]
Specifies one or more called functions, and optionally, the stack size at the calls.

call-info examples:

calls MyFuncl : stack 16
calls MyFunc2, MyFunc3, MyFunc4

[ stack 1 size
Specifies the size of a stack frame.

stack-size examples:

24
stack 28



The stack usage control file __¢

size

Description A decimal integer, or 0x followed by a hexadecimal integer. Either alternative can
optionally be followed by a suffix indicating a power of two (K=210, u=2%0, g=23,
=240 p=050)

Example size examples:
24
0x18
2048
2K
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e The IAR Archive Tool—iarchive—creates and manipulates a library (an
archive) of several ELF object files

e The IAR ELF Tool—ielftool—performs various transformations on an ELF
executable image (such as fill, checksum, format conversions, etc)

e The IAR ELF Dumper—ielfdump—creates a text representation of the
contents of an ELF relocatable or executable image

e The IAR ELF Object Tool—iobjmanip—is used for performing low-level
manipulation of ELF object files

e The IAR Absolute Symbol Exporter—isymexport—exports absolute
symbols from a ROM image file, so that they can be used when you link an
add-on application.

The IAR Archive Tool—iarchive

The IAR Archive Tool, iarchive, can create a library (an archive) file from several
ELF object files. You can also use iarchaive to manipulate ELF libraries.

A library file contains several relocatable ELF object modules, each of which can be
independently used by a linker. In contrast with object modules specified directly to the
linker, each module in a library is only included if it is needed.

For information about how to build a library in the IDE, see the IDE Project
Management and Building Guide for ARM.

INVOCATION SYNTAX
The invocation syntax for the archive builder is:

iarchive parameters

465



The IAR Archive Tool—iarchive

Parameters
The parameters are:

Parameter Description

command Command line options that define an operation to be performed.
Such an option must be specified before the name of the library file.

libraryfile The library file to be operated on.

objectfilel ... The object file(s) that the specified command operates on.
objectfileN

options Command line options that define actions to be performed. These

options can be placed anywhere on the command line.

Table 41: iarchive parameters

Examples

This example creates a library file called mylibrary.a from the source object files
modulel.o, module.2.o0, and module3.o:

iarchive mylibrary.a modulel.o module2.o module3.o.
This example lists the contents of mylibrary.a:
iarchive --toc mylibrary.a

This example replaces module3. o in the library with the content in the module3. o file
and appends module4 .o tomylibrary.a:

iarchive --replace mylibrary.a module3.o module4d.o

SUMMARY OF IARCHIVE COMMANDS

This table summarizes the iarchive commands:

Command line option Description

--create Creates a library that contains the listed object files.
--delete, -d Deletes the listed object files from the library.
--extract, -x Extracts the listed object files from the library.
--replace, -r Replaces or appends the listed object files to the library.
--symbols Lists all symbols defined by files in the library.

--toc, -t Lists all files in the library.

Table 42: iarchive commands summary

For more information, see Descriptions of options, page 479.
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SUMMARY OF IARCHIVE OPTIONS

This table summarizes the iarchive options:

Command line option Description

-f Extends the command line.

--output, -o Specifies the library file.

--verbose, -V Reports all performed operations.

--version Sends tool output to the console and then exits.

Table 43: iarchive options summary

For more information, see Descriptions of options, page 479.

DIAGNOSTIC MESSAGES

This section lists the messages produced by iarchive:

La00l: could not open file filename

iarchive failed to open an object file.

La002: illegal path pathname

The path pathname is not a valid path.

La006: too many parameters to cmd command

A list of object modules was specified as parameters to a command that only accepts a
single library file.

La007: too few parameters to cmd command

A command that takes a list of object modules was issued without the expected modules.

La008: lib is not a library file

The library file did not pass a basic syntax check. Most likely the file is not the intended
library file.

La009: lib has no symbol table

The library file does not contain the expected symbol information. The reason might be
that the file is not the intended library file, or that it does not contain any ELF object
modules.
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La0l0: no library parameter given

The tool could not identify which library file to operate on. The reason might be that a
library file has not been specified.

La0l I: file file already exists

The file could not be created because a file with the same name already exists.

La013: file confusions, lib given as both library and object

The library file was also mentioned in the list of object modules.

La0l4: module module not present in archive lib

The specified object module could not be found in the archive.

La0l5: internal error

The invocation triggered an unexpected error in iarchive.

Ms003: could not open file filename for writing

iarchive failed to open the archive file for writing. Make sure that it is not write
protected.

Ms004: problem writing to file filename

An error occurred while writing to file £ilename. A possible reason for this is that the
volume is full.

Ms005: problem closing file filename

An error occurred while closing the file filename.

The IAR ELF Tool—ielftool

IAR C/C++ Development Guide
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The IAR ELF Tool, ielftool, can generate a checksum on specific ranges of
memories. This checksum can be compared with a checksum calculated on your
application.

The source code for ielftool and a Microsoft VisualStudio 2005 template project are
available in the arm\src\elfutils directory. If you have specific requirements for
how the checksum should be generated or requirements for format conversion, you can
modify the source code accordingly.
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INVOCATION SYNTAX

The invocation syntax for the IAR ELF Tool is:

ielftool [options] inputfile outputfile [options]

The ielftool tool will first process all the fill options, then it will process all the
checksum options (from left to right).

Parameters

The parameters are:

Parameter Description
inputfile An absolute ELF executable image produced by the ILINK linker.
options Any of the available command line options, see Summary of ielftool

options, page 469.

outputfile An absolute ELF executable image.

Table 44: ielftool parameters

See also Rules for specifying a filename or directory as parameters, page 246.

Example

This example fills a memory range with 0xFF and then calculates a checksum on the
same range:

ielftool my_input.out my_output.out --fill OxFF;0-0xFF
--checksum __checksum:4,crc32;0-0xFF

SUMMARY OF IELFTOOL OPTIONS
This table summarizes the ielftool command line options:

Command line option  Description

--bin Sets the format of the output file to binary.
--checksum Generates a checksum.

--fill Specifies fill requirements.

--ihex Sets the format of the output file to linear Intel hex.
--parity Generates parity bits.

--self_reloc Not for general use.

--silent Sets silent operation.

--simple Sets the format of the output file to Simple code.
--simple-ne As --simple, but without an entry record.

Table 45: ielftool options summary
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Command line option  Description

--srec Sets the format of the output file to Motorola S-records.
--srec-len Restricts the number of data bytes in each S-record.
--srec-s3only Restricts the S-record output to contain only a subset of records.
--strip Removes debug information.

--titxt Saves as Tl-txt format.

--verbose, -V Prints all performed operations.

Table 45: ielftool options summary (Continued)

For more information, see Descriptions of options, page 479.

The IAR ELF Dumper—ielfdump

The IAR ELF Dumper for ARM, ielfdumparm, can be used for creating a text
representation of the contents of a relocatable or absolute ELF file.

ielfdumparm can be used in one of three ways:

o To produce a listing of the general properties of the input file and the ELF segments
and ELF sections it contains. This is the default behavior when no command line
options are used.

o To also include a textual representation of the contents of each ELF section in the
input file. To specify this behavior, use the command line option --a11l.

o To produce a textual representation of selected ELF sections from the input file. To
specify this behavior, use the command line option --section.

INVOCATION SYNTAX

The invocation syntax for ielfdumparm is:

ielfdumparm input_file [output_file]

Note: ielfdumparmis a command line tool which is not primarily intended to be used

in the IDE.

Parameters

The parameters are:

Parameter Description

input_file An ELF relocatable or executable file to use as input.

Table 46: ielfdumparm parameters
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Description

output_file

A file or directory where the output is emitted. If absent and no
--output option is specified, output is directed to the console.

Table 46: ielfdumparm parameters (Continued)

See also Rules for specifying a filename or directory as parameters, page 246.

SUMMARY OF IELFDUMP OPTIONS

This table summarizes the ielfdumparm command line options:

Command line option

Description

--a

--all

--code
-f
--output, -o
--no_header
--no_rel_section

--no_strtab

--range
--raw
--section, -s
--segment, -g
--source

--use_full_std_t
emplate_names

--version

Generates output for all sections except string table sections.

Generates output for all input sections regardless of their names or
numbers.

Dumps all sections that contain executable code.
Extends the command line.

Specifies an output file.

Suppresses production of a list header in the output.
Suppresses dumping of . rel/.rela sections.
Suppresses dumping of string table sections.
Disassembles only addresses in the specified range.

Uses the generic hexadecimal/ASCII output format for the contents
of any selected section, instead of any dedicated output format for
that section.

Generates output for selected input sections.
Generates output for segments with specified numbers.
Includes source with disassembled code in executable files.

Uses full short full names for some Standard C++ templates.

Sends tool output to the console and then exits.

Table 47: ielfdumparm options summary

For more information, see Descriptions of options, page 479.

The IAR ELF Object Tool—iobjmanip

Use the IAR ELF Object Tool, iobjmanip, to perform low-level manipulation of ELF

object files.
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INVOCATION SYNTAX
The invocation syntax for the IAR ELF Object Tool is:

iobjmanip options inputfile outputfile

Parameters
The parameters are:

Parameter Description

options Command line options that define actions to be performed. These
options can be placed anywhere on the command line. At least one of
the options must be specified.

inputfile A relocatable ELF object file.

outputfile A relocatable ELF object file with all the requested operations applied.

Table 48: iobjmanip parameters

See also Rules for specifying a filename or directory as parameters, page 246.

Examples

This example renames the section . example in input.o to .example2 and stores the
result in output.o:

iobjmanip --rename_section .example=.example2 input.o output.o

SUMMARY OF IOBJMANIP OPTIONS

This table summarizes the iobjmanip options:

Command line option Description

-f Extends the command line.
--remove_file_path Removes path information from the file symbol.
--remove_section Removes one or more section.
--rename_section Renames a section.

--rename_symbol Renames a symbol.

--silent Sets silent operation.

--strip Removes debug information.

--version Sends tool output to the console and then exits.

Table 49: iobjmanip options summary

For more information, see Descriptions of options, page 479.
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DIAGNOSTIC MESSAGES

This section lists the messages produced by iobjmanip:

LmO00I: No operation given

None of the command line parameters specified an operation to perform.

LmO002: Expected nr parameters but got nr

Too few or too many parameters. Check invocation syntax for iobjmanip and for the
used command line options.

LmO003: Invalid section/symbol renaming pattern pattern

The pattern does not define a valid renaming operation.

LmO004: Could not open file filename

iobjmanip failed to open the input file.

LmO005: ELF format error msg
The input file is not a valid ELF object file.

LmO006: Unsupported section type nr

The object file contains a section that iobjmanip cannot handle. This section will be
ignored when generating the output file.

LmO007: Unknown section type nr

iobjmanip encountered an unrecognized section. iobjmanip will try to copy the
content as is.

LmO008: Symbol symbol has unsupported format

iobjmanip encountered a symbol that cannot be handled. i objmanip will ignore this
symbol when generating the output file.

LmO009: Group type nr not supported

iobjmanip only supports groups of type GRP_COMDAT. If any other group type is
encountered, the result is undefined.

LmO010: Unsupported ELF feature in file: msg

The input file uses a feature that iobjmanip does not support.
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LmOII: Unsupported ELF file type

The input file is not a relocatable object file.

LmO012: Ambiguous rename for section/symbol name (altl and alt2)
An ambiguity was detected while renaming a section or symbol. One of the alternatives
will be used.

LmOI13: Section name removed due to transitive dependency on
name

A section was removed as it depends on an explicitly removed section.

LmO14: File has no section with index nr

A section index, used as a parameter to --remove_section Or --rename_section,
did not refer to a section in the input file.

Ms003: could not open file filename for writing

iobjmanip failed to open the output file for writing. Make sure that it is not write
protected.

Ms004: problem writing to file filename

An error occurred while writing to file £ilename. A possible reason for this is that the
volume is full.

Ms005: problem closing file filename

An error occurred while closing the file £ilename.

The IAR Absolute Symbol Exporter—isymexport

The IAR Absolute Symbol Exporter, i symexport, can export absolute symbols from a
ROM image file, so that they can be used when you link an add-on application.

To keep symbols from your symbols file in your final application, the symbols must be
referred to, either from your source code or by using the linker option --keep.
INVOCATION SYNTAX

The invocation syntax for the IAR Absolute Symbol Exporter is:

isymexport [options] inputfile outputfile [options]
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Parameters

The parameters are:

Parameter Description

inputfile A ROM image in the form of an executable ELF file (output from
linking).

options Any of the available command line options, see Summary of isymexport

options, page 475.

outputfile A relocatable ELF file that can be used as input to linking, and which
contains all or a selection of the absolute symbols in the input file.
The output file contains only the symbols, not the actual code or data
sections. A steering file can be used to control which symbols that are
included, and also to rename some of the symbols if that is desired.

Table 50: isymexport parameters
See also Rules for specifying a filename or directory as parameters, page 246.

In the IDE, to add the export of library symbols, choose Project>Options>Build
Actions and specify your command line in the Post-build command line text field, for
example like this:

STOOLKIT_DIRS\bin\isymexport.exe "STARGET_PATHS"
"$PROJ_DIRS\const_lib.symbols"

SUMMARY OF ISYMEXPORT OPTIONS

This table summarizes the isymexport command line options:

Command line option Description

--edit Specifies a steering file.

-f Extends the command line.

-f Extends the command line.
--generate_vfe_header Declares that the image does not contain any virtual

function calls to potentially discarded functions.

--reserve_ranges Generates symbols to reserve the areas in ROM and
RAM that the image uses.

--version Sends tool output to the console and then exits.

Table 51: isymexport options summary

For more information, see Descriptions of options, page 479.
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Show directive

Syntax

Parameters

Description

Example
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STEERING FILES

A steering file can be used for controlling which symbols that are included, and also to
rename some of the symbols if that is desired. In the file, you can use show and hide
directives to select which public symbols from the input file that are to be included in
the output file. rename directives can be used for changing the names of symbols in the
input file.

When you use a steering file, only actively exported symbols will be available in the
output file. Thus, a steering file without show directives will generate an output file
without symbols.

Syntax
The following syntax rules apply:

o FEach directive is specified on a separate line.
C comments (/*. ..*/) and C++ comments (// . . .) can be used.

Patterns can contain wildcard characters that match more than one possible
character in a symbol name.

The * character matches any sequence of zero or more characters in a symbol name.

The ? character matches any single character in a symbol name.

Example

rename XXX_* as YYY_* /*Change symbol prefix from xxx_ to YYY_ */
show YYY_* /* Export all symbols from YYY package */
hide *_internal /* But do not export internal symbols */
show zzz? /* Export zzza, but not zzzaaa */

hide zzzx /* But do not export zzzx */

show pattern

pattern A pattern to match against a symbol name.

A symbol with a name that matches the pattern will be included in the output file unless
this is overridden by a later hide directive.

/* Include all public symbols ending in _pub. */
show *_pub
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Hide directive

Syntax hide pattern
Parameters
pattern A pattern to match against a symbol name.
Description A symbol with a name that matches the pattern will not be included in the output file

unless this is overridden by a later show directive.
Example /* Do not include public symbols ending in _sys. */

hide *_sys

Rename directive

Syntax rename patternl as pattern2

Parameters
patternl A pattern used for finding symbols to be renamed. The pattern
can contain no more than one * or ? wildcard character.

pattern2 A pattern used for the new name for a symbol. If the pattern
contains a wildcard character, it must be of the same kind as in
patternl.
Description Use this directive to rename symbols from the output file to the input file. No exported

symbol is allowed to match more than one rename pattern.

rename directives can be placed anywhere in the steering file, but they are executed
before any show and hide directives. Thus, if a symbol will be renamed, all show and
hide directives in the steering file must refer to the new name.

If the name of a symbol matches a patterni pattern that contains no wildcard
characters, the symbol will be renamed pattern2 in the output file.

If the name of a symbol matches a patterni pattern that contains a wildcard character,
the symbol will be renamed pattern2 in the output file, with part of the name matching
the wildcard character preserved.

Example /* xxx_start will be renamed Y_start_X in the output file,
xxX_stop will be renamed Y_stop_X in the output file. */
rename xxxX_* as Y_*_X
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DIAGNOSTIC MESSAGES

This section lists the messages produced by isymexport:

Es001: could not open file filename

isymexport failed to open the specified file.

Es002: illegal path pathname

The path pathname is not a valid path.

Es003: format error: message

A problem occurred while reading the input file.

Es004: no input file

No input file was specified.

Es005: no output file

An input file, but no output file was specified.

Es006: too many input files

More than two files were specified.

Es007: input file is not an ELF executable

The input file is not an ELF executable file.

Es008: unknown directive: directive

The specified directive in the steering file is not recognized.

Es009: unexpected end of file

The steering file ended when more input was required.

Es010: unexpected end of line

A line in the steering file ended before the directive was complete.

EsOl I: unexpected text after end of directive

There is more text on the same line after the end of a steering file directive.
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EsO12: expected text

The specified text was not present in the steering file, but must be present for the
directive to be correct.

EsO13: pattern can contain at most one * or ?

Each pattern in the current directive can contain at most one * or one ? wildcard
character.

EsOl4: rename patterns have different wildcards

Both patterns in the current directive must contain exactly the same kind of wildcard.
That is, both must either contain:

e No wildcards
e Exactly one *

e Exactly one ?

This error occurs if the patterns are not the same in this regard.

Es014: ambiguous pattern match: symbol matches more than one
rename pattern

A symbol in the input file matches more than one rename pattern.

Descriptions of options

Syntax
For use with

Description

This section gives detailed reference information about each command line option
available for the different utilities.

ielfdumparm

Use this option as a shortcut for --all --no_strtab.

This option is not available in the IDE.
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--all

Syntax
For use with

Description

--bin
Syntax
For use with

Description

--checksum

Syntax

Parameters
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--all
ielfdumparm

Use this option to include the contents of all ELF sections in the output, in addition to
the general properties of the input file. Sections are output in index order, except that
each relocation section is output immediately after the section it holds relocations for.

By default, no section contents are included in the output.

This option is not available in the IDE.

--bin
ielftool
Sets the format of the output file to binary.

To set related options, choose:

Project>Options>Output converter

--checksum
{symbol[+offset] |address}:size,algorithm[:[1|2] [m] [L|W] [r][i]|p]]
[,start]; rangel; range...]

symbol The name of the symbol where the checksum value should be
stored. Note that it must exist in the symbol table in the input
ELF file.

offset An offset to the symbol.

address The absolute address where the checksum value should be
stored.

size The number of bytes in the checksum: 1, 2, or 4; must not be

larger than the size of the checksum symbol.



algorithm

12

Llw
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The checksum algorithm used, one of:

* sum, a byte-wise calculated arithmetic sum. The result is
truncated to 8 bits.

* sum8wide, a byte-wise calculated arithmetic sum. The result is
truncated to the size of the symbol.

e sum32, a word-wise (32 bits) calculated arithmetic sum.

* crcl6, CRC16 (generating polynomial 0x11021); used by
default.

* crc32, CRC32 (generating polynomial 0x104C11DB7).
* crc64iso, CRC64iso (generating polynomial 0x1B).

* crc64ecma, CRC64ECMA (generating polynomial
0x42F0E1EBA9EA3693).

* crc=n, CRC with a generating polynomial of n.
If specified, can be one of:

e 1 - Specifies one's complement.

* 2 - Specifies two's complement.

Reverses the order of the bits within each byte when calculating
the checksum.

Specifies the size of the unit for which a checksum should be
calculated.

Choose between:
L, calculates a checksum on 32 bits in every iteration
w, calculates a checksum on 16 bits in every iteration.

If you do not specify a unit size, 8 bits will be used by default.
Using these parameters does not add any additional error
detection power to the checksum.

Reverses the byte order of the input data. This has no effect
unless the number of bits per iteration has been set using the L or
W parameters.
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For use with

Description

Example
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ilp Use either i or p, if the start value is bigger than 0. If specified,
can be one of:

e i - Initializes the checksum value with the start value.

*p - Prefixes the input data with a word of size size that
contains the start value.

start By default, the initial value of the checksum is 0. If necessary,
use start to supply a different initial value. If not 0, then either
i or p must be specified.

range The address range on which the checksum should be calculated.
Hexadecimal and decimal notation is allowed (for example,
0x8002-0x8FFF).

Symbols that are present in ELF file can be used in the range
description (for example,
__checksum_begin-__checksum_end).

ielftool

Use this option to calculate a checksum with the specified algorithm for the specified
ranges. If you have an external definition for the checksum (for example, a hardware
CRC implementation), use the appropriate parameters to the - -checksum option to
match the external design. (In this case, learn more about that design in the hardware
documentation.) The checksum will then replace the original value in symbol. A new
absolute symbol will be generated; with the symbol name suffixed with _value
containing the calculated checksum. This symbol can be used for accessing the
checksum value later when needed, for example during debugging.

If the --checksum option is used more than once on the command line, the options are
evaluated from left to right. If a checksum is calculated for a symbo1 that is specified in
a later evaluated - -checksum option, an error is issued.

This example shows how to use the crc16 algorithm with the start value 0 over the
address range 0x8000-0x8FFF:

ielftool --checksum=__ checksum:2,crcl6;0x8000-0x8FFF
sourceFile.out destinationFile.out

The input data i read from sourceFile.out, and the resulting checksum value of size
2 bytes will be stored at the symbol __ checksum. The modified ELF file is saved as
destinationFile.out leaving sourceFile.out untouched.



See also

--code

Syntax
For use with

Description

-=Create

Syntax

Parameters

For use with

Description
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In the next example, a symbol is used for specifying the start of the range:

ielftool --checksum=__ checksum:2,crcl6;__ checksum_start-0x8FFF

sourceFile.out destinationFile.out

Checksum calculation for verifying image integrity, page 202
To set related options, choose:

Project>Options>Linker>Checksum

--code
ielfdump
Use this option to dump all sections that contain executable code (sections with the ELF

section attribute SHF_EXECINSTR).

This option is not available in the IDE.

--create libraryfile objectfilel ... objectfileN

libraryfile The library file that the command operates on. See Rules for
specifying a filename or directory as parameters, page 246.

objectfilel ... The object file(s) to build the library from.
objectfileN

iarchive

Use this command to build a new library from a set of object files (modules). The object
files are added to the library in the exact order that they are specified on the command
line.

If no command is specified on the command line, --create is used by default.

This option is not available in the IDE.
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--delete, -d

Syntax

Parameters

For use with

Description

--edit

Syntax
For use with

Description

See also

--extract, -x

Syntax

Parameters
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--delete libraryfile objectfilel ... objectfileN
-d libraryfile objectfilel ... objectfileN

libraryfile The library file that the command operates on. See Rules for
specifying a filename or directory as parameters, page 246.

objectfilel ... The object file(s) that the command operates on.
objectfileN

iarchive

Use this command to remove object files (modules) from an existing library. All object
files that are specified on the command line will be removed from the library.

This option is not available in the IDE.

--edit steering file
isymexport

Use this option to specify a steering file to control which symbols that are included in
the isymexport output file, and also to rename some of the symbols if that is desired.

Steering files, page 476.

This option is not available in the IDE.

--extract libraryfile [objectfilel ... objectfileN]
-x libraryfile [objectfilel ... objectfileN]
libraryfile The library file that the command operates on. See Rules for

specifying a filename or directory as parameters, page 246.



-f

For use with

Description

Syntax
Parameters
For use with

Description
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objectfilel ... The object file(s) that the command operates on.
objectfileN

iarchive

Use this command to extract object files (modules) from an existing library. If a list of
object files is specified, only these files are extracted. If a list of object files is not
specified, all object files in the library are extracted.

This option is not available in the IDE.

-f filename

See Rules for specifying a filename or directory as parameters, page 246.
iarchive, ielfdumparm, iobjmanip, and isymexport.
Use this option to make the tool read command line options from the named file, with

the default filename extension xc1.

In the command file, you format the items exactly as if they were on the command line
itself, except that you can use multiple lines, because the newline character acts just as
a space or tab character.

Both C and C++ style comments are allowed in the file. Double quotes behave in the
same way as in the Microsoft Windows command line environment.

This option is not available in the IDE.
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-fill

Syntax --fill [v;]pattern;rangel;range...]

Parameters
v Generates virtual fill for the fill command. Virtual fill is filler
bytes that are included in checksumming, but that are not
included in the output file. The primary use for this is certain
types of hardware where bytes that are not specified by the image
have a known value (typically, 0xFF or 0x0).

pattern A hexadecimal string with the 0x prefix (for example, 0xEF)
interpreted as a sequence of bytes, where each pair of digits
corresponds to one byte (for example 0x123456, for the
sequence of bytes 0x12, 0x34, and 0x56). This sequence is
repeated over the fill area. If the length of the fill pattern is
greater than 1 byte, it is repeated as if it started at address 0.

range Specifies the address range for the fill. Hexadecimal and decimal
notation is allowed (for example, 0x8002-0x8FFF). Note that
each address must be 4-byte aligned.

Symbols that are present in the ELF file can be used in the range
description (for example.
__checksum_begin-__checksum_end).

For use with ielftool

Description Use this option to fill all gaps in one or more ranges with a pattern, which can be either
an expression or a hexadecimal string. The contents will be calculated as if the fill
pattern was repeatedly filled from the start address until the end address is passed, and
then the real contents will overwrite that pattern.

If the --£i11 option is used more than once on the command line, the fill ranges cannot
overlap each other.

To set related options, choose:

Project>Options>Linker>Checksum

--generate_vfe_header

Syntax --generate_vfe_header

For use with isymexport
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Description Use this option to declare that the image does not contain any virtual function calls to
potentially discarded functions.

When the linker performs virtual function elimination, it discards virtual functions that
appear not to be needed. For the optimization to be applied correctly, there must be no
virtual function calls in the image that affect the functions that are discarded.

See also Virtual function elimination, page 208.

To set this options, use:

Project>Options>Linker>Extra Options

--ihex
Syntax --ihex
For use with ielftool
Description Sets the format of the output file to linear Intel hex.

To set related options, choose:

Project>Options>Linker>Output converter

--no_header

Syntax --no_header
For use with ielfdumparm
Description By default, a standard list header is added before the actual file content. Use this option

to suppress output of the list header.

This option is not available in the IDE.

--no_rel_section

Syntax --no_rel_section

For use with ielfdumparm
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Description

--no_strtab

Syntax
For use with

Description

--output, -o

Syntax

Parameters
For use with

Description
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By default, whenever the content of a section of a relocatable file is generated as output,
the associated section, if any, is also included in the output. Use this option to suppress
output of the relocation section.

This option is not available in the IDE.

--no_strtab
ielfdumparm
Use this option to suppress dumping of string table sections (sections of type

SHT_STRTAB).

This option is not available in the IDE.

-o {filename|directory}
--output {filename|directory}

See Rules for specifying a filename or directory as parameters, page 246.
iarchive and ielfdumparm.

iarchive

By default, iarchive assumes that the first argument after the iarchive command is
the name of the destination library. Use this option to explicitly specify a different
filename for the library.

ielfdumparm

By default, output from the dumper is directed to the console. Use this option to direct
the output to a file instead. The default name of the output file is the name of the input
file with an added id filename extension

You can also specify the output file by specifying a file or directory following the name
of the input file.

This option is not available in the IDE.



--parity

Syntax

Parameters

For use with

Description
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--parity{symbol[+offset] |address}:size,algo: flashbasel: flags];ran

gel; range...]

symbol

offset

address

size

algo

flashbase

flags

range

ielftool

The name of the symbol where the parity bytes should be
stored. Note that it must exist in the symbol table in the
input ELF file.

An offset to the symbol. By default, 0.

The absolute address where the parity bytes should be
stored.

The maximum number of bytes that the parity generation
can use. An error will be issued if this value is exceeded.
Note that the size must fit in the specified symbol in the ELF
file.

Choose between:

odd, uses odd parity.
even, Uses even parity.

The start address of the flash memory. Parity bits will not be
generated for the addresses between flashbase and the
start address of the range. If f1ashbase and the start
address of the range coincide, parity bits will be generated
for all addresses

Choose between:

r, reverses the byte order within each word.
L, processes 4 bytes at a time.

W, processes 2 bytes at a time.

B, processes 1 byte at a time.

The address range over which the parity bytes should be
generated. Hexadecimal and decimal notation are allowed
(for example, 0x8002-0x8FFF).

Use this option to generate parity bytes over specified ranges. The range is traversed left
to the right and the parity bits are generated using the odd or even algorithm. The parity
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=-=-ram_reserve_ranges

Syntax

Parameters

For use with

Description

See also

--range

Syntax

Parameters

For use with

Description
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bits are finally stored in the specified symbol where they can be accessed by your
application.

This option is not available in the IDE.

--ram_reserve_ranges [=symbol_prefix]

symbol_prefix The prefix of symbols created by this option.

isymexport

Use this option to generate symbols for the areas in RAM that the image uses. One
symbol will be generated for each such area. The name of each symbol is based on the
name of the area and is prefixed by the optional parameter symbol_prefix.

Generating symbols that cover an area in this way prevents the linker from placing other
content at the affected addresses. This can be useful when linking against an existing
image.

If --ram_reserve_ranges is used together with --reserve_ranges, the RAM
areas will get their prefix from the --ram_reserve_ranges option and the non-RAM
areas will get their prefix from the --reserve_ranges option.

--reserve_ranges, page 493.

This option is not available in the IDE.

--range start-end

start-end Disassemble code where the start address is greater than or
equal to start, and where the end address is less than end.

ielfdumparm

Use this option to specify a range for which code from an executable will be dumped.
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This option is not available in the IDE.

--raw
Syntax --raw
For use with ielfdumparm
Description By default, many ELF sections will be dumped using a text format specific to a

particular kind of section. Use this option to dump each selected ELF section using the
generic text format.

The generic text format dumps each byte in the section in hexadecimal format, and
where appropriate, as ASCII text.

This option is not available in the IDE.

--remove_file_path

Syntax --remove_file_path
For use with iobjmanip
Description Use this option to make iobjmanip remove information about the directory structure

of the project source tree from the generated object file, which means that the file
symbol in the ELF object file is modified.

This option must be used in combination with --remove_section ".comment".

This option is not available in the IDE.

--remove_section

Syntax --remove_section {section | number}

Parameters
section The section—or sections, if there are more than one section with

the same name—to be removed.
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number The number of the section to be removed. Section numbers can
be obtained from an object dump created using ielfdumparm.

For use with iobjmanip

Description Use this option to make iobjmanip omit the specified section when generating the
output file.

This option is not available in the IDE.

--rename_section

Syntax --rename_section {oldname|oldnumber}=newname

Parameters
oldname The section—or sections, if there are more than one section with
the same name—to be renamed.

oldnumber The number of the section to be renamed. Section numbers can
be obtained from an object dump created using iel fdumparm.

newname The new name of the section.

For use with iobjmanip

Description Use this option to make iobjmanip rename the specified section when generating the
output file.

This option is not available in the IDE.

--rename_symbol

Syntax --rename_symbol oldname =newname
Parameters
oldname The symbol to be renamed.
newname The new name of the symbol.
For use with iobjmanip
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--replace, -r

Syntax

Parameters

For use with

Description

--reserve_ranges

Syntax

Parameters

For use with

Description
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Use this option to make iobjmanip rename the specified symbol when generating the
output file.

This option is not available in the IDE.

--replace libraryfile objectfilel ... objectfileN
-r libraryfile objectfilel ... objectfileN

libraryfile The library file that the command operates on. See Rules for
specifying a filename or directory as parameters, page 246.

objectfilel ... The object file(s) that the command operates on.
objectfileN

iarchive

Use this command to replace or add object files (modules) to an existing library. The
object files specified on the command line either replace existing object files in the
library (if they have the same name) or are appended to the library.

This option is not available in the IDE.

--reserve_ranges [=symbol_prefix]|

symbol_prefix The prefix of symbols created by this option.

isymexport

Use this option to generate symbols for the areas in ROM and RAM that the image uses.
One symbol will be generated for each such area. The name of each symbol is based on
the name of the area and is prefixed by the optional parameter symbol_prefix.

Generating symbols that cover an area in this way prevents the linker from placing other
content at the affected addresses. This can be useful when linking against an existing
image.
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See also

--section, -s

Syntax

Parameters

For use with

Description

Example
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If --reserve_ranges is used together with --ram_reserve_ranges, the RAM
areas will get their prefix from the --ram_reserve_ranges option and the non-RAM
areas will get their prefix from the --reserve_ranges option.

--ram_reserve_ranges, page 490.

This option is not available in the IDE.

--section section_number|section_name[,...]
--s section_number|section_namel, ...]

section_number The number of the section to be dumped.

section_name The name of the section to be dumped.

ielfdumparm

Use this option to dump the contents of a section with the specified number, or any
section with the specified name. If a relocation section is associated with a selected
section, its contents are output as well.

If you use this option, the general properties of the input file will not be included in the
output.

You can specify multiple section numbers or names by separating them with commas,
or by using this option more than once.

By default, no section contents are included in the output.
-s 3,17 /* Sections #3 and #17

-s .debug_frame, 42 /* Any sections named .debug_frame and
also section #42 */

This option is not available in the IDE.



--segment, -g

Syntax

Parameters

For use with

Description

--self _reloc

Syntax
For use with

Description

--silent

Syntax
For use with

Description
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--segment segment_number],...]

-g segment_numberl,...]

The number of a segment whose contents will be included
in the output.

segmnt_number

ielfdumparm

Use this option to select specific segments (parts of an executable image indicated by
program headers) for inclusion in the output.

This option is not available in the IDE.

--self_reloc
ielftool

This option is intentionally not documented as it is not intended for general use.

This option is not available in the IDE.

--silent
iobjmanip and ielftool.

Causes the tool to operate without sending any messages to the standard output stream.

By default, the tool sends various messages via the standard output stream. You can use
this option to prevent this. The tool sends error and warning messages to the error output
stream, so they are displayed regardless of this setting.

This option is not available in the IDE.
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--simple
Syntax

For use with

Description

--simple-ne
Syntax

For use with

Description

==source

Syntax
For use with

Description

==Srec

Syntax

For use with
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--simple
ielftool

Sets the format of the output file to Simple code.
To set related options, choose:

Project>Options>Output converter

--simple-ne
ielftool

Sets the format of the output file to Simple code, but no entry record is generated.
To set related options, choose:

Project>Options>Output converter

—-—-source

ielfdumparm

Use this option to make ielftool include source for each statement before the code
for that statement, when dumping code from an executable file. To make this work, the

executable image must be built with debug information, and the source code must still
be accessible in its original location.

This option is not available in the IDE.

—-—-srecC

ielftool



Description

--srec-len

Syntax

Parameters

For use with

Description

--srec-s3only

Syntax
For use with

Description

--strip
Syntax
For use with

Description
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Sets the format of the output file to Motorola S-records.
To set related options, choose:

Project>Options>Output converter

--srec-len=length

length The number of data bytes in each S-record.

ielftool

Restricts the number of data bytes in each S-record. This option can be used in
combination with the --srec option.

This option is not available in the IDE.

--srec-s3only
ielftool

Restricts the S-record output to contain only a subset of records, that is SO, S3 and S7
records. This option can be used in combination with the --srec option.

This option is not available in the IDE.

--strip
iobjmanip and ielftool.

Use this option to remove all sections containing debug information before the output
file is written.
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--symbols

Syntax

Parameters

For use with

Description

--titxt

Syntax
For use with

Description

--toc, -t

Syntax
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Note that ielftool needs an unstripped input ELF image. If you use the --strip
option in the linker, remove it and use the --strip option in ielftool instead.

To set related options, choose:

Project>Options>Linker>Output>Include debug information in output

--symbols libraryfile

libraryfile The library file that the command operates on. See Rules for
specifying a filename or directory as parameters, page 246.

iarchive

Use this command to list all external symbols that are defined by any object file
(module) in the specified library, together with the name of the object file (module) that
defines it.

In silent mode (--silent), this command performs symbol table-related syntax checks
on the library file and displays only errors and warnings.

This option is not available in the IDE.

--titxt
ielftool

Sets the format of the output file to TI-txt.
To set related options, choose:

Project>Options>Output converter

--toc libraryfile
-t libraryfile



Parameters

For use with

Description
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libraryfile The library file that the command operates on. See Rules for
specifying a filename or directory as parameters, page 246.

iarchive

Use this command to list the names of all object files (modules) in a specified library.

In silent mode (--silent), this command performs basic syntax checks on the library
file, and displays only errors and warnings.

This option is not available in the IDE.

--use_full_std_template_names

Syntax
For use with

Description

--verbose, -V

Syntax

For use with

Description

--use_full_std_template_names
ielfdumparm

Normally, the names of some standard C++ templates are used in the output in an
abbreviated form in the unmangled names of symbols (for example, "std: :string"
instead of "std: :basic_string<char, std::char_traits<char>,
std_::allocator<char>>"). Use this option to make ielfdump use the
unabbreviated form.

This option is not available in the IDE.

--verbose
-V (iarchive only)

iarchive and ielftool.

Use this option to make the tool report which operations it performs, in addition to
giving diagnostic messages.

This option is not available in the IDE because this setting is always enabled.
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--version
Syntax --version
For use with iarchive, ielfdump, iobjmanip, isymexport
Description Use this option to make the tool send version information to the console and then exit.

This option is not available in the IDE.
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Implementation-defined
behavior for Standard C

e Descriptions of implementation-defined behavior

If you are using C89 instead of Standard C, see Implementation-defined behavior
for C89, page 517. For a short overview of the differences between Standard
C and C89, see C language overview, page 175.

Descriptions of implementation-defined behavior

This section follows the same order as the C standard. Each item includes references to
the ISO chapter and section (in parenthesis) that explains the implementation-defined
behavior.

Note: The IAR Systems implementation adheres to a freestanding implementation of
Standard C. This means that parts of a standard library can be excluded in the
implementation.

J-.3.1 TRANSLATION

Diagnostics (3.10, 5.1.1.3)
Diagnostics are produced in the form:
filename, linenumber levell[tag]: message

where £ilename is the name of the source file in which the error was encountered,
linenumber is the line number at which the compiler detected the error, level is the
level of seriousness of the message (remark, warning, error, or fatal error), tag is a
unique tag that identifies the message, and message is an explanatory message, possibly
several lines.

White-space characters (5.1.1.2)

At translation phase three, each non-empty sequence of white-space characters is
retained.
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J.3.2 ENVIRONMENT

The character set (5.1.1.2)

The source character set is the same as the physical source file multibyte character set.
By default, the standard ASCII character set is used. However, if you use the
--enable_multibytes compiler option, the host character set is used instead.

Main (5.1.2.1)

The function called at program startup is called main. No prototype is declared for
main, and the only definition supported for main is:

int main(void)

To change this behavior, see System initialization, page 130.

The effect of program termination (5.1.2.1)

Terminating the application returns the execution to the startup code (just after the call
to main).

Alternative ways to define main (5.1.2.2.1)

There is no alternative ways to define the main function.

The argv argument to main (5.1.2.2.1)

The argv argument is not supported.

Streams as interactive devices (5.1.2.3)

The streams stdin, stdout, and stderr are treated as interactive devices.

Signals, their semantics, and the default handling (7.14)

In the DLIB runtime environment, the set of supported signals is the same as in Standard
C. A raised signal will do nothing, unless the signal function is customized to fit the
application.

Signal values for computational exceptions (7.14.1.1)

In the DLIB runtime environment, there are no implementation-defined values that
correspond to a computational exception.
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Signals at system startup (7.14.1.1)

In the DLIB runtime environment, there are no implementation-defined signals that are
executed at system startup.

Environment names (7.20.4.5)

In the DLIB runtime environment, there are no implementation-defined environment
names that are used by the getenv function.

The system function (7.20.4.6)

The system function is not supported.
J.3.3 IDENTIFIERS

Multibyte characters in identifiers (6.4.2)

Additional multibyte characters may not appear in identifiers.

Significant characters in identifiers (5.2.4.1, 6.1.2)
The number of significant initial characters in an identifier with or without external
linkage is guaranteed to be no less than 200.

J.3.4 CHARACTERS

Number of bits in a byte (3.6)

A byte contains 8 bits.

Execution character set member values (5.2.1)

The values of the members of the execution character set are the values of the ASCII
character set, which can be augmented by the values of the extra characters in the host
character set.

Alphabetic escape sequences (5.2.2)

The standard alphabetic escape sequences have the values \a-7, \b-8, \£-12, \n-10,
\r-13, \t-9, and \v-11.

Characters outside of the basic executive character set (6.2.5)

A character outside of the basic executive character set that is stored in a char is not
transformed.
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Plain char (6.2.5, 6.3.1.1)

A plain char is treated as an unsigned char.

Source and execution character sets (6.4.4.4, 5.1.1.2)

The source character set is the set of legal characters that can appear in source files. By
default, the source character set is the standard ASCII character set. However, if you use
the command line option --enable_multibytes, the source character set will be the
host computer’s default character set.

The execution character set is the set of legal characters that can appear in the execution
environment. By default, the execution character set is the standard ASCII character set.

However, if you use the command line option --enable_multibytes, the execution
character set will be the host computer’s default character set. The DLIB runtime
environment needs a multibyte character scanner to support a multibyte execution
character set. See Locale, page 141.

Integer character constants with more than one character (6.4.4.4)

An integer character constant that contains more than one character will be treated as an
integer constant. The value will be calculated by treating the leftmost character as the
most significant character, and the rightmost character as the least significant character,
in an integer constant. A diagnostic message will be issued if the value cannot be
represented in an integer constant.

Wide character constants with more than one character (6.4.4.4)
A wide character constant that contains more than one multibyte character generates a
diagnostic message.

Locale used for wide character constants (6.4.4.4)

By default, the C locale is used. If the --enable_multibytes compiler option is used,
the default host locale is used instead.

Locale used for wide string literals (6.4.5)

By default, the C locale is used. If the - -enable_multibytes compiler option is used,
the default host locale is used instead.

Source characters as executive characters (6.4.5)

All source characters can be represented as executive characters.
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J.3.5 INTEGERS

Extended integer types (6.2.5)

There are no extended integer types.

Range of integer values (6.2.6.2)

The representation of integer values are in the two's complement form. The most
significant bit holds the sign; 1 for negative, O for positive and zero.

For information about the ranges for the different integer types, see Basic data

types—integer types, page 321.

The rank of extended integer types (6.3.1.1)

There are no extended integer types.

Signals when converting to a signed integer type (6.3.1.3)

No signal is raised when an integer is converted to a signed integer type.

Signed bitwise operations (6.5)

Bitwise operations on signed integers work the same way as bitwise operations on
unsigned integers; in other words, the sign-bit will be treated as any other bit.

J.3.6 FLOATING POINT

Accuracy of floating-point operations (5.2.4.2.2)

The accuracy of floating-point operations is unknown.

Rounding behaviors (5.2.4.2.2)

There are no non-standard values of FLT_ROUNDS.

Evaluation methods (5.2.4.2.2)

There are no non-standard values of FLT_EVAL_METHOD.

Converting integer values to floating-point values (6.3.1.4)

When an integral value is converted to a floating-point value that cannot exactly
represent the source value, the round-to-nearest rounding mode is used (FLT_ROUNDS is
defined to 1).
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Converting floating-point values to floating-point values (6.3.1.5)

When a floating-point value is converted to a floating-point value that cannot exactly
represent the source value, the round-to-nearest rounding mode is used (FLT_ROUNDS is
defined to 1).

Denoting the value of floating-point constants (6.4.4.2)

The round-to-nearest rounding mode is used (FLT_ROUNDS is defined to 1).

Contraction of floating-point values (6.5)

Floating-point values are contracted. However, there is no loss in precision and because
signaling is not supported, this does not matter.

Default state of FENV_ACCESS (7.6.1)

The default state of the pragma directive FENV_ACCESS is OFF.

Additional floating-point mechanisms (7.6, 7.12)

There are no additional floating-point exceptions, rounding-modes, environments, and
classifications.

Default state of FP_CONTRACT (7.12.2)

The default state of the pragma directive FP_CONTRACT is OFF.
J.3.7 ARRAYS AND POINTERS

Conversion from/to pointers (6.3.2.3)

For information about casting of data pointers and function pointers, see Casting, page
328.

ptrdiff_t (6.5.6)

For information about ptrdiff_t, see ptrdiff t, page 328.
J.3.8 HINTS

Honoring the register keyword (6.7.1)

User requests for register variables are not honored.
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Inlining functions (6.7.4)

User requests for inlining functions increases the chance, but does not make it certain,
that the function will actually be inlined into another function. See Inlining functions,
page 71.

J.3.9 STRUCTURES, UNIONS, ENUMERATIONS, AND
BITFIELDS
Sign of 'plain’ bitfields (6.7.2, 6.7.2.1)

For information about how a 'plain’ int bitfield is treated, see Bitfields, page 322.

Possible types for bitfields (6.7.2.1)

All integer types can be used as bitfields in the compiler’s extended mode, see -e, page
261.

Bitfields straddling a storage-unit boundary (6.7.2.1)

A bitfield is always placed in one—and one only—storage unit, which means that the
bitfield cannot straddle a storage-unit boundary.

Allocation order of bitfields within a unit (6.7.2.1)

For information about how bitfields are allocated within a storage unit, see Bitfields,
page 322.

Alignment of non-bitfield structure members (6.7.2.1)

The alignment of non-bitfield members of structures is the same as for the member
types, see Alignment, page 319.

Integer type used for representing enumeration types (6.7.2.2)

The chosen integer type for a specific enumeration type depends on the enumeration
constants defined for the enumeration type. The chosen integer type is the smallest
possible.

J.3.10 QUALIFIERS

Access to volatile objects (6.7.3)

Any reference to an object with volatile qualified type is an access, see Declaring
objects volatile, page 331.
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J.3.11 PREPROCESSING DIRECTIVES

Mapping of header names (6.4.7)

Sequences in header names are mapped to source file names verbatim. A backslash '\'
is not treated as an escape sequence. See Overview of the preprocessor, page 407.
Character constants in constant expressions (6.10.1)

A character constant in a constant expression that controls conditional inclusion
matches the value of the same character constant in the execution character set.

The value of a single-character constant (6.10.1)

A single-character constant may only have a negative value if a plain character (char)
is treated as a signed character, see --char_is_signed, page 254.

Including bracketed filenames (6.10.2)

For information about the search algorithm used for file specifications in angle brackets
<>, see Include file search procedure, page 237.

Including quoted filenames (6.10.2)

For information about the search algorithm used for file specifications enclosed in
quotes, see Include file search procedure, page 237.

Preprocessing tokens in #include directives (6.10.2)

Preprocessing tokens in an #include directive are combined in the same way as outside
an #include directive.

Nesting limits for #include directives (6.10.2)

There is no explicit nesting limit for #include processing.

Universal character names (6.10.3.2)

Universal character names (UCN) are not supported.

Recognized pragma directives (6.10.6)

In addition to the pragma directives described in the chapter Pragma directives, the
following directives are recognized and will have an indeterminate effect. If a pragma
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directive is listed both in the chapter Pragma directives and here, the information
provided in the chapter Pragma directives overrides the information here.

alignment

baseaddr
basic_template_matching
building_ runtime
can_instantiate

codeseg

constseg

cspy_support

dataseg

define_type_info
do_not_instantiate
early_dynamic_initialization
function

function_effects

hdrstop

important_typedef
instantiate

keep_definition
library_default_requirements
library provides
library_requirement_override
memory

module_name

no_pch

once

system_include

vector
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warnings

Default __DATE__ and __TIME__ (6.10.8)

The definitions for __TIME _ and __DATE__ are always available.
J.3.12 LIBRARY FUNCTIONS

Additional library facilities (5.1.2.1)

Most of the standard library facilities are supported. Some of them—the ones that need
an operating system—require a low-level implementation in the application. For more
information, see The DLIB runtime environment, page 107.

Diagnostic printed by the assert function (7.2.1.1)

The assert () function prints:

filename: linenr expression -- assertion failed

when the parameter evaluates to zero.

Representation of the floating-point status flags (7.6.2.2)

For information about the floating-point status flags, see fenv.h, page 422.

Feraiseexcept raising floating-point exception (7.6.2.3)

For information about the feraiseexcept function raising floating-point exceptions,
see Floating-point environment, page 326.

Strings passed to the setlocale function (7.11.1.1)

For information about strings passed to the setlocale function, see Locale, page 141.

Types defined for float_t and double_t (7.12)

The FLT_EVAL_METHOD macro can only have the value 0.

Domain errors (7.12.1)

No function generates other domain errors than what the standard requires.

Return values on domain errors (7.12.1)

Mathematic functions return a floating-point NaN (not a number) for domain errors.
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Underflow errors (7.12.1)

Mathematic functions set errno to the macro ERANGE (a macro in errno . h) and return
zero for underflow errors.

fmod return value (7.12.10.1)

The £mod function returns a floating-point NaN when the second argument is zero.

The magnitude of remquo (7.12.10.3)

The magnitude is congruent modulo INT_MAX.

signal() (7.14.1.1)

The signal part of the library is not supported.

Note: The default implementation of signal does not perform anything. Use the
template source code to implement application-specific signal handling. See signal,
page 137 and raise, page 135, respectively.

NULL macro (7.17)

The NULL macro is defined to 0.

Terminating newline character (7.19.2)

stdout stream functions recognize either newline or end of file (EOF) as the
terminating character for a line.

Space characters before a newline character (7.19.2)

Space characters written to a stream immediately before a newline character are
preserved.

Null characters appended to data written to binary streams (7.19.2)

No null characters are appended to data written to binary streams.

File position in append mode (7.19.3)

The file position is initially placed at the beginning of the file when it is opened in
append-mode.

Truncation of files (7.19.3)

Whether a write operation on a text stream causes the associated file to be truncated
beyond that point, depends on the application-specific implementation of the low-level
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file routines. See Briefly about input and output (I/0), page 108.

File buffering (7.19.3)

An open file can be either block-buffered, line-buffered, or unbuffered.

A zero-length file (7.19.3)

Whether a zero-length file exists depends on the application-specific implementation of
the low-level file routines.

Legal file names (7.19.3)

The legality of a filename depends on the application-specific implementation of the
low-level file routines.

Number of times a file can be opened (7.19.3)

Whether a file can be opened more than once depends on the application-specific
implementation of the low-level file routines.

Multibyte characters in a file (7.19.3)

The encoding of multibyte characters in a file depends on the application-specific
implementation of the low-level file routines.

remove() (7.19.4.1)

The effect of a remove operation on an open file depends on the application-specific
implementation of the low-level file routines. See Briefly about input and output (1/0),
page 108.

rename() (7.19.4.2)

The effect of renaming a file to an already existing filename depends on the
application-specific implementation of the low-level file routines. See Briefly about
input and output (I/0), page 108.

Removal of open temporary files (7.19.4.3)

Whether an open temporary file is removed depends on the application-specific
implementation of the low-level file routines.

Mode changing (7.19.5.4)

freopen closes the named stream, then reopens it in the new mode. The streams stdin,
stdout, and stderr can be reopened in any new mode.
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Style for printing infinity or NaN (7.19.6.1, 7.24.2.1)

The style used for printing infinity or NaN for a floating-point constant is inf and nan
(znrF and NAN for the F conversion specifier), respectively. The n-char-sequence is not
used for nan.

%p in printf() (7.19.6.1, 7.24.2.1)

The argument to a $p conversion specifier, print pointer, to printf () is treated as
having the type void *. The value will be printed as a hexadecimal number, similar to
using the $x conversion specifier.

Reading ranges in scanf (7.19.6.2, 7.24.2.1)

A - (dash) character is always treated as a range symbol.

%p in scanf (7.19.6.2, 7.24.2.2)

The %p conversion specifier, scan pointer, to scanf () reads a hexadecimal number and
converts it into a value with the type void *.

File position errors (7.19.9.1, 7.19.9.3, 7.19.9.4)

On file position errors, the functions fgetpos, ftell, and £setpos store EFPOS in

errno.

An n-char-sequence after nan (7.20.1.3, 7.24.4.1.1)

An n-char-sequence after a NaN is read and ignored.

errno value at underflow (7.20.1.3, 7.24.4.1.1)

errno i8 set to ERANGE if an underflow is encountered.

Zero-sized heap objects (7.20.3)

A request for a zero-sized heap object will return a valid pointer and not a null pointer.

Behavior of abort and exit (7.20.4.1, 7.20.4.4)

A call to abort () or _Exit () will not flush stream buffers, not close open streams, and
not remove temporary files.

Termination status (7.20.4.1, 7.20.4.3, 7.20.4.4)

The termination status will be propagated to __exit () as a parameter. exit () and
_Exit () use the input parameter, whereas abort uses EXIT_FAILURE.
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The system function return value (7.20.4.6)

The system function is not supported.

The time zone (7.23.1)

The local time zone and daylight savings time must be defined by the application. For
more information, see _ time32, page 138.

Range and precision of time (7.23)

For information about range and precision, see time.h, page 422. The application must
supply the actual implementation for the functions t ime and clock. See _ time32, page
138 and clock, page 133, respectively.

clock() (7.23.2.1)

The application must supply an implementation of the c1ock function. See clock, page
133.

%Z replacement string (7.23.3.5, 7.24.5.1)

By default, ": " is used as a replacement for $z. Your application should implement the
time zone handling. See  time32, page 138.

Math functions rounding mode (F.9)

The functions in math.h honor the rounding direction mode in FLT-ROUNDS.

J.3.13 ARCHITECTURE

Values and expressions assigned to some macros (5.2.4.2, 7.18.2,
7.18.3)

There are always 8 bits in a byte.

MB_LEN_MAX is at the most 6 bytes depending on the library configuration that is used.

For information about sizes, ranges, etc for all basic types, see Data representation, page
319.

The limit macros for the exact-width, minimum-width, and fastest minimum-width
integer types defined in stdint.h have the same ranges as char, short, int, long,
and long long.

The floating-point constant FLT_ROUNDS has the value 1 (to nearest) and the
floating-point constant FLT_EVAL_METHOD has the value O (treat as is).
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The number, order, and encoding of bytes (6.2.6.1)

See Data representation, page 319.

The value of the result of the sizeof operator (6.5.3.4)

See Data representation, page 319.

J- 4 LOCALE

Members of the source and execution character set (5.2.1)

By default, the compiler accepts all one-byte characters in the host’s default character
set. If the compiler option --enable_multibytes is used, the host multibyte
characters are accepted in comments and string literals as well.

The meaning of the additional character set (5.2.1.2)

Any multibyte characters in the extended source character set is translated verbatim into
the extended execution character set. It is up to your application with the support of the
library configuration to handle the characters correctly.

Shift states for encoding multibyte characters (5.2.1.2)

Using the compiler option --enable_multibytes enables the use of the host’s default
multibyte characters as extended source characters.

Direction of successive printing characters (5.2.2)

The application defines the characteristics of a display device.

The decimal point character (7.1.1)

The default decimal-point character is a'.". You can redefine it by defining the library
configuration symbol _LOCALE_DECIMAL_POINT.

Printing characters (7.4, 7.25.2)

The set of printing characters is determined by the chosen locale.

Control characters (7.4, 7.25.2)

The set of control characters is determined by the chosen locale.
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Characters tested for (7.4.1.2,7.4.1.3,7.4.1.7,7.4.1.9, 7.4.1.10,
7.4.1.11,7.25.2.1.2,7.25.5.1.3, 7.25.2.1.7, 7.25.2.1.9, 7.25.2.1.10,
7.25.2.1.11)

The sets of characters tested are determined by the chosen locale.

The native environment (7.1.1.1)

The native environment is the same as the "C" locale.

Subject sequences for numeric conversion functions (7.20.1,
7.24.4.1)

There are no additional subject sequences that can be accepted by the numeric
conversion functions.

The collation of the execution character set (7.21.4.3, 7.24.4.4.2)

The collation of the execution character set is determined by the chosen locale.

Message returned by strerror (7.21.6.2)

The messages returned by the strerror function depending on the argument is:

Argument Message

EZERO no error

EDOM domain error

ERANGE range error

EFPOS file positioning error
EILSEQ multi-byte encoding error
<0 || >99 unknown error

all others error nnn

Table 52: Message returned by strerror()—DLIB runtime environment

IAR C/C++ Development Guide
516  Compiling and Linking for ARM



Implementation-defined
behavior for C89

e Descriptions of implementation-defined behavior

If you are using Standard C instead of C89, see Implementation-defined behavior
for Standard C, page 501. For a short overview of the differences between
Standard C and C89, see C language overview, page 175.

Descriptions of implementation-defined behavior

The descriptions follow the same order as the ISO appendix. Each item covered includes
references to the ISO chapter and section (in parenthesis) that explains the
implementation-defined behavior.

TRANSLATION

Diagnostics (5.1.1.3)
Diagnostics are produced in the form:
filename, linenumber levell[tag]: message

where filename is the name of the source file in which the error was encountered,
linenumber is the line number at which the compiler detected the error, Ievel is the
level of seriousness of the message (remark, warning, error, or fatal error), tag is a
unique tag that identifies the message, and messageis an explanatory message, possibly
several lines.

ENVIRONMENT

Arguments to main (5.1.2.2.2.1)

The function called at program startup is called main. No prototype was declared for
main, and the only definition supported for main is:

int main(void)

To change this behavior for the DLIB runtime environment, see System initialization,
page 130.
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Interactive devices (5.1.2.3)

The streams stdin and stdout are treated as interactive devices.
IDENTIFIERS

Significant characters without external linkage (6.1.2)

The number of significant initial characters in an identifier without external linkage is
200.

Significant characters with external linkage (6.1.2)

The number of significant initial characters in an identifier with external linkage is 200.

Case distinctions are significant (6.1.2)

Identifiers with external linkage are treated as case-sensitive.
CHARACTERS

Source and execution character sets (5.2.1)

The source character set is the set of legal characters that can appear in source files. The
default source character set is the standard ASCII character set. However, if you use the
command line option --enable_multibytes, the source character set will be the host
computer’s default character set.

The execution character set is the set of legal characters that can appear in the execution
environment. The default execution character set is the standard ASCII character set.
However, if you use the command line option --enable_multibytes, the execution
character set will be the host computer’s default character set. The DLIB runtime
environment needs a multibyte character scanner to support a multibyte execution
character set.

See Locale, page 141.

Bits per character in execution character set (5.2.4.2.1)

The number of bits in a character is represented by the manifest constant CHAR_BIT.
The standard include file 1imits.h defines CHAR_BIT as 8.

Mapping of characters (6.1.3.4)

The mapping of members of the source character set (in character and string literals) to
members of the execution character set is made in a one-to-one way. In other words, the
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same representation value is used for each member in the character sets except for the
escape sequences listed in the ISO standard.

Unrepresented character constants (6.1.3.4)

The value of an integer character constant that contains a character or escape sequence
not represented in the basic execution character set or in the extended character set for
a wide character constant generates a diagnostic message, and will be truncated to fit the
execution character set.

Character constant with more than one character (6.1.3.4)

An integer character constant that contains more than one character will be treated as an
integer constant. The value will be calculated by treating the leftmost character as the
most significant character, and the rightmost character as the least significant character,
in an integer constant. A diagnostic message will be issued if the value cannot be
represented in an integer constant.

A wide character constant that contains more than one multibyte character generates a
diagnostic message.
Converting multibyte characters (6.1.3.4)

The only locale supported—that is, the only locale supplied with the IAR C/C++
Compiler—is the ‘C’ locale. If you use the command line option
--enable_multibytes, the DLIB runtime environment will support multibyte
characters if you add a locale with multibyte support or a multibyte character scanner to
the library.

See Locale, page 141.

Range of 'plain’ char (6.2.1.1)

A ‘plain’ char has the same range as an unsigned char.
INTEGERS

Range of integer values (6.1.2.5)

The representation of integer values are in the two's complement form. The most
significant bit holds the sign; 1 for negative, O for positive and zero.

See Basic data types—integer types, page 321, for information about the ranges for the
different integer types.
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Demotion of integers (6.2.1.2)

Converting an integer to a shorter signed integer is made by truncation. If the value
cannot be represented when converting an unsigned integer to a signed integer of equal
length, the bit-pattern remains the same. In other words, a large enough value will be
converted into a negative value.

Signed bitwise operations (6.3)
Bitwise operations on signed integers work the same way as bitwise operations on
unsigned integers; in other words, the sign-bit will be treated as any other bit.

Sign of the remainder on integer division (6.3.5)

The sign of the remainder on integer division is the same as the sign of the dividend.

Negative valued signed right shifts (6.3.7)
The result of a right-shift of a negative-valued signed integral type preserves the sign-bit.
For example, shifting 0xFF00 down one step yields 0xFF80.

FLOATING POINT

Representation of floating-point values (6.1.2.5)

The representation and sets of the various floating-point numbers adheres to IEEE
854-1987. A typical floating-point number is built up of a sign-bit (s), a biased
exponent (e), and a mantissa (m).

See Basic data types—floating-point types, page 326, for information about the ranges
and sizes for the different floating-point types: £loat and double.

Converting integer values to floating-point values (6.2.1.3)

When an integral number is cast to a floating-point value that cannot exactly represent
the value, the value is rounded (up or down) to the nearest suitable value.
Demoting floating-point values (6.2.1.4)

When a floating-point value is converted to a floating-point value of narrower type that
cannot exactly represent the value, the value is rounded (up or down) to the nearest
suitable value.
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ARRAYS AND POINTERS

size_t (6.3.3.4, 7.1.1)

See size_t, page 328, for information about size_t.

Conversion from/to pointers (6.3.4)

See Casting, page 328, for information about casting of data pointers and function
pointers.

ptrdiff_t (6.3.6, 7.1.1)

See ptrdiff t, page 328, for information about the ptrdiff_t.
REGISTERS

Honoring the register keyword (6.5.1)

User requests for register variables are not honored.

STRUCTURES, UNIONS, ENUMERATIONS, AND BITFIELDS

Improper access to a union (6.3.2.3)

If a union gets its value stored through a member and is then accessed using a member
of a different type, the result is solely dependent on the internal storage of the first
member.

Padding and alignment of structure members (6.5.2.1)

See the section Basic data types—integer types, page 321, for information about the
alignment requirement for data objects.

Sign of 'plain’ bitfields (6.5.2.1)

A 'plain’ int bitfield is treated as an unsigned int bitfield. All integer types are
allowed as bitfields.

Allocation order of bitfields within a unit (6.5.2.1)

Bitfields are allocated within an integer from least-significant to most-significant bit.

Can bitfields straddle a storage-unit boundary (6.5.2.1)

Bitfields cannot straddle a storage-unit boundary for the chosen bitfield integer type.
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Integer type chosen to represent enumeration types (6.5.2.2)

The chosen integer type for a specific enumeration type depends on the enumeration
constants defined for the enumeration type. The chosen integer type is the smallest
possible.

QUALIFIERS

Access to volatile objects (6.5.3)

Any reference to an object with volatile qualified type is an access.
DECLARATORS

Maximum numbers of declarators (6.5.4)

The number of declarators is not limited. The number is limited only by the available
memory.

STATEMENTS

Maximum number of case statements (6.6.4.2)

The number of case statements (case values) in a switch statement is not limited. The
number is limited only by the available memory.

PREPROCESSING DIRECTIVES

Character constants and conditional inclusion (6.8.1)

The character set used in the preprocessor directives is the same as the execution
character set. The preprocessor recognizes negative character values if a 'plain' character
is treated as a signed character.

Including bracketed filenames (6.8.2)

For file specifications enclosed in angle brackets, the preprocessor does not search
directories of the parent files. A parent file is the file that contains the #include
directive. Instead, it begins by searching for the file in the directories specified on the
compiler command line.

Including quoted filenames (6.8.2)

For file specifications enclosed in quotes, the preprocessor directory search begins with
the directories of the parent file, then proceeds through the directories of any
grandparent files. Thus, searching begins relative to the directory containing the source
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file currently being processed. If there is no grandparent file and the file is not found,
the search continues as if the filename was enclosed in angle brackets.
Character sequences (6.8.2)

Preprocessor directives use the source character set, except for escape sequences. Thus,
to specify a path for an include file, use only one backslash:

#include "mydirectory\myfile"
Within source code, two backslashes are necessary:

file = fopen("mydirectory\\myfile", "rt");

Recognized pragma directives (6.8.6)

In addition to the pragma directives described in the chapter Pragma directives, the
following directives are recognized and will have an indeterminate effect. If a pragma
directive is listed both in the chapter Pragma directives and here, the information
provided in the chapter Pragma directives overrides the information here.

alignment

baseaddr
basic_template_matching
building_runtime
can_instantiate

codeseg

constseg

Ccspy_support

dataseg
define_type_info
do_not_instantiate
early_dynamic_initialization
function
function_effects
hdrstop
important_typedef

instantiate
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keep_definition

library default_requirements
library_provides
library_requirement_override
memory

module_name

no_pch

once

system_include

vector

warnings

Default __DATE__and __TIME__ (6.8.8)

The definitions for __TIME _ and __DATE__ are always available.

LIBRARY FUNCTIONS FOR THE IAR DLIB RUNTIME
ENVIRONMENT

Note that some items in this list only apply when file descriptors are supported by the
library configuration. See the chapter The DLIB runtime environment for more
information about runtime library configurations.

NULL macro (7.1.6)

The NULL macro is defined to 0.

Diagnostic printed by the assert function (7.2)
The assert () function prints:
filename: linenr expression -- assertion failed

when the parameter evaluates to zero.

Domain errors (7.5.1)

NaN (Not a Number) will be returned by the mathematic functions on domain errors.
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Underflow of floating-point values sets errno to ERANGE (7.5.1)
The mathematics functions set the integer expression errno to ERANGE (a macro in
errno.h) on underflow range errors.
fmod() functionality (7.5.6.4)

If the second argument to fmod () is zero, the function returns NaN; errno is set to
EDOM.

signal() (7.7.1.1)

The signal part of the library is not supported.

Note: The default implementation of signal does not perform anything. Use the
template source code to implement application-specific signal handling. See signal,
page 137 and raise, page 135, respectively.

Terminating newline character (7.9.2)

stdout stream functions recognize either newline or end of file (EOF) as the
terminating character for a line.

Blank lines (7.9.2)

Space characters written to the stdout stream immediately before a newline character
are preserved. There is no way to read the line through the stdin stream that was
written through the stdout stream.

Null characters appended to data written to binary streams (7.9.2)

No null characters are appended to data written to binary streams.

Files (7.9.3)

Whether the file position indicator of an append-mode stream is initially positioned at
the beginning or the end of the file, depends on the application-specific implementation
of the low-level file routines.

Whether a write operation on a text stream causes the associated file to be truncated
beyond that point, depends on the application-specific implementation of the low-level
file routines. See Briefly about input and output (I/0), page 108.

The characteristics of the file buffering is that the implementation supports files that are
unbuffered, line buffered, or fully buffered.

Whether a zero-length file actually exists depends on the application-specific
implementation of the low-level file routines.
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Rules for composing valid file names depends on the application-specific
implementation of the low-level file routines.

Whether the same file can be simultaneously open multiple times depends on the
application-specific implementation of the low-level file routines.

remove() (7.9.4.1)

The effect of a remove operation on an open file depends on the application-specific
implementation of the low-level file routines. See Briefly about input and output (1/0),
page 108.

rename() (7.9.4.2)

The effect of renaming a file to an already existing filename depends on the
application-specific implementation of the low-level file routines. See Briefly about
input and output (1/0), page 108.

%p in printf() (7.9.6.1)

The argument to a $p conversion specifier, print pointer, to printf () is treated as
having the type void *. The value will be printed as a hexadecimal number, similar to
using the $x conversion specifier.

%p in scanf() (7.9.6.2)

The %p conversion specifier, scan pointer, to scanf () reads a hexadecimal number and
converts it into a value with the type void *.

Reading ranges in scanf() (7.9.6.2)

A - (dash) character is always treated as a range symbol.

File position errors (7.9.9.1, 7.9.9.4)

On file position errors, the functions fgetpos and ftell store EFPOS in errno.

Message generated by perror() (7.9.10.4)
The generated message is:

usersuppliedprefix: errormessage

Allocating zero bytes of memory (7.10.3)

The calloc (), malloc (), and realloc () functions accept zero as an argument.
Memory will be allocated, a valid pointer to that memory is returned, and the memory
block can be modified later by realloc.
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Behavior of abort() (7.10.4.1)

The abort () function does not flush stream buffers, and it does not handle files,
because this is an unsupported feature.

Behavior of exit() (7.10.4.3)

The argument passed to the exit function will be the return value returned by the main
function to cstartup.

Environment (7.10.4.4)

The set of available environment names and the method for altering the environment list
is described in getenv, page 134.

system() (7.10.4.5)

How the command processor works depends on how you have implemented the system
function. See system, page 138.

Message returned by strerror() (7.11.6.2)

The messages returned by strerror () depending on the argument is:

Argument Message

EZERO no error

EDOM domain error

ERANGE range error

EFPOS file positioning error
EILSEQ multi-byte encoding error
<0 || >99 unknown error

all others error nnn

Table 53: Message returned by strerror()—DLIB runtime environment

The time zone (7.12.1)

The local time zone and daylight savings time implementation is described in __ time32,
page 138.

clock() (7.12.2.1)

From where the system clock starts counting depends on how you have implemented the
clock function. See clock, page 133.
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