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はじめに
IAR Embedded Workbench の使用開始の手順へようこそ。

本ガイドについて

本ガイドの目的は、IAR Embedded Workbench の概要と IDE の使用方法、
組込みシステムソフトウェアの開発ツールの使用方法について説明する
ことです。本ガイドでは一部の機能に重点を置いて、ツールの目的と機
能について解説します。

 C/C++ プログラミング言語や組込みシステムのアプリケーション開発、
使用するマイクロコントローラのアーキテクチャと命令セット（チップ
メーカのマニュアルを参照してください）、ホストコンピュータのオペ
レーティングシステムについての実践的な知識が必要です。

注 : 本ガイドの説明の一部は、特定のマイクロコントローラや
IAR Embedded Workbench の特定の派生製品パッケージにのみ該当しま
す。たとえば、C++ をサポートしてないパッケージがありますがここで
はこの機能について説明しています。

表記規則

本ガイドでプログラミング言語 C と記述されている場合、特に記述がな
い限り C++ も含まれます。

製品インストール先のディレクトリ（例 : ターゲット \doc）の記述があ
る場合、その場所までのフルパス（例 : c:\Program Files\IAR 
Systems\Embedded Workbench N.n\ ターゲット \doc）を意味します。
GSEW-3
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概要
● 製品ポートフォリオの概要

● デバイスサポート

● チュートリアル

● ユーザドキュメンテーション

● その他のリソース

インストールとライセンスについて詳しくは、製品に同梱されて

いるクリックリファレンスを参照してください。

製品ポートフォリオの概要

次の図は、IAR システムおよびサードパーティベンダのさまざまなツー
ルと、それらがどのように相互に動作するかを示します。

IAR Embedded Workbench は、組込みシステムの完全なアプリケー
ションプロジェクト開発および管理を可能にする統合開発環境を提供し
ます。この環境は、コンパイル、リンク、デバッグのためのツールから構
GSEW-3

概要 7



成され、総合的かつ専用のターゲットをサポートしています。どの
マイクロコントローラを使用するかに関係なく、ユーザインタ
フェースは同じです。

IAR visualSTATE は、有限オートマトンに基づいて組込みアプリ
ケーションを設計、テスト、実装するための開発ツールのセットが
統合されています。形式検証および検証ツールを提供し、設計から
C ソースコードを生成します。使用を開始するあたって、製品のイ
ンストレーションにはチュートリアルや入門ガイド、いくつかのサ
ンプルが用意されており、一般的な内容と特定の評価ボード用に分
かれています。

IAR 評価キットは、特定のマイクロコントローラ用に組込みアプ
リケーションを開発するための統合型キットです。各キットには評価
ボード、サンプルプロジェクトを含むソフトウェア開発ツール、ハー
ドウェアデバッグプローブまたはエミュレータが含まれています。

I-jet はインサーキットデバッグプローブで、チップの JTAG/SWD
ポートを USB 経由で ホスト PC に接続します。I-jet は IAR Embedded 
Workbench に統合されており、プラグアンドプレイの互換性があり
ます。

サードパーティツールおよびユーティリティ

さまざまなサードパーティツールおよびユーティリティを、IAR 
Embedded Workbench に統合できます。こうした製品には、バー
ジョン管理システム、エディタ、RTOS 対応デバッグおよびさまざ
まなデバッグプローブ用の C-SPY プラグインモジュール、プロト
コルスタックなどがあります。

他のビルドツールとの相互運用

製品で使用するオブジェクト形式およびアプリケーションバイナ
リのインタフェースによっては、IAR ツールチェーンは他のベン
ダのツールチェーンと相互に運用可能です。相互運用のレベルは、
GSEW-3
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サードパーティのデバッガでの IAR ツールの実行可能ファイルのデ
バッグからリンクレベルの完全な互換性までさまざまです。

デバイスサポート

製品開発を円滑に始めるために、IAR 製品にはさまざまなデバイス用に
事前設定されたファイルが含まれています。

周辺 I/O ヘッダファイルは、周辺ユニットを定義するデバイス固有の
I/O ヘッダです。

リンカ設定ファイルには、コードとデータをメモリに配置するためにリ
ンカで必要な情報が含まれています。製品パッケージによっては、リン
カ設定ファイル用のテンプレート、またはサポートされているデバイス
用のすぐに使用可能なリンカ設定ファイルが提供されています。

デバイス記述ファイルは、周辺レジスタおよびそれらのグループの定義
など、デバッグに必要なデバイス固有の詳細な部分を取り扱います。
つまり、デバッグの実行中に SFR アドレスやビット名を参照できます。

フラッシュローダはターゲットにダウンロードされるエージェントで、
デバッガからアプリケーションをフェッチしてフラッシュメモリにプロ
グラムします。製品パッケージに応じて、一部のデバイス向けフラッシュ
ローダが利用できます。使用するデバイスが含まれていない場合は、独自
のフラッシュローダをビルドできます。一部のデバッグプローブは対応す
る機能を提供しますので、専用のフラッシュローダは必要ありません。

導入のためのサンプルプロジェクト（ソフトウェア開発用）を用意して、
スムーズに開始できるようにしています。製品パッケージに応じて、数
個から数百個の実際のソースコードのサンプルが含まれており、複雑さ
は単純な LED の点滅から USB のマスストレージコントローラまでさま
ざまです。これらのサンプルには、[Help]（ヘルプ）メニューから表示で
きるインフォメーションセンタからアクセスできます。

チュートリアル

チュートリアルでは、IAR Embedded Workbench IDE とそのツールの基本
的な使用方法を確認するための実践トレーニングを提供します。チュー
トリアルは異なるパートに分かれており、チュートリアル全体をまとめ
て使用するか、個々のチュートリアルを見るよう選択することもできま
す。チュートリアルは、ハードウェアを用意せずにデバッガの使用を開
始できるように、C-SPY シミュレータ用に設定されています。

チュートリアルには、インフォメーションセンタ（IDE の [Help]（ヘル
プ）メニューにより表示）からアクセスできます。チュートリアルに必
要なファイルはすべて ターゲット \tutorディレクトリにあります。
9
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ユーザドキュメンテーション

ユーザドキュメンテーションは、ハイパーテキスト PDF 形式、お
よびコンテキスト依存のオンラインヘルプシステム（HTML フォー
マット）があります。ドキュメンテーションには、インフォメー
ションセンタ（IAR Embedded Workbench IDE の [Help]（ヘルプ）メ
ニューにより表示）からアクセスできます。オンラインヘルプシス
テムにも、IDE で F1 キーによりアクセスできます。

ユーザドキュメンテーションに含まれていない可能性のある直前の
変更については、[Help]（ヘルプ）メニューからアクセスできるリ
リースノートを読むことをお勧めします。

すべてのドキュメンテーションは、ターゲット \docと common\doc

の各ディレクトリにあります。

その他のリソース

IAR システムズの Web サイト (http://www.iarsys.co.jp/customer) では、
テクニカルノートやアプリケーションノートを見ることができます。

保守契約 (SUA) を締結している場合、IAR システムズの Web サイ
トの MyPages から、最新の製品情報にアクセスして製品のアップ
デートおよび新しいデバイスのサポートファイルをダウンロードす
ることも可能です。

技術サポートのリクエスト

IAR システムズのツールに問題があった場合は、以下のトラブル
シューティングのヒントのリストをチェックしてください。

1 まずユーザドキュメントの該当トピックをご覧ください。ガイドラ
インについては、インフォメーションセンタを参照してください。

2 リリースノートの「既知の問題」の項を読んで、報告済みの内容に
関連があるかどうか調べます。

3 問題が解決しない場合、問題点の切り分けをしてみてください。
再現する小さなコードのサンプル、プロジェクト設定、問題の再
現方法についての説明があると、タイムリにサポートを提供する上
で非常に役に立ちます。

4 Web サイト経由、または IAR システムズの担当者に連絡してレポー
トを送信してください。製品名、バージョン、ライセンス番号、保
守契約者番号を必ず含めるようにしてください。
GSEW-3
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IAR Embedded 
Workbench の概要
本章では、IAR Embedded Workbench® に含まれるさまざまなツー

ルの概要を説明します。

IDE

IDE は、アプリケーションのビルドに必要なすべてのツールが統合され
たフレームワークです。C/C++ コンパイラ、アセンブラ、リンカ、ライ
ブラリツール、エディタ、プロジェクトマネージャ、IAR C-SPY® デ
バッガが含まれます。

製品パッケージに付属のツールチェーンは、特定のマイクロコントロー
ラをサポートしています。IDE では、さまざまなマイクロコントローラ
に対する複数のツールチェーンを同時に格納できます。つまり、いくつ
かのマイクロコントローラ用に IAR Embedded Workbench をインストー
ルしている場合、どのマイクロコントローラ向けに開発するかを選択で
きます。

注 : ビルド済みプロジェクト環境で外部ツールとして利用する場合は、
コンパイラ、アセンブラ、リンカ、C-SPY デバッガを、コマンドライン
環境で実行することもできます。

IDE を起動するには：

Windows の［スタート］メニューのスタートボタンをクリックするか、
ワークスペースのファイル名（ファイル拡張子 eww）をダブルクリック、
あるいは IarIdePm.exeというファイル（IAR Embedded Workbench の
common\binディレクトリにあります）を使用します。
GSEW-3
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IDE のメインウィンドウが開きます。

最初に IAR Embedded Workbench を開くと、IDE のメインウィンド
ウに IAR インフォメーションセンタが表示されます。ここでは、
チュートリアルやサンプルプロジェクト、サポート情報、リリース
ノートなど、必要な情報がすべて得られます。

IDE の設定

好みや要件に合わせて IDE を設定する方法は数多くあります :

● ウィンドウの編成 — ウィンドウは特定の位置にドッキングして、
タブグループとして編成できます。また、ウィンドウをフロー
ティング化することができます。フローティングウィンドウは、
常に他のウィンドウよりも前に表示されます。フローティング
ウィンドウのサイズや位置を変更しても、現在開かれている他
のウィンドウは影響を受けません。メインウィンドウの下端に
あるステータスバーには、ウィンドウのサイズを変更するため
のヘルプが用意されています。

メニューバー ツールバー

言語の選択 — 他の言語が利用
可能な製品パッケージステータスバー

インフォメーションセンタ

［ワークスペース］ウィンドウ
GSEW-3
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● レビジョン管理システムやエディタなど、外部ツールでツールチェー
ンを拡張。また、IAR visualSTATE をツールチェーンに追加して、IDE
でステートマシンダイアグラムをプロジェクトに直接追加することも
可能です。

● [Tools]（ツール）メニューからの外部ツールの呼出し。

● コマンドによる IDE のカスタマイズ。たとえば次のものが使用でき
ます。

● エディタの設定

● 共通フォントの変更

● キーカスタマイズの変更

● 任意の外部エディタの使用

● プロジェクトビルドコマンドの設定

● [Messages]（メッセージ）ウィンドウへの出力数の設定

オンラインヘルプシステムを参照するには :
[Help]>[Content]（ヘルプ > 目次）を選択するか、IDE でウィンドウまた
はダイアログボックスをクリックして F1 キーを押します。

オンラインヘルプシステムが表示されます :

たとえば次のようなコンテキストに合ったヘルプ情報が表示されます。

● IDE と C-SPY
● コンパイラ
13
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● ライブラリ

● MISRA-C

IAR C/C++ コンパイラ

プログラミング言語

ほとんどの製品パッケージでは、IAR C/C++ コンパイラとともに使
用可能な高度なプログラミング言語が 2 つあります。

C 言語は：組込みシステム業界で最も幅広く使用されている高級プ
ログラミング言語です。以下の標準に準拠したフリースタンディン
グアプリケーションのビルドが可能です。

● 標準 C － C99 とも呼ばれる標準の C。本ガイドでは、この規格
を C 規格と呼びます。

● C89 － C94、C90、C89、ANSI C とも呼ばれ、この規格は
MISRA-C が有効なときに必須です。

C++ （製品パッケージによって異なります）。以下のすべての標準が
使用できます。

● 標準 C++ － 例外およびランタイム型情報で、異なるレベルのサ
ポートを使用できます（製品パッケージによって異なります）。

● Embedded C++ (EC++) － C++プログラミング標準のサブセット。
業界団体である Embedded C++ Technical Committee により定義
されています。

● IAR 拡張 Embedded C++ － テンプレート、多重継承（製品パッ
ケージによって異なります）、名前空間、新しいキャスト演算
子、標準テンプレートライブラリ (STL) などの追加機能をサ
ポートしています。

MISRA-C

MISRA-C は、安全性を重視するシステムの開発に適した規則のセッ
トです。MISRA-C を構成する規則は、C プログラミング言語の ISO
標準により厳しい安全対策を適用することを意図しています。使用
する製品パッケージに応じて、MISRA-C:2004 と MISRA-C:1998 の
両方をサポートしています。

コンパイラ拡張

コンパイラには、C/C++ 言語の標準機能に加えて、広範な拡張機
能が用意されています。
GSEW-3
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C 言語拡張は次の 2 つのグループに分類できます。

● 組込みシステムプログラミングの拡張 — 一般的にメモリの制限を満
たしたり、割込みなど特殊な関数を宣言するために使用する特定のマ
イクロコントローラでの効率的な組込みプログラミングに特化した
拡張。

● C 規格に対する緩和 — 規格を緩和した軽微な言語拡張、わずかな構文
の拡張で得られる便利な機能。

プラグマディレクティブは、ソースコードが移植可能であることを徹底
する目的で、ベンダ固有の拡張機能で使用されるために C 規格で定義さ
れたメカニズムです。事前定義されたディレクティブは、コンパイラの
動作（メモリの配置方法、拡張キーワードの許可 / 禁止、ワーニング
メッセージの表示 / 非表示など）を制御します。

プラグマディレクティブは、コンパイラでは常に有効になっています。

プリプロセッサの機能以下に例を示します。

● 事前定義されたプリプロセッサシンボルで、コンパイルの時間や異
なるコンパイラ設定など、コンパイル時間の環境を調べることがで
きます。

● #defineディレクティブに加えてコンパイラオプションまたは IDE で
定義される、ユーザ定義のプリプロセッサシンボル。

マイクロコントローラの低レベルの機能へのアクセスは、 不可欠です。
コンパイラは、低レベルプロセッサの処理に直接アクセス可能にする組
込み関数、C モジュールとアセンブラモジュールの混在、インラインア
センブラなどの方法でこれをサポートしています。使用する方法を慎重
に選択してください。

IAR アセンブラ

IAR アセンブラは、使用するマイクロコントローラに対して、柔軟な
ディレクティブと式演算子のセットを使用してマクロアセンブラを再
配置します。C 言語プリプロセッサを内蔵しており、条件アセンブリ
をサポートしています。

アセンブラは、シンボリックアセンブラ言語ニーモニックを実行可能な
マシンコードに変換します。効率的なアセンブラアプリケーションを記
述するためには、使用するマイクロコントローラのアーキテクチャと命
令セットを理解しておく必要があります。
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アプリケーション全体をアセンブラ言語で記述するのではない場合
でも、正確なタイミングや特殊な命令シーケンスを要求するマイク
ロコントローラのメカニズムを使用する場合など、コードの一部を
アセンブラで記述する必要が生じることがあります。

IAR リンカと関連ツール

使用するパッケージに応じて、IAR Embedded Workbench には
XLINK リンカまたは ILINK リンカのどちらかが用意されています。

これらはサイズが小さい 1 ファイルのアセンブラアプリケーション
のリンクと、大規模で再配置可能な複数モジュール、C/C++、アプ
リケーションや、C/C++ とアセンブラ混在アプリケーションのリン
クの両方に適しています。

どちらのリンカも、設定ファイルを使用します。このファイルで、
ターゲットシステムのメモリマップのコードおよびデータ領域に個
別の位置を指定し、コードとデータ配置を完全に制御することがで
きます。

リンクする前に、入力順に関係なく（ライブラリを除く）、リンカ
はすべての入力ファイルにあるあらゆるシンボルの依存関係の完全
な解決を実行します。また、すべてのモジュールについてコンパイ
ラ設定の整合性をチェックし、正しいバージョンおよび派生品の
C/C++ ランタイムライブラリが使用されていることを確認します。

リンカは、リンクするアプリケーションが実際に必要なライブラリ
モジュール（ユーザライブラリおよび標準 C/C++ の派生ライブラ
リ）だけを自動的にロードします。正確に言うと、実際に使用され
るライブラリモジュールの関数のみがロードされます。

IAR ILINK リンカは、1 つまたは複数の再配置可能なオブジェクト
ファイルを、1 つまたは複数のオブジェクトライブラリの選択した
部分と組み合わせて、実行可能イメージを生成します。

ILINK が作成する最終出力は、ELF（デバッグ情報の DWARF を含
む）形式の実行可能なイメージを含む、絶対オブジェクトファイル
です。このファイルは、ELF/DWARF をサポートする C-SPY などの
デバッガにダウンロードできます。あるいは、任意の適切な
フォーマットに変換した後で EPROM にプログラミングすること
ができます。

ELF ファイルを処理するために、アーカイバ、ELF ダンパ、フォー
マットコンバータなどのさまざまなユーティリティがあります。

使用する製品パッケージによっては、多くのアプリケーションにつ
いて ILINK が最大スタック使用量を計算できます。
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IAR XLINK リンカは、IAR システムズのコンパイラまたはアセンブラに
よって生成された 1 つまたは複数の再配置可能オブジェクトファイルを結
合して、使用するマイクロコントローラ用にマシンコードを生成します。
XLINK は、C-SPY デバッガで使用される UBROF のほかに、30 以上の業
界標準のローダフォーマットを生成できます。

また、XLINK はすべてのモジュールに対して詳細な C/C++ タイプの
チェックを実行します。

XLINK が生成する最終出力は、マイクロコントローラやハードウェアエ
ミュレータにダウンロードでき、ターゲットで実行可能な絶対オブジェ
クトファイルです。出力ファイルに、選択した出力フォーマットに応じ
たデバッグ情報を含めるかどうかを選択することもできます。

ライブラリを処理するために、ライブラリツール XAR と XLIB が含まれ
ています。
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IAR C-SPY デバッガ
IAR C-SPY デバッガは、組込みアプリケーション開発用の高級言語
デバッガです。

IAR システムズのコンパイラやアセンブラと併せて使用するように
設計されており、IDE に完全統合されているため、開発とデバッグ
をシームレスに切り替えることができます。このため、以下のよう
な操作が可能です。

● デバッグ中の編集。デバッグセッション中に、デバッグの制御
に使用するものと同じソースコードウィンドウで直接修正を行
うことができます。変更内容は、次にプロジェクトをリビルド
するときに有効になります。

● デバッガ起動前に、ソースコードにブレークポイント設定可能。
ソースコード中のブレークポイントは、コードを追加した後も、
ソースコードの同一部分に対応付けられます。
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C-SPY は、デバッガの基本機能セットを提供する部分とドライバで構成
されています。C-SPY ドライバは、ターゲットシステムとの通信および
ターゲットシステムの管理を提供します。また、特殊ブレークポイント
など、ターゲットシステムが提供する機能へのユーザインタフェースと
して、専用のメニュー、ウィンドウ、ダイアログボックスを提供します。

以下の図は、C-SPY およびターゲットシステムの概要を示します。

製品パッケージによっては、C-SPY と併せて、シミュレータドライバや
さまざまなハードウェアデバッガシステム用の追加ドライバもインス
トールされます。

C-SPY の詳細については、本ガイドの「49 ページの デバッグ」を参照
してください。
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C-SPY プラグインモジュール

C-SPY は、モジュール型のアーキテクチャとして設計されていま
す。デバッガに追加機能を実装するための SDK（ソフトウェア開
発キット）は、プラグインモジュールという形で提供されていま
す。これらのモジュールは IDE に統合可能です。

IAR システムズかサードパーティ製のプラグインモジュールを使用
できます。このようなモジュールの例を以下に示します。

● [Code Coverage]（コードカバレッジ）、[Symbols]（シンボル）、
[Stack]（スタック）プラグイン（これらはすべて IDE に問題な
く統合されます）。

● 特定のデバッグシステムを使用するための様々なC-SPYドライバ。

● リアルタイム OS 対応のデバッグのための RTOS プラグインモ
ジュール。

● IAR visualSTATE と IAR Embedded Workbench 間のインタフェース
として機能する C-SPYLink。これは、標準 C レベルシンボリッ
クデバッグのほか、真の意味での高水準ステートマシンデバッ
グを C-SPY で直接可能にします。

C-SPY SDK の詳細については、IAR システムズまでお問い合わせく
ださい。
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組込みアプリケーション
の開発
組込みアプリケーションソフトウェアの開発

を始める前に、次の概念に目を通すことをお

勧めします。

● 開発サイクル

● 一般的に使用されるソフトウェアモデル

● ビルド処理

● パフォーマンス重視のプログラミング

● ハードウェアおよびソフトウェア要因の考慮

● アプリケーションの実行

開発サイクル

実際の開発が始まる前に、要件と設計をまとめて
アプリケーションアーキテクチャを指定（手動ま
たは visualSTATE などの自動コード生成ツールを
使用）する必要があります。こうすることで、
IAR Embedded Workbench IDE を使用する準備が整
います。

以下は一般的な開発サイクルです。

● 一般オブジェクトおよびツール固有のオブジェ
クトを含むプロジェクトを設定する

● C/C++ またはアセンブラでソースコードファイ
ルを作成

● デバッグのためにプロジェクトをビルド（コン
パイルおよびリンク）

● ソースコードのエラーを修正

● アプリケーションのテストおよびデバッグ

● リリース用にビルド

● イメージをフラッシュメモリまたは PROM メモリにロード
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一般的に使用されるソフトウェアモデル

以下は一般的に使用されるソフトウェアモデルの一部です。

● スーパーループシステム（タスクが連続して実行されます）

● マルチタスクシステム（タスクはリアルタイム OS によってスケ
ジュールされます）

● 有限オートマトンモデル

通常は、スーパーループシステムまたはマルチタスクシステムを使
用し、アプリケーションのロジックを整理する一般的な方法は有限
オートマトンを使用して設計するやり方です。

スーパーループシステム

マルチタスキングカーネルがなくては、CPU によって一度に 1 つの
タスクしか実行できません。これを、シングルタスクシステムまた
はスーパーループと呼び、基本的には終わらないループで実行さ
れ、適切な操作を連続して実行するプログラムです。リアルタイム
カーネルが使用されないため、ソフトウェアや重要な処理のリアル
タイム部分には割込みサービスルーチン (ISR) を使用する必要があ
ります（割込みレベル）。

スーパーループは、プログラムが大きくなると保守が難しくなる可
能性があります。あるコンポーネントが動作している場合、ISR 以
外の他のコンポーネントは割り込むことができないため、１つのコ
ンポーネントの応答時間はシステムの他のすべてのコンポーネント
の実行時間に依存します。このため、リアルタイム性が劣ります。

このタイプのシステムは通常、リアルタイムの動作が重要でない場
合に使用されます。
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プリエンプティブマルチタスクシステム

リアルタイムオペレーティングシステムを使用する際、単一の CPU 上
で複数のタスクを同時に実行できます。すべてのタスクは、CPU 全体を
完全に所有するかのごとく実行されます。RTOS は各タスクを有効 / 無
効にすることによりスケジューリングします。マルチタスクシステムで
は、異なるスケジューリングアルゴリズムがあり、CPU の算出能力はタ
スク間で分散されます。

リアルタイムシステムは、プリエンプティブタスクとして処理をしてい
ます。リアルタイムオペレーティングシステムには、定義済みの時間に
タスクに割込み、必要があればタスク切替えを実行する通常のタイマ割
込みが必要です。そのため、割込みタスクかどうかに関係なく、READY
ステートで最も優先度の高いタスクは常に実行されます。割込みサービ
スルーチン (ISR) でより高い優先度のタスクが準備されると、タスク切替
えが発生して、そのタスクは割込みタスクが戻される前に実行されます。

有限オートマトンモデル

有限オートマトンモデルは、単純に入ってくるイベントを推定される外
向きのアクションに変換します。これは純粋に反作用を示すエンジンま
たはコアであり、オペレーティングシステムとは混同しないでください。
どの時点でも、システムは可能なステートのいずれかにあります。環境か
らの入力に応じて、システムはステートを変えることができます。ステー
トの変更が発生すると同時に、環境についてアクションを実行できます。
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たとえば、電子機器のサブシステムは
On または Off で、ドアは Open または
ClosedAndUnlocked などというようにで
す。有限オートマトンでは、可能な物
理ステートをすべてマップする必要は
なく、ソリューションにとって重要な
ステートのみをマップすればすみます。

有限オートマトンモデルの重要な特徴
のひとつは、並列処理を行う能力です。
この場合において、並列処理という言
葉は複数のパラレルステートシステム
を同時に処理することを指します。

たとえば、自動販売機において考慮し
なければならないすべてのケースを想
定してください。

● カップがいっぱいになる前に取り出された

● 支払を処理中に顧客が注文をキャンセルしたときのクレジット
カード口座の処理

● 前の注文が完了する前に新規の注文が開始された場合

● 注文の最中にいずれかの電子部品によってマシンが停止した場
合、料金が顧客に返金されるかどうか

ステートチャート図は高度なレベルから設計を見ることができ、
複雑性を処理するために必要な全体像を維持することが可能です。
いったんステートチャートモデルが作成されると、意図したとおり
に動作するかどうか検証することができます。また、IAR visualSTATE
は設計と 100% 一致する C/C++ ソースコードを生成します。

ステートマシンの使用は、信頼性、サイズ、決定論的な実行が主要
な基準であるモニタリング、測定、制御などのように、論理指向の
アプリケーションに非常に有効です。

ビルド処理

このセクションでは、ビルドプロセスの概要について説明します。
つまり、コンパイラ、アセンブラ、リンカなどさまざまなビルド
ツールがどのように組み合わさり、ソースコードから実行可能イ
メージに移行するかについて説明します。ビルド処理はさらに以下
に分類されます。
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● 変換プロセス

● リンク処理

● リンク後

変換プロセス

アプリケーションソースファイルを中間オブジェクトファイルに変換す
るツールは IDE に 2 つあります。それは、IAR C/C++ コンパイラおよび
IAR アセンブラです。どちらも、ILINK を使用する製品には ELF/DWARF
フォーマットで、XLINK を使用する製品には UBROF フォーマットで再
配置可能オブジェクトファイルをそれぞれ生成します。

注 : このコンパイラは、C/C++ ソースコードをアセンブラソースコード
に変換するときにも使用できます。必要な場合、アセンブラソースコー
ドを修正してからオブジェクトコードにアセンブルできます。

以下の図は、変換プロセスを示します。

変換後は、任意の数の
モジュールを 1 つの
アーカイブ、つまりラ
イブラリにパッキング
してファイルを整理す
ることができます。

リンク処理

IAR コンパイラおよび
アセンブラにより生成
されるオブジェクト
ファイルおよびライブ
ラリの再配置可能モ
ジュールは、そのまま
実行することはできま
せん。これらが実行可
能なアプリケーション
となるには、リンクされる必要があります。

注 : 製品パッケージに応じて、別のベンダのツールセットにより生成さ
れたモジュールもビルドに含めることができます。ただし、AEABI 準拠
でない場合、同じベンダのコンパイラユーティリティライブラリが必要
な点に注意してください。

リンカは、最終的なアプリケーションのビルドに使用します。通常は、
リンカは入力として以下の情報を必要とします。
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● いくつかのオブジェクトファイル、場合によってはライブラリ

● プログラムの開始ラベル（ILINK リンカのデフォルト設定、およ
び XLINK リンカのユーザ設定）

● ターゲットシステムのメモリ内でのコードおよびデータの配置
を記述したリンカ設定ファイル

以下の図はリンクプロセスを示します。

注 : 標準 C/C++ ライブラリには、コンパイラのサポートルーチン
と、C/C++ 標準ライブラリ関数の実装が含まれます。

ILINK リンカは、実行可能イメージを含む ELF フォーマットの絶
対オブジェクトファイルを生成します。XLINK は、C-SPY デバッ
ガで使用される IAR システム独自のデバッグフォーマット、
UBROF に加えて、30 以上の業界標準のローダフフォーマットを生
成できます。

リンクの途中で、リンカが stdoutおよび stderrに関するエラー
メッセージを生成することがあります。ILINK はログメッセージも
生成し、これはアプリケーションがなぜリンクされたかを理解する
場合、たとえば、モジュールが含まれた理由やセクションが削除さ
れた理由を理解するときに役に立ちます。
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リンク後

リンク後、生成された絶対実行可能イメージは以下のことに使用でき
ます。

● IAR C-SPY デバッガ、または生成されたフォーマットを読み取るその
他の外部デバッガへのロード。

● フラッシュ /PROM メモリを使用したフラッシュ /PROM へのプログラ
ミング。ILINK を使用してリンクする際、これを実現するには、イ
メージの実際のバイトを標準の Motorola S-record フォーマットまたは
Intel-Hex フォーマットに変換する必要があります。XLINK はこれら
のフォーマットのどれでも直接生成できるため、これ以外の変換は不
要です。

次の図は出力の用法を示します。

パフォーマンス重視のプログラミング

ここでは、以下についてのヒントを提供します。

● データ型の適切な使用

● レジスタ定義の容易化

● コンパイラ変換の容易化
27
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データ型の適切な使用

データサイズは適切に使用する必要があります。8 ビットの処理は、
たいていは 32 ビットの CPU 上では非効率的です。逆に、32 ビット
の処理は 8 ビットの CPU にとっては効率が悪くなります。整数定
数を使用する場合、36Lというように必ず適切なサフィックスを追
加してください。

符号付きの値は、マイナスの値が使用できることを意味します。
ただし、コンパイラがこうした値を変更する場合、算術演算が使用
されます。符号なしの値の場合、コンパイラはビットおよびシフ
ト演算を使用します。これらは算術演算よりも通常は効果的です。
マイナスの値が必要ない場合、符号なしの型を使用してください。

浮動小数点数の処理は通常、大きなライブラリ関数が必要になりか
ねないため、非常にコストがかかります。こうした演算を整数演算
（より効率的です）に置き換えることを検討してください。

メモリ配置およびポインタ型は、8 ビットおよび 16 ビットのアー
キテクチャ上では効率が上がり、小さいメモリ領域や小さいアドレ
ス、小さいポインタを目指す場合は生成されるコードも小さくなり
ます。最も大きいメモリ型やポインタの使用は避けてください。

キャストでポインタを起点にしたり、異なる型の式を混在させるこ
とは避けるべきです。こうすると非効率なコードが生成され、情報
が失われるリスクがあります。

構造体におけるパディングは、CPU でアラインメントが必要な場合
に発生します。メモリを浪費しないように、フィールドをサイズ別
に整列して、パディングに使用されるメモリ量が最小限になるよう
にしてください。

レジスタ定義の円滑化

関数パラメータとローカル変数（グローバル変数とは対照的に）
は、レジスタに配置できてスコープ内にある間だけ存在すればすむ
ため、メモリ消費量が少なくなります。グローバル変数を使用する
と、変数にアクセスする関数の呼出しのたびに更新の必要があるた
め、オーバヘッドが発生します。

可変引数 （printf スタイル）は避けるべきです。その理由は、引数
がスタックに強制適用されるためです。強制適用されない場合、
これらの引数はレジスタで引き渡されます。
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コンパイラ変換の円滑化

関数プロトタイプは、型変換（暗黙のキャスト）が不要でソースコード
の問題が発見しやすくなるため、使用するべきです。また、プロトタイ
ピングによって、コンパイラがより効率的なコードを生成しやすくなり
ます。

静的宣言された変数および関数は、最高の最適化を達成するために、
宣言されたファイルやモジュールでのみ使用するべきです。

インラインアセンブラは、コンパイラがコードを最適化する際に大きな
障害となることがあります。使用するコンパイラで asmキーワードがど
のように機能するか確認してください。

「賢い」ソースコードは、分かりやすいコードと置き換えるべきです。
分かりやすいコードは保守が簡単で、プログラミングのエラーを含む確
率が少なく、たいていはコンパイラが最適化しやすいからです。

volatile キーワードは、同時にアクセスされる変数を保護するために使
用してください。つまり、割込みルーチンや別のスレッドで実行される
コードなどによって、非同期でアクセスされる変数ということです。
こうすれば、こうした変数がアクセスされる場合、コンパイラは常にメ
モリから読込み、メモリに書込みます。

空白のループは、 遅延を達成するほかに何も影響を与えないコードで、
コンパイラによって削除されるかもしれません。代わりに、OS サービ
ス、組込み関数、CPU タイマを使用するか、volatile 宣言された変数にア
クセスします。

長い基本ブロックは、可能であれば作成してください。基本ブロック
は、関数呼出しを持たないソースコードの割り込まれないシーケンスで
す。これによって、より効率的なレジスタ定義と最適化の良好な結果に
つながります。

ハードウェアおよびソフトウェア要因の考慮

通常、専用マイクロコントローラに記述される組込みソフトウェアは、
何らかの外部イベントの発生を待機するエンドレスループとして設計で
きます。このソフトウェアは、ROM に置かれ、リセット時に実行され
ます。この種のソフトウェアを作成する際には、いくつかのハードウェ
ア要因およびソフトウェア要因を考慮する必要があります。
29

GSEW-3

組込みアプリケーションの開発



CPU 機能および制限
命令セットの相互作用や異なるプロセッサモードなど、使用するマ
イクロコントローラで利用可能な機能、およびアラインメントの制
約は、しっかり理解しておく必要があります。これらを正しく設定
するには、ハードウェアのマニュアルを読んで理解することが重要
です。

コンパイラは、こうした機能を拡張キーワードやプラグマディレク
ティブ、コンパイラオブジェクトなどの手段によってサポートして
います。

プロジェクトを IDE で設定するときに、使用するデバイスに適した
デバイスオブジェクトを選択する必要があります。以下の選択は自
動的に行われます。

● 使用するデバイスに合った CPU 固有のオプションの設定

● デフォルトのリンカ設定ファイルの決定（製品パッケージに
よって異なります）

製品パッケージによっては、ターゲット \configディレクトリに
リンカ設定ファイルのテンプレート、または一部あるいはサ
ポートされているすべてのデバイス用の定義済みリンカ設定
ファイルが含まれています。これらのファイルのファイル拡張
子は、xcl（XLINK）または icf（ILINK）です。

● デフォルトのデバイス記述ファイルの決定。

これらのファイルはターゲット \configディレクトリにあり、
ファイル名の拡張子は ddfか svdです（製品パッケージによっ
て異なります）。

内部および外部メモリのマッピング

組込みシステムには、通常、オンチップ RAM、外部 DRAM、外部
SRAM、外部 ROM、外部 EEPROM、フラッシュメモリなど、さま
ざまなタイプのメモリが含まれます。

組込みソフトウェア開発者は、これらのさまざまなメモリタイプの
機能を理解する必要があります。たとえば、オンチップ RAM は、
通常、他のメモリタイプより高速なので、時間重視のアプリケー
ションでは、頻繁にアクセスされる変数をこのメモリに配置するこ
とでメリットを得ることができます。逆に、アクセスは頻繁に行わ
れないが、電源を切った後でもその値を保持する必要がある設定
データは、EEPROM またはフラッシュメモリに保存する必要があ
ります。
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メモリを効率的に使用するため、コンパイラでは、関数とデータオブ
ジェクトのメモリへの配置を制御するためのさまざまな仕組みを提供し
ています。リンカは、リンカ設定ファイルで指定したディレクティブに
従って、メモリにコードとデータを配置します。

周辺ユニットとの通信

外部デバイスがマイクロコントローラに接続される場合、シグナル伝達
用インタフェースを初期化および制御し、たとえば、チップを使用し
て、ピンを選択し、外部割込みシグナルを検出および処理して行いま
す。通常、初期化および制御はランタイムに実行する必要があります。
通常、これは特殊関数レジスタ (SFR) を使用して行います。これらのレ
ジスタは、通常、チップ設定を制御するビットを含む、専用アドレスで
使用できます。

標準の周辺ユニットは、デバイス専用の I/O ヘッダファイル（拡張子は h）
で定義されており、 ターゲット \incディレクトリにあります。該当する
インクルードファイルをアプリケーションソースファイルにインクルー
ドしてください。追加の I/O ヘッダファイルが必要な場合は、既存の
ヘッダファイルをテンプレートとして使用することにより作成できます。

割込みの処理

組込みシステムでは、ボタン押下の検出など、外部イベントを即座に処
理するために割込みを使用します。通常はコード中で割込みが発生する
と、マイクロコントローラは実行中のコードを停止し、その代わりに割
込みルーチンの実行を開始します。

コンパイラは専用のキーワードでプロセッサの例外タイプをサポートし
ています。つまり、割込みルーチンを C で記述できます。

システム起動

すべての組込みシステムでは、アプリケーションの main関数が呼び出
される前に、システム起動コードが実行され、ハードウェアとソフト
ウェアの両方のシステムが初期化されます。

組込みソフトウェア開発者は、この起動コードを専用メモリアドレスに
配置するか、ベクタテーブルからポインタを使用してアクセスできるよ
うにしなければなりません。つまり、起動コードおよび初期ベクタテー
ブルは、ROM、EPROM、フラッシュメモリなど、不揮発性メモリに配
置する必要があります。

C/C++ アプリケーションでは、さらに、すべてのグローバル変数を初期
化する必要があります。この初期化は、リンカおよびシステム起動コー
ドで扱われます。詳細については、33 ページの アプリケーションの実行
を参照してください。
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ランタイムライブラリ

製品パッケージに応じて、次の 2 つのライブラリのどちらか一方、
または両々が用意されています。使用するライブラリを選択する必
要があります。

● IAR DLIBライブラリは標準のCとC++に対応しています。このラ
イブラリは、IEEE 754 フォーマットの浮動小数点数もサポート
しています。また、ロケール、ファイル記述子、マルチバイト
文字などのさまざまなレベルのサポートを指定して構成するこ
とができます。

● IAR CLIBライブラリは軽量ライブラリで、標準の C に完全に対応
しているわけではありません。IEEE 754 フォーマットの浮動小
数点の数値にも完全には対応しておらず、Embedded C++ もサ
ポートしていません。旧型の CLIB ライブラリが提供されている
場合は、旧バージョンとの互換性のためです。新しいアプリ
ケーションプロジェクトには使用しないでください。

注 : アセンブラソースコードだけで構成されたプロジェクトの場合
は、ランタイムライブラリを選択する必要はありません。

ラインタイムライブラリは、さまざまなプロジェクトの設定用にビ
ルドされたビルド済みライブラリとして提供されます。IDE は、
プロジェクトの設定に合ったライブラリを自動的に使用します。
製品パッケージによっては、使用する構成にビルド済みライブラリ
がない場合があります。その場合は、自分でライブラリをビルドす
る必要があります。

製品パッケージによっては、ライブラリがソースファイルとして用
意されていることもあります。これらはディレクトリターゲット

\src\libにあります。つまり、ライブラリをカスタマイズして自
分でビルドできます。IDE は、ライブラリプロジェクトテンプレー
トを提供しています。これを使用して自作ライブラリのビルドが可
能です。

ランタイム環境

ランタイム環境は、アプリケーションを実行するための環境です。
このランタイム環境は、選択したランタイムライブラリ、ターゲッ
トハードウェア、ソフトウェア環境、アプリケーションのソース
コードによって異なります。

最もコード効率の高いランタイム環境を設定するには、アプリケー
ションやハードウェアの要件を特定する必要があります。必要な機
能が多いほど、コードのサイズも大きくなります。
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必要なランタイム環境を構成するには、これを以下の方法でカスタマイ
ズすると便利です。

● scanf入力フォーマッタおよび printf出力フォーマッタなど、ライブ
ラリオブジェクトの設定。

● スタックサイズの指定（マイクロコントローラによっては複数のス
タック）。

マイクロコントローラによっては、非静的自動変数をスタック上また
は静的オーバレイエリアのどちらに配置するかも指定する必要があり
ます。スタックは実行時に動的に割り当てられるのに対し、スタック
オーバレイエリアはリンク時に静的に割り当てられます。

● ヒープサイズ、およびメモリ内の配置場所の指定。製品パッケージ
にっては、複数のヒープを使用してそれらを異なるメモリ領域に配置
することも可能です。

● cstartupなどの特定のライブラリ関数を、自分でカスタマイズした
関数でオーバライドする。

● ロケール、ファイル記述子、マルチバイト文字など特定の標準ライブ
ラリ機能のサポートレベルを、Normal/Full（DLIB ライブラリの場合
のみ可能）のいずれかのライブラリ構成を選択して指定する。また、
自分でライブラリ構成を作成することもできますが、ライブラリのリ
ビルドが必要になります。この機能により、ランタイム環境を完全管
理できます。

ハードウェア上でアプリケーションを実行するには、キャラクタベースの
I/O に低レベルのルーチンを実装する必要があります（通常は CLIB の場
合が putcharと getcharで、DLIB の場合は __readと __writeです）。

アプリケーションの実行

このセクションでは、組込みアプリケーションの実行の概要を以下の
3 つのフェーズに分けて説明します。

● 初期化

● 実行

● 終了
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初期化フェーズ

初期化フェーズは、アプリケーションの起動時（CPU のリセット
時）、main関数が入力される前に実行されます。初期化フェーズ
は、おおまかに以下のように分割できます。

● ハードウェア初期化。たとえば、スタックポインタの初期化など

ハードウェア初期化は通常、システム起動コード cstartupで実
行され、必要に応じて、ユーザが提供する追加の低レベルルー
チンで実行されます。また、ハードウェアの残りの部分のリ
セット / 起動や、ソフトウェア C/C++ システム初期化の準備の
ための CPU などの設定が行われる場合もあります。

● ソフトウェア C/C++ システム初期化

一般的に、この初期化フェーズでは、main関数が呼び出される前
に、すべてのグローバル（静的にリンカされた）C/C++ オブジェ
クトがその正しい初期化値を受け取っていることが前提です。

● アプリケーション初期化

これは、使用しているアプリケーションにより異なります。一般
的に、RTOS カーネルの設定や、RTOS が実行するアプリケー
ションの初期タスクの開始が含まれます。ベアボーンアプリケー
ションでは、さまざまな割込みの設定、通信の初期化、デバイ
スの初期化などが含まれます。

ROM/ フラッシュベースのシステムでは、定数や関数がすでに
ROM に配置されています。RAM に配置されたすべてのシンボル
は、main関数が呼び出される前に初期化される必要があります。
また、リンカにより、利用可能な RAM はすでに変数、スタック、
ヒープなどの異なるエリアに分割されています。
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以下の一連の図は、初期化の各段階の概要を簡単に示します。図ではメ
モリのレイアウトは一般化されています。

1 アプリケーションが
起動したら、システ
ム起動コードは、マ
イクロコントローラ
に応じて、まず事前
に定義されているス
タックエリアの開始
または終了ポイント
へのスタックポイン
タの初期化など、
ハードウェアの初期
化を実行します。

2 次に、ゼロ初期化さ
れるメモリがクリアされ
ます。すなわち、これら
のメモリにゼロが埋め込
まれます。一般的に、こ
れはゼロで初期化される
データなどのデータで、
たとえば int i = 0;

などで宣言される変数
です。
35

GSEW-3

組込みアプリケーションの開発



3 初期化済みデータの場合、
int i = 6;などゼロ以外の
値で宣言されたデータは、
イニシャライザが ROM から
RAM にコピーされます。

4 最後に main関数が呼び出さ
れます。

実行フェーズ

組込みアプリケーションのソフトウェアは、通常、割込み駆動型の
ループか、外部相互処理や内部イベントを制御するためのポーリ
ングを使用するループのいずれかで実装されます。割込み駆動型
システムの場合、割込みは、通常、main 関数の開始時に初期化さ
れます。
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リアルタイム動作システムで、応答性が重要な場合、マルチタスクシス
テムが必要になることがあります。つまり、アプリケーションソフト
ウェアは、リアルタイムオペレーティングシステムで補足する必要があ
ります。この場合、RTOS およびさまざまなタスクは、main関数の開始
前に初期化される必要があります。

終了フェーズ

一般的に、組込み関数は実行を停止しません。終了する場合、正しい終
了動作を定義する必要があります。

アプリケーションを制御したまま終了するには、標準 C ライブラリ関数
の exit、_Exit、abortのいずれかを呼び出すか、mainから戻ります。
mainから戻ると、exit関数が実行されます。すなわち、静的およびグ
ローバル変数の C++ デストラクタが呼び出され（C++ のみ）、開いてい
るすべてのファイルが閉じます。
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アプリケーションプロ
ジェクトの作成
この章では、IDE でアプリケーションプロジェクトを設定するた

めの開発サイクルについて解説します。開発サイクルは、以下の

手順で構成されます。

● ワークスペースの作成

● 新しいプロジェクトの作成

● プロジェクトオプションの設定

● プロジェクトへのソースファイルの追加

● ツール固有のオプションの設定

● コンパイル

● リンク

ステップバイステップのチュートリアルのいずれかを使用して学

習する場合は、[Help]（ヘルプ）メニューから表示できるイン

フォメーションセンタからチュートリアルにアクセスできます。

ワークスペースの作成

[File]>[New]>[Workspace]（ファイル > 新規 > ワークスペース）を選択
して、プロジェクトを追加するワークスペースを作成します。空白の
ワークスペースウィンドウが表示されます。

注 : IDE を初めて起動したときは、既製のワークスペースが開いている
ので、それをプロジェクト用に使用できます。

プロジェクトを作成してワークスペースに追加する準備はこれで完了
です。
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スムーズに開発を開始するためのサンプルが用意されています。
製品パッケージに応じて、数個から数百個の実際のソースコードの
サンプルが含まれており、複雑さは単純な LED の点滅から USB の
マスストレージコントローラまでさまざまです。使用する製品パッ
ケージに応じて、サポートされているほとんどのデバイスのサンプ
ルがあります。これらのサンプルには、[Help]（ヘルプ）メニュー
から表示できるインフォメーションセンタからアクセスできます。

新しいプロジェクトの作成

1 [Project]>[Create 
New Project]（プ
ロジェクト > 新規
プロジェクト）を
選択します。

[Tool chain]
（ツールチェ－ン）
ドロップダウンリ
ストから、使用す
るツールチェーン
を選択します。複
数のマイクロコン
トローラ用に IDE
をインストールし
ている場合、それ
らがドロップダウンリストに表示されます。

プロジェクトリストのリストから、新しいプロジェクトの基礎とす
るテンプレートを選択します。たとえば、[Empty project]（空白の
プロジェクト）を選択すると、単にデフォルトのプロジェクト設定
を使用した空のプロジェクトが作成されます。

2 プロジェクトを保存します。

3 [Workspace]（ワークスペース）
ウィンドウにプロジェクトが表
示されます。
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デフォルトで、デバッグとリリースという 2 つのビルド構成が作成され
ます。これらを使用して、プロジェクト（プロジェクト設定およびビル
ドのファイルパート）の派生形を定義できます。独自のビルド構成を定
義することもできます。構成は、ウィンドウ上端のドロップダウンメ
ニューから選択します。

4 ファイルをプロジェクトに追加する前に、ワークスペースを保存してく
ださい。

プロジェクトに関連する以下のファイルが作成されます。

● ワークスペースファイル（ファイル名の拡張子 eww）。このファイル
には、ワークスペースに追加したすべてのプロジェクトがリストされ
ます。

● プロジェクトファイル（ファイル名の拡張子 ewpと ewd）。これらの
ファイルには、ビルドオプションなど、プロジェクト固有の設定に関
する情報が保存されます。

● ウィンドウの配置やブレークポイントなど、現在のセッションに関す
る情報は、projects\settingsディレクトリに作成されるファイルに
保持されます。

プロジェクトオプションの設定

ビルド構成全体に同じオプションを設定するには：

1 [Workspace]（ワークスペース）
ウィンドウでプロジェクトフォル
ダのアイコンを選択し、右クリッ
クして [Options]（オプション）
を選択します。

2 [General Options]（一般オプショ
ン）カテゴリには、ターゲットや
出力、ライブラリ、ランタイム環
境のオプションがあります。ここ
で行う設定は、ビルド構成全体と同じでなければなりません。

特に [Target]（ターゲット）ページで選択したデバイスによって、使用
する製品パッケージに合わせて、デフォルトのデバッガデバイス記述
ファイルとおよびデフォルトのリンカ設定ファイルが自動的に決まる点
に注意してください。さらに、選択したデバイスに合わせて他のオプ
ションが自動的に設定されます。
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プロジェクトへのソースファイルの追加

1 [Workspace]（ワークスペース）
ウィンドウで、ソースファイルの
追加先としてグループかプロジェ
クトを選択します。この例では、
直接プロジェクトに追加します。

2 [Project]>[Add Files]（プロジェク
ト > ファイルの追加）を選択し
て、標準の参照ダイアログボック
スを開きます。ファイルを探し、
[Open]（開く）をクリックしてそ
れらを自分のプロジェクトに追加
します。

いくつかのファイルのグループを
作成して、プロジェクトの要件に合わせてソースファイルを論理的
に整理することができます。

新しいドキュメントを作成するには：

ツールバーで [New Document]（新規ドキュメント）をクリックし
ます。エディタウィンドウにファイルが表示されます。1 つまたは
複数のテキストファイルを作成または開くことができます。複数の
ファイルを開く場合、タブグループに整列されます。複数のエディ
タウィンドウを同時に開いておくことができます。

関数の 参照を検索するには :
エディタウィンドウで、ヘルプが必要な項目を選択して F1 キーを
押します。オンラインヘルプシステムが表示されます。
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エディタウィンドウでは、すべての C または Embedded C++ のライブラ
リ関数、キーワードや組込み関数などすべてのコンパイラ言語拡張につ
いてヘルプを参照できます。

エディタを設定するには：

[Tools]>[Options]（ツール > オプション）を選択して、[IDE Options]
（IDE オプション）ダイアログボックスで適切なオプションのカテゴリを
選択します。

ツール固有のオプションの設定

1 [Workspace]（ワークスペース）ウィンドウでプロジェクトを選択し、
ファイルグループまたは個別のファイルを選びます。[Project]>[Options]

（プロジェクト > オプション）を選択して、[Options]（オプション）ダ
イアログボックスを開きます。
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2 [Category]（カテゴリ）リストでツールを選択し、適切なページで
設定を行います。リストで使用可能なツールは、製品パッケージに
よって異なります。

ツールチェーンの標準ツールパートのほかに、ビルド前とビルド後
のアクションのオプション、および外部ツールを呼び出すためのオ
プションを設定できます。

特定のコンパイラ
オプションを設定
する前に、複数
ファイルのコンパ
イルを使用するかどうかを指定できます。コンパイラの 1 回の呼び
出しで複数のソースファイルのコンパイルを可能にすることによ
り、多くの場合に最適化がより効率的になります。ただし、ビルド
時間に影響することがあります。このため、作業の開発フェーズで
はこのオプションを無効にしておくのが望ましいと言えます。

注 : ご使用の製品パッケージが複数ファイルのコンパイルをサポー
トしない場合は、[Multi-file Compilation]（複数ファイルのコンパイ
ル）オプションは使用できません。
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コンパイル

1 つまたは複数のファイルをコンパイルするには :
1  [Workspace]（ワークスペース）ウィンドウでファイルを選択するか、

コンパイルするファイルが表示されているエディタウィンドウをクリッ
クします。

2 ツールバーの [Compile]（コンパイル）をクリックします。

または、[Project]（プロジェクト）メニューで使用可能な以下のコマン
ドのいずれかを使用します :

[Make]（メイク） — 最後のビルド以降に変更されたファイルだけをコンパ
イル、アセンブル、リンクして、現在のビルド構成を最新の状態に更新。

[Rebuild All]（すべてを再ビルド） — アクティブなプロジェクト構成のす
べてのファイルをビルドして再度リンク。

[Batch build]（バッチビルド） — 指定したバッチビルド構成を作成し、指
定したバッチをビルドするためのダイアログボックスを表示します。

3 ソースコードのエラーが
生成された場合は、
[Build]（ビルド）ウィン
ドウでエラーメッセージ
をダブルクリックするこ
とで、適切なソースファ
イルの正しい位置に切り
替えます。

4 1 つまたは複数のファイ
ルをコンパイルあるいはアセンブルした後は、IDE によってプロジェク
トディレクトリに 2 つの新しいディレクトリとファイルが作成されてい
ます。ビルド構成の名前が Debug だとすると、これらのディレクトリを
含む同じ名前のディレクトリが作成されています。

● List — リストファイルの保存先ディレクトリで、拡張子は lst、
map、log。

● Obj — コンパイラとアセンブラが生成したオブジェクトファイルの保
存先ディレクトリ。これらのファイルはリンカへの入力として使用さ
れ、拡張子は XLINK と併用する製品の場合は rnn（nn は製品パッ
ケージによって異なります）、ILINK と併用する製品では oです。

● Exe — 実行可能ファイルのディレクトリ。C-SPY への入力として使用
され、拡張子は XLINK と使用する製品の場合は dnn（nn は製品パッ
ケージによって異なります）、ILINK と共に使用する製品では outで
す。このディレクトリは、オブジェクトファイルをリンクするまでは
空であることに注意してください。
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[Workspace]（ワークスペース）ウィンドウで結果を参照す
るには：

コンパイルの後で、[Workspace]
（ワークスペース）ウィンドウの [+]
アイコンをクリックして、表示を拡
大します。

[Workspac]（ワークスペース）ウィ
ンドウには IDE によって作成された
出力フォルダのアイコンが表示され
ています。このフォルダには、生成
されたすべての出力ファイルが保存
されます。同様に、インクルードさ
れているすべてのヘッダファイルも
表示され、ファイル間の依存関係
を示しています。

生成されたファイルのファイル名の
拡張子は、製品パッケージによって
異なります。

リンク

1 [Workspace]（ワークスペース）ウィンドウでプロジェクトを選択し、
右クリックしてコンテキストメニューから [Options]（オプション）
を選択します。続いて、[Category]（カテゴリ）リストで [Linker]
（リンカ）を選択して、リンカのオプションページを表示します。

2 設定が終わったら、[Project]>[Make]（プロジェクト > 作成）を選択
します。進捗状況は、[Build]（ビルド）メッセージウィンドウに表
示されます。リンクの結果は、デバッグ情報を含む出力ファイルに
なります（デバッグ情報付きでビルドした場合）。

リンカオプションの設定時には、出力オプションや出力形式、リン
カ設定ファイル、マップファイルおよびログファイルの選択に注意
してください。
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出力形式

XLINK リンカは、数多くの形式を生成できます。出力形式は、目的に
合せて選択することが重要です。デバッガに出力をロードする場合は、
デバッグ情報付きで出力する必要があります。最終のアプリケーション
プロジェクトでは、別の方法として、出力を PROM プログラマにロード
することができます。この場合は、Intel-hex、Motorola S-records など、
プログラマでサポートされている出力形式を使用する必要があります。

ILINK リンカでは、ELF 形式（デバッグ情報用の DWARF を含む）の出
力ファイルを作成します。ELF 形式ではなく、Motorola または
Intel-standard 形式のファイルが必要な場合（ファイルを PROM メモリに
ロードする場合など）、ファイルを変換する必要があります。[Options]
（オプション）ダイアログボックスで [Converter]（コンバータ）カテゴ
リを選択し、適切なオプションを設定してください。

リンカ設定ファイル

プログラムコードとデータは、リンカ設定ファイル（ファイル名の拡張
子は ILINK では icf、XLINK では xcl）で指定された設定に基づいて、
メモリに配置されます。セクションをメモリに配置する方法の構文につ
いて理解していることが重要です。

製品パッケージによっては、ターゲット \configディレクトリにリンカ
設定ファイルのテンプレート、または一部あるいはサポートされている
すべてのデバイス用の定義済みリンカ設定ファイルが含まれています。
製品に備わっている C-SPY シミュレータに付属のファイルやテンプレー
トを使用できますが、それらをターゲットシステムに使用する場合は、
実際のハードウェアのメモリレイアウトに合わせて調整する必要があり
ます。

リンカ設定ファイルを詳細に確認するには、IAR Embedded Workbench エ
ディタのようなテキストエディタか、ファイルの内容を印刷して定義が
ハードウェアメモリのレイアウト要件に合っているかどうか確認してく
ださい。

リンカマップとログファイル

XLINK と ILINK はどちらも、詳細なリストを生成できます。

● XLINK はマップファイルを生成でき、これにはセグメントマップやシ
ンボルリスト、モジュールサマリなどが任意で含まれます。

● ILINK は、一般的に配置のサマリを含むマップファイルを生成できま
す。また、ILINK はログファイルを生成できます。このファイルには、
初期化やモジュールの選択、セクションの選択などについて、リンカ
が決定した事項が記録されます。
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一般的に、この情報は次のことを詳しく調べるときに役立ちます。

● セグメント / セクションおよびコードがどのようにメモリに配置
されたか

● どのソースファイルが実際に最終のイメージに含まれたか

● どのシンボルが実際にインクルードされたか、およびその値

● 個々の関数がメモリのどこに配置されたか
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デバッグ 
C-SPY デバッガの機能の一部を紹介することにより、本章ではそ

れらの機能と使用方法について説明します。

● デバッグの設定

● デバッガの起動

● アプリケーションの実行

● 変数の検証

● メモリとレジスタのモニタ

● ブレークポイントの使用

● ターミナル I/O の表示

● アプリケーションのランタイムでの動作の解析

インストールした製品パッケージによって、C-SPY が含まれてい

る場合とそうでない場合があります。

使用するハードウェアによっては、ここで紹介しない追加機能が

使用する C-SPY ドライバで利用可能なことがあります。一般的に

は、これは異なるタイプのウォッチポイントの設定や追加のブ

レークポイントタイプ、さまざまなトリガシステム、より複雑な

トレースシステムなどに該当します。

デバッグの設定

1 C-SPY を起動する前に、[Project]>[Options]>[Debugger]>[Setup]（プロ
ジェクト > オプション > デバッガ > 設定）を選択し、シミュレータや
ハードウェアデバッガシステムの中から使用するデバッガシステムに
合った C-SPY ドライバを選んでください。

2 [Category]（カテゴリ）リストで、適切な C-SPY ドライバを選択し、設定
を確認します。

3 C-SPY の設定が終わったら、[OK] をクリックします。

4 [Tools]>[Options]>[Debugger]（ツール > オプション > デバッガ）を選択し
て以下を設定します。
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● デバッガの動作

● デバッガによるスタック使用率のトラッキング

C-SPY 起動前のハードウェア設定

C-SPY マクロを使用して、C-SPY が起動する前にターゲットハード
ウェアを初期化できます。たとえば、コードをダウンロードする前
に有効にしなければならない外部メモリをハードウェアで使用する
場合、デバッグするアプリケーションをダウンロードする前に、
C-SPY はこのアクションを実行するマクロを必要とします。次に例
を示します。

1 新しいテキストファイルを作成して、マクロ関数を定義します。
たとえば、外部の SDRAM を有効にするマクロは以下のようになり
ます :

/* 使用するマクロ関数 */
enableExternalSDRAM()
{
  __message "Enabling external SDRAM\n";

  __writeMemory32（ /* ここにコードを配置 */ ）;
  /* 必要に応じてここにコードを追加 */
}

/* セットアップマクロが実行時間を決定 */
execUserPreload()
{
  enableExternalSDRAM();
}

組込みの execUserPreloadセットアップマクロ関数が使用され、
マクロ関数はターゲットシステムとの通信が確立されてから、
C-SPY がアプリケーションをダウンロードするまでの間に直接実行
されます。

2 ファイル名拡張子を macとしてこのファイルを保存します。

3 C-SPY を起動する前に、[Project]>[Options]>[Debugger]（プロジェ
クト > オプション > デバッガ）を選択して、[Setup]（設定）タブを
クリックします。オプション [Use Setup file]（セットアップファイ
ルの使用）を選択して、作成したマクロファイルを選択します。こ
れで、起動マクロが C-SPY の起動シーケンス中にロードされるよ
うになります。
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デバッガの起動

デバッガを起動するには、次のどちらかの手順に従います :

ダウンロードしてデバッグは C-SPY を起動して、現在のプロジェクトを
ターゲットシステムにロードします。

ダウンロードなしにデバッグは、現在のプロジェクトをターゲットシス
テムに再ロードせずに C-SPY を起動します。コードイメージがすでに
ターゲットにあるために、ロードが必要ないときを想定しています。

複数のデバッグファイル（イメージ）をターゲットシステムにロード
できます。IDE で追加のデバッグファイルをロードするには、
[Project]>[Options]>[Debugger]>[Images]（プロジェクト > オプション >
デバッガ > イメージ）を選択します。すなわち、プログラム全体は複数
のイメージで構成されることになります。たとえば、アプリケーション
（1 つのイメージ）がブートローダ（別のイメージ）によって起動される
とします。アプリケーションイメージとブートローダは別のプロジェク
トを使用してビルドされ、別の出力ファイルを生成します。
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C-SPY が起動して、アプリケーションがロードされます。

C-SPY は、ウィンドウの内容を更新するためにターゲットシステム
から読み込む必要があります（[Memory]（メモリ）や [Trace]（ト
レース）ウィンドウなど、更新の必要があるウィンドウの場合）。
これによって、デバッグ中に反応時間が影響を受けます。同時に複
数のウィンドウを開いていて、反応時間が長すぎる場合（特にハー
ドウェア上でアプリケーションを実行中）、ウィンドウを 1 つか 2 つ
閉じて反応時間を短縮します。

C-SPY を終了するには :

[Debug]（デバッグ）ツールバーの [Stop Debugging]（デバッグ停
止）ボタンをクリックします。

[View]（表示）メニューで
C-SPY ウィンドウが使用可能に

ダウンロード用コマンドドライバ固有のメニュー 
（ドライバに関連する名前） ブレークポイントの切替え

[Debug Log]（デバッグログ）ウィンドウ
デバッガ出力を表示
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アプリケーションの実行

以下のような実行コマンドは、[Debug]（デバッグ）メニューと [Debug]
（デバッグ）ツールバーにあります。

[Step Over]（ステップオーバ）は、C/C++ 関数やアセンブラサブルーチ
ンに入らずに、次の文 / 関数呼出し / 命令を実行します。

[Step Into]（ステップイン）は、C/C++ 関数やアセンブラサブルーチン
に入って、次の文 / 命令を実行します。

[Next Statement]（次のステートメント）は、個々の関数呼出しで停止せ
ずに次の C/C++ 文まで直接実行します。

また、[Go]（実行）、[Berak]（ブレーク）、[Reset]（リセット）、[Run to 
Cursor]（カーソルまで実行）、[Autostep]（自動ステップ）などのコマン
ドは、メニューおよびツールバーにあります。

C-SPY はステップポイントの機能によってステートメント単位でステップ
を実行できるため、行単位でステップを実行する他の多くのデバッガより
も高い精度でステップ実行できます。複雑なステートメントの一部である
個別の関数呼出しにステップインできる機能は、複数回ネストしている
関数呼出しを含む C ソースコードを使用している場合に、特に役に立ち
ます。また、コンストラクタ、デストラクタ、代入演算子、その他の
ユーザ定義演算子など、多くの間接的な関数呼出しを使用する傾向があ
る C++ でも、ステップイン機能が非常に役に立ちます。

関数呼出し検証するには：

1 [View]>[Call Stack]（表示 > 呼出しスタック）
を選択して、[Call Stack]（呼出しスタック）
ウィンドウを開きます。C/C++ 関数呼出しス
タックが、現在の関数とともに上部に表示さ
れます。いずれかの関数をダブルクリックす
ると、IDE で影響を受けるすべてのウィンド
ウの内容がが更新されて、特定の呼出しフ
レームのステートが表示されます。

この機能は通常、以下の 2 つの目的で使用します。

● 現在の関数の呼出し元のコンテキストを決定する場合

● 不正な変数やパラメータの値を検出したときに、その発生元をトレー
スして、呼出しチェーン内で問題が発生した関数を特定する場合
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逆アセンブリモードでデバッグするには：

[View]>[Disassembly]
（表示 > 逆アセンブ
リ）を選択して
[Disassembly]（逆ア
センブリ）ウィンド
ウを開きます（まだ
開いていない場合）。
現在の C 文に対応
するアセンブラコー
ドが表示されます。

逆アセンブリモード
では、一度に 1 つの
アセンブラ命令単位
でアプリケーション
を実行できます。対照的に、C/C++ モードでは一度に 1 つのステー
トメントまたは関数単位でアプリケーションを実行します。どちら
のモードでデバッグしている場合でも、レジスタとメモリを表示し
たり、その内容を書き換えたりすることができます。

モードを切り替えるには :

マウスポインタを使用して、使用するモードに応じて、[Editor]（エ
ディタ）ウィンドウか [Disassembly]（逆アセンブリ）ウィンドウを
アクティブにします。

コードカバレッジ情報を表示するには：

[Disassembly]（逆アセンブリ）ウィンドウで右クリックして [Code 
Coverage]>[Enable]（コードカバレッジ > 有効）を選択し、コンテ
キストメニューから [Code Coverage]>[Show]（コードカバレッジ > 
表示）を選択します。実行済みのコードは、緑色のひし形で示され
ます。63 ページの コードカバレッジも参照してください。

変数の検証 
C-SPY では、ソースコードの変数や式をモニタして、アプリケー
ションを実行したときのそれらの値をトレースできます。いくつか
の方法で変数を参照できます。

ツールチップウォッチは、変数の値やより複雑な式をエディタウィ
ンドウで参照する最も簡単な方法です。マウスポインタで変数を指
すだけで、 変数の横にその値が表示されます。
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[Locals]（ローカル）ウィンドウは、 [View]（表示）メニューから表示で
き、ローカル変数、つまりアクティブな関数の自動変数と関数パラメー
タが自動的に表示されます。

[Watch]（ウォッチ）ウィンドウは [View]（表示）メニューから表示し
ます。これを使用して、選択した C-SPY 式および変数の値をモニタリン
グできます。

[Live Watch]（ライブウォッチ）ウィンドウは [View]（表示）メニュー
から表示します。アプリケーション実行中に継続的に式の値がサンプリ
ングされて表示されます。式の変数は、グローバル変数のように、静的
に特定できる必要があります。このウィンドウでは、プログラム実行中
にターゲットシステムがメモリの読取りをサポートしている必要があり
ます。

[Statics]（静的変数）ウィンドウは [View]（表示）メニューから表示しま
す。静的記憶寿命変数の値が自動的に表示されます。さらに、表示する
こうした変数を自由に選択できます。

[Auto]（自動）ウィンドウは [View]（表示）メニューから表示します。
現在の文の中、または近くにある変数と式の自動選択の内容が表示され
ます。

[Quick Watch]（クイックウォッチ）ウィンドウは、変数または式の値
をいつ評価したりモニタリングするかを、正確に制御できる素早い方法
です。

トレースデータの収集は、 はドライバ固有のメニューから表示します。
イベントのシーケンス（通常は実行されたマシン命令）をターゲットシ
ステムに収集できます。使用しているターゲットシステムに応じて、追
加タイプのトレースデータが収集できます。たとえば、メモリのリード /
ライトアクセス、C-SPY 式の値などを記録できます。65 ページの ト
レースも参照してください。

注 : 最適化レベルとして [None]（なし）が使用されている場合、すべて
の非静的変数はそのスコープが継続している間は有効であり、したがっ
て、そのような変数は完全にデバッグ可能です。それよりも高いレベル
の最適化が使用されている場合は、変数は完全にデバッグできない可能
性があります。

ウィンドウでは、式の追加、変更、削除、表示フォーマットの変更を行
うことができます。コンテキストメニューはすべてのウィンドウで、操
作コマンドとともに利用できます。ウィンドウ間でのドラッグアンドド
ロップは、該当する箇所ではサポートされちます。
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変数の値を調べるには :

1 たとえば、[Watch]（ウォッチ）ウィンドウを開くには、
[View]>[Watch]（表示 > ウォッチ）を選択します。

2 変数を選択するには、この手順に従います : 

● [Watch]（ウォッチ）ウィンドウで点線の長方形をクリックします。

● 表示される入力フィールドに変数名を入力して、Enter キーを押
します。

● エディタウィンドウから [Watch]（ウォッチ）ウィンドウに変数
をドラッグしても、ウォッチポイントを設定できます。

この例では、
[Watch]（ウォッ
チ）ウィンドウ
に変数の現在の
値 i と配列 Fib
が表示されま
す。Fib配列を
展開すると、
さらに詳細にモ
ニタできます。

3 [Watch]（ウォッチ）ウィンドウから変数を削除するには、削除する
変数を選択して、[Delete]（削除）キーをクリックします。

メモリとレジスタのモニタ

C-SPY には、メモリとレジスタをモニタするウィンドウが多数あり、
それらは個々に [View]（表示）メニューから表示できます。

[Memory]（メモリ）ウィンドウは、指定したメモリ領域（C-SPY
ではメモリゾーン）の最新の状態を表示します。内容は編集できま
す。データカバレッジ（製品パッケージによって異なります）、とア
プリケーションの実行方法を示すために色が使用されます。指定エ
リアに特定の値を設定して、メモリ位置と範囲に直接ブレークポイ
ントを設定できます。このウィンドウで数個のインスタンスを開き、
様々なメモリエリアをモニタできます。
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[Symbolic memory]（シンボルメモリ）ウィンドウは、静的記憶寿命
変数がメモリ内でどのように配置されるかを表示します。これにより、
メモリの使用が理解し易くなり、制限を超えたバッファなど上書きされ
た変数に起因して発生した問題の調査に役立ちます。

[Stack]（スタック）ウィンドウは、メモリ内でのスタック変数の配置
を含むスタック内容を表示します。詳細については、64 ページの スタッ
クの使用量を参照してください。

[Register]（レジスタ）ウィンドウは、プロセッサレジスタと SFR の内
容の最新状態を表示し、それを編集できます。

特定の変数の内容を表示するには、単純にその変数を [Memory]（メモリ）
ウィンドウまたは [Symbolic memory]（シンボルメモリ）ウィンドウにド
ラッグします。変数が配置されているメモリエリアが表示されます。

ブレークポイントの使用

使用する C-SPY ドライバに応じて、さまざまな種類のブレークポイント
を設定できます。

[Code]（コード）ブレークポイントは、プログラムロジックが正しいか
どうかや、トレースの出力を取得するためにコードの位置を探すときに
使用します。

[Log]（ログ）ブレークポイントは、アプリケーションのソースコード
にコードを追加することなく、トレース出力を追加する便利な方法です。

[Trace Start]（トレース開始）および [Trace Stop]（トレース停止）
ブレークポイントは、トレースデータの収集を開始および停止します。
2 つの実行ポイント間で命令を分析する便利な方法です。65 ページの ト
レースも参照してください。

[Data]（データ）ブレークポイントは、リードまたはライトのメモリア
クセスのためにトリガされます。データブレークポイントは通常、デー
タがいつどのように変化するかを調べるときに使用します。

これらのブレークポイントに加えて、使用するデバッグシステムによっ
ては、C-SPY ドライバはさらに複雑または異なる種類の他のブレークポ
イントあるいはトリガをサポートすることがあります。
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ブレークポイントを設定するには：

挿入ポイントを左側の余白、または文の中か近くに配置して、ダブ
ルクリックしてコードブレークポイントを切り替えます。

または、[Breakpoints]（ブレークポイント）ダイアログボックスは、
[Editor]（エディタ）ウィンドウ、[Breakpoints]（ブレークポイント）
ウィンドウ、[Disassembly]（逆アセンブリ）ウィンドウのコンテキ
ストメニューから開くことができます。このダイアログボックスで
は、異なるタイプのブレークポイントを細かく設定して編集するこ
とができます。

注 : ほとんどのハードウェアデバッグシステムでは、アプリケー
ションが実行中でないときにだけブレークポイントを設定できます。

ブレークポイントは、[Editor]（エディタ）ウィンドウの左余白にア
イコンで示されます。

ブレークポイントアイコンが表示されない場合は、[IDE Options]> 

[Editor]（IDE オプション > エディタ）ダイアログボックスで [Show 
bookmarks]（ブックマークの表示）オプションが選択されているこ
とを確認します。

マウスポインタをブレークポイントアイコンに置くだけで、同じ位
置に設定したすべてのブレークポイントに関する詳細なツールチッ
プ情報を取得できます。最初の行がユーザブレークポイント情報
を、後続する行が、ユーザブレークポイントの実装に使用する物理
ブレークポイントを説明します。後者の情報は、[Breakpoint Usage]

（ブレークポイントの使用）ダイアログボックスでも表示されます。

コードブレークポイ
ント

ログブレークポイント

ツールチップ情報

無効化されたコード
ブレークポイント
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すべての定義済みブレークポイントを表示するには：

[View]>[Breakpoints]（表示 > ブレーク ポ
イント）を選択して、[Breakpoints]（ブ
レークポイント）ウィンドウを開きます。
このウィンドウにはすべてのブレークポ
イントがリストされます。ここでは、ブ
レークポイントのモニタや有効 / 無効の切
替えを簡単に行うことができます。また、
新しいブレークポイントの定義や、既存
のブレークポイントの修正、削除も行う
ことができます。

ブレークポイントの使用状況を調べるには :

1 [Breakpoints Usage]（ブレークポイントの使用）ウィンドウ（C-SPY ドラ
イバ固有のメニューから表示）を開き、定義済みのものや C-SPY で内部
的に使用されるものも含めて、すべてのブレークポイントを低レベルで
表示します。

通常は、ターゲットハードウェアには限られた数のハードウェアブレー
クポイント（C-SPY でブレークポイントの設定に使用）があり、時には
1 ～ 2 しかないこともあります。使用可能なハードウェアブレークポイ
ントの数を超えると、デバッガが実行中に強制的にシングルステップで
実行するようになります。この場合、大幅に実行速度が低下します。

限られた数のハードウェアブレークポイントしか持たないハードウェア
デバッガシステムでは、[Breakpoint Usage]（ブレークポイントの使用）
ウィンドウを使用して以下のことを実行します。

● すべてのブレークポイントの使用状況を確認

● ターゲットシステムでサポートされているアクティブなブレークポイ
ントの数をチェック

● 可能であれば、使用できるブレークポイントを効率よく利用できるよ
うにデバッガを設定
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ブレークポイントまで実行するには：

1 ツールバーの [Go]（実行）ボタンをクリックします。

次に設定されたブレークポイントまでアプリケーションが実行され
ます。[Debug Log]（デバッグログ）ウィンドウには、ブレークポイ
ントのトリガに関する情報が含まれます。

2 ブレークポイントを選択して右クリックし、コンテキストメニュー
から [Toggle Breakpoint]（ブレークポイントの切替え）(xxx) を選択
してブレークポイントを削除します。

ターミナル I/O の表示

場合によっては、stdinや stdoutを使用するアプリケーションの
構文を、ハードウェアを使用しないでデバッグする必要がありま
す。C-SPY では、[Terminal I/O]（ターミナル I/O）ウィンドウを使
用して、stdinと stdoutをシミュレーションできます。

[Terminal I/O] ウィンドウを使用するには：

1 以下のオプションを使用してアプリケーションをビルドします :

これは、stdinと stdoutを [Terminal I/O] ウィンドウに接続する低
レベルルーチンが、リンクされていることを意味します。

2 アプリケーションをビルドして C-SPY を起動します。

カテゴリ 設定

[Linker]>[Config]（リンカ > 設定）

（XLINK の場合）

With I/O emulation modules（I/O エ
ミュレーションモジュール付き）

[General Options]>[Library Configuration]

（一般オプション > ライブラリ設定）

（ILINK の場合）

Library low-level interface implementation

（低レベルインタフェースのライブラ

リ実装）
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3 [View]>[Terminal I/O]（［ 表示 ]>
［ ターミナル I/O]）を選択して
[Terminal I/O] ウィンドウを開
きます。このウィンドウには、
I/O 処理からの出力が表示され
ます。

アプリケーションのランタイムでの動作の解析

C-SPY には、ボトルネックを発見して、アプリケーションのすべての部
分がテスト済みであることを検証するために、アプリケーションのラン
タイム動作の解析に使用可能なさまざまな機能が用意されています。

● プロファイリング

● コードカバレッジ

● スタックの使用量

● トレース

プロファイリング

2 種類のプロファイリングのどちらかを選択できます :

関数プロファイリングでは、実行時間のほとんどが費やされる関数が見
つけやすくなります。これらの関数は、コードを最適化するときに重点
を置くべき部分です。簡単に関数を最適化するには、実行速度最適化を
指定してコンパイルします。別の方法として、最も効率的なアドレッシ
ングモードを使用するメモリ内に関数を移動することもできます。

命令プロファイリング情報、すなわち各命令が何回実行されたかが
[Disassembly]（逆アセンブリ）ウィンドウに表示され、非常に詳細なレ
ベルでコード（特にアセンブラのソースコード）を微調整できます。
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プロファイリングを使用するには :

1 以下のオプションを使用してアプリケーションをビルドします :

2 アプリケーションをビルドして C-SPY を起動します。

3 プロファイリングを使用する前に、設定する必要があります。設定
は、C-SPY ドライバおよびターゲットシステムによって異なります。

4 [Function Profiler]（関数プロファイラ）ウィンドウを開くには、ド
ライバ固有のメニューから [Profiling]（プロファイリング）を選択
します。

5 [Enable]（有効）ボタンをクリックして、 プロファイラを有効にし
ます。

6 アプリケーションの実行を開始して、プロファイリング情報を収集
します。

7 プロファイリング情報が [Function Profiler]（関数プロファイラ）
ウィンドウに表示されます。

情報をソートするには、対象の列見出しをクリックします。

8 新しいサンプリングを開始する前に、[Clear]（クリア）ボタンをク
リックします。

9 [Graph]（グラフ）ボタンをクリックすると、パーセント値を表す
列の表示方法を数値や棒グラフに切り替えることができます。

カテゴリ 設定

C/C++ コンパイラ [Output]>[Generate debug information]（出力 > デバッ

グ情報の生成）

Linker 

（XLINK の場合）

[Format]>[Debug information for C-SPY]（形式 >C-SPY
のデバッグ情報）

Linker 

（ILINK の場合）

[Output]>[Include debug information in output]（出力 >
出力ファイルにデバッグ情報を含める）
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コードカバレッジ

コードカバレッジ機能は、コードのあらゆる部分が実行されたことを確
認するテスト手順を設計する場合に便利です。また、コードに到達不可
能な部分が存在するかどうかを調べる場合にも使用できます。

注 : ハードウェア上でデバッグする際に、コードカバレッジ制限がある
ときがあります。特に、サイクルカウンタの統計が使用できない場合が
あります。

コードカバレッジを使用するには：

1 以下のオプションを使用してアプリケーションをビルドします :

2 アプリケーションをビルドして C-SPY を起動します。

3 [View]>[Code 
Coverage]（表示 >
コードカバレッジ）
を選択して、[Code 
Coverage]（コードカ
バレッジ）ウィンド
ウを開きます。

4 [Activate]（有効化）
ボタンをクリックし
て、コードカバレッ
ジアナライザを有効
にします。

5 実行を開始します。プログラムの終了に到達した、ブレークポイントが
トリガされたなどの理由で実行が停止したときは、[Refresh]（更新）ボ
タンをクリックして、コードカバレッジ情報を確認します。

カテゴリ 設定

C/C++ コンパイラ [Output]>[Generate debug information]（出力 > デバッグ

情報の生成）

Linker（XLINK の場合） [Format]>[Debug information for C-SPY]（形式 >C-SPY の

デバッグ情報）

Linker（ILINK の場合） [Output]>[Include debug information in output]（出力 > 出

力ファイルにデバッグ情報を含める）

Debugger [Plugins]>[Code Coverage]（プラグイン > コードカバ

レッジ）
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[Code Coverage] ウィンドウに、現在のコードカバレッジ解析のス
テータスが表示されます。つまり、解析を開始してからコードのど
の部分が少なくとも 1 回は実行されたかです。コンパイラは、文や
関数呼出しごとにステップポイントという形式で詳細なステップ実
行情報を生成します。レポートには、すべてのモジュールと関数に
ついての情報が表示されます。アプリケーション停止時点で実行済
みのすべてのステップポイントの割合がレポートされ、実行されて
いないすべてのステップポイントが一覧表示されます。

6  カバレッジは、無効にするまで続行されます。

注 : コードカバレッジは、[Disassembly] ウィンドウにも表示できま
す。実行されるコードは、緑色のひし形で示されます。

スタックの使用量

[Stack]（スタック）ウィンドウは、メモリ内でのスタック変数の配
置を含むスタック内容を表示します。また、スタックの整合性
チェックを実行し、スタックオーバフローを検出してワーニングす
ることもできます。

[Stack] ウィンドウにスタックの内容が表示されます。これは、以下
の場合に役立ちます :

● C モジュールからアセンブラモジュールを呼び出すか、その逆の
ときに、スタック使用量を調べる場合

● 適切なエレメントがスタック上に配置されているかどうかを調
べる場合

● スタックが正しく復元されているかどうかを調べる場合

スタックの使用をトラッキングするには：

1 [Project]>[Options]>[Debugger]>[Plugins]（プロジェクト > オプショ
ン > デバッガ > プラグイン）を選択した後、プラグインのリストか
ら [Stack] を選択します。

2 [Tools]>[Options]>[Stack]（ツール > オプション > スタック）を選択
して、スタックのトラッキングを設定します。スタックポイントが
いつ有効になるかを指定しなければならない場合があることに注意
してください。

3 アプリケーションをビルドして C-SPY を起動します。
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4 [View]>[Stack]（表示 > スタック）を選択します。

[Stack] ウィンドウの複数のインスタンスを表示し、それぞれ異なるス
タックを表示する（スタックが複数ある場合）か、同じスタックを異な
る表示設定値で表示することができます。

マウスポインタをスタックバーの上に移動すると、スタック使用量に関
するツールチップ情報が表示されます。

スタックオーバフローを検出するには：

[Tools]>[Options]>[Stack]（ツール > オプション > スタック）を選択して、
オプションの [Enable stack checks]（スタックチェックの有効化）を選択
します。

これは、アプリケーションが実行を停止したときに、C-SPY がスタック
オーバフローのワーニングを出力できることを意味します。ワーニング
は、スタック使用量がユーザが指定するしきい値を超えたときか、スタッ
クポインタがスタックメモリ範囲以外のエリアを指したときに出力され
ます。

トレース

トレースデータを収集することで、特定の状態（アプリケーションのク
ラッシュなど）になるまでのプログラムの流れを分析したり、トレース
データを使用して問題の原因を特定したりすることができます。トレー
スデータは、不規則な症状が散発的に発生するようなプログラミングエ
ラーを特定する際に役立ちます。

現在のス
タックポイ
ンタ

未使用のスタックメ
モリ、淡い灰色

現在のスタッ
クポインタ

使用中のスタック
メモリ、濃い灰色

スタックビュー

ツールチッ
プ情報を提
供するグラ
フィカルス
タックバー
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トレースとは、収集されたマシン命令のシーケンスを記録したもの
です。使用する C-SPY ドライバによって、使用可能なトレース
データが決まります。

● C-SPY シミュレータは、[Trace Expressions]（トレース式）ウィン
ドウで選択した C-SPY 式の値を記録します。[Trace]（トレース）
ウィンドウにはすべての命令が表示されますが、[Function Trace]
（関数トレース）ウィンドウには、関数呼出しと関数からの呼び
出しに対応するトレースデータだけが表示されます。

● ハードウェアデバッガシステムステムの C-SPY ドライバは、使用
するハードウェアがこれをサポートする場合に、トレースデー
タを収集できます。たとえば、トレース収集のための専用の通
信チャンネルや専用のトレースバッファがある場合などです。
この場合、[Trace]（トレース）ウィンドウには収集されたデータ
が反映されます。

トレースデータを収集するには :

1 シミュレータでトレースデータを収集するために、特定のビルド設
定は不要です 。ハードウェアデバッガシステムを使用する場合、
トレースデータを先に設定する必要があります。詳しくは、ドライ
バのマニュアルを参照してください。

2 アプリケーションをビルドして C-SPY を起動します。

3 ドライバ固有のメニューから [Trace]（トレース）を選択して [Trace]
（トレース）ウィンドウを開き、[Activate]（有効化）ボタンをク
リックし、トレースデータの収集を有効にします。

4 実行を開始します。ブレークポイントがトリガされたなどの理由で
実行が停止したときは、[Trace] ウィンドウにトレースデータが表示
されます。

ブレークポイントを使用してトレースデータの収集を開始す
るには：

2 つの実行ポイント間でトレースデータを収集する簡単な方法は、
専用のブレークポイントを使用してデータ収集を開始および停止す
ることです。エディタまたは [Disassembly]（逆アセンブリ）ウィン
ドウで右クリックして、コンテキストメニューから [Trace Start]

（トレース開始）または [Trace Stop]（トレース停止）ブレークポイ
ントを切り替えます。C-SPY シミュレータで、C-SPY システムマク
ロ __setTraceStartBreakと __setTraceStopBreakを使用するこ
とも可能です。
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