
w
w

w
.ia

r.
co

m
Installation and Licensing

Quick Reference



This Quick Reference booklet describes how to:

● Install your IAR product with a Mobile or PC-
locked single-user license

● Install your IAR product with a Network multi-
user license

● Update your existing IAR product

● Transfer your license from one computer to 
another.

For more information, see the Licensing Guide, which 
is included on the installation media.

If you are evaluating an IAR product, you should follow 
the stages A and B of the installation procedure for 
Mobile or PC-locked licenses.

Installation procedure—Mobile or PC-
locked license
The installation is a three-stage procedure:

A Install your IAR product.

B Activate your new license. A License Wizard will 
guide you through the process. A temporary startup 
license will be activated.

C Activate the permanent license, which opens up the 
product for permanent use. You perform this step 
when you have received a notification that your 
permanent license is available.

Follow the detailed steps for each stage, see the Mobile or 
PC-locked license pane in this booklet.

Installation procedure—network 
license
A Install the IAR License Server on a server computer. 

(Omit this step if the license server is already 
installed.)

B Activate your network license by using the IAR 
License Manager on the server computer.

C Install your IAR product on the client computers.

Follow the detailed steps for each stage, see the Network 
license pane in this booklet.
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Mobile license
A Mobile license is a single-user license, locked to a dongle 
(hardware lock). A dongle is a device you attach to the 
computer’s USB port or parallell port, which allows you to 
easily move the license to another computer by just moving 
the dongle.

PC-locked license
A PC-locked license is a single-user license, locked to the 
computer where your IAR product is installed.   

Network license
A Network license is a multi-user license, located on a 
license server and used by multiple users on a network.

The network license is locked either to the computer where 
the license server runs, or to a dongle (hardware lock).

The network license enables you to use your IAR product on 
all client computers on the network. Using the network 
license’s commuter feature, you can temporarily use your 
IAR product without the license server.

Product update
You perform a product update on a computer where a 
previous version of the same product is already installed.

An update uses the same license number as your existing 
product but it requires a license renewal. Use the Check for 
license renewal function in the License Manager to get a 
valid license if necessary. Note that without a valid Software 
Update Agreement (SUA) you are not entitled to product 
updates and will not get new licenses when you check for 
license renewals.

Note: If you are upgrading from a size-limited license for 
IAR Embedded Workbench, make sure to perform a 
Rebuild All command and rebuild all your libraries, when 
you build your project for the first time using the new 
license.



A. Installing your IAR product
1 Remove any dongles.

2 Insert the installation media. The installation program 
should start automatically. If it does not, run the 
autorun.exe program from the media.

3 Click Install... to start the installation of your IAR product. 

4 Accept the license agreement when prompted.

5 If prompted, select either a Complete or a Custom 
installation. If you choose Custom, select the components 
you want to install in the next dialog box.

6 Accept the default installation directory or specify a 
directory of your choice.

7 Choose which program folder on the Windows Start menu 
to place the shortcut in.

8 In the next dialog box, click Install to install the program 
files.

B. Activating your license

1 After installation, start your IAR product. Unless you 
already have an activated valid license, a License Wizard 
will start.

2 Select If you have a license number, enter it here and 
type the license number you find in the Welcome letter 
(available in the product box) and then click Next.

Note: If you need an evaluation license, select Register with IAR 
Systems to get an evaluation license instead.

If the IAR License Manager cannot access the internet, you can 
make an Offline Activation. For more information, see Activating 
your license while offline in the Licensing Guide.

3 Click Register and register your product on the web page 
that is displayed. When you have completed the registration 
and you have received your verification email from IAR 
Systems, click Next in the License Wizard to continue with 
the license activation.
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4 If you have a Mobile license, attach the dongle to your 
computer. Make sure that only the appropriate dongle is 
connected to your computer. If your dongle has not arrived 
yet, you can temporarily lock your license to your computer 
(one computer only). When you receive your dongle, repeat 
the activation, but choose to lock the license to the dongle 
instead. Note that it is possible to lock multiple products to 
the same dongle.

5 Confirm your license details.

6 At the end of the activation process, your license has been 
activated with a temporary startup license (or an evaluation 
license). You can now start using your IAR product.

7 You will receive a notification by email when the permanent 
license is available.

C. Activating for permanent use

1 Start the IAR License Manager from the Windows Start 
menu or from the Help menu in your IAR product.

2 In the License Manager, choose Check for License 
Renewal from the License menu.

3 If there is a new license available for any of your IAR 
products, a dialog box appears, asking if you want to update 
that license.

4 Click Yes and the license will be activated for permanent 
use.



A. Installing the IAR License Server
The license server consists of two parts: the IAR License Manager and 
the Sentinel RMS License Manager.

Note: Your IAR product version requires version 2.x of IAR License 
Server. Some IAR Embedded Workbench products require version 1.4x 
or older of the license server. A new and an old license server cannot 
coexist on the same computer. If the latest 2.x version of the license server 
is already installed, proceed to step B.

1 Choose a suitable server computer to act as the license server.

2 Remove any dongles.

3 Insert the IAR License Server installation media. The installation 
program should start automatically. If it does not, run the 
autorun.exe program from the installation media.

4 Click Install the IAR License Server. This will first install the 
IAR License Manager and then immediately continue with the 
Sentinel RMS License Manager.

5 Follow the instructions provided in the installation wizards and 
accept the license agreements when prompted.

6 Configure your firewall to allow inbound traffic on UDP port 5093 
(if this was not done by the server installer).

B. Activating your license

1 Start the IAR License Manager on the server computer and choose 
License>Activate License.

2 Type the license number that you find in the Welcome letter 
(available in the product box) and then click Next.

If the IAR License Manager cannot access the internet, you can make an 
Offline Activation. For more information, see Activating your license 
while offline in the Licensing Guide.

3 Click Register and register your product on the web page that is 
displayed. When you have completed the registration and you 
have received your verification email from IAR Systems, click 
Next in the License Wizard to continue with the license activation.
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4 Confirm that the current computer is the server where the network 
license should be installed.

5 If you have a dongle, attach it to the server. Make sure that only the 
appropriate dongle is attached to the server. If your dongle has not 
arrived yet, you can temporarily lock your license to the server 
computer itself. When you receive your dongle, repeat the 
activation, but choose to lock the license to the dongle instead.

6 Confirm your license details and click Next to activate the license.

7 Finish the License Wizard. The license should now be installed and 
ready to use.

8 To see your license in the License Manager, choose View>Network 
Licenses.

You will receive a notification by email when the permanent license 
is available.

C. Activating for permanent use

1 On the license server computer, start the IAR License Manager 
from the Windows Start menu.

2 In the License Manager, choose Check for License Renewal from 
the License menu.

3 If there is a new license available for any of your IAR products, a 
dialog box appears, asking if you want to update that license.

4 Click Yes and the license will be activated for permanent use.

D. Using the network license on a client 
computer

Before you proceed, the license server must be up and running.

Repeat these steps on each client computer:

1 If you do not already have the new version of the product installed 
(for example, an evaluation version), follow the procedure A. 
Installing your IAR product earlier in this booklet.

2 When you start your IAR product, it will find the license server and 
ask you to confirm it. Click Yes. If the license server is not found 
automatically, see Manually specifying a network license server in 
the Licensing Guide.

You are now finished with the installation and the licensed product can be 
used.



A. Installing the product update

1 If you want to use multiple versions of your IAR product in parallel, 
make sure to install the new version in a different directory.

2 If you instead wish to completely replace your existing installation—that 
is, to use exactly the same installation directory—do as follows:
● First make copies of any product files you have modified in your 

existing installation. These files will otherwise be overwritten. Your 
own project files will remain intact.

● Then uninstall the current version of the product by selecting the 
appropriate Uninstall... item from the Control Panel.

3 Insert the installation media of your IAR product. The installation 
program should start automatically. If it does not, run the autorun.exe 
program from the installation media.

4 Click Install... to start the installation of your IAR product.

5 Accept the license agreement when prompted.

6 Accept the default installation directory or specify a directory of your 
choice.

7 If prompted, select either a Complete or a Custom installation. If you 
choose Custom, select the components you want to install in the next 
dialog box.

8 In the next dialog box, click Install to install the program files.

You are now finished with the product update.

Note: A product update might also require that you renew your license. This is 
described in the following sections.

B. Renewing a Mobile or PC-locked license

1 Your previous license is not valid for the new version. Your IAR product 
will discover this and display a dialog box asking whether to check for 
license renewal. Note that you can also check for license renewal from 
the License Manager by choosing License>Check for license renewal 
(this might take some time).
If the IAR License Manager cannot access the internet, you must make a 
new offline activation, see Activating your license while offline in the 
Licensing Guide.

2 If an updated license is found, you will be prompted to accept it before it 
is installed.

You are now finished and the updated product can be used.
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C. Renewing a network license
Note: The network licenses cannot have any commuter authorization checked out 
when the license is renewed.

1 Start the IAR License Manager on the license server computer.

2 Choose License>Check for License Renewals. This might take some 
time.
If the IAR License Manager cannot access the internet, you must make a 
new offline activation, see Activating your license while offline in the 
Licensing Guide.

3 On the client computers, you must restart your IAR product or start the 
IAR License Manager to make it detect the renewed license.

You are now finished and the updated product can be used.

Updating the IAR License Server
Product updates for network licenses might come with an updated license server. 
If that is the case, perform the following steps on the computer where you have 
the current license server installed.

Note: This will shut down the license server and make all network licenses 
temporarily unavailable.

The setup program will uninstall the old version of the license server.

1 Remove any dongles.

2 Insert the IAR License Server installation media. The installation program 
should start automatically. If it does not, run the autorun.exe program 
from the installation media.

3 Click Install the IAR License Server. This will first install the IAR 
License Manager and then immediately continue with the Sentinel RMS 
License Manager.

4 Follow the instructions provided in the installation wizards and accept the 
license agreements when prompted.

You are now finished with the IAR Systems license server update.



A. Moving a Mobile license
If you want to move your Mobile license to another computer, do as follows:

1 Your IAR product is already installed and activated on computer A as described 
earlier in this booklet.

2 Install your IAR product on computer B and move the dongle to this computer.

3 Activate your license on computer B. Follow the activation procedure as 
described for Mobile licenses.

You can now use your IAR product on both computers by simply moving the dongle 
between them. Note that the dongle is generic, which means that you can lock several 
IAR products to the same dongle.

B. Transferring a PC-locked license
You might want to transfer your PC-locked license to another computer, for example 
when you have purchased a new computer.

To transfer a license between two computers, the license must first be deactivated on 
the old computer and then activated on the new computer.

1 On the old computer, start the IAR License Manager from the Windows Start 
menu or choose Help>License Manager in the your IAR product.

2 Select the product whose license you want to move by double-clicking on it. 
Detailed information about the license is displayed. Make sure to write down 
your license number somewhere before you deactivate your license on the old 
computer, as the number will be needed to activate your license on the new 
computer.
If a transfer is allowed for your license, the Transfer License button is available. 
Click it to deactivate the license on this computer.
Alternatively, you can also do this from the License menu. In that case, you will 
get a list of all transferrable licenses activated on the computer.

3 On the new computer, install your IAR product as described for PC-locked 
licenses.

4 When your IAR product is first started on the new computer, it discovers that a 
valid license for the installed product is missing, and starts the License Wizard.

5 In the License Wizard, type the license number and click Next. Follow the 
activation procedure as described for PC-locked licenses.

Note that you can perform the installation before or after you have deactivated the 
license on the old computer, but you will not be able to activate the license on the 
new computer until you have deactivated it on the old computer.

The license is now available on the new computer.

Note: You can make up to three license transfers during a 12-month period.
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C. Moving a network license locked to a dongle
A network license can only be transferred to another server computer if the license is 
locked to a dongle. If you must transfer a network license that is locked to the server PC, 
you must contact IAR Systems.

If your network license is locked to a dongle, do as follows:

1 Install the IAR License Server on the new computer as described earlier in this 
booklet.

2 Connect the dongle on the new license server computer. Start the IAR License 
Manager and activate your product, using the license number as described earlier 
in this booklet.
You have now transferred the license server software to the new computer.

3 On the client computers, start the IAR License Manager and choose the new 
license server as the license provider:

● Choose License>Use Network License
● Select the new license server and click Next.

The clients will now look for the license at the new location.



Locating the license number

In some cases, you must manually locate and provide the license number of the product you are 
using. If this is applicable for your installation, you will be prompted to do so when you start the 
product for the first time.
The license number can be found in the Welcome letter accompanying the product. It can also 
be found using the IAR License Manager, available from the Help menu in your IAR product or 
from the Windows Start menu. Select your license on the Product List page and double-click 
to display license information. See the Licensing Guide for details.

System requirements

For client computers, see the Release notes on your product installation media. 
For the license server computer (network licenses only), see the Release notes on your license 
server installation media.
Note: To install and activate the product, you must have administrator privileges on the 
computer and an Internet connection. If the computer does not have an Internet connection, 
you can make an offline activation. See the Licensing Guide for details.

Troubleshooting

If you have problems concerning the installation or license:
● Read the Licensing Guide, included on the product installation media.
● See the technical notes on the Technical Support pages on the IAR Systems website: 

www.iar.com/support
● Contact IAR Systems Technical Support. Information about how to access our Technical 

Support can be found at www.iar.com/support. Choose Collect Diagnostic 
Information from the Help menu to prepare a log file and a diagnostic file and keep them 
at hand.

IAR, IAR Embedded Workbench, and visualSTATE are 
trademarks owned by IAR Systems AB.
© Copyright 2009-2015 IAR Systems AB.
Part number: QREW_LMS2-4. Fourth edition: January 2015.
This guide applies to version 2.1x of the license server.
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